perl-Module-Install-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. Name: perl-Module-Install
  2. Version: 1.19
  3. Release: 1%{?_dist_release}
  4. Summary: Standalone, extensible Perl module installer
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Module-Install/
  8. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/Module-Install-%{version}.tar.gz
  9. BuildArch: noarch
  10. # Note, Makefile.PL is going to complain about having lower versions of
  11. # certain modules than is supported. (Especially under F-10.) However,
  12. # all tests pass and AFAICT everything works just fine in normal usage.
  13. BuildRequires: perl(Archive::Tar)
  14. BuildRequires: perl(CPAN)
  15. BuildRequires: perl(Devel::PPPort)
  16. BuildRequires: perl(ExtUtils::Install)
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(ExtUtils::ParseXS)
  19. BuildRequires: perl(File::Remove)
  20. BuildRequires: perl(File::Spec)
  21. BuildRequires: perl(JSON)
  22. BuildRequires: perl(LWP::UserAgent)
  23. BuildRequires: perl(Module::Build)
  24. BuildRequires: perl(Module::CoreList)
  25. BuildRequires: perl(Module::ScanDeps)
  26. #BuildRequires: perl(PAR::Dist)
  27. BuildRequires: perl(Parse::CPAN::Meta)
  28. BuildRequires: perl(Test::CPAN::Meta)
  29. BuildRequires: perl(Test::Harness)
  30. BuildRequires: perl(Test::MinimumVersion)
  31. BuildRequires: perl(Test::More)
  32. BuildRequires: perl(Test::Pod)
  33. BuildRequires: perl(YAML::Tiny)
  34. Requires: perl(Archive::Tar)
  35. Requires: perl(ExtUtils::ParseXS)
  36. Requires: perl(Module::Build)
  37. Requires: perl(Module::ScanDeps)
  38. #Requires: perl(PAR::Dist)
  39. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. Packager: shaolin
  43. %description
  44. Module::Install is a package for writing installers for CPAN (or CPAN-like)
  45. distributions that are clean, simple, minimalist, act in a strictly correct
  46. manner with ExtUtils::MakeMaker, and will run on any Perl installation
  47. version 5.005 or newer.
  48. %prep
  49. %setup -q -n Module-Install-%{version}
  50. %build
  51. %{__perl} Makefile.PL INSTALLDIRS=vendor
  52. make %{?_smp_mflags}
  53. %install
  54. make pure_install DESTDIR=%{buildroot}
  55. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  56. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  57. rm -rf %{buildroot}/blib/lib/auto/share/dist/Module-Install/dist_file.txt
  58. %{_fixperms} %{buildroot}/*
  59. find %{buildroot}%{perl_vendorlib} -type f -perm +100 -exec chmod a-x {} \;
  60. %check
  61. make test AUTOMATED_TESTING=1
  62. %files
  63. %doc Changes LICENSE README
  64. %{perl_vendorlib}/*
  65. %{_mandir}/man3/*
  66. %changelog
  67. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.19-1
  68. - new upstream release.
  69. - rebuilt with perl-5.26.
  70. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.04-2
  71. - rebuild with VineSeed environment
  72. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.04-1
  73. - initial build for Vine Linux
  74. * Thu Jan 12 2012 Iain Arnell <iarnell@gmail.com> 1.04-1
  75. - update to latest upstream version
  76. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1.01-2
  77. - Perl mass rebuild
  78. * Sat May 14 2011 Iain Arnell <iarnell@gmail.com> 1.01-1
  79. - update to latest upstream version
  80. - clean up spec for modern rpmbuild
  81. * Thu Mar 10 2011 Steven Pritchard <steve@kspei.com> 1.00-1
  82. - Update to 1.00.
  83. - Update build dependencies:
  84. + Archive::Tar >= 1.44
  85. + ExtUtils::Install >= 1.52
  86. + ExtUtils::ParseXS >= 2.19
  87. + JSON >= 2.14
  88. + LWP::UserAgent >= 5.812
  89. + Module::Build >= 0.29
  90. + Module::CoreList >= 2.17
  91. + Module::ScanDeps >= 0.89
  92. - Update description (pulled from module).
  93. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.95-3
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  95. * Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-2
  96. - 661697 rebuild for fixing problems with vendorach/lib
  97. * Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-1
  98. - Mass rebuild with perl-5.12.0 & update
  99. * Thu Feb 25 2010 Marcela Mašláňová <mmaslano@redhat.com> - 0.91-4
  100. - change to DESTDIR
  101. - add README
  102. - dist_file.txt wasn't packaged -> removed, it's needed only for test of build
  103. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.91-3
  104. - rebuild against perl 5.10.1
  105. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  107. * Sun Jun 14 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.91-1
  108. - update to 0.91
  109. - add br on Parse::CPAN::Meta: 1.39
  110. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.90-1
  111. - update to 0.90
  112. - add br on JSON, Test::Harness (3.13)
  113. - update br on YAML::Tiny (1.38)
  114. * Mon May 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.87-1
  115. - update to 0.87
  116. * Sun Apr 26 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.85-1
  117. - update to 0.85
  118. - add BR on File::Spec
  119. * Thu Apr 09 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.82-1
  120. - update to 0.82
  121. * Sun Mar 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.80-1
  122. - update to 0.80
  123. - remove 03_autoinstall.t swizzle (now self-skipped; see RT29448)
  124. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.79-1
  125. - update to 0.79
  126. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.77-2
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  128. * Thu Dec 04 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.77-1
  129. - update to 0.77
  130. * Wed Jun 04 2008 Steven Pritchard <steve@kspei.com> 0.75-1
  131. - Update to 0.75.
  132. * Sat May 31 2008 Steven Pritchard <steve@kspei.com> 0.74-1
  133. - Update to 0.74.
  134. - Update versioned dependencies for File::Remove, Module::ScanDeps,
  135. PAR::Dist, and YAML::Tiny.
  136. - BR Test::CPAN::Meta.
  137. * Fri May 16 2008 Steven Pritchard <steve@kspei.com> 0.73-1
  138. - Update to 0.73.
  139. - BR File::Remove.
  140. - Drop zero-length README.
  141. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.68-3
  142. - disable broken test (upstream bug present)
  143. - add Test::MinimumVersion as BR
  144. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.68-2
  145. - rebuild for new perl
  146. * Mon Jan 28 2008 Steven Pritchard <steve@kspei.com> 0.68-1
  147. - Update to 0.68.
  148. - Explicitly require Archive::Tar and ExtUtils::ParseXS.
  149. * Sun Dec 30 2007 Ralf Corsépius <rc040203@freenet.de> - 0.67-2
  150. - BR: perl(Test::More), perl(CPAN) (BZ 419631).
  151. - Remove TEST_POD (Unused).
  152. - Add AUTOMATED_TESTING.
  153. - BR: perl(Test::Pod) for AUTOMATED_TESTING.
  154. - Adjust License-tag.
  155. * Fri May 18 2007 Steven Pritchard <steve@kspei.com> 0.67-1
  156. - Update to 0.67.
  157. - BR Archive::Tar, ExtUtils::ParseXS, and YAML::Tiny.
  158. - Add a couple more docs.
  159. * Tue Mar 13 2007 Steven Pritchard <steve@kspei.com> 0.65-1
  160. - Update to 0.65.
  161. - Use fixperms macro instead of our own chmod incantation.
  162. - BR ExtUtils::MakeMaker.
  163. * Sun Sep 17 2006 Steven Pritchard <steve@kspei.com> 0.64-2
  164. - Rebuild.
  165. * Fri Aug 25 2006 Steven Pritchard <steve@kspei.com> 0.64-1
  166. - Update to 0.64.
  167. - Fix find option order.
  168. * Thu Jun 08 2006 Steven Pritchard <steve@kspei.com> 0.63-1
  169. - Update to 0.63.
  170. * Mon May 08 2006 Steven Pritchard <steve@kspei.com> 0.62-2
  171. - Fix Source0 URL.
  172. * Sat May 06 2006 Steven Pritchard <steve@kspei.com> 0.62-1
  173. - Update to 0.62.
  174. - Drop executable bit from everything in vendor_perl to make rpmlint happy.
  175. * Thu Mar 23 2006 Steven Pritchard <steve@kspei.com> 0.61-1
  176. - Specfile autogenerated by cpanspec 1.63.
  177. - Drop explicit BR: perl.
  178. - Turn on TEST_POD.