perl-MRO-Compat-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. # MRO is part of the Perl core since 5.9.5
  2. %global mro_in_core %(perl -e 'print $] > 5.009005 ? 1 : 0;')
  3. Name: perl-MRO-Compat
  4. Version: 0.13
  5. Release: 1%{?_dist_release}
  6. Summary: Mro::* interface compatibility for Perls < 5.9.5
  7. License: GPL+ or Artistic
  8. Group: Development/Libraries
  9. URL: http://search.cpan.org/dist/MRO-Compat/
  10. Source0: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/MRO-Compat-%{version}.tar.gz
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildArch: noarch
  15. # Build
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. # Module
  18. %if ! %{mro_in_core}
  19. BuildRequires: perl(Class::C3)
  20. BuildRequires: perl(Class::C3::XS)
  21. %endif
  22. # Test
  23. BuildRequires: perl(Test::More)
  24. BuildRequires: perl(Test::Pod)
  25. BuildRequires: perl(Test::Pod::Coverage)
  26. # Runtime
  27. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  28. %if ! %{mro_in_core}
  29. Requires: perl(Class::C3)
  30. Requires: perl(Class::C3::XS)
  31. %endif
  32. %description
  33. The "mro" namespace provides several utilities for dealing with method
  34. resolution order and method caching in general in Perl 5.9.5 and higher.
  35. This module provides those interfaces for earlier versions of Perl (back
  36. to 5.6.0 anyways).
  37. It is a harmless no-op to use this module on 5.9.5+. That is to say,
  38. code which properly uses MRO::Compat will work unmodified on both older
  39. Perls and 5.9.5+.
  40. If you're writing a piece of software that would like to use the parts
  41. of 5.9.5+'s mro:: interfaces that are supported here, and you want
  42. compatibility with older Perls, this is the module for you.
  43. %prep
  44. %setup -q -n MRO-Compat-%{version}
  45. # Fix script interpreter
  46. perl -pi -e 's|^#!./perl|#!/usr/bin/perl|' t/15pkg_gen.t
  47. %build
  48. perl Makefile.PL INSTALLDIRS=vendor
  49. make %{?_smp_mflags}
  50. %install
  51. rm -rf %{buildroot}
  52. make pure_install DESTDIR=%{buildroot}
  53. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  54. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  55. %{_fixperms} %{buildroot}
  56. %check
  57. make test
  58. %clean
  59. rm -rf %{buildroot}
  60. %files
  61. %defattr(-,root,root,-)
  62. %doc ChangeLog README t/
  63. %{perl_vendorlib}/MRO/
  64. %{_mandir}/man3/MRO::Compat.3pm*
  65. %changelog
  66. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.13-1
  67. - new upstream release.
  68. - rebuilt with perl-5.26.
  69. * Wed Dec 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
  70. - updated to 0.12
  71. - built with perl 5.16.3
  72. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
  73. - initial build for Vine Linux
  74. * Thu Jan 26 2012 Paul Howarth <paul@city-fan.org> - 0.11-9
  75. - Spec clean-up:
  76. - Only require Class::C3 with perl < 5.9.5
  77. - Require Class::C3::XS for performance and consistency, but only with
  78. perl < 5.9.5
  79. - Use DESTDIR rather than PERL_INSTALL_ROOT
  80. - Make %%files list more explicit
  81. - Classify buildreqs by build/module/test
  82. - Don't use macros for commands
  83. - Use tabs
  84. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-8
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  86. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.11-7
  87. - Perl mass rebuild
  88. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-6
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  90. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-5
  91. - Rebuild to fix problems with vendorarch/lib (#661697)
  92. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-4
  93. - Mass rebuild with perl-5.12.0
  94. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
  95. - Rebuild against perl 5.10.1
  96. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  98. * Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
  99. - Auto-update to 0.11 (by cpan-spec-update 0.01)
  100. - Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
  101. - Altered br on perl(Class::C3) (0.19 => 0.20)
  102. * Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.10-1
  103. - Update to 0.10
  104. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  106. * Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09
  107. - Update to 0.09
  108. * Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.07-1
  109. - Update to 0.07
  110. * Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.05-6
  111. - Rebuild for new perl
  112. * Thu Dec 06 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-5
  113. - Bump
  114. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-4
  115. - Update INstall -> install
  116. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-3
  117. - Add Test::Pod deps
  118. * Tue Dec 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-2
  119. - Make Class::C3 dep explicit
  120. * Tue Sep 18 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-1
  121. - Specfile autogenerated by cpanspec 1.71