perl-List-MoreUtils-XS-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. Name: perl-List-MoreUtils-XS
  2. Version: 0.428
  3. Release: 6%{?_dist_release}
  4. Summary: Provide compiled List::MoreUtils functions
  5. # Code from List-MoreUtils < 0.417 is GPL+ or Artistic
  6. # Anything after that is ASL 2.0
  7. # "git blame" on the upstream repo will probably be needed to
  8. # determine the license of any particular chunk of code
  9. License: (GPL+ or Artistic) and ASL 2.0
  10. URL: https://metacpan.org/release/List-MoreUtils-XS
  11. Source0: https://cpan.metacpan.org/authors/id/R/RE/REHSACK/List-MoreUtils-XS-%{version}.tar.gz
  12. Patch0: List-MoreUtils-XS-0.428-unbundle.patch
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. # Module Build
  16. BuildRequires: coreutils
  17. BuildRequires: findutils
  18. BuildRequires: gcc
  19. BuildRequires: make
  20. BuildRequires: perl >= 2:5.26.2
  21. BuildRequires: perl(Capture::Tiny)
  22. BuildRequires: perl(Config::AutoConf)
  23. BuildRequires: perl(ExtUtils::CBuilder)
  24. # Module Runtime
  25. BuildRequires: perl(base)
  26. BuildRequires: perl(Exporter)
  27. BuildRequires: perl(strict)
  28. BuildRequires: perl(vars)
  29. BuildRequires: perl(warnings)
  30. BuildRequires: perl(XSLoader)
  31. # Test Suite
  32. BuildRequires: perl(JSON::PP)
  33. BuildRequires: perl(List::Util)
  34. BuildRequires: perl(Math::Trig)
  35. BuildRequires: perl(overload)
  36. BuildRequires: perl(Storable)
  37. BuildRequires: perl(Test::Builder::Module)
  38. BuildRequires: perl(Test::LeakTrace)
  39. BuildRequires: perl(Test::More)
  40. BuildRequires: perl(Tie::Array)
  41. # Runtime
  42. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  43. # Don't "provide" private Perl libs
  44. %{?perl_default_filter}
  45. %description
  46. This module provides accelerated versions of functions in List::MoreUtils.
  47. %prep
  48. %setup -q -n List-MoreUtils-XS-%{version}
  49. # Unbundle bundled modules except private inc::Config::AutoConf::LMU
  50. %patch0
  51. find inc/ -type f ! -name LMU.pm -print -delete
  52. %build
  53. perl Makefile.PL \
  54. INSTALLDIRS=vendor \
  55. OPTIMIZE="%{optflags}"\
  56. NO_PERLLOCAL=1 \
  57. NO_PACKLIST=1
  58. make %{?_smp_mflags}
  59. %install
  60. make install DESTDIR=%{buildroot}
  61. find %{buildroot} -type f -name '*.bs' -empty -delete
  62. %{_fixperms} -c %{buildroot}
  63. %check
  64. make test
  65. %files
  66. %license ARTISTIC-1.0 GPL-1 LICENSE
  67. %doc Changes MAINTAINER.md README.md
  68. %{perl_vendorarch}/auto/List/
  69. %{perl_vendorarch}/List/
  70. %{_mandir}/man3/List::MoreUtils::XS.3*
  71. %changelog
  72. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.428-6
  73. - initial build for Vine Linux.
  74. - rebuilt with perl-5.26.
  75. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-5
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  77. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-4
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  79. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.428-3
  80. - Perl 5.28 rebuild
  81. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  83. * Thu Dec 21 2017 Paul Howarth <paul@city-fan.org> - 0.428-1
  84. - Update to 0.428
  85. - Fix build fails on perl ≥ 5.27.4 with -DDEBUGGING (CPAN RT#123613)
  86. - Update ppport.h to 3.37 for improved blead support
  87. - Fix context arg to croak() (CPAN RT#123869)
  88. - Fix one() returning true on empty list (CPAN RT#123870)
  89. - Pamper $a/$b/$_ refcounting bugs (CPAN RT#123868)
  90. * Tue Oct 3 2017 Paul Howarth <paul@city-fan.org> - 0.426-1
  91. - Update to 0.426
  92. - Fix broken format in part (GH#4)
  93. - Fix gcc 4.7 sequence point warning (GH#5)
  94. - Fix incorrect padname resolving for perl > 5.21.6 (CPAN RT#122883)
  95. - Fix compiling issue on CentOS 4 and CentOS 5
  96. * Sat Aug 19 2017 Paul Howarth <paul@city-fan.org> - 0.423-1
  97. - Update to 0.423
  98. - Fix dealing with lists with one element on bremove/binsert (GH#2)
  99. - Add support for compilers before C99
  100. - Fix some 32-bit compiler warnings
  101. - Add support for compilers without statement expression feature
  102. * Tue Aug 15 2017 Paul Howarth <paul@city-fan.org> - 0.422-1
  103. - Update to 0.422
  104. - Rename 'occurances' into 'occurrences' (CPAN RT#91991, CPAN RT#122806)
  105. - Add DESCRIPTION to Pod clarifying the role of List::MoreUtils::XS
  106. - Improve Makefile.PL regarding some build artifacts
  107. * Tue Aug 15 2017 Paul Howarth <paul@city-fan.org> - 0.421-1
  108. - Update to 0.421
  109. - Fix a lot of potential memory leaks when callbacks throw exceptions
  110. - Add some new functions: qsort, binsert, bremove, listcmp, arrayify
  111. (CPAN RT#17230), samples (CPAN RT#77562), minmaxstr (CPAN RT#106401),
  112. lower_bound, upper_bound, equal_range, frequencies, occurances, mode
  113. (CPAN RT#91991), zip6 (CPAN RT#42921), reduce_0, reduce_1, reduce_u
  114. - Improve tests
  115. - Make List::MoreUtils::XS independent from List::MoreUtils
  116. Note that List::MoreUtils::XS doesn't guarantee API stability: this
  117. feature is only provided through List::MoreUtils as frontend
  118. - Improve configure toolchain to use Config::AutoConf 0.315
  119. - Speed up some inner loops by hinting the expected result
  120. - Fix mind screwed up issue in upper_bound and reduce elements visited in
  121. equal_range
  122. - Correct license in META (CPAN RT#122702)
  123. - Fix issues with -DPERL_IMPLICIT_SYS on Windows with Strawberry-Perl
  124. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.418-6
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  126. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.418-5
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  128. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.418-4
  129. - Perl 5.26 rebuild
  130. * Mon Apr 3 2017 Paul Howarth <paul@city-fan.org> - 0.418-3
  131. - Incorporate package review feedback (#1437588)
  132. - Fix URL
  133. - Unbundle bundled modules except private inc::Config::AutoConf::LMU
  134. * Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-2
  135. - Sanitize for Fedora submission
  136. * Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-1
  137. - Initial RPM version