perl-LDAP-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. Name: perl-LDAP
  2. Version: 0.64
  3. Release: 1%{?_dist_release}
  4. Summary: LDAP Perl module
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/perl-ldap/
  8. Source0: http://www.cpan.org/authors/id/G/GB/GBARR/perl-ldap-%{version}.tar.gz
  9. BuildArch: noarch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. # [Core Features]
  12. BuildRequires: perl(Convert::ASN1)
  13. BuildRequires: perl(IO::Socket::SSL)
  14. # [optional modules]
  15. BuildRequires: perl(Authen::SASL) >= 2.00
  16. BuildRequires: perl(IO::Socket::INET6)
  17. BuildRequires: perl(JSON)
  18. BuildRequires: perl(URI::ldap) >= 1.1
  19. BuildRequires: perl(MIME::Base64)
  20. BuildRequires: perl(XML::SAX::Writer)
  21. # [test]
  22. BuildRequires: perl(Test::More) >= 0.98
  23. BuildRequires: perl(LWP::UserAgent)
  24. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  25. Requires: perl(Authen::SASL)
  26. Provides: perl-ldap = %{version}-%{release}
  27. Obsoletes: perl-ldap < 0.44
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: shaolin
  31. %description
  32. Net::LDAP is a collection of modules that implements a LDAP services API
  33. for Perl programs. The module may be used to search directories or perform
  34. maintenance functions such as adding, deleting or modifying entries.
  35. %description -l ja
  36. Net::LDAP は、LDAP サービス API を実装する Perl モジュール集です。
  37. このモジュールを使って、LDAP ディレクトリ検索や、LDAP エントリの
  38. 追加・削除・修正などの機能を Perl から利用可能になります。
  39. %prep
  40. %setup -q -n perl-ldap-%{version}
  41. chmod -c 644 bin/* contrib/* lib/Net/LDAP/DSML.pm
  42. %{__perl} -pi -e 's|^#!/usr/local/bin/perl\b|#!%{__perl}|' contrib/*
  43. # Filter unwanted Provides:
  44. cat << \EOF > %{name}-prov
  45. #!/bin/sh
  46. %{__perl_provides} $* |\
  47. sed -e '/perl(Net::LDAP::Filter)$/d'
  48. EOF
  49. %define __perl_provides %{_builddir}/perl-ldap-%{version}/%{name}-prov
  50. chmod +x %{__perl_provides}
  51. %build
  52. %{__perl} Makefile.PL INSTALLDIRS=vendor < /dev/null
  53. make %{?_smp_mflags}
  54. %install
  55. rm -rf %{buildroot}
  56. make pure_install DESTDIR=%{buildroot}
  57. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  58. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  59. chmod -R u+w %{buildroot}/*
  60. %check
  61. make test
  62. %clean
  63. rm -rf %{buildroot}
  64. %files
  65. %doc Changes CREDITS
  66. %doc contrib/ bin/
  67. %{perl_vendorlib}/Bundle/
  68. %{perl_vendorlib}/LWP/
  69. %{perl_vendorlib}/Net/
  70. %{_mandir}/man3/*.3pm*
  71. %changelog
  72. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.64-1
  73. - updated to 0.64
  74. - built with perl 5.16.3
  75. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.44-2
  76. - rebuild
  77. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.44-1
  78. - renamed to perl-LDAP from perl-ldap for consistency
  79. - updated to 0.44
  80. - previous Vine changelog as follows:
  81. - Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 0.3202-1vl5
  82. - spec in utf-8
  83. - applied vine5 versioning policy
  84. - Sun Sep 03 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3202-0vl2
  85. - changed Group to Development/Libraries
  86. - Sun Apr 03 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3202-0vl1
  87. - new upstream release
  88. - Tue Feb 08 2005 HOTTA Michihide <hotta@net-newbie.com> 0.31-0vl1
  89. - Initial build for Vine Linux 3.1.
  90. - Mon Feb 23 2004 <yasuma@miraclelinux.com> 0.31-1
  91. - Initial build.
  92. * Mon Feb 6 2012 Marcela Maslanova <mmaslano@redhat.com> - 1:0.44-1
  93. - update which should fix RT#66753
  94. - clean specfile according to new guidelines
  95. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.40-6
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  97. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1:0.40-5
  98. - Perl mass rebuild
  99. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.40-4
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  101. * Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:0.40-3
  102. - 661697 rebuild for fixing problems with vendorach/lib
  103. * Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:0.40-2
  104. - Mass rebuild with perl-5.12.0
  105. * Mon Apr 12 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:0.40-1
  106. - update
  107. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1:0.34-7
  108. - rebuild against perl 5.10.1
  109. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.34-6
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  111. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.34-5
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  113. * Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:0.34-4
  114. - rebuild for new perl
  115. * Mon Apr 09 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-3
  116. - Resolves: bz#226267
  117. - Only filter out the unversioned Provides: perl(Net::LDAP::Filter) to
  118. avoid breaking dependencies.
  119. * Thu Apr 05 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-2
  120. - Resolves: bz#226267
  121. - Filter out provides perl(Net::LDAP::Filter) per package review.
  122. * Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-1
  123. - New version: 0.34
  124. * Wed Sep 27 2006 Robin Norwood <rnorwood@redhat.com> - 1:0.33-3
  125. - Bugzilla: 207430
  126. - Incorporate fixes from Jose Oliveira's patch
  127. - Add perl(IO::Socket::SSL) as a BuildRequires as well
  128. - Other cleanups from Jose
  129. * Wed Sep 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.33-1.3
  130. - Add a requirement for IO::Socket::SSL, per bug #122066
  131. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
  132. - rebuild
  133. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.33-1.2
  134. - rebuild for new perl-5.8.8
  135. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  136. - rebuilt for new gcc
  137. * Tue Apr 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.33-1
  138. - Update to 0.33.
  139. * Sat Apr 02 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.3202-1
  140. - Update to 0.3202.
  141. - Specfile cleanup. (#153766)
  142. * Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 0.31-5
  143. - rebuild
  144. * Wed Mar 10 2004 Chip Turner <cturner@redhat.com> - 0.31-1
  145. - Specfile autogenerated.