perl-Gtk2-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. #
  2. # Rebuild option:
  3. #
  4. # --with testsuite - run the test suite (requires X)
  5. #
  6. Name: perl-Gtk2
  7. Version: 1.2493
  8. Release: 1%{?_dist_release}
  9. Summary: Perl interface to the GTK+2
  10. Summary(ja): GTK+2 用の Perl インタフェース
  11. Group: Development/Libraries
  12. License: LGPLv2+
  13. URL: http://search.cpan.org/dist/Gtk2/
  14. Source0: http://www.cpan.org/authors/id/T/TS/TSCH/Gtk2-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: perl >= 5.8.0
  17. BuildRequires: gtk2-devel
  18. BuildRequires: perl(ExtUtils::Depends)
  19. BuildRequires: perl(ExtUtils::PkgConfig)
  20. BuildRequires: perl(Glib) >= 1.280
  21. BuildRequires: perl(Cairo) >= 1.000
  22. BuildRequires: perl(Pango) >= 1.220
  23. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  24. Requires: perl(Glib) >= 1.280
  25. Requires: perl(Cairo) >= 1.000
  26. Requires: perl(Pango) >= 1.220
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %description
  30. This module allows you to write Gtk+ graphical user interfaces in a
  31. perlish and object-oriented way, freeing you from the casting and
  32. memory management in C, yet remaining very close in spirit to original
  33. API. Find out more about Gtk+ at http://www.gtk.org.
  34. %prep
  35. %setup -q -n Gtk2-%{version}
  36. # Provides: exclude perl(main)
  37. cat <<__EOF__ > %{name}-perl.prov
  38. #!/bin/sh
  39. /usr/lib/rpm/perl.prov \$* | grep -v '^perl(main)$'
  40. __EOF__
  41. %define __perl_provides %{_builddir}/Gtk2-%{version}/%{name}-perl.prov
  42. chmod +x %{__perl_provides}
  43. # Requires: exclude unversioned perl(Glib)
  44. cat <<__EOF__ > %{name}-perl.req
  45. #!/bin/sh
  46. /usr/lib/rpm/perl.req \$* | grep -v '^perl(Glib)$'
  47. __EOF__
  48. %define __perl_requires %{_builddir}/Gtk2-%{version}/%{name}-perl.req
  49. chmod +x %{__perl_requires}
  50. %build
  51. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  56. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  57. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  58. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  59. chmod -R u+w $RPM_BUILD_ROOT/*
  60. %check
  61. %{?_with_testsuite:make test}
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc AUTHORS ChangeLog.pre-git LICENSE NEWS README TODO
  67. %doc examples/ gtk-demo/
  68. %{perl_vendorarch}/auto/Gtk2/
  69. %{perl_vendorarch}/Gtk2*
  70. %{_mandir}/man3/*.3pm*
  71. %changelog
  72. * Fri Dec 5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2493-1
  73. - updated to 1.2493
  74. * Tue Jul 22 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.202-3
  75. - build with Perl 5.16
  76. * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 1.202-2vl6
  77. - build with perl 5.12.3
  78. - add Vendor and Distribution tags
  79. * Tue Nov 04 2008 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.202-1
  80. - new upstream release
  81. * Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.162-1
  82. - initial build for Vine Linux
  83. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-4
  84. - Rebuild for perl 5.10 (again)
  85. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.162-3
  86. - Autorebuild for GCC 4.3
  87. * Tue Feb 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-2
  88. - rebuild for new perl
  89. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-1
  90. - Update to 1.162
  91. * Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.144-1
  92. - Update to 1.144.
  93. * Mon Feb 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.143-1
  94. - Update to 1.143.
  95. * Sun Jan 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.142-1
  96. - Update to 1.142.
  97. * Wed Nov 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.141-1
  98. - Update to 1.141.
  99. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.140-1
  100. - Update to 1.140.
  101. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.122-1
  102. - Update to 1.122.
  103. * Mon May 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-2
  104. - Requires perl(Cairo) (distro >= FC-5).
  105. * Tue Apr 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-1
  106. - Update to 1.121.
  107. * Tue Mar 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.120-1
  108. - Update to 1.120.
  109. * Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.104-1
  110. - Update to 1.104.
  111. - Requires perl(Glib) >= 1.105 (1.104 had problems with perl 5.8.8).
  112. * Thu Jan 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.103-1
  113. - Update to 1.103.
  114. - Converted the Gtk2::Helper man page to utf8 (#177802).
  115. - Provides list: filtered out perl(main) (#177802).
  116. * Wed Nov 30 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.102-1
  117. - Update to 1.102.
  118. * Thu Oct 6 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.101-1
  119. - Update to 1.101.
  120. * Thu Sep 8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.100-1
  121. - Update to 1.100.
  122. * Fri Jul 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.083-1
  123. - Update to 1.083.
  124. * Mon Jun 27 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.082-1
  125. - Update to 1.082.
  126. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  127. - rebuilt
  128. * Thu Mar 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-2
  129. - Use perl-Glib for versioning control (patch by Ville Skyttä).
  130. * Tue Mar 8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-1
  131. - Update to 1.080.
  132. * Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.062-1
  133. - Update to 1.062.
  134. * Mon Oct 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.2
  135. - Removed irrelevant or duplicated documentation files.
  136. - Description simplified (as suggested by Ville Skyttä).
  137. * Tue Oct 5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.1
  138. - Update to 1.061.
  139. * Tue Oct 5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.2
  140. - make test commented: needs X.
  141. * Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.1
  142. - First build.