perl-File-Copy-Recursive-vl.spec 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. %define pkgname File-Copy-Recursive
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.38
  5. Release: 2%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/D/DM/DMUEY/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: Perl extension for recursively copying files and directories
  14. Summary(ja): 再帰的にファイルおよびディレクトリをコピーする Perl 拡張
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. This module copies and moves directories recursively (or single files,
  21. well... singley) to an optional depth and attempts to preserve each file or
  22. directory's mode.
  23. %description -l ja
  24. このモジュールは、ディレクトリ(あるいは、単一のファイル)をオプションにより深
  25. さを考慮し、各ファイルおよびディレクトリのモードを保ちながら、再帰的にコピー
  26. または移動します。
  27. %prep
  28. %setup -q -n File-Copy-Recursive-0.38
  29. %build
  30. perl Makefile.PL INSTALLDIRS="vendor"
  31. %{__make}
  32. %install
  33. %{__rm} -rf ${RPM_BUILD_ROOT}
  34. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  35. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  36. sed "s@^$RPM_BUILD_ROOT@@g" |
  37. grep -v ^%{_mandir} |
  38. grep -v perllocal.pod |
  39. grep -v "\.packlist" > %{name}.files
  40. if [ "$(cat %{name}.files)X" = "X" ] ; then
  41. echo "ERROR: EMPTY FILE LIST"
  42. exit -1
  43. fi
  44. # remove unnecessary files.
  45. %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  46. %{__rm} ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/File/Copy/Recursive/.packlist
  47. %clean
  48. %{__rm} -rf ${RPM_BUILD_ROOT}
  49. %files -f %{name}.files
  50. %defattr(-,root,root)
  51. %doc Changes README
  52. %{_mandir}/*/*
  53. %changelog
  54. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38-2
  55. - rebuilt with perl-5.16.3.
  56. * Sun Oct 09 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.38-1
  57. - initial build for Vine Linux