perl-Exporter-Tiny-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. # Test::Warnings introduced in Fedora 18
  2. %if 0%{?fedora} < 18 && 0%{?rhel} < 7
  3. %global no_test_warnings 1
  4. %else
  5. %global no_test_warnings 0
  6. %endif
  7. Name: perl-Exporter-Tiny
  8. Version: 1.002001
  9. Release: 3%{?_dist_release}
  10. Summary: An exporter with the features of Sub::Exporter but only core dependencies
  11. License: GPL+ or Artistic
  12. URL: https://metacpan.org/release/Exporter-Tiny
  13. Source0: https://cpan.metacpan.org/modules/by-module/Exporter/Exporter-Tiny-%{version}.tar.gz
  14. BuildArch: noarch
  15. # Module Build
  16. BuildRequires: coreutils
  17. BuildRequires: findutils
  18. BuildRequires: make
  19. BuildRequires: perl >= 2:5.26.2
  20. BuildRequires: perl(ExtUtils::MakeMaker)
  21. # Module Runtime
  22. BuildRequires: perl(Carp)
  23. BuildRequires: perl(strict)
  24. BuildRequires: perl(warnings)
  25. # Test Suite
  26. BuildRequires: perl(lib)
  27. BuildRequires: perl(Test::More)
  28. # Optional Tests
  29. BuildRequires: perl(Test::Fatal)
  30. %if ! %{no_test_warnings}
  31. BuildRequires: perl(Test::Warnings)
  32. %endif
  33. # Runtime
  34. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  35. Requires: perl(Carp)
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. # Avoid doc-file dependency on perl(base)
  39. %{?perl_default_filter}
  40. %description
  41. Exporter::Tiny supports many of Sub::Exporter's external-facing features
  42. including renaming imported functions with the -as, -prefix and -suffix
  43. options; explicit destinations with the into option; and alternative
  44. installers with the installer option. But it's written in only about 40%%
  45. as many lines of code and with zero non-core dependencies.
  46. Its internal-facing interface is closer to Exporter.pm, with configuration
  47. done through the @EXPORT, @EXPORT_OK and %%EXPORT_TAGS package variables.
  48. Exporter::Tiny performs most of its internal duties (including resolution of
  49. tag names to sub names, resolution of sub names to coderefs, and installation
  50. of coderefs into the target package) as method calls, which means they can be
  51. overridden to provide interesting behavior.
  52. %prep
  53. %setup -q -n Exporter-Tiny-%{version}
  54. %build
  55. perl Makefile.PL INSTALLDIRS=vendor
  56. make %{?_smp_mflags}
  57. %install
  58. make pure_install DESTDIR=%{buildroot}
  59. find %{buildroot} -type f -name .packlist -delete
  60. %{_fixperms} -c %{buildroot}
  61. %check
  62. make test
  63. %files
  64. %if 0%{?_licensedir:1}
  65. %license COPYRIGHT LICENSE
  66. %else
  67. %doc COPYRIGHT LICENSE
  68. %endif
  69. %doc Changes CREDITS examples/ README TODO
  70. %{perl_vendorlib}/Exporter/
  71. %{_mandir}/man3/Exporter::Tiny.3*
  72. %{_mandir}/man3/Exporter::Tiny::Manual::Etc.3*
  73. %{_mandir}/man3/Exporter::Tiny::Manual::Exporting.3*
  74. %{_mandir}/man3/Exporter::Tiny::Manual::Importing.3*
  75. %{_mandir}/man3/Exporter::Tiny::Manual::QuickStart.3*
  76. %{_mandir}/man3/Exporter::Shiny.3*
  77. %changelog
  78. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
  79. - initial build for Vine Linux.
  80. - rebuilt with perl-5.26.
  81. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.002001-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  83. * Wed Jul 18 2018 Paul Howarth <paul@city-fan.org> - 1.002001-1
  84. - Update to 1.002001
  85. - Added support for generating and exporting non-code symbols such as $Foo,
  86. @Bar, and %%Baz
  87. - Improved test coverage, up from 88.78%% on coveralls.io to 96.74%%
  88. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-6
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  90. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.000000-5
  91. - Perl 5.28 rebuild
  92. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-4
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  94. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-3
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  96. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.000000-2
  97. - Perl 5.26 rebuild
  98. * Mon May 22 2017 Paul Howarth <paul@city-fan.org> - 1.000000-1
  99. - Update to 1.000000
  100. - Repackage as 1.000000
  101. - All shipped files are now GPL+ or Artistic
  102. - Drop EL-5 support
  103. - Drop BuildRoot: and Group: tags
  104. - Drop explicit buildroot cleaning in %%install section
  105. - Drop explicit %%clean section
  106. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.044-2
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  108. * Mon Jan 30 2017 Paul Howarth <paul@city-fan.org> - 0.044-1
  109. - Update to 0.044
  110. - Support { -as => CODE } to programmatically rename functions
  111. - Restructure documentation
  112. - Simplify find command using -delete
  113. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.042-6
  114. - Perl 5.24 rebuild
  115. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.042-5
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  117. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.042-4
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  119. * Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.042-3
  120. - Perl 5.22 rebuild
  121. * Fri Mar 6 2015 Paul Howarth <paul@city-fan.org> - 0.042-2
  122. - Correct license tagging (#1199491)
  123. * Thu Oct 9 2014 Paul Howarth <paul@city-fan.org> - 0.042-1
  124. - Update to 0.042
  125. - Add an 'unimport' feature
  126. - Option validation needs to happen after expanding tags
  127. - Housekeeping on %%TRACKED
  128. * Wed Sep 17 2014 Paul Howarth <paul@city-fan.org> - 0.040-1
  129. - Update to 0.040
  130. - Document warning and error messages produced by Exporter::Tiny
  131. - Exporter::Tiny would previously cause B.pm to be loaded into memory any
  132. time it exported anything: it no longer does
  133. - No longer die when redefining locally defined subs
  134. - Warn when redefining any subs
  135. - Use %%license where possible
  136. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.038-3
  137. - Perl 5.20 rebuild
  138. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.038-2
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  140. * Fri Apr 4 2014 Paul Howarth <paul@city-fan.org> - 0.038-1
  141. - Update to 0.038
  142. - Added: Support Exporter.pm's import negation syntax qw( !foo )
  143. - Added: Support Exporter.pm's regexp import syntax qw( /foo/ )
  144. - Fix minor error in documentation of generators
  145. - Improved handling of hashrefs of options passed to tags, and hashrefs of
  146. options found within %%EXPORT_TAGS arrayrefs
  147. - Only attempt to merge hashes if we're sure they're both really hashes!
  148. * Mon Mar 17 2014 Paul Howarth <paul@city-fan.org> - 0.036-2
  149. - Sanitize for Fedora submission
  150. * Thu Mar 13 2014 Paul Howarth <paul@city-fan.org> - 0.036-1
  151. - Initial RPM version