perl-Event-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. Name: perl-Event
  2. Version: 1.27
  3. Release: 1%{?_dist_release}
  4. Summary: Event loop processing
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Event/
  8. Source0: http://search.cpan.org/CPAN/authors/id/J/JP/JPRIT/Event-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: perl(Carp)
  11. BuildRequires: perl(Config)
  12. BuildRequires: perl(Exporter)
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(Test)
  15. BuildRequires: perl(Time::HiRes)
  16. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  17. Requires: perl(Time::HiRes)
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %if %{_dist_release} > "vl6"
  21. %global __requires_exclude %{?__requires_exclude:__requires_exclude|}perl\\(attrs\\)
  22. %endif
  23. %{?perl_default_filter}
  24. %description
  25. The Event module provide a central facility to watch for various types of
  26. events and invoke a callback when these events occur. The idea is to delay the
  27. handling of events so that they may be dispatched in priority order when it is
  28. safe for callbacks to execute.
  29. %prep
  30. %setup -q -n Event-%{version}
  31. # Fix up permissions and shellbangs
  32. find ./ -type f -exec chmod -c -x {} \;
  33. perl -pi -e 's|#!./perl|#!/usr/bin/perl|' demo/*.t t/*.t util/bench.pl
  34. %{_fixperms} demo/ util/
  35. # Fix character encoding
  36. #patch0 -p1
  37. %if %{_dist_release} <= "vl6"
  38. cat << \EOF > %{name}-req
  39. #!/bin/sh
  40. %{__perl_requires} $* | sed -e '/perl(attrs)/d'
  41. EOF
  42. %global __perl_requires %{_builddir}/Event-%{version}/%{name}-req
  43. chmod +x %{__perl_requires}
  44. %endif
  45. %build
  46. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  47. make %{?_smp_mflags}
  48. %install
  49. make pure_install DESTDIR=%{buildroot}
  50. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  51. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  52. find %{buildroot} -depth -type d -exec rmdir --ignore-fail-on-non-empty {} ';'
  53. %{_fixperms} %{buildroot}
  54. %check
  55. make test
  56. %files
  57. %doc ANNOUNCE ChangeLog README README.EV TODO
  58. %doc Tutorial.pdf Tutorial.pdf-errata.txt demo/ t/ util/
  59. %doc %{perl_vendorarch}/Event.pod
  60. %{perl_vendorarch}/auto/Event/
  61. %{perl_vendorarch}/Event.pm
  62. %{perl_vendorarch}/Event/
  63. %{_mandir}/man3/Event.3pm*
  64. %{_mandir}/man3/Event::MakeMaker.3pm*
  65. %{_mandir}/man3/Event::generic.3pm*
  66. %changelog
  67. * Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.27-1
  68. - new upstream release.
  69. - rebuilt with perl-5.26.
  70. * Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.24-1
  71. - new upstream release
  72. - dropt Patch0 merged into upstream
  73. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20-2
  74. - build with Perl 5.16
  75. * Fri Mar 02 2012 MATSUBAYASHi Kohji <shaolin@vinelinux.org> - 1.20-1
  76. - initial build for Vine Linux
  77. * Sun Jan 15 2012 Paul Howarth <paul@city-fan.org> 1.20-1
  78. - update to 1.20 (test suite fixes)
  79. - BR: perl(Carp), perl(Config), perl(Exporter)
  80. - since upstream doesn't ship license files, neither should we
  81. - make %%files list more explicit
  82. - use a patch to fix character encoding rather than scripted iconv
  83. - use DESTDIR rather than PERL_INSTALL_ROOT
  84. - no need for additional filtering on top of %%{?perl_default_filter}
  85. - don't package INSTALL file
  86. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.15-3
  87. - rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  88. * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> 1.15-2
  89. - perl mass rebuild
  90. * Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 1.15-1
  91. - update to latest upstream version
  92. - clean up spec for modern rpmbuild
  93. - filter perl(attrs) from requires
  94. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.12-6
  95. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  96. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-5
  97. - rebuild to fix problems with vendorarch/lib (#661697)
  98. * Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-4
  99. - mass rebuild with perl-5.12.0
  100. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-3
  101. - mass rebuild with perl-5.12.0
  102. * Mon Dec 07 2009 Stepan Kasal <skasal@redhat.com> 1.12-2
  103. - rebuild against perl 5.10.1
  104. * Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
  105. - add perl_default_filter
  106. - auto-update to 1.12 (by cpan-spec-update 0.01)
  107. - added a new req on perl(Test) (version 1)
  108. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-3
  109. - rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  110. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-2
  111. - rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  112. * Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
  113. - update to 1.11
  114. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-5
  115. - rebuild for perl 5.10 (again)
  116. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> 1.09-4
  117. - autorebuild for GCC 4.3
  118. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-3
  119. - rebuild for new perl
  120. * Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-2
  121. - bump
  122. * Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-1
  123. - update to 1.09
  124. - add t/ to doc
  125. * Sat Nov 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.08-1
  126. - update to 1.08
  127. * Sun Oct 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.07-1
  128. - update to 1.07
  129. * Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-2
  130. - bump for mass rebuild
  131. * Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-1
  132. - add explicit provides: perl(Event) = version... wasn't being picked up
  133. automagically for some reason
  134. - tweaked summary line
  135. - bumped release
  136. * Thu Jun 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-0
  137. - initial spec file for F-E