perl-Eval-Closure-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. Name: perl-Eval-Closure
  2. Version: 0.14
  3. Release: 1%{?_dist_release}
  4. Summary: Safely and cleanly create closures via string eval
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Eval-Closure/
  8. Source0: http://www.cpan.org/authors/id/D/DO/DOY/Eval-Closure-%{version}.tar.gz
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(PadWalker)
  15. BuildRequires: perl(Perl::Tidy)
  16. BuildRequires: perl(Scalar::Util)
  17. BuildRequires: perl(Sub::Exporter)
  18. BuildRequires: perl(Test::Fatal)
  19. BuildRequires: perl(Test::More)
  20. BuildRequires: perl(Test::Output)
  21. BuildRequires: perl(Test::Requires)
  22. BuildRequires: perl(Try::Tiny)
  23. Requires: perl(Perl::Tidy)
  24. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  25. %{?perl_default_filter}
  26. %description
  27. String eval is often used for dynamic code generation. For instance, Moose uses
  28. it heavily, to generate inlined versions of accessors and constructors, which
  29. speeds code up at runtime by a significant amount. String eval is not without
  30. its issues however - it's difficult to control the scope it's used in (which
  31. determines which variables are in scope inside the eval), and it's easy to miss
  32. compilation errors, since eval catches them and sticks them in $@ instead.
  33. This module attempts to solve these problems. It provides an eval_closure
  34. function, which evals a string in a clean environment, other than a fixed list
  35. of specified variables. Compilation errors are rethrown automatically.
  36. %prep
  37. %setup -q -n Eval-Closure-%{version}
  38. %build
  39. %{__perl} Makefile.PL INSTALLDIRS=vendor
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf %{buildroot}
  43. make pure_install DESTDIR=%{buildroot}
  44. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  45. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  46. %{_fixperms} %{buildroot}/*
  47. %check
  48. make test
  49. %clean
  50. rm -rf %{buildroot}
  51. %files
  52. %doc Changes LICENSE README
  53. %{perl_vendorlib}/*
  54. %{_mandir}/man3/*
  55. %changelog
  56. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.14-1
  57. - new upstream release.
  58. - rebuilt with perl-5.26.
  59. * Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.11-1
  60. - updated to 0.11
  61. - built with perl 5.16.3
  62. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.08-1
  63. - initial build for Vine Linux
  64. * Fri Feb 10 2012 Iain Arnell <iarnell@gmail.com> 0.08-1
  65. - update to latest upstream version
  66. * Sat Feb 04 2012 Iain Arnell <iarnell@gmail.com> 0.07-1
  67. - update to latest upstream version
  68. - update description
  69. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-3
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  71. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-2
  72. - Perl mass rebuild
  73. * Tue Jun 07 2011 Iain Arnell <iarnell@gmail.com> 0.06-1
  74. - update to latest upstream version
  75. * Wed May 04 2011 Iain Arnell <iarnell@gmail.com> 0.05-1
  76. - update to latest upstream version
  77. * Wed Apr 20 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
  78. - update to latest upstream version
  79. * Thu Mar 03 2011 Iain Arnell <iarnell@gmail.com> 0.03-1
  80. - update to latest upstream version
  81. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  83. * Fri Jan 28 2011 Iain Arnell <iarnell@gmail.com> 0.02-1
  84. - update to latest upstream version
  85. * Sun Jan 23 2011 Iain Arnell <iarnell@gmail.com> 0.01-1
  86. - Specfile autogenerated by cpanspec 1.78.