perl-Encode-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342
  1. # Because encoding sub-package has independent version, version macro gets
  2. # redefined.
  3. %global cpan_version 2.98
  4. %global encoding_version 2.22
  5. Name: perl-Encode
  6. Version: %{cpan_version}
  7. # Keep increasing release number even when rebasing version because
  8. # perl-encoding sub-package has independent version which does not change
  9. # often and consecutive builds would clash on perl-encoding NEVRA. This is the
  10. # same case as in perl.spec.
  11. Release: 1%{?_dist_release}
  12. Summary: Character encodings in Perl
  13. # ucm: UCD
  14. # other files: GPL+ or Artistic
  15. License: (GPL+ or Artistic) and UCD
  16. Group: Development/Libraries
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. URL: https://metacpan.org/pod/Encode
  20. Source0: https://cpan.metacpan.org/authors/id/D/DA/DANKOGAI/Encode-%{cpan_version}.tar.gz
  21. BuildRequires: coreutils
  22. BuildRequires: findutils
  23. BuildRequires: make
  24. BuildRequires: perl
  25. BuildRequires: perl(ExtUtils::MakeMaker)
  26. BuildRequires: perl(File::Spec)
  27. BuildRequires: perl(File::Spec::Functions)
  28. BuildRequires: perl(strict)
  29. BuildRequires: perl(warnings)
  30. # enc2xs is run at build-time
  31. # Run-time:
  32. BuildRequires: perl(bytes)
  33. BuildRequires: perl(Carp)
  34. BuildRequires: perl(Config)
  35. BuildRequires: perl(constant)
  36. BuildRequires: perl(Exporter) >= 5.57
  37. BuildRequires: perl(File::Basename)
  38. BuildRequires: perl(File::Find)
  39. BuildRequires: perl(Filter::Util::Call)
  40. BuildRequires: perl(Getopt::Long)
  41. BuildRequires: perl(Getopt::Std)
  42. # I18N::Langinfo is optional
  43. BuildRequires: perl(MIME::Base64)
  44. BuildRequires: perl(overload)
  45. BuildRequires: perl(parent) >= 0.221
  46. # PerlIO::encoding is optional
  47. # POSIX is optional
  48. BuildRequires: perl(re)
  49. # Storable is optional
  50. BuildRequires: perl(utf8)
  51. BuildRequires: perl(vars)
  52. BuildRequires: perl(XSLoader)
  53. # Tests:
  54. # Benchmark not used
  55. BuildRequires: perl(charnames)
  56. BuildRequires: perl(File::Compare)
  57. BuildRequires: perl(File::Copy)
  58. BuildRequires: perl(FileHandle)
  59. BuildRequires: perl(FindBin)
  60. BuildRequires: perl(IO::Select)
  61. BuildRequires: perl(IPC::Open3)
  62. # IPC::Run not used
  63. BuildRequires: perl(lib)
  64. BuildRequires: perl(Scalar::Util)
  65. BuildRequires: perl(Symbol)
  66. BuildRequires: perl(Test)
  67. BuildRequires: perl(Test::More)
  68. BuildRequires: perl(Tie::Scalar)
  69. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  70. Requires: perl(parent) >= 0.221
  71. %{?perl_default_filter}
  72. %global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\((Encode::ConfigLocal|MY)\\)
  73. # Filter under-specified dependencies
  74. %global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\((Exporter|parent)\\)$
  75. %description
  76. The Encode module provides the interface between Perl strings and the rest
  77. of the system. Perl strings are sequences of characters.
  78. %package -n perl-encoding
  79. Summary: Write your Perl script in non-ASCII or non-UTF-8
  80. Version: %{encoding_version}
  81. License: GPL+ or Artistic
  82. Group: Development/Libraries
  83. # Keeping this sub-package arch-specific because it installs files into
  84. # arch-specific directories.
  85. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  86. Requires: perl(Carp)
  87. # Config not needed on perl ≥ 5.008
  88. # Consider Filter::Util::Call as mandatory, bug #1165183, CPAN RT#100427
  89. Requires: perl(Filter::Util::Call)
  90. # I18N::Langinfo is optional
  91. # PerlIO::encoding is optional
  92. Requires: perl(utf8)
  93. Conflicts: perl-Encode < 2.64-2
  94. %description -n perl-encoding
  95. With the encoding pragma, you can write your Perl script in any encoding you
  96. like (so long as the Encode module supports it) and still enjoy Unicode
  97. support.
  98. However, this encoding module is deprecated under perl 5.18. It uses
  99. a mechanism provided by perl that is deprecated under 5.18 and higher, and may
  100. be removed in a future version.
  101. The easiest and the best alternative is to write your script in UTF-8.
  102. # To mirror files from perl-devel (bug #456534)
  103. # Keep architecture specific because files go into vendorarch
  104. %package devel
  105. Summary: Perl Encode Module Generator
  106. Version: %{cpan_version}
  107. Group: Development/Libraries
  108. Requires: %{name}%{?_isa} = %{cpan_version}-%{release}
  109. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  110. Recommends: perl-devel%{?_isa}
  111. Requires: perl(Encode)
  112. %description devel
  113. enc2xs builds a Perl extension for use by Encode from either Unicode Character
  114. Mapping files (.ucm) or Tcl Encoding Files (.enc). You can use enc2xs to add
  115. your own encoding to perl. No knowledge of XS is necessary.
  116. %prep
  117. %setup -q -n Encode-%{cpan_version}
  118. %build
  119. # Additional scripts can be installed by appending MORE_SCRIPTS, UCM files by
  120. # INSTALL_UCM.
  121. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  122. make %{?_smp_mflags}
  123. %install
  124. make pure_install DESTDIR=$RPM_BUILD_ROOT
  125. find $RPM_BUILD_ROOT -type f -name .packlist -delete
  126. find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -delete
  127. %{_fixperms} $RPM_BUILD_ROOT/*
  128. # remove files that conflict with perl's
  129. rm -f %{buildroot}%{_bindir}/piconv
  130. rm -f %{buildroot}%{_bindir}/enc2xs
  131. rm -rf %{buildroot}%{_mandir}
  132. %check
  133. make test
  134. %files
  135. %doc AUTHORS Changes README
  136. %{_bindir}/encguess
  137. #%{_bindir}/piconv
  138. %{perl_vendorarch}/auto/*
  139. %{perl_vendorarch}/Encode*
  140. %exclude %{perl_vendorarch}/Encode/*.e2x
  141. %exclude %{perl_vendorarch}/Encode/encode.h
  142. #%{_mandir}/man1/encguess.*
  143. #%{_mandir}/man1/piconv.*
  144. #%{_mandir}/man3/Encode.*
  145. #%{_mandir}/man3/Encode::*
  146. %files -n perl-encoding
  147. %doc AUTHORS Changes README
  148. %{perl_vendorarch}/encoding.pm
  149. #%{_mandir}/man3/encoding.*
  150. %files devel
  151. #%{_bindir}/enc2xs
  152. #%{_mandir}/man1/enc2xs.*
  153. %{perl_vendorarch}/Encode/*.e2x
  154. %{perl_vendorarch}/Encode/encode.h
  155. %changelog
  156. * Sat Jan 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.98-1
  157. - new upstream release.
  158. * Mon May 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.84-11
  159. - initial build for Vine Linux.
  160. * Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 4:2.84-10
  161. - Increase epoch to favour standalone package
  162. * Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 3:2.84-9
  163. - Weak perl-Encode-devel dependency on perl-devel to Recommends level
  164. (bug #1129443)
  165. * Mon Apr 11 2016 Petr Pisar <ppisar@redhat.com> - 3:2.84-8
  166. - 2.84 bump
  167. * Thu Mar 24 2016 Petr Pisar <ppisar@redhat.com> - 3:2.83-7
  168. - 2.83 bump
  169. * Tue Feb 09 2016 Petr Pisar <ppisar@redhat.com> - 3:2.82-6
  170. - 2.82 bump
  171. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3:2.80-5
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  173. * Mon Jan 25 2016 Petr Pisar <ppisar@redhat.com> - 3:2.80-4
  174. - 2.80 bump
  175. * Fri Jan 22 2016 Petr Pisar <ppisar@redhat.com> - 3:2.79-3
  176. - 2.79 bump
  177. * Thu Sep 24 2015 Petr Pisar <ppisar@redhat.com> - 3:2.78-2
  178. - 2.78 bump
  179. * Wed Sep 16 2015 Petr Pisar <ppisar@redhat.com> - 3:2.77-1
  180. - 2.77 bump
  181. * Fri Jul 31 2015 Petr Pisar <ppisar@redhat.com> - 3:2.76-2
  182. - Increase release number to have unique perl-encoding NEVRA
  183. * Fri Jul 31 2015 Petr Pisar <ppisar@redhat.com> - 3:2.76-1
  184. - 2.76 bump
  185. * Wed Jul 01 2015 Petr Pisar <ppisar@redhat.com> - 3:2.75-1
  186. - 2.75 bump
  187. * Thu Jun 25 2015 Petr Pisar <ppisar@redhat.com> - 3:2.74-1
  188. - 2.74 bump
  189. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3:2.73-3
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  191. * Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2:2.73-2
  192. - Perl 5.22 rebuild
  193. - Increase Epoch to favour standalone package
  194. * Mon Apr 20 2015 Petr Pisar <ppisar@redhat.com> - 2:2.73-1
  195. - 2.73 bump
  196. * Mon Mar 16 2015 Petr Pisar <ppisar@redhat.com> - 2:2.72-1
  197. - 2.72 bump
  198. * Thu Mar 12 2015 Petr Pisar <ppisar@redhat.com> - 2:2.71-1
  199. - 2.71 bump
  200. * Wed Mar 04 2015 Petr Pisar <ppisar@redhat.com> - 2:2.70-2
  201. - Correct license from (GPL+ or Artistic) to ((GPL+ or Artistic) and UCD)
  202. * Thu Feb 05 2015 Petr Pisar <ppisar@redhat.com> - 2:2.70-1
  203. - 2.70 bump
  204. * Fri Jan 23 2015 Petr Pisar <ppisar@redhat.com> - 2:2.68-1
  205. - 2.68 bump
  206. * Fri Dec 05 2014 Petr Pisar <ppisar@redhat.com> - 2:2.67-1
  207. - 2.67 bump
  208. * Wed Dec 03 2014 Petr Pisar <ppisar@redhat.com> - 2:2.66-1
  209. - 2.66 bump
  210. * Tue Nov 18 2014 Petr Pisar <ppisar@redhat.com> - 2:2.64-2
  211. - Consider Filter::Util::Call dependency as mandatory (bug #1165183)
  212. - Sub-package encoding module
  213. * Mon Nov 03 2014 Petr Pisar <ppisar@redhat.com> - 2:2.64-1
  214. - 2.64 bump
  215. * Mon Oct 20 2014 Petr Pisar <ppisar@redhat.com> - 2:2.63-1
  216. - 2.63 bump
  217. * Wed Sep 03 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2:2.62-5
  218. - Increase Epoch to favour standalone package
  219. * Tue Aug 26 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1:2.62-4
  220. - Perl 5.20 rebuild
  221. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.62-3
  222. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  223. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.62-2
  224. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  225. * Mon Jun 02 2014 Petr Pisar <ppisar@redhat.com> - 1:2.62-1
  226. - 2.62 bump
  227. * Wed Apr 30 2014 Petr Pisar <ppisar@redhat.com> - 1:2.60-1
  228. - 2.60 bump
  229. * Mon Apr 14 2014 Petr Pisar <ppisar@redhat.com> - 1:2.59-1
  230. - 2.59 bump
  231. * Mon Mar 31 2014 Petr Pisar <ppisar@redhat.com> - 1:2.58-1
  232. - 2.58 bump
  233. * Fri Jan 03 2014 Petr Pisar <ppisar@redhat.com> - 1:2.57-1
  234. - 2.57 bump
  235. * Mon Sep 16 2013 Petr Pisar <ppisar@redhat.com> - 1:2.55-1
  236. - 2.55 bump
  237. * Mon Sep 02 2013 Petr Pisar <ppisar@redhat.com> - 1:2.54-1
  238. - 2.54 bump
  239. * Wed Aug 21 2013 Jitka Plesnikova <jplesnik@redhat.com> - 1:2.52-1
  240. - 2.52 bump
  241. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.51-7
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  243. * Fri Jul 26 2013 Petr Pisar <ppisar@redhat.com> - 1:2.51-6
  244. - Specify more dependencies
  245. * Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 1:2.51-5
  246. - Put epoch into dependecny declaration
  247. * Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1:2.51-4
  248. - Link minimal build-root packages against libperl.so explicitly
  249. * Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1:2.51-3
  250. - Perl 5.18 rebuild
  251. * Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1:2.51-2
  252. - Perl 5.18 rebuild
  253. * Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1:2.51-1
  254. - Increase epoch to compete with perl.spec
  255. * Fri May 17 2013 Petr Pisar <ppisar@redhat.com> - 2.51-2
  256. - Specify all dependencies
  257. * Thu May 02 2013 Petr Pisar <ppisar@redhat.com> - 2.51-1
  258. - 2.51 bump
  259. * Mon Apr 29 2013 Petr Pisar <ppisar@redhat.com> - 2.50-1
  260. - 2.50 bump (recoding does not launders taintedness)
  261. * Tue Mar 05 2013 Petr Pisar <ppisar@redhat.com> - 2.49-1
  262. - 2.49 bump
  263. * Mon Feb 18 2013 Petr Pisar <ppisar@redhat.com> - 2.48-1
  264. - 2.48 bump
  265. * Thu Sep 20 2012 Petr Pisar <ppisar@redhat.com> 2.47-1
  266. - Specfile autogenerated by cpanspec 1.78.
  267. - Make devel sub-package architecture specific due to file location