perl-Devel-GlobalDestruction-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. # Package is noarch from perl 5.13.7
  2. %global noarch_package %(perl -e 'print (($] >= 5.013007) ? 1 : 0);')
  3. Summary: Expose PL_dirty, the flag that marks global destruction
  4. Name: perl-Devel-GlobalDestruction
  5. Version: 0.13
  6. Release: 1%{?_dist_release}
  7. License: GPL+ or Artistic
  8. Group: Development/Libraries
  9. URL: http://search.cpan.org/dist/Devel-GlobalDestruction
  10. Source: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Devel-GlobalDestruction-%{version}.tar.gz
  11. %if %{noarch_package}
  12. BuildArch: noarch
  13. %endif
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: perl(ExtUtils::CBuilder) >= 0.27
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. BuildRequires: perl(Sub::Exporter::Progressive) >= 0.001011
  18. BuildRequires: perl(XSLoader)
  19. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  20. # Don't "provide" private Perl libs
  21. %{?perl_default_filter}
  22. %description
  23. Perl's global destruction is a little tricky to deal with with respect to
  24. finalizers because it's not ordered and objects can sometimes disappear.
  25. Writing defensive destructors is hard and annoying, and usually if global
  26. destruction is happening you only need the destructors that free up non
  27. process local resources to actually execute.
  28. For these constructors you can avoid the mess by simply bailing out if
  29. global destruction is in effect.
  30. %prep
  31. %setup -q -n Devel-GlobalDestruction-%{version}
  32. %build
  33. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  34. make %{?_smp_mflags}
  35. %install
  36. rm -rf %{buildroot}
  37. make pure_install DESTDIR=%{buildroot}
  38. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  39. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  40. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  41. %{_fixperms} %{buildroot}
  42. %check
  43. make test
  44. %clean
  45. rm -rf %{buildroot}
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc Changes t/
  49. %if %{noarch_package}
  50. %{perl_vendorlib}/Devel/
  51. %else
  52. %{perl_vendorarch}/auto/Devel/
  53. %{perl_vendorarch}/Devel/
  54. %endif
  55. %{_mandir}/man3/Devel::GlobalDestruction.3pm*
  56. %changelog
  57. * Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.13-1
  58. - updated to 0.13
  59. - built with perl 5.16.3
  60. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.04-1
  61. - initial build for Vine Linux
  62. * Fri Jan 13 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
  63. - Update to 0.04
  64. - To detect a perl with ${^GLOBAL_PHASE}, check for the feature itself
  65. instead of a specific perl version
  66. - Update the documentation to reflect the use of ${^GLOBAL_PHASE} if available
  67. - Stop depending on Scope::Guard for the tests
  68. - Upgrade ppport.h from version 3.13 to 3.19
  69. - Drop no-longer-necessary buildreq perl(Scope::Guard)
  70. - Use DESTDIR rather than PERL_INSTALL_ROOT
  71. - BR: perl(XSLoader)
  72. * Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
  73. - Fedora 17 mass rebuild
  74. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-2
  75. - Perl mass rebuild
  76. * Fri Jun 24 2011 Paul Howarth <paul@city-fan.org> - 0.03-1
  77. - Update to 0.03
  78. - Drop the XS code on perl versions recent enough to have ${^GLOBAL_PHASE}
  79. (5.13.7 onwards)
  80. - Require at least Perl 5.6
  81. - Use XSLoader without a fallback to DynaLoader
  82. - Use our instead of use vars
  83. - This release by FLORA -> update source URL
  84. - Package is noarch from perl 5.13.7
  85. - Package Changes file
  86. - Use %%{?perl_default_filter}
  87. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-12
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  89. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-11
  90. - Rebuild to fix problems with vendorarch/lib (#661697)
  91. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-10
  92. - Mass rebuild with perl-5.12.0
  93. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.02-9
  94. - Mass rebuild with perl-5.12.0
  95. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.02-8
  96. - rebuild against perl 5.10.1
  97. * Sun Aug 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.02-7
  98. - bump
  99. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-6
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  101. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-5
  102. - Stripping bad provides of private Perl extension libs
  103. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-4
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  105. * Mon Nov 03 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-3
  106. - bump
  107. * Sat Nov 01 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-2
  108. - tweak summary
  109. * Sun Oct 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-1
  110. - clean up for review submission
  111. * Sun Oct 19 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.02-0.1
  112. - initial RPM packaging
  113. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)