perl-Declare-Constraints-Simple-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. Name: perl-Declare-Constraints-Simple
  2. Version: 0.03
  3. Release: 2%{?_dist_release}
  4. Summary: Declarative Validation of Data Structures
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Declare-Constraints-Simple/
  8. Source0: http://search.cpan.org/CPAN/authors/id/P/PH/PHAYLON/Declare-Constraints-Simple-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. BuildArch: noarch
  11. # Build
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. # Module
  14. BuildRequires: perl(aliased)
  15. BuildRequires: perl(Carp::Clan)
  16. BuildRequires: perl(Class::Inspector)
  17. BuildRequires: perl(Scalar::Util)
  18. # Test suite
  19. BuildRequires: perl(Test::More)
  20. BuildRequires: perl(Test::Pod)
  21. BuildRequires: perl(Test::Pod::Coverage)
  22. # Runtime
  23. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  24. %if "%{_dist_release}" > "vl6"
  25. # Filter unwanted Requires: (rpm 4.9 onwards)
  26. %global __requires_exclude ^perl\\(Declare::Constraints::Simple-Library\\)
  27. %else
  28. # Filter unwanted Requires (prior to rpm 4.9)
  29. %global reqfilt /bin/sh -c "%{__perl_requires} | grep -Fvx 'perl(Declare::Constraints::Simple-Library)'"
  30. %define __perl_requires %{reqfilt}
  31. %endif
  32. %description
  33. The main purpose of this module is to provide an easy way to build a
  34. profile to validate a data structure. It does this by giving you a set of
  35. declarative keywords in the importing namespace.
  36. %prep
  37. %setup -q -n Declare-Constraints-Simple-%{version}
  38. %build
  39. %{__perl} Makefile.PL INSTALLDIRS=vendor
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf %{buildroot}
  43. make pure_install DESTDIR=%{buildroot}
  44. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  45. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  46. %{_fixperms} %{buildroot}
  47. %check
  48. make test
  49. %clean
  50. rm -rf %{buildroot}
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc Changes README t/
  54. %{perl_vendorlib}/Declare/
  55. %{_mandir}/man3/Declare::Constraints::Simple.3pm*
  56. %{_mandir}/man3/Declare::Constraints::Simple::Library.3pm*
  57. %{_mandir}/man3/Declare::Constraints::Simple::Library::Array.3pm*
  58. %{_mandir}/man3/Declare::Constraints::Simple::Library::Base.3pm*
  59. %{_mandir}/man3/Declare::Constraints::Simple::Library::Exportable.3pm*
  60. %{_mandir}/man3/Declare::Constraints::Simple::Library::General.3pm*
  61. %{_mandir}/man3/Declare::Constraints::Simple::Library::Hash.3pm*
  62. %{_mandir}/man3/Declare::Constraints::Simple::Library::Numerical.3pm*
  63. %{_mandir}/man3/Declare::Constraints::Simple::Library::OO.3pm*
  64. %{_mandir}/man3/Declare::Constraints::Simple::Library::Operators.3pm*
  65. %{_mandir}/man3/Declare::Constraints::Simple::Library::Referencial.3pm*
  66. %{_mandir}/man3/Declare::Constraints::Simple::Library::Scalar.3pm*
  67. %{_mandir}/man3/Declare::Constraints::Simple::Result.3pm*
  68. %changelog
  69. * Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.03-2
  70. - rebuilt with perl 5.16.3
  71. * Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.03-1
  72. - initial build for Vine Linux
  73. * Mon Jan 23 2012 Paul Howarth <paul@city-fan.org> - 0.03-15
  74. - Spec clean-up
  75. - Make %%files list more explicit
  76. - Classify buildreqs by build/module/test
  77. - Use search.cpan.org source URL
  78. - Don't use macros for commands
  79. - Use tabs
  80. * Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-14
  81. - Spec clean-up
  82. - Simplify pre-rpm-4.9 provides filter
  83. - Use DESTDIR rather than PERL_INSTALL_ROOT
  84. - Make %%files list more specific
  85. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-13
  86. - Perl mass rebuild
  87. * Sun Feb 13 2011 Paul Howarth <paul@city-fan.org> - 0.03-12
  88. - Fix dependency filter for rpm 4.9 onwards
  89. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-11
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  91. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-10
  92. - Rebuild to fix problems with vendorarch/lib (#661697)
  93. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-9
  94. - Mass rebuild with perl-5.12.0
  95. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-8
  96. - Mass rebuild with perl-5.12.0
  97. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-7
  98. - Mass rebuild with perl-5.12.0
  99. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.03-6
  100. - Rebuild against perl 5.10.1
  101. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-5
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  103. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-4
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  105. * Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.03-3
  106. - Rebuild for new perl
  107. * Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-2
  108. - Bump
  109. * Tue May 01 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-1
  110. - Specfile autogenerated by cpanspec 1.71