perl-DateTime-Format-Builder-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. # Note: Some tests for this package are disabled by default, as they
  2. # require network access and would thus fail in the buildsys' mock
  3. # environments. To build locally while enabling tests, either:
  4. #
  5. # rpmbuild ... --define '_with_network_tests 1' ...
  6. # rpmbuild ... --with network_tests ...
  7. # define _with_network_tests 1 in your ~/.rpmmacros
  8. #
  9. # Note that right now, the only way to run tests locally from a cvs sandbox
  10. # "make noarch" type scenario is the third one.
  11. %define real_version 0.81
  12. Name: perl-DateTime-Format-Builder
  13. # 0.80 in reality, but rpm can't get it
  14. Version: 0.8100
  15. Release: 1%{?_dist_release}
  16. Summary: Create DateTime parser classes and objects
  17. Group: Development/Libraries
  18. License: Artistic 2.0
  19. URL: http://search.cpan.org/dist/DateTime-Format-Builder
  20. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Builder-%{real_version}.tar.gz
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildArch: noarch
  23. ## core
  24. BuildRequires: perl(Test::More)
  25. ## non-core
  26. BuildRequires: perl(Module::Build)
  27. BuildRequires: perl(Class::ISA)
  28. BuildRequires: perl(Class::Factory::Util)
  29. BuildRequires: perl(DateTime)
  30. BuildRequires: perl(DateTime::Format::Strptime)
  31. BuildRequires: perl(Params::Validate) >= 0.73
  32. # note -- listed as a BR but _not_ needed with Fedora perl
  33. #BuildRequires: perl(Task::Weaken)
  34. BuildRequires: perl(Test::Pod)
  35. ## For extended testing
  36. BuildRequires: perl(DateTime::Format::HTTP)
  37. BuildRequires: perl(DateTime::Format::Mail)
  38. BuildRequires: perl(DateTime::Format::IBeat)
  39. Provides: perl(DateTime::Format::Builder) = %{version}
  40. # for signature checking
  41. %{?_with_network_tests:BuildRequires: perl(Module::Signature) }
  42. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  43. %{?perl_default_filter}
  44. %description
  45. DateTime::Format::Builder creates DateTime parsers. Many string formats of
  46. dates and times are simple and just require a basic regular expression to
  47. extract the relevant information. Builder provides a simple way to do this
  48. without writing reams of structural code.
  49. Builder provides a number of methods, most of which you'll never need, or at
  50. least rarely need. They're provided more for exposing of the module's innards
  51. to any subclasses, or for when you need to do something slightly beyond what
  52. is expected.
  53. %prep
  54. %setup -q -n DateTime-Format-Builder-%{real_version}
  55. # digital signature checking. Not essential, but nice
  56. %{?_with_network_tests: cpansign -v }
  57. # POD doesn't like E<copy> very much...
  58. perl -pi -e 's/E<copy>/(C)/' `find lib/ -type f`
  59. # silence rpmlint
  60. sed -i '1s~^#!.*perl~#!%{__perl}~' t/*.t
  61. %build
  62. %{__perl} Makefile.PL INSTALLDIRS=vendor
  63. make %{?_smp_mflags}
  64. %install
  65. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  66. find %{buildroot} -type f -name .packlist -exec rm -f {} +
  67. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  68. %{_fixperms} %{buildroot}/*
  69. %check
  70. make test
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc Changes LICENSE README examples/ t/
  74. %{perl_vendorlib}/*
  75. %{_mandir}/man3/*.3*
  76. %changelog
  77. * Sat Dec 20 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8100-1
  78. - updated to 0.81
  79. - built with perl 5.16.3
  80. * Sun Jan 6 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.8000-1
  81. - initial build based on Fedora development package
  82. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-10
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  84. * Wed Jun 20 2012 Petr Pisar <ppisar@redhat.com> - 0.8000-9
  85. - Perl 5.16 rebuild
  86. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-8
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  88. * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.8000-7
  89. - Perl mass rebuild
  90. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.8000-6
  91. - Perl mass rebuild
  92. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-5
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  94. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-4
  95. - 661697 rebuild for fixing problems with vendorach/lib
  96. * Sun Dec 12 2010 Iain Arnell <iarnell@gmail.com> 0.8000-3
  97. - use perl_default_filter
  98. - clean up spec for modern rpmbuild
  99. * Fri May 14 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-2
  100. - add provides with rpm version for other packages
  101. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-1
  102. - Mass rebuild with perl-5.12.0
  103. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.7901-5
  104. - rebuild against perl 5.10.1
  105. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-4
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  107. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-3
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  109. * Tue Mar 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.7901-2
  110. - rebuild for new perl
  111. * Sat Jan 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.7901-1
  112. - update to 0.7901
  113. - additional docs
  114. - some spec rework
  115. * Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-4
  116. - bump for mass rebuild
  117. * Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-3
  118. - bump for release & build, not in that order
  119. * Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-2
  120. - additional br's
  121. * Fri Aug 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-1
  122. - Initial spec file for F-E