perl-DBI-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. Summary: A database access API for perl
  2. Summary(ja): perl 用データベース接続 API
  3. Name: perl-DBI
  4. Version: 1.643
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL or Artistic
  10. URL: https://dbi.perl.org/
  11. Source0: https://cpan.metacpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libxcrypt-devel
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. # Run-time
  16. BuildRequires: perl(base)
  17. BuildRequires: perl(constant)
  18. BuildRequires: perl(Carp)
  19. # Clone is optional
  20. BuildRequires: perl(Clone)
  21. BuildRequires: perl(Coro)
  22. BuildRequires: perl(Coro::Handle)
  23. BuildRequires: perl(Coro::Select)
  24. BuildRequires: perl(Cwd)
  25. BuildRequires: perl(Data::Dumper)
  26. # DB_File is optional
  27. BuildRequires: perl(DB_File)
  28. BuildRequires: perl(DynaLoader)
  29. BuildRequires: perl(Errno)
  30. BuildRequires: perl(Exporter)
  31. BuildRequires: perl(Fcntl)
  32. BuildRequires: perl(File::Basename)
  33. BuildRequires: perl(File::Spec)
  34. BuildRequires: perl(Getopt::Long)
  35. BuildRequires: perl(IO::File)
  36. BuildRequires: perl(IO::Select)
  37. BuildRequires: perl(IPC::Open3)
  38. BuildRequires: perl(Math::BigInt)
  39. # MLDBM is optional
  40. ##BuildRequires: perl(MLDBM)
  41. # RPC::PlClient is optional
  42. ##BuildRequires: perl(RPC::PlClient) >= 0.2000
  43. # RPC::PlServer is optional
  44. ##BuildRequires: perl(RPC::PlServer)
  45. BuildRequires: perl(Scalar::Util)
  46. # SQL::Statement is optional
  47. BuildRequires: perl(SQL::Statement)
  48. BuildRequires: perl(Storable)
  49. BuildRequires: perl(Symbol)
  50. BuildRequires: perl(threads)
  51. BuildRequires: perl(Tie::Hash)
  52. BuildRequires: perl(UNIVERSAL)
  53. # Tests
  54. BuildRequires: perl(Encode)
  55. BuildRequires: perl(File::Path)
  56. BuildRequires: perl(lib)
  57. BuildRequires: perl(Net::Daemon::Test)
  58. BuildRequires: perl(Test::More)
  59. BuildRequires: perl(Test::Simple)
  60. # Optional tests
  61. BuildRequires: perl(Test::Pod)
  62. BuildRequires: perl(Test::Pod::Coverage)
  63. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  64. Requires: perl(Math::BigInt)
  65. %description
  66. DBI is a database access Application Programming Interface (API) for
  67. the Perl Language. The DBI API Specification defines a set of
  68. functions, variables and conventions that provide a consistent
  69. database interface independent of the actual database being used.
  70. %description -l ja
  71. DBI は Perl でデータベースにアクセスするための API です.
  72. DBI API では,実際に使われるデータベースに依存しない様に,
  73. 関数,変数などの取り決めが定義されています.
  74. %debug_package
  75. %prep
  76. %setup -q -n DBI-%{version}
  77. iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
  78. mv lib/DBD/Gofer.pm{.new,}
  79. chmod 644 ex/*
  80. chmod 744 dbixs_rev.pl
  81. sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
  82. %build
  83. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  84. make %{?_smp_mflags}
  85. %install
  86. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  87. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  88. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  89. find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
  90. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  91. chmod -R u+w %{buildroot}/*
  92. # Remove Win32 specific files and man pages to avoid unwanted dependencies
  93. rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
  94. %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
  95. perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
  96. %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
  97. %check
  98. make test
  99. %clean
  100. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  101. %files
  102. %defattr(-,root,root)
  103. %doc Changes README.md ex/
  104. %{perl_vendorarch}/*.p*
  105. %{perl_vendorarch}/Bundle/
  106. %{perl_vendorarch}/DBD/
  107. %{perl_vendorarch}/DBI/
  108. %{perl_vendorarch}/auto/DBI/
  109. %{_bindir}/*
  110. %{_mandir}/*/*
  111. %changelog
  112. * Sat Sep 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.643-1
  113. - updated to 1.642.
  114. * Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.642-1
  115. - updated to 1.642.
  116. - rebuilt with perl-5.26.
  117. - added BR:libxcrypt-devel.
  118. * Fri Dec 5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.632-1
  119. - updated to 1.632
  120. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
  121. - build with Perl 5.16
  122. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
  123. - updated to 1.618; spec revamped
  124. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
  125. - rebuild with perl 5.12.3
  126. - using __perl_requires macro for VineSeed (vl6)
  127. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
  128. - spec in utf-8
  129. * Thu May 1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
  130. - rebuilt with perl-5.10.0.
  131. * Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
  132. - new upstream release
  133. * Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
  134. - new upstream release
  135. * Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
  136. - new upstream release
  137. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
  138. - new upstream release
  139. - changed Group to Development/Libraries
  140. - installed module files to vendor_perl
  141. * Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
  142. - use filter-requires-dbi.sh instead of find-requires.perl
  143. * Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
  144. - new upstream version
  145. - build on perl-5.8.6-0vl1
  146. * Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
  147. - new upstream version
  148. * Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
  149. - update 1.37
  150. - build with perl-5.8.0
  151. - add make test
  152. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
  153. - updated 1.21
  154. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
  155. - updated 1.20
  156. * Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
  157. - the spec was in Shift-JIS. Fixed.
  158. * Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
  159. - updated 1.19
  160. * Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
  161. - rebuild on perl-5.6.0
  162. - changed mandir to /usr/share/man
  163. - removed version in Requires perl
  164. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
  165. - updated perl-DBL-1.15
  166. * Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
  167. - fixed Vine Linux
  168. * Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  169. - Cleanups
  170. * Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  171. - build for main distribution
  172. - use %%{_tmppath}
  173. - change name of specfile
  174. - don't use a find script to generate file lists
  175. - general cleanup
  176. - add descriptive summary and description
  177. * Mon Aug 14 2000 Tim Powers <timp@redhat.com>
  178. - Spec file was autogenerated.