perl-Crypt-SSLeay-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. # -*- coding: utf-8 -*-
  2. # Disable network tests by default
  3. %bcond_with network_tests
  4. %define origname Crypt-SSLeay
  5. Name: perl-Crypt-SSLeay
  6. Summary: OpenSSL glue that provides LWP https support
  7. Version: 0.72
  8. Release: 2%{?_dist_release}
  9. License: GPL or Artistic
  10. Group: Development/Libraries
  11. URL: http://search.cpan.org/dist/Crypt-SSLeay/
  12. Source0: http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
  13. # Adapt to OpenSSL 1.1.0, bug #1383756, CPAN RT#118343
  14. Patch0: Crypt-SSLeay-0.72-Do-not-use-SSLv2_client_method-with-OpenSSL-1.1.0.patch
  15. Patch1: Crypt-SSLeay-0.72-Fix-building-on-Perl-without-dot-in-INC.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: openssl-devel
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(Path::Class)
  20. BuildRequires: perl(Test::Pod::Coverage)
  21. BuildRequires: perl(Try::Tiny)
  22. BuildRequires: perl(URI)
  23. BuildRequires: perl-libwww-perl
  24. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  25. Requires: openssl
  26. Distribution: Vine Linux
  27. Vendor: Project Vine
  28. Packager: iwaim
  29. %description
  30. This perl module provides support for the https protocol under LWP, so
  31. that a LWP::UserAgent can make https GET & HEAD & POST
  32. requests. Please see perldoc LWP for more information on POST
  33. requests.
  34. The Crypt::SSLeay package contains Net::SSL, which is automatically
  35. loaded by LWP::Protocol::https on https requests, and provides the
  36. necessary SSL glue for that module to work.
  37. %prep
  38. %setup -q -n %{origname}-%{version}
  39. %patch0 -p1
  40. %patch1 -p1
  41. # Placate rpmlint
  42. chmod -c -x lib/Net/SSL.pm
  43. # Filter unwanted Provides:
  44. cat << EOF > %{name}-prov
  45. #!/bin/sh
  46. %{__perl_provides} $* |\
  47. sed -e '/perl(DB)/d'
  48. EOF
  49. %define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
  50. chmod +x %{__perl_provides}
  51. %build
  52. if pkg-config openssl ; then
  53. export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
  54. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  55. fi
  56. %{__perl} Makefile.PL --%{!?with_network_tests:no-}live-tests \
  57. INC="$INC" LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="%{optflags}" \
  58. </dev/null
  59. make %{?_smp_mflags}
  60. %clean
  61. rm -rf $RPM_BUILD_ROOT
  62. %install
  63. rm -rf $RPM_BUILD_ROOT
  64. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  65. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  66. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  67. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  68. chmod -R u+w $RPM_BUILD_ROOT/*
  69. chmod -R 644 eg/*
  70. chmod -R 644 certs/*
  71. %check
  72. make test
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc Changes eg/* certs/*
  76. %{perl_vendorarch}/auto/Crypt/
  77. %{perl_vendorarch}/Crypt/
  78. %{perl_vendorarch}/Net/
  79. %{_mandir}/man3/*.3*
  80. %changelog
  81. * Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.72-2
  82. - rebuilt with openssl-1.1.1.
  83. - imported Patch0-1 from rawhide.
  84. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.72-1
  85. - new upstream release.
  86. - removed all patches (fixed in upstream).
  87. - added BR:perl(Path::Class) and BR:perl(Try::Tiny).
  88. * Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.57-3
  89. - rebuilt with perl 5.16.3
  90. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
  91. - build with perl 5.12.3
  92. * Wed Apr 7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
  93. - initial build for Vine Linux
  94. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
  95. - rebuild against perl 5.10.1
  96. * Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
  97. - change Makefile for openssl 1.0, which couldn't be found properly before
  98. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
  99. - rebuilt with new openssl
  100. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  102. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  104. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
  105. - rebuild with new openssl
  106. * Mon Oct 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
  107. - add examples into doc
  108. * Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
  109. - fix patches for fuzz
  110. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
  111. - rebuild for new perl
  112. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
  113. - Autorebuild for GCC 4.3
  114. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
  115. - Rebuild for deps
  116. * Wed Dec 5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
  117. - Rebuild for new openssl
  118. * Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
  119. - Remove unnecessary BR: pkgconfig
  120. * Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
  121. - Fix buildroot per package review
  122. - Resolves: bz#226248
  123. * Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
  124. - Update to latest upstream version.
  125. - Remove old patch (patch applied to upstream)
  126. - Several fixes for package review:
  127. - Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
  128. - Apply patch to avoid prompting for input when building Makefile
  129. - Fix defattr line
  130. - Resolves: bz#226248
  131. * Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
  132. - perl(ExtUtils::MakeMaker::Coverage) is now available
  133. * Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
  134. - 0.56 is the latest CPAN version, not 0.55
  135. * Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
  136. - Update to latest version from CPAN: 0.55
  137. - Remove two old patches, update lib64 patch for Makefile.PL changes.
  138. * Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
  139. - New version: 0.53
  140. * Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
  141. - Resolves: bug#217138
  142. - fix a segfault on x86_64
  143. * Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
  144. - Filter out Provides perl(DB)
  145. - bug #205562
  146. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
  147. - rebuild
  148. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
  149. - bump again for double-long bug on ppc(64)
  150. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
  151. - rebuilt for new gcc4.1 snapshot and glibc changes
  152. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
  153. - rebuild for new perl-5.8.8 / gcc / glibc
  154. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  155. - rebuilt for new gcc
  156. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  157. - rebuilt for new gcj
  158. * Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
  159. - rebuilt against new openssl
  160. - added missing SSL_library_init()
  161. * Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
  162. - Own more installed dirs (#73908).
  163. - Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
  164. - Require perl(:MODULE_COMPAT_*).
  165. - Run tests in the %%check section.
  166. - Fix License, Source0, URL, and Group tags.
  167. * Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
  168. - remove brp-compress
  169. * Tue Mar 8 2005 Joe Orton <jorton@redhat.com> 0.51-6
  170. - rebuild
  171. * Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
  172. - build for FC3
  173. * Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
  174. - build for RHEL3 U4
  175. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  176. - rebuilt
  177. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  178. - rebuilt
  179. * Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
  180. - update to upstream 0.51
  181. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  182. - rebuilt
  183. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com>
  184. - pass openssl includes to make as INC and ldflags in as LDFLAGS
  185. * Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
  186. - patch to support /usr/lib64 before /usr/lib
  187. * Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
  188. - rebuild
  189. * Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
  190. - automated release bump and build
  191. * Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
  192. - description update
  193. * Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
  194. - move to 0.39
  195. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  196. - automated rebuild
  197. * Fri Dec 7 2001 root <root@redhat.com>
  198. - Spec file was autogenerated.