perl-Crypt-DSA-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. %define module Crypt-DSA
  2. %define name perl-%{module}
  3. %define version 1.17
  4. %define release 2%{_dist_release}
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Summary: DSA Signatures and Key Generation
  9. Group: Development/Libraries
  10. License: GPL or Artistic
  11. Url: http://search.cpan.org/dist/%{module}/
  12. Source: http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: perl-Digest-SHA1, perl(Math::BigInt)
  16. BuildRequires: perl(Carp)
  17. BuildRequires: perl(Convert::PEM)
  18. BuildRequires: perl(Crypt::DES_EDE3)
  19. BuildRequires: perl(Data::Buffer) >= 0.01
  20. BuildRequires: perl(Digest::SHA1)
  21. BuildRequires: perl(ExtUtils::MakeMaker)
  22. BuildRequires: perl(File::Spec)
  23. BuildRequires: perl(File::Which) >= 0.05
  24. BuildRequires: perl(IPC::Open3)
  25. BuildRequires: perl(Math::BigInt) >= 1.78
  26. BuildRequires: perl(Math::BigInt::GMP)
  27. BuildRequires: perl(Perl::MinimumVersion) >= 1.20
  28. BuildRequires: perl(Test::CPAN::Meta) >= 0.12
  29. BuildRequires: perl(Test::More) >= 0.42
  30. BuildRequires: perl(Test::MinimumVersion) >= 0.008
  31. BuildRequires: perl(Test::Pod) >= 1.26
  32. BuildRequires: openssl
  33. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  34. # Crypt::DSA::Keychain calls openssl for DSA parameter generation
  35. Requires: openssl
  36. # Some operations are really slow without GMP (or Pari, but we test with GMP)
  37. Requires: perl(Math::BigInt::GMP)
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. %description
  41. Crypt::DSA is an implementation of the DSA (Digital Signature Algorithm)
  42. signature verification system. The implementation itself is pure Perl,
  43. although the heavy-duty mathematics underneath are provided by
  44. the Math::Pari library.
  45. This package provides DSA signing, signature verification,
  46. and key generation.
  47. %prep
  48. %setup -q -n %{module}-%{version}
  49. %build
  50. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor"
  51. %{__make}
  52. %check
  53. echo -e "\n\nWill take several minutes for the tests. Please wait.\n\n"
  54. ## WARNING: you'll need many hardware input / network traffic
  55. ## to keep the 'entropy pool' filled with random bits -
  56. ## otherwise the test will take enormous amount of time (shaolin)
  57. %{__make} test
  58. %{__make} test AUTOMATED_TESTING=1 TEST_FILES="xt/*.t"
  59. %install
  60. make pure_install DESTDIR=%{buildroot}
  61. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  62. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  63. %{_fixperms} %{buildroot}
  64. %clean
  65. rm -rf %{buildroot}
  66. %files
  67. %defattr(-,root,root)
  68. %doc README Changes
  69. %{_mandir}/man3*/*
  70. %{perl_vendorlib}/Crypt/*
  71. %changelog
  72. * Sat Nov 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.17-2
  73. - rebuilt with perl 5.16.3
  74. - moved to Development/Libraries Group
  75. * Mon Mar 12 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
  76. - updated to 1.17
  77. * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-1vl5
  78. - rebuild with perl 5.10
  79. - new versioning policy
  80. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl1
  81. - built for VineSeed
  82. * Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.43
  83. - add Requires: perl-Convert-PEM/perl-Data-Buffer
  84. * Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.42
  85. - built for Vine 4.2 (testing)
  86. - 1st build for Vine