perl-Crypt-DES_EDE3-vl.spec 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. %define module Crypt-DES_EDE3
  2. %define name perl-%{module}
  3. %define version 0.01
  4. %define release 3%{_dist_release}
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Summary: Triple-DES EDE encryption/decryption
  9. Group: Development/Libraries
  10. License: GPL or Artistic
  11. Url: http://search.cpan.org/dist/%{module}/
  12. Source: http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}
  15. Buildrequires: perl(Crypt::DES)
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. Crypt::DES_EDE3 implements DES-EDE3 encryption.
  22. This is triple-DES encryption where an encrypt operation is
  23. encrypt-decrypt-encrypt, and decrypt is decrypt-encrypt-decrypt.
  24. This implementation uses Crypt::DES to do its dirty DES work,
  25. and simply provides a wrapper around that module: setting up
  26. the individual DES ciphers, initializing the keys, and performing
  27. the encryption/decryption steps.
  28. DES-EDE3 encryption requires a key size of 24 bytes.
  29. You're probably best off not using this module directly,
  30. as the encrypt and decrypt methods expect 8-octet blocks.
  31. You might want to use the module in conjunction with Crypt::CBC,
  32. for example. This would be DES-EDE3-CBC, or triple-DES in outer CBC mode.
  33. #'
  34. %prep
  35. %setup -q -n %{module}-%{version}
  36. %build
  37. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{_prefix}"
  38. %{__make}
  39. # %check
  40. # %{__make} test
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. make install DESTDIR=$RPM_BUILD_ROOT
  44. # rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
  45. # rm -rf %{buildroot}%{perl_vendorarch}
  46. find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %files
  50. %defattr(-,root,root)
  51. %doc README Changes
  52. %{_mandir}/man3*/*
  53. %{perl_vendorlib}/Crypt/*
  54. %changelog
  55. * Wed Nov 5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.01-3
  56. - rebuilt with perl 5.16.3
  57. - moved to Development/Libraries Group
  58. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.01-2
  59. - rebuild with perl-5.12.3
  60. * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-1vl5
  61. - rebuild with perl 5.10
  62. - new versioning policy
  63. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl1
  64. - built for VineSeed
  65. * Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.43
  66. - add Requires: and Buildrequires: perl-Crypt-DES
  67. * Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.42
  68. - built for Vine 4.2 (testing)