perl-Class-Load-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. %define perl_bootstrap 1
  2. Name: perl-Class-Load
  3. Version: 0.20
  4. Release: 1%{?_dist_release}
  5. Summary: A working (require "Class::Name") and more
  6. Group: Development/Libraries
  7. License: GPL+ or Artistic
  8. URL: http://search.cpan.org/dist/Class-Load/
  9. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Class-Load-%{version}.tar.gz
  10. BuildArch: noarch
  11. # ===================================================================
  12. # Module build requirements
  13. # ===================================================================
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. # ===================================================================
  16. # Module requirements
  17. # ===================================================================
  18. BuildRequires: perl(base)
  19. BuildRequires: perl(Carp)
  20. BuildRequires: perl(Data::OptList)
  21. BuildRequires: perl(Module::Implementation) >= 0.04
  22. BuildRequires: perl(Module::Runtime) >= 0.012
  23. BuildRequires: perl(Package::Stash) >= 0.14
  24. BuildRequires: perl(strict)
  25. BuildRequires: perl(Try::Tiny)
  26. BuildRequires: perl(warnings)
  27. # ===================================================================
  28. # Test requirements
  29. # ===================================================================
  30. BuildRequires: perl(Test::Fatal)
  31. BuildRequires: perl(Test::More)
  32. BuildRequires: perl(Test::Requires)
  33. # ===================================================================
  34. # Runtime requirements
  35. # ===================================================================
  36. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  37. # Also requires core module perl(Exporter) via a "use base" construct
  38. %description
  39. require EXPR only accepts Class/Name.pm style module names, not Class::Name.
  40. How frustrating! For that, we provide load_class 'Class::Name'.
  41. It's often useful to test whether a module can be loaded, instead of throwing
  42. an error when it's not available. For that, we provide
  43. try_load_class 'Class::Name'.
  44. Finally, sometimes we need to know whether a particular class has been loaded.
  45. Asking %%INC is an option, but that will miss inner packages and any class for
  46. which the filename does not correspond to the package name. For that, we
  47. provide is_class_loaded 'Class::Name'.
  48. %prep
  49. %setup -q -n Class-Load-%{version}
  50. %build
  51. perl Makefile.PL INSTALLDIRS=vendor
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf %{buildroot}
  55. make pure_install DESTDIR=%{buildroot}
  56. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  57. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  58. %{_fixperms} %{buildroot}
  59. %check
  60. make test %{!?perl_bootstrap:RELEASE_TESTING=1}
  61. %clean
  62. rm -rf %{buildroot}
  63. %files
  64. %doc Changes LICENSE README
  65. %{perl_vendorlib}/Class/
  66. %{_mandir}/man3/Class::Load.3pm*
  67. %changelog
  68. * Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.20-1
  69. - new upstream release
  70. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.18-2
  71. - rebuild with perl-5.16
  72. * Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.18-1
  73. - Update to 0.18:
  74. - Require Package::Stash ≥ 0.14 (CPAN RT#75095)
  75. * Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.17-1
  76. - Update to 0.17:
  77. - Require Module::Runtime 0.012, which has a number of useful bug fixes
  78. - A bug in Class::Load caused test failures when Module::Runtime 0.012 was
  79. used with Perl 5.8.x (CPAN RT#74897)
  80. * Thu Feb 9 2012 Paul Howarth <paul@city-fan.org> - 0.15-1
  81. - Update to 0.15:
  82. - Small test changes to accomodate latest version of Module::Implementation
  83. - BR: at least version 0.04 of perl(Module::Implementation)
  84. * Tue Feb 7 2012 Paul Howarth <paul@city-fan.org> - 0.14-1
  85. - Update to 0.14:
  86. - Use Module::Implementation to handle loading the XS or PP versions of the
  87. code; using this module fixes a few bugs
  88. - Under taint mode, setting an implementation in the
  89. CLASS_LOAD_IMPLEMENTATION env var caused a taint error
  90. - An invalid value in the CLASS_LOAD_IMPLEMENTATION env var is now detected
  91. and reported immediately; no attempt is made to load an invalid
  92. implementation
  93. - BR: perl(Module::Implementation)
  94. - BR: perl(base), perl(Carp), perl(strict) and perl(warnings) for completeness
  95. - Drop version requirement for perl(Package::Stash), no longer present upstream
  96. - Drop explicit runtime dependencies, no longer needed
  97. - Don't BR: perl(Class::Load::XS) or perl(Pod::Coverage::Moose) if we're
  98. bootstrapping
  99. - Don't run the release tests when bootstrapping as the Pod coverage test will
  100. fail in the absence of Pod::Coverage::Moose
  101. * Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.13-2
  102. - Fedora 17 mass rebuild
  103. * Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 0.13-1
  104. - Update to 0.13:
  105. - Fix some bugs with our use of Try::Tiny, which could cause warnings on some
  106. systems where Class::Load::XS wasn't installed (CPAN RT#72345)
  107. - BR: perl(Test::Without::Module)
  108. * Tue Oct 25 2011 Paul Howarth <paul@city-fan.org> - 0.12-1
  109. - Update to 0.12:
  110. - Require Module::Runtime ≥ 0.011, which fixes problems with Catalyst under
  111. Perl 5.8 and 5.10
  112. - Add versioned runtime dependencies for Module::Runtime and Package::Stash
  113. * Wed Oct 5 2011 Paul Howarth <paul@city-fan.org> - 0.11-1
  114. - Update to 0.11:
  115. - Don't accept package names that start with a digit
  116. - Rewrite some of the guts to use Module::Runtime rather than reimplementing
  117. its functionality
  118. - BR: perl(Module::Runtime) ≥ 0.009
  119. - Drop all support for older distributions as required module
  120. Module::Runtime ≥ 0.009 will not be available prior to F-16
  121. * Tue Sep 6 2011 Paul Howarth <paul@city-fan.org> - 0.10-1
  122. - Update to 0.10:
  123. - Fix is_class_loaded to ignore $ISA (but still look for @ISA) when trying to
  124. determine whether a class is loaded
  125. - Lots of internals cleanup
  126. - BR: perl(Package::Stash) ≥ 0.32 and perl(Try::Tiny)
  127. - Update patches to apply cleanly
  128. * Tue Aug 16 2011 Paul Howarth <paul@city-fan.org> - 0.08-1
  129. - Update to 0.08:
  130. - The previous version was missing a prereq declaration for Data::OptList
  131. (CPAN RT#70285)
  132. - This release by DROLSKY -> update source URL
  133. - Package new documentation: LICENSE and README
  134. - Add build requirements for new release tests and run them:
  135. - perl(Pod::Coverage::Moose)
  136. - perl(Test::CPAN::Changes)
  137. - perl(Test::EOL)
  138. - perl(Test::NoTabs)
  139. - perl(Test::Pod)
  140. - perl(Test::Pod::Coverage)
  141. - perl(Test::Requires)
  142. - perl(Test::Spelling) and aspell-en
  143. - Add patch for building with ExtUtils::MakeMaker < 6.30
  144. - Add patch for building with Test::More < 0.88
  145. - Add patch for building without Test::Requires
  146. - Add patch for fixing spell checker word list
  147. - Don't try to run the POD Coverage test if we don't have Pod::Coverage::Moose
  148. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
  149. - Perl mass rebuild
  150. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  152. * Tue Dec 21 2010 Paul Howarth <paul@city-fan.org> - 0.06-3
  153. - Drop explicit dependency on core module perl(Exporter) (#656408)
  154. * Tue Nov 23 2010 Paul Howarth <paul@city-fan.org> - 0.06-2
  155. - Sanitize spec for Fedora submission
  156. * Mon Nov 22 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
  157. - Initial RPM version