perl-Carp-Clan-vl.spec 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. %define perl_sitelib %(eval "`perl -V:installsitelib`"; echo $installsitelib)
  2. Summary: Report errors from perspective of caller of a "clan" of modules for Perl
  3. Name: perl-Carp-Clan
  4. Version: 6.04
  5. Release: 3%{?_dist_release}
  6. License: distributable
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/S/ST/STBEY/Carp-Clan-%{version}.tar.gz
  9. URL: http://search.cpan.org/~stbey/Carp-Clan/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildArch: noarch
  12. BuildRequires: perl >= 5
  13. BuildRequires: perl(Test::Exception)
  14. Requires: perl >= 5
  15. Conflicts: perl-Bit-Vector <= 6.3
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. This module reports errors from the perspective of the caller of a
  20. "clan" of modules, similar to "Carp.pm" itself. But instead of giving
  21. it a number of levels to skip on the calling stack, you give it a
  22. pattern to characterize the package names of the "clan" of modules
  23. which shall never be blamed for any error. :-)
  24. So these modules stick together like a "clan" and any error which
  25. occurs will be blamed on the "outsider" script or modules not belonging
  26. to this "clan".
  27. %prep
  28. %setup -q -n Carp-Clan-%{version}
  29. %build
  30. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  31. make
  32. %install
  33. rm -rf %{buildroot}
  34. make DESTDIR=%{buildroot} pure_install
  35. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  36. find %{buildroot}%{_prefix} -type f -print |
  37. sed "s@^%{buildroot}@@g" |
  38. grep -v perllocal.pod |
  39. grep -v %{_mandir} |
  40. grep -v "\.packlist" > %{name}-filelist
  41. if [ "$(cat %{name}-filelist)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. %check
  46. make test
  47. %clean
  48. rm -rf %{buildroot}
  49. %files -f %{name}-filelist
  50. %defattr(-,root,root)
  51. %doc Changes license/Artistic.txt license/GNU_GPL.txt README
  52. %dir %{perl_vendorlib}/Carp
  53. %{_mandir}/man3/Carp::Clan.3pm*
  54. %changelog
  55. * Sun Jul 6 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 6.04-3
  56. - fix Conflicts
  57. * Tue Jul 1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 6.04-2
  58. - build with Perl 5.16
  59. - drop defining %%__find_provides and %%__find_requires
  60. - update BuildRequires and Conflicts
  61. * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 6.04-1
  62. - new upstrem release
  63. - add Vendor and Distribution tags
  64. - update files in doc
  65. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.00-1vl5
  66. - new upstream release
  67. - addede BuildRequires: perl-Test-Exception
  68. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.3-1vl5
  69. - applied new versioning policy
  70. - built with perl-5.10.0
  71. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 5.3-0vl1
  72. - initial release