perl-CPAN-Meta-YAML-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. # We don't really need ExtUtils::MakeMaker ≥ 6.30
  2. %global old_eumm %(perl -MExtUtils::MakeMaker -e 'print (($ExtUtils::MakeMaker::VERSION < 6.30) ? 1 : 0);' 2>/dev/null || echo 0)
  3. # We need to patch the test suite if we have Test::More < 0.88
  4. %global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
  5. Name: perl-CPAN-Meta-YAML
  6. Version: 0.005
  7. Release: 2%{?_dist_release}
  8. Summary: Read and write a subset of YAML for CPAN Meta files
  9. License: GPL+ or Artistic
  10. Group: Development/Libraries
  11. URL: http://search.cpan.org/dist/CPAN-Meta-YAML/
  12. Source0: http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/CPAN-Meta-YAML-%{version}.tar.gz
  13. Patch0: CPAN-Meta-YAML-0.004-old-EU::MM.patch
  14. Patch1: CPAN-Meta-YAML-0.004-old-Test::More.patch
  15. Patch2: CPAN-Meta-YAML-0.004-old-Scalar::Util.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  17. BuildArch: noarch
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(File::Spec)
  20. BuildRequires: perl(Test::CPAN::Meta)
  21. BuildRequires: perl(Test::More)
  22. BuildRequires: perl(Test::Pod)
  23. # RHEL <= 6 doesn't have a recent enough perl(version) for perl(Test::Version)
  24. %if 0%{?fedora} || 0%{?rhel} > 6
  25. BuildRequires: perl(Test::Version)
  26. %endif
  27. BuildRequires: perl(YAML)
  28. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: shaolin
  32. %description
  33. This module implements a subset of the YAML specification for use in reading
  34. and writing CPAN metadata files like META.yml and MYMETA.yml. It should not be
  35. used for any other general YAML parsing or generation task.
  36. %prep
  37. %setup -q -n CPAN-Meta-YAML-%{version}
  38. # We don't really need ExtUtils::MakeMaker ≥ 6.30
  39. %if %{old_eumm}
  40. %patch0 -p1
  41. %endif
  42. # We need to patch the test suite if we have Test::More < 0.88
  43. %if %{old_test_more}
  44. %patch1 -p1
  45. %endif
  46. # Fix operation with Scalar::Util < 1.18 properly (CPAN RT#53490)
  47. %patch2 -p1
  48. %build
  49. perl Makefile.PL
  50. make %{?_smp_mflags}
  51. %install
  52. rm -rf %{buildroot}
  53. make pure_install DESTDIR=%{buildroot}
  54. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  55. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  56. %{_fixperms} %{buildroot}
  57. %check
  58. make test TEST_FILES="t/*.t xt/*/*.t"
  59. %clean
  60. rm -rf %{buildroot}
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc Changes LICENSE README
  64. %{perl_sitelib}/CPAN/
  65. %{_mandir}/man3/CPAN::Meta::YAML.3pm*
  66. %changelog
  67. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.005-2
  68. - rebuild
  69. * Tue Feb 21 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.005-1
  70. - initial package for Vine Linux
  71. * Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.005-2
  72. - Fedora 17 mass rebuild
  73. * Tue Dec 13 2011 Paul Howarth <paul@city-fan.org> - 0.005-1
  74. - Update to 0.005:
  75. - Fix documentation to clarify that users are responsible for UTF-8
  76. encoding/decoding
  77. * Wed Sep 7 2011 Paul Howarth <paul@city-fan.org> - 0.004-1
  78. - Update to 0.004:
  79. - Generated from ADAMK/YAML-Tiny-1.50.tar.gz
  80. - BR: perl(Test::Version) for additional test coverage
  81. - Update patch for building with ExtUtils::MakeMaker < 6.30
  82. - Add patch to support building with Test::More < 0.88
  83. - Add patch to fix operation with Scalar::Util < 1.18
  84. * Tue Aug 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.003-7
  85. - Install to vendor perl directories to avoid potential debuginfo conflicts
  86. with the main perl package if this module ever becomes arch-specific
  87. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.003-6
  88. - Perl mass rebuild
  89. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.003-4
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  91. * Thu Jan 27 2011 Paul Howarth <paul@city-fan.org> - 0.003-3
  92. - Trim %%description (#672807)
  93. * Wed Jan 26 2011 Paul Howarth <paul@city-fan.org> - 0.003-2
  94. - Sanitize for Fedora submission
  95. * Tue Jan 25 2011 Paul Howarth <paul@city-fan.org> - 0.003-1
  96. - Initial RPM version