perl-Bit-Vector-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. Summary: Efficient bit vector, set of integers and "big int" math library
  2. Name: perl-Bit-Vector
  3. Version: 7.4
  4. Release: 1%{?_dist_release}
  5. Group: Development/Libraries
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: distributable
  9. URL: https://metacpan.org/pod/distribution/Bit-Vector/Vector.pod
  10. Source0: https://cpan.metacpan.org/authors/id/S/ST/STBEY/Bit-Vector-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: perl
  13. BuildRequires: perl(Carp::Clan) >= 5.3
  14. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  15. Requires: perl(Carp::Clan) >= 5.3
  16. Conflicts: perl-Date-Calc < 5.0
  17. %description
  18. Bit::Vector is an efficient C library which allows you to handle
  19. bit vectors, sets (of integers), "big integer arithmetic" and
  20. boolean matrices, all of arbitrary sizes.
  21. The library is efficient (in terms of algorithmical complexity)
  22. and therefore fast (in terms of execution speed) for instance
  23. through the widespread use of divide-and-conquer algorithms.
  24. The package also includes an object-oriented Perl module for
  25. accessing the C library from Perl, and optionally features
  26. overloaded operators for maximum ease of use.
  27. The C library can nevertheless be used stand-alone, without Perl.
  28. %prep
  29. %setup -q -n Bit-Vector-%{version}
  30. %build
  31. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  32. make
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. make DESTDIR=$RPM_BUILD_ROOT pure_install
  36. find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
  37. sed "s@^$RPM_BUILD_ROOT@@g" | \
  38. grep -v perllocal.pod | \
  39. grep -v %{_mandir} | \
  40. grep -v "\.packlist" > Bit-Vector-%{version}-filelist
  41. if [ "$(cat Bit-Vector-%{version}-filelist)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
  46. find examples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
  47. rm -f %{buildroot}%{perl_vendorarch}/auto/Bit/Vector/.packlist
  48. %check
  49. make test
  50. %clean
  51. rm -rf $RPM_BUILD_ROOT
  52. %files -f Bit-Vector-%{version}-filelist
  53. %defattr(-,root,root)
  54. %license Artistic.txt GNU_GPL.txt GNU_LGPL.txt
  55. %doc CHANGES.txt CREDITS.txt README.txt examples
  56. %dir %{perl_vendorarch}/auto/Bit
  57. %dir %{perl_vendorarch}/auto/Bit/Vector
  58. %dir %{perl_vendorarch}/Bit
  59. %dir %{perl_vendorarch}/Bit/Vector
  60. %{_mandir}/man3/*3pm*
  61. %changelog
  62. * Thu Oct 31 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4-1
  63. - new upstream release.
  64. * Sun Jul 6 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 7.3-1
  65. - build with Perl 5.16
  66. - update Requires and BuildRequires
  67. * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 7.1-1
  68. - new upstream release
  69. - add Vendor and Distribution tags
  70. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4-1
  71. - new upstream release
  72. - built with perl-5.10.0
  73. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 6.4-0vl1
  74. - new upstream release
  75. - update Summary and description
  76. - add Requires: perl-Carp-Clan >= 5.3
  77. - add some license documents
  78. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 6.3-0vl1
  79. - version up to 6.3
  80. - add directories in %%files section
  81. - add some documents
  82. - add Conflicts: perl-Date-Calc < 5.0
  83. * Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 6.1-12vl1
  84. - build Rawhide-6.1-12 for Vine Linux
  85. * Wed Jan 30 2002 cturner@redhat.com
  86. - Specfile autogenerated