pdflib-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. Summary: Portable C library for dynamically generating PDF files.
  2. Summary(ja): PDF ファイルをダイナミックに生成する C ライブラリ
  3. Name: pdflib
  4. Version: 4.0.1
  5. Release: 1%{?_dist_release}
  6. Group: Development/Libraries
  7. License: Aladdin Free Public License
  8. URL: http://www.pdflib.com/
  9. Source: http://www.pdflib.com/pdflib/download/%{name}-%{version}.tar.gz
  10. Patch0: pdflib-4.0.1-config_sub.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. %description
  15. PDFlib is a C library for generating PDF files. It offers a graphics
  16. API with support for drawing, text, fonts, images, and hypertext. Call PDFlib
  17. routines from within your client program and voila: dynamic PDF files!
  18. For detailed instructions on PDFlib programming and the associated API,
  19. see the PDFlib Programming Manual, included in PDF format in the
  20. PDFlib distribution.
  21. %description -l ja
  22. PDFlib は PDF ファイルを作成するのに使われる C のライブラリです.
  23. グラフィクス API が提供されており,図形,テキスト,フォント,画像,
  24. ハイパーテキスト等がサポートされています.PDFlib のルーチンを
  25. プログラムから利用すれば,ダイナミック PDF ファイルの出来上がりです.
  26. PDFlib プログラミングや API に関するくわしい説明は,PDFlib プログラミング
  27. マニュアルに書かれており,その PDF ファイルが附属しています.
  28. %package devel
  29. Group: Development/Libraries
  30. Summary: Header file for pdflib
  31. Summary(ja): PDFlib 用のヘッダファイル
  32. %description devel
  33. This package contains the files needed for compiling programs using
  34. the PDF library.
  35. %description devel -l ja
  36. このパッケージには PDF ライブラリを使ったプログラムのコンパイルに
  37. 必要な各種ファイルが収められています.
  38. #%package perl5
  39. #Group: Development/Libraries
  40. #Summary: PDFlib bindings for Perl5
  41. #Summary(ja): Perl5 用 PDFlib バインディング
  42. #
  43. #
  44. #%description perl5
  45. #This package contains perl bindings for the pdflib library.
  46. #
  47. #%description perl5 -l ja
  48. #このパッケージには PDFlib ライブラリへの Perl バインディングが
  49. #収められています.
  50. #%package python1.5
  51. #Group: Development/Libraries
  52. #Summary: PDFlib bindings for Python 1.5
  53. #Summary(ja): Python 1.5 用 PDFlib バインディング
  54. #
  55. #
  56. #%description python1.5
  57. #This package contains python bindings for the pdflib library.
  58. #
  59. #%description python1.5 -l ja
  60. #このパッケージには PDFlib ライブラリへの Python バインディングが
  61. #収められています.
  62. #%package tcl8.0
  63. #Group: Development/Libraries
  64. #Summary: PDFlib bindings for Tcl 8.0
  65. #Summary(ja): Tcl 8.0 用 PDFlib バインディング
  66. #
  67. #
  68. #%description tcl8.0
  69. #This package contains tcl bindings for the pdflib library.
  70. #
  71. #%description tcl8.0 -l ja
  72. #このパッケージには PDFlib ライブラリへの Tcl バインディングが
  73. #収められています.
  74. #%package java1.2
  75. #Group: Development/Libraries
  76. #Summary: PDFlib bindings for Java 1.2
  77. #Summary(ja): Java 1.2 用 PDFlib バインディング
  78. #
  79. #
  80. #%description java1.2
  81. #This package contains java bindings for the pdflib library.
  82. #
  83. #%description java1.2 -l ja
  84. #このパッケージには PDFlib ライブラリへの Java バインディングが
  85. #収められています.
  86. %prep
  87. %setup -q
  88. %patch0 -p1 -b .config_sub
  89. %build
  90. %configure --with-perl=no --with-py=no --with-tcl=no --with-java=no
  91. make
  92. %install
  93. rm -rf ${RPM_BUILD_ROOT}
  94. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  95. %makeinstall
  96. %clean
  97. rm -rf ${RPM_BUILD_ROOT}
  98. %post
  99. /sbin/ldconfig
  100. %postun
  101. /sbin/ldconfig
  102. #%post java1.2
  103. #/sbin/ldconfig
  104. #%postun java1.2
  105. #/sbin/ldconfig
  106. %files
  107. %defattr(-,root,root)
  108. %{_bindir}/*
  109. %attr(755,root,root) %{_libdir}/libpdf.so.*
  110. %exclude %{_libdir}/libpdf.la
  111. %files devel
  112. %defattr(-,root,root)
  113. %doc readme.txt doc/*
  114. %{_includedir}/pdflib.h
  115. %{_libdir}/libpdf.so
  116. %exclude %{_libdir}/libpdf.a
  117. #%files perl5
  118. #%defattr(-,root,root)
  119. #/usr/lib/perl5
  120. #%files python1.5
  121. #%defattr(-,root,root)
  122. #/usr/lib/python1.5
  123. #%files tcl8.0
  124. #%defattr(-,root,root)
  125. #/usr/lib/tcl8.0
  126. #%files java1.2
  127. #%defattr(-,root,root)
  128. #%doc /usr/local/jdk1.2/docs
  129. #/usr/lib/libpdf_java.*
  130. #/usr/local/jdk1.2/jre
  131. %changelog
  132. * Mon Dec 20 2010 Shu KONNO <owa@bg.wakwak.com> 4.0.1-1
  133. - changed spec file as vine5 style, and spec in utf-8
  134. - s/Copyright/License/
  135. - added pdflib-4.0.1-config_sub.patch
  136. - exclude %{_libdir}/libpdf.{a,la}
  137. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.1-0vl3
  138. - fixed %%defattr
  139. * Fri Jun 22 2001 <sagami@vinelinux.org>
  140. - 4.0.1-0vl2: correct Group
  141. * Thu Jun 21 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  142. - updated to new upstream 4.0.1 release
  143. - disable {perl,python,tcl} subpackages at the moment
  144. * Sun May 20 2001 Henrik Seidel <Henrik.Seidel@gmx.de>
  145. - upgraded to 4.0.0
  146. * Thu Oct 19 2000 Henrik Seidel <Henrik.Seidel@gmx.de>
  147. - upgraded to 3.02
  148. * Thu Mar 9 2000 Henrik Seidel <Henrik.Seidel@gmx.de>
  149. - upgraded to 3.0
  150. * Tue Sep 14 1999 Henrik Seidel <Henrik.Seidel@gmx.de>
  151. - upgraded to 2.01
  152. * Tue Jul 27 1999 Henrik Seidel <Henrik.Seidel@gmx.de>
  153. - initial revision