pcre-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: pcre
  3. Version: 8.44
  4. Release: 1%{?_dist_release}
  5. Summary: Perl-compatible regular expression library
  6. Summary(ja): Perl 互換の正規表現ライブラリ
  7. Group: System Environment/Libraries
  8. License: BSD
  9. URL: http://www.pcre.org/
  10. Source0: https://ftp.pcre.org/pub/pcre/%{name}-%{version}.tar.bz2
  11. # Upstream thinks RPATH is good idea.
  12. Patch0: pcre-8.21-multilib.patch
  13. # Refused by upstream, bug #675477
  14. Patch1: pcre-8.32-refused_spelling_terminated.patch
  15. # Fix recursion stack estimator, upstream bug #2173, refused by upstream
  16. Patch2: pcre-8.41-fix_stack_estimator.patch
  17. # Link applications to PCRE-specific symbols when using POSIX API, bug #1667614,
  18. # upstream bug 1830, partially borrowed from PCRE2, proposed to upstream,
  19. # This amends ABI, application built with this patch cannot run with
  20. # previous libpcreposix builds.
  21. Patch3: pcre-8.42-Declare-POSIX-regex-function-names-as-macros-to-PCRE.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: zlib-devel
  24. BuildRequires: bzip2-devel
  25. BuildRequires: libedit-devel
  26. # New libtool to get rid of rpath
  27. BuildRequires: autoconf, automake, libtool
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: inagaki
  31. %description
  32. Perl-compatible regular expression library.
  33. PCRE has its own native API, but a set of "wrapper" functions that are based on
  34. the POSIX API are also supplied in the library libpcreposix. Note that this
  35. just provides a POSIX calling interface to PCRE: the regular expressions
  36. themselves still follow Perl syntax and semantics. The header file
  37. for the POSIX-style functions is called pcreposix.h.
  38. %package devel
  39. Summary: Development files for %{name}
  40. Summary(ja): %{name} の開発用ファイル
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. %description devel
  44. Development files (Headers, libraries for static linking, etc) for %{name}.
  45. %package -n compat32-%{name}
  46. Summary: Perl-compatible regular expression library
  47. Summary(ja): Perl 互換の正規表現ライブラリ
  48. Group: System Environment/Libraries
  49. %description -n compat32-%{name}
  50. Perl-compatible regular expression library.
  51. PCRE has its own native API, but a set of "wrapper" functions that are based on
  52. the POSIX API are also supplied in the library libpcreposix. Note that this
  53. just provides a POSIX calling interface to PCRE: the regular expressions
  54. themselves still follow Perl syntax and semantics. The header file
  55. for the POSIX-style functions is called pcreposix.h.
  56. %package -n compat32-%{name}-devel
  57. Summary: Development files for %{name}
  58. Summary(ja): %{name} の開発用ファイル
  59. Group: Development/Libraries
  60. Requires: compat32-%{name} = %{version}-%{release}
  61. %description -n compat32-%{name}-devel
  62. Development files (Headers, libraries for static linking, etc) for %{name}.
  63. %prep
  64. %setup -q
  65. # Get rid of rpath
  66. %patch0 -p1 -b .multilib
  67. %patch1 -p1 -b .terminated_typos
  68. %patch2 -p2
  69. %patch3 -p1
  70. # Because of rpath patch
  71. libtoolize --copy --force && autoreconf -vif
  72. # One contributor's name is non-UTF-8
  73. for F in ChangeLog; do
  74. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  75. touch --reference "$F" "${F}.utf8"
  76. mv "${F}.utf8" "$F"
  77. done
  78. %build
  79. %configure \
  80. --enable-jit \
  81. --disable-static \
  82. --enable-utf8 \
  83. --enable-unicode-properties \
  84. --enable-pcregrep-libz \
  85. --enable-pcregrep-libbz2 \
  86. --enable-pcretest-libedit \
  87. --enable-pcre8 \
  88. --enable-pcre16 \
  89. --enable-pcre32
  90. make %{?_smp_mflags}
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  96. %check
  97. %ifarch s390 s390x ppc
  98. # larger stack is needed on s390, ppc
  99. ulimit -s 10240
  100. %endif
  101. make %{?_smp_mflags} check VERBOSE=yes
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %post -p /sbin/ldconfig
  105. %postun -p /sbin/ldconfig
  106. %post -n compat32-%{name} -p /sbin/ldconfig
  107. %postun -n compat32-%{name} -p /sbin/ldconfig
  108. %files
  109. %defattr(-,root,root)
  110. %license COPYING LICENCE
  111. %doc AUTHORS ChangeLog NEWS README
  112. %{_bindir}/pcregrep
  113. %{_libdir}/*.so.*
  114. %{_mandir}/man1/pcregrep.*
  115. %files devel
  116. %defattr(-,root,root)
  117. %doc doc/html/*
  118. %{_bindir}/pcre-config
  119. %{_bindir}/pcretest
  120. %{_includedir}/*
  121. %{_libdir}/*.so
  122. %{_libdir}/pkgconfig/*.pc
  123. %{_mandir}/man1/pcre-config.*
  124. %{_mandir}/man1/pcretest.*
  125. %{_mandir}/man3/*
  126. %if %{build_compat32}
  127. %files -n compat32-%{name}
  128. %defattr(-, root, root)
  129. %{_libdir}/*.so.*
  130. %files -n compat32-%{name}-devel
  131. %defattr(-, root, root)
  132. %{_libdir}/*.so
  133. %endif
  134. %changelog
  135. * Sun Mar 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.44-1
  136. - new upstream release.
  137. * Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.43-1
  138. - new upstream release.
  139. - imported Patch2 and 3 from rawhide.
  140. * Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
  141. - create comapt32 packages
  142. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  143. - new upstream release.
  144. - dropped Patch1000,1001: fixed in upstream.
  145. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  146. - new upstream release.
  147. - removed Patch2,Patch3 (no longer needed).
  148. - added Patch1000 to fix CVE-2016-1283.
  149. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  150. - new upstream release
  151. - added patches including security fix from Fedora (CVE-2014-8964)
  152. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  153. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  154. (bug #1165626)
  155. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  156. - Reset non-matched groups within capturing group up to forced match
  157. (bug #1161587)
  158. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  159. - Fix typos in manual pages (bugs #675476, #675477)
  160. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  161. - new upstream release
  162. - add --enable-pcre32 and --enable-pcretest-libedit
  163. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  164. - new upstream release
  165. - add --enable-pcre16 --enable-pcre8 --enable-jit
  166. - API change
  167. - change includedir to /usr/include
  168. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  169. - new upstream release
  170. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  171. - new upstream release
  172. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  173. - rebuilt with rpm-4.8.1 for pkg-config
  174. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  175. - new upstream release
  176. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  177. - new upstream release with security fix
  178. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  179. - new upstream release
  180. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  181. - new upstream release
  182. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  183. - add --enable-unicode-properties to configure option
  184. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  185. - new upstream release
  186. - added BR: zlib-devel, bzip2-devel
  187. - removed static libraries from devel package
  188. - added Packager tag
  189. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  190. - new upstream release
  191. - spec in UTF-8
  192. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  193. - new upstream release
  194. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  195. - use macro for Release
  196. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  197. - apply new virsioning policy.
  198. - remove *.la
  199. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  200. - new upstream release
  201. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  202. - new upstream release
  203. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  204. - new upstream release
  205. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  206. - rebuild with new environment/toolchain
  207. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  208. - new upstream release
  209. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  210. - added --enable-utf8 option
  211. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  212. - new upstream release
  213. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  214. - new upstream release
  215. - added Japanese summary
  216. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  217. - new upstream release
  218. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  219. - new upstream release
  220. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  221. - skip 'make check' on alpha
  222. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  223. - change install section
  224. - change files section
  225. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  226. - update to 4.1
  227. - add %{_bindir}/pcretest
  228. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  229. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  230. - rebuild with new toolchains
  231. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  232. - Update to 3.9
  233. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  234. - Update to 3.7
  235. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  236. - Update to 3.5
  237. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  238. - Build for VineSeed
  239. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  240. - Move libpcre to /lib, grep uses it these days (#41104)
  241. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  242. - Move this to a separate package, used to be in kdesupport, but it's
  243. generally useful...