pciutils-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: PCI bus related utilities.
  3. Summary(ja): Linux PCI ユーティリティ
  4. Name: pciutils
  5. Version: 3.6.4
  6. Release: 1%{?_dist_release}
  7. Group: Applications/System
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
  12. Source: https://mirrors.edge.kernel.org/pub/software/utils/pciutils/pciutils-%{version}.tar.xz
  13. #change pci.ids directory to hwdata, fedora/rhel specific
  14. Patch1: pciutils-2.2.1-idpath.patch
  15. #add support for directory with another pci.ids, rejected by upstream, rhbz#195327
  16. Patch2: pciutils-dir-d.patch
  17. Buildroot: %{_tmppath}/%{name}-%{version}-root
  18. ExclusiveOS: Linux
  19. BuildRequires: sed
  20. Requires: hwdata
  21. Requires: %{name}-libs = %{version}-%{release}
  22. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  23. %description
  24. The pciutils package contains various utilities for inspecting and
  25. setting devices connected to the PCI bus. The utilities provided
  26. require kernel version 2.1.82 or newer (which support the
  27. /proc/bus/pci interface).
  28. %description -l ja
  29. このパッケージには PCI バスに接続された各種デバイスの状態を見たり
  30. 設定したりする為のユーティリティが収められています.
  31. このパッケージに収められたユーティリティはカーネル 2.1.82 以降
  32. (/proc/bus/pci インタフェースがサポートされているもの) を必要とします.
  33. %package devel
  34. Summary: Linux PCI development library.
  35. Summary(ja): Linux PCI 開発ライブラリ
  36. Group: Development/Libraries
  37. Requires: %{name}-libs = %{version}-%{release}
  38. Provides: pkgconfig(libpci) = %{version}
  39. %description devel
  40. This package contains a library for inspecting and setting
  41. devices connected to the PCI bus.
  42. %description devel -l ja
  43. このパッケージには PCI バスに接続された各種デバイスの状態を見たり
  44. 設定したりするのに必要なライブラリが収められています.
  45. %package libs
  46. Summary: Linux PCI library
  47. Summary(ja): Linux PCI ライブラリ
  48. Group: System Environment/Libraries
  49. %description libs
  50. This package contains a library for inspecting and setting
  51. devices connected to the PCI bus.
  52. %package static
  53. Summary: Linux PCI satic library
  54. Summary(ja): Linux PCI スタッティックライブラリ
  55. Group: System Environment/Libraries
  56. Requires: %{name}-devel = %{version}-%{release}
  57. %description static
  58. This package contains a library for inspecting and setting
  59. devices connected to the PCI bus.
  60. ## to build compat32 for x86_64 architecture support
  61. %package -n compat32-%{name}-libs
  62. Summary: Linux PCI library.
  63. Group: Development/Libraries
  64. Requires: compat32-%{name}-devel = %{version}-%{release}
  65. %description -n compat32-%{name}-libs
  66. This package contains a library for inspecting and setting
  67. devices connected to the PCI bus.
  68. %package -n compat32-%{name}-devel
  69. Summary: Linux PCI development library.
  70. Group: Development/Libraries
  71. %description -n compat32-%{name}-devel
  72. This package contains a library for inspecting and setting
  73. devices connected to the PCI bus.
  74. %prep
  75. %setup -q -n pciutils-%{version}
  76. %autopatch -p1
  77. sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
  78. %build
  79. make SHARED="no" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
  80. mv lib/libpci.a lib/libpci.a.toinstall
  81. make clean
  82. make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
  83. #fix lib vs. lib64 in libpci.pc (static Makefile is used)
  84. sed -i -e "s|^libdir=.*$|libdir=%{_libdir}|" lib/libpci.pc
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. install -d $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8,%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/pci}
  88. install -p lspci setpci update-pciids $RPM_BUILD_ROOT/sbin
  89. install -p lspci.8 setpci.8 update-pciids.8 $RPM_BUILD_ROOT%{_mandir}/man8
  90. install -p lib/libpci.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
  91. ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libpci.so
  92. mv lib/libpci.a.toinstall lib/libpci.a
  93. install -p lib/libpci.a $RPM_BUILD_ROOT%{_libdir}
  94. /sbin/ldconfig -N $RPM_BUILD_ROOT%{_libdir}
  95. install -p lib/pci.h $RPM_BUILD_ROOT%{_includedir}/pci
  96. install -p lib/header.h $RPM_BUILD_ROOT%{_includedir}/pci
  97. install -p lib/config.h $RPM_BUILD_ROOT%{_includedir}/pci
  98. install -p lib/types.h $RPM_BUILD_ROOT%{_includedir}/pci
  99. install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  100. %post libs -p /sbin/ldconfig
  101. %postun libs -p /sbin/ldconfig
  102. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  103. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  104. %files
  105. %defattr(-,root,root,-)
  106. %{_mandir}/man8/*
  107. %attr(0755, root, root) /sbin/*
  108. %license COPYING
  109. %doc README ChangeLog pciutils.lsm
  110. %files devel
  111. %defattr(-,root,root,-)
  112. %{_libdir}/libpci.so
  113. %{_libdir}/pkgconfig/libpci.pc
  114. %{_includedir}/pci
  115. %files libs
  116. %defattr(-,root,root,-)
  117. %{_libdir}/libpci.so.*
  118. %files static
  119. %defattr(-,root,root,-)
  120. %{_libdir}/libpci.a
  121. %if %{build_compat32}
  122. %files -n compat32-%{name}-devel
  123. %defattr(-,root,root,-)
  124. %{_libdir}/libpci.so
  125. %{_libdir}/pkgconfig/libpci.pc
  126. %{_includedir}/pci
  127. %files -n compat32-%{name}-libs
  128. %defattr(-,root,root,-)
  129. %{_libdir}/libpci.so.*
  130. %endif
  131. %clean
  132. rm -rf $RPM_BUILD_ROOT
  133. %changelog
  134. * Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
  135. - new upstream release.
  136. - dropped all patches.
  137. - imported Patch0-2 from rawhide.
  138. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  139. - new upstream release
  140. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  141. - new upstream release
  142. * Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
  143. - new upstream release
  144. - update Patch3 (pciutils-havepread.patch)
  145. * Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
  146. - new upstream release
  147. - update Patch8 (pciutils-3.3.0-multilib.patch)
  148. * Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  149. - new upstream release
  150. * Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
  151. - new upstream release
  152. * Sun Oct 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.8-1
  153. - new upstream release
  154. - remove Patch1 (pciutils-2.2.4-buf.patch)
  155. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
  156. - rebuilt with rpm-4.8.1 for pkg-config
  157. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-3
  158. - add Requires: %{name}-libs = %{version}-%{release} (devel package)
  159. * Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-2
  160. - removed %%if !%%{build_compat32} case condition
  161. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.2-1
  162. - new upstream release
  163. - add shared library
  164. - split shared library to -libs
  165. - split static library to -static
  166. * Fri Nov 7 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
  167. - new upstream release
  168. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1vl5
  169. - new upstream release
  170. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.4-1vl5
  171. - applied new versioning policy, spec in utf-8
  172. * Wed Dec 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
  173. - new upstream release
  174. * Sun Feb 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.1-1vl2
  175. - rebuilt for x86_64 architecture support
  176. - added compat32-* packages for x86_64 architecture support
  177. * Sun Dec 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-1vl1
  178. - updated to 2.2.1 based on fedora package
  179. * Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-8
  180. - add patch for glibc macros (#151032, <redhat-bugzilla@linuxnetz.de>)
  181. * Tue Jan 25 2005 Bill Nottingham <notting@redhat.com> - 2.1.99.test8-6
  182. - remove explicit kernel dep (#146153)
  183. * Sat Nov 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-4vl1
  184. - use hwdata for pci.ids database.
  185. - merged with rawhide package.
  186. - update to 2.1.10
  187. - fix dir perms on /usr/include/pci
  188. - don't forcibly strip binaries
  189. - require hwdata now that pci.ids is there
  190. - man page is now owned by root
  191. * Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.8-25vl1
  192. - based on 2.1.8-25 from Rawhide and rebuilt for Vine Linux
  193. * Wed Oct 17 2001 Bill Nottingham <notting@redhat.com>
  194. - dump all the patches, ship pci.ids direct out of sourceforge CVS
  195. * Wed Sep 26 2001 Bill Nottingham <notting@redhat.com>
  196. - broadcom bcm5820 id (#53592)
  197. * Fri Aug 10 2001 Bill Nottingham <notting@redhat.com>
  198. - more ids
  199. * Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
  200. - add newline in printf in PCI-X patch (#49277)
  201. * Mon Jul 9 2001 Bill Nottingham <notting@redhat.com>
  202. - update broadcom patch
  203. - add new ids from 2.4.6
  204. * Mon May 28 2001 Bill Nottingham <notting@redhat.com>
  205. - add a couple of e1000 ids
  206. * Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
  207. - another megaraid id
  208. * Wed Mar 21 2001 Bill Nottingham <notting@redhat.com>
  209. - another megaraid id
  210. * Wed Mar 14 2001 Preston Brown <pbrown@redhat.com>
  211. - LSI SCSI PCI id
  212. * Wed Feb 21 2001 Nalin Dahyabhai <nalin@redhat.com>
  213. - fix formatting problems
  214. * Wed Feb 21 2001 Preston Brown <pbrown@redhat.com>
  215. - add IBM ServeRAID entries
  216. * Tue Feb 20 2001 Preston Brown <pbrown@redhat.com>
  217. - i860 entries.
  218. * Mon Feb 19 2001 Helge Deller <hdeller@redhat.de>
  219. - added various pci ids
  220. * Fri Feb 2 2001 Bill Nottingham <notting@redhat.com>
  221. - fix mishap in fixing mishap
  222. * Thu Feb 1 2001 Bill Nottingham <notting@redhat.com>
  223. - fix apparent mishap in pci.ids update from kernel (#25520)
  224. * Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
  225. - pci.ids updates
  226. * Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
  227. - big pile of pci.ids updates
  228. * Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  229. - clean up patches to not generate badly-formatted files
  230. * Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
  231. - Vortex fixes laroche originally applied on kudzu moved here.
  232. * Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
  233. - pci ids for i815, new ati hardware
  234. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  235. - automatic rebuild
  236. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  237. - yet more IDs
  238. - PCI-X support from Matt Domsch
  239. * Fri Jul 7 2000 Bill Nottingham <notting@redhat.com>
  240. - some more QLogic ids
  241. * Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
  242. - more IDs from Dell
  243. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  244. - update to 2.1.8
  245. * Fri Apr 21 2000 Bill Nottingham <notting@redhat.com>
  246. - update to 2.1.7
  247. * Mon Apr 17 2000 Bill Nottingham <notting@redhat.com>
  248. - update to 2.1.6
  249. * Fri Mar 3 2000 Bill Nottingham <notting@redhat.com>
  250. - add a couple of ids
  251. * Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
  252. - update to 2.1.5
  253. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  254. - handle compressed man pages
  255. * Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
  256. - update to 2.1.4
  257. * Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
  258. - update to 2.1.3
  259. * Fri Dec 24 1999 Bill Nottingham <notting@redhat.com>
  260. - update to 2.1.2
  261. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  262. - add -devel package
  263. * Thu May 20 1999 Bill Nottingham <notting@redhat.com>
  264. - update to 2.0
  265. * Mon Apr 19 1999 Jakub Jelinek <jj@ultra.linux.cz>
  266. - update to 1.99.5
  267. - fix sparc64 operation
  268. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  269. - auto rebuild in the new build environment (release 2)
  270. * Thu Feb 4 1999 Bill Nottingham <notting@redhat.com>
  271. - initial build