parole-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214
  1. # by default don't build the browser plugin
  2. # use bcond_without to change the default
  3. #%bcond_with mozilla
  4. %define PAROLE_BIN %{_libexecdir}/%{name}
  5. Name: parole
  6. Version: 0.8.1
  7. Release: 1%{?_dist_release}
  8. Summary: Media player for the Xfce desktop
  9. Summary(ja): Xfce デスクトップのメディアプレーヤー
  10. Group: Applications/Multimedia
  11. License: GPLv2+
  12. URL: http://goodies.xfce.org/projects/applications/parole
  13. Source0: http://archive.xfce.org/src/apps/parole/0.8/%{name}-%{version}.tar.bz2
  14. Source10: parole.sh
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: clutter-devel >= 1.16.4
  17. BuildRequires: clutter-gtk-devel >= 1.4.4
  18. BuildRequires: dbus-devel >= 0.60
  19. BuildRequires: dbus-glib-devel >= 0.70
  20. BuildRequires: desktop-file-utils
  21. BuildRequires: gettext
  22. BuildRequires: glib2-devel >= 2.32.0
  23. BuildRequires: gstreamer1-devel
  24. BuildRequires: gstreamer1-plugins-base-devel
  25. BuildRequires: gtk3-devel >= 3.2.0
  26. BuildRequires: gtk-doc
  27. BuildRequires: intltool
  28. BuildRequires: libnotify-devel >= 0.4.1
  29. BuildRequires: libxfce4ui-devel >= 4.11.0
  30. BuildRequires: libxfce4util-devel >= 4.10.0
  31. BuildRequires: taglib-devel >= 1.4
  32. BuildRequires: xfce4-dev-tools
  33. BuildRequires: xfconf-devel >= 4.10.0
  34. #%if %{with mozilla}
  35. #BuildRequires: xulrunner-devel
  36. #%endif
  37. Requires: gstreamer1-plugins-good
  38. Obsoletes: %{name}-mozplugin
  39. %description
  40. Parole is a modern simple media player based on the GStreamer framework and
  41. written to fit well in the Xfce desktop. Parole features playback of local
  42. media files, DVD/CD and live streams. Parole is extensible via plugins.
  43. The project still in its early developments stage, but already contains the
  44. following features:
  45. * Audio playback
  46. * Video playback with optional subtitle
  47. * Playback of live sources
  48. %description -l ja
  49. Parole は GStreamer フレームワークに基づき Xfce デスクトップに
  50. 馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
  51. Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
  52. 特色とします。
  53. Parole はプラグインを介して拡張が可能です。
  54. このプロジェクトはまだ開発の初期段階ですが、
  55. 既に以下の機能がふくまれています。
  56. * オーディオの再生
  57. * 任意のサブタイトルがあるビデオの再生
  58. * ライブストリームの再生
  59. %package devel
  60. Summary: Development files for %{name}
  61. Summary(ja): %{name} の開発ファイル
  62. Group: Development/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. %description devel
  65. The %{name}-devel package contains header files for developing plugins for
  66. %{name}.
  67. %description devel -l ja
  68. %{name}-devel パッケージ は %{name} のプラグインを開発するための
  69. ヘッダファイルを含みます。
  70. %prep
  71. %setup -q
  72. %build
  73. %configure --disable-static --enable-gtk-doc --enable-clutter
  74. make %{?_smp_mflags} V=1
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  79. ## wrapper install
  80. mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
  81. mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
  82. install -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  83. %find_lang %{name}
  84. desktop-file-install \
  85. --delete-original \
  86. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  87. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %post
  91. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  92. update-mime-database %{_datadir}/mime &> /dev/null || :
  93. %postun
  94. if [ $1 -eq 0 ] ; then
  95. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  96. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  97. fi
  98. update-mime-database %{_datadir}/mime &> /dev/null || :
  99. %posttrans
  100. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  101. %files -f %{name}.lang
  102. %defattr(-,root,root,-)
  103. %doc AUTHORS COPYING README TODO THANKS
  104. %{PAROLE_BIN}
  105. %{_bindir}/%{name}
  106. %dir %{_libdir}/%{name}-0
  107. %{_libdir}/%{name}-0/*.so
  108. %{_datadir}/appdata/%{name}.appdata.xml
  109. %{_datadir}/applications/%{name}.desktop
  110. %{_datadir}/icons/hicolor/*
  111. %{_datadir}/%{name}
  112. %files devel
  113. %defattr(-,root,root,-)
  114. %doc %{_datadir}/gtk-doc/html/Parole-Plugins/
  115. %{_includedir}/%{name}
  116. %changelog
  117. * Sat Dec 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.1-1
  118. - new upstream release
  119. * Sun Mar 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-1
  120. - new upstream release
  121. - updated to SOURCE10
  122. - built with libxfce4util 4.12.1 and gstreamer1-plugins
  123. * Sat Jul 12 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
  124. - new upstream release
  125. * Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  126. - new upstream release
  127. * Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
  128. - new upstream release
  129. - deleted Patch1
  130. - added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
  131. - changed BuildRequires
  132. - gtk2-devel >= 2.16.0 to 2.20.0
  133. - glib2-devel >= 2.16.0 to 2.32.0
  134. - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
  135. - libxfcegui4-devel >= 4.6.0 to 4.8.0
  136. - libxfce4util-devel >= 4.6.0 to 4.8.0
  137. * Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
  138. - rebuilt with new libxfce4util
  139. * Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
  140. - added Obsoletes tag: %%{name}-mozplugin
  141. - added wrapper script to detect nonfree package installed
  142. * Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
  143. - new upstream release
  144. - obsoleted -mozplugin package
  145. * Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
  146. - new upstream release
  147. * Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
  148. - new upstream release
  149. * Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
  150. - new upstream release
  151. - added BuildRequires: glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
  152. * Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
  153. - new upstream release
  154. - added BuildRequires: gstreamer-devel
  155. - splitted mozplugin package
  156. * Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
  157. - new upstream release
  158. - dropt all pathces
  159. * Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
  160. - initial build for VineSeed
  161. * Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
  162. - BuildRequire taglib-devel and fix libnotify requirement
  163. * Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
  164. - Update to 0.1.90
  165. - Loads of additional translations
  166. * Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
  167. - Initial package