papi-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. %bcond_with bundled_libpfm
  2. Summary: Performance Application Programming Interface
  3. Summary(ja): パフォーマンス計測 API
  4. Name: papi
  5. Version: 5.4.1
  6. Release: 2%{?_dist_release}
  7. License: BSD
  8. Group: Development/Tools
  9. URL: http://icl.cs.utk.edu/papi/
  10. Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: autoconf
  13. BuildRequires: doxygen
  14. BuildRequires: ncurses-devel
  15. BuildRequires: gcc-gfortran
  16. BuildRequires: kernel-headers >= 2.6.32
  17. BuildRequires: chrpath
  18. BuildRequires: lm-sensors-devel >= 3.0.0
  19. %if %{without bundled_libpfm}
  20. BuildRequires: libpfm-devel >= 4.4.0-5
  21. BuildRequires: libpfm-static >= 4.4.0-5
  22. %endif
  23. # Following required for net component
  24. BuildRequires: net-tools
  25. # Following required for inifiband component
  26. # BuildRequires: libibmad-devel
  27. BuildRequires: pkgconfig
  28. Requires: papi-libs = %{version}-%{release}
  29. # Right now libpfm does not know anything about s390 and will fail
  30. ExcludeArch: s390 s390x
  31. %description
  32. PAPI provides a programmer interface to monitor the performance of
  33. running programs.
  34. %package libs
  35. Summary: Libraries for PAPI clients
  36. Summary(ja): PAPI クライアント用のライブラリ
  37. Group: System Environment/Libraries
  38. %description libs
  39. This package contains the run-time libraries for any application that wishes
  40. to use PAPI.
  41. %package devel
  42. Summary: Header files for the compiling programs with PAPI
  43. Summary(ja): PAPI を用いたプログラムのコンパイルに必要なヘッダファイル
  44. Group: Development/Libraries
  45. Requires: papi = %{version}-%{release}
  46. Requires: pkgconfig
  47. %description devel
  48. PAPI-devel includes the C header files that specify the PAPI user-space
  49. libraries and interfaces. This is required for rebuilding any program
  50. that uses PAPI.
  51. %package testsuite
  52. Summary: Set of tests for checking PAPI functionality
  53. Summary(ja): PAPI の機能を確認するためのテストプログラム集
  54. Group: Development/Libraries
  55. Requires: papi = %{version}-%{release}
  56. %description testsuite
  57. PAPI-testuiste includes compiled versions of papi tests to ensure
  58. that PAPI functions on particular hardware.
  59. %package static
  60. Summary: Static libraries for the compiling programs with PAPI
  61. Summary(ja): PAPI を用いたプログラムのコンパイルに必要な静的ライブラリ
  62. Group: Development/Libraries
  63. Requires: papi-devel = %{version}-%{release}
  64. %description static
  65. PAPI-static includes the static versions of the library files for
  66. the PAPI user-space libraries and interfaces.
  67. %prep
  68. %setup -q
  69. %build
  70. %if %{without bundled_libpfm}
  71. # Build our own copy of libpfm.
  72. %global libpfm_config --with-pfm-incdir=%{_includedir} --with-pfm-libdir=%{_libdir}
  73. %endif
  74. cd src
  75. #autoconf
  76. %configure \
  77. --with-perf-events \
  78. %{?libpfm_config} \
  79. --with-static-lib=yes --with-shared-lib=yes --with-shlib \
  80. --with-components='appio coretemp example lmsensors lustre micpower net rapl stealtime'
  81. # implicit enabled components: perf_event perf_event_uncore
  82. #components currently removed from configure: infiniband, mx
  83. #components currently left out because of build configure/build issues
  84. # --with-components="bgpm coretemp_freebsd cuda host_micpower nvml vmware"
  85. cd components/lmsensors
  86. %configure --with-sensors_incdir=%{_includedir}/sensors \
  87. --with-sensors_libdir=%{_libdir}
  88. cd ../..
  89. #DBG workaround to make sure libpfm just uses the normal CFLAGS
  90. DBG="" make %{?_smp_mflags}
  91. #generate updated versions of the documentation
  92. #DBG workaround to make sure libpfm just uses the normal CFLAGS
  93. pushd ../doc
  94. DBG="" make
  95. DBG="" make install
  96. popd
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. cd src
  100. make DESTDIR=$RPM_BUILD_ROOT LDCONFIG=/bin/true install-all
  101. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/*.so*
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %post libs -p /sbin/ldconfig
  105. %postun libs -p /sbin/ldconfig
  106. %files
  107. %defattr(-,root,root,-)
  108. %{_bindir}/*
  109. %dir /usr/share/papi
  110. /usr/share/papi/papi_events.csv
  111. %doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
  112. %doc %{_mandir}/man1/*
  113. %files libs
  114. %defattr(-,root,root,-)
  115. %{_libdir}/*.so.*
  116. %doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_includedir}/*.h
  120. %if %{with bundled_libpfm}
  121. %{_includedir}/perfmon/*.h
  122. %endif
  123. %{_libdir}/*.so
  124. %{_libdir}/pkgconfig/*.pc
  125. %doc %{_mandir}/man3/*
  126. %files testsuite
  127. %defattr(-,root,root,-)
  128. /usr/share/papi/run_tests*
  129. /usr/share/papi/ctests
  130. /usr/share/papi/ftests
  131. /usr/share/papi/components
  132. /usr/share/papi/testlib
  133. %files static
  134. %defattr(-,root,root,-)
  135. %{_libdir}/*.a
  136. %changelog
  137. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> - 5.4.1-2
  138. - rebuild with gfortran-8.2.0
  139. * Wed Mar 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.4.1-1
  140. - new upstream release
  141. * Fri Feb 6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.4.0-3
  142. - initial build for Vine Linux
  143. * Thu Dec 18 2014 William Cohen <wcohen@redhat.com> - 5.4.0-2
  144. - Split out papi-libs as separate subpackage. (#1172875)
  145. * Mon Nov 17 2014 William Cohen <wcohen@redhat.com> - 5.4.0-1
  146. - Rebase to papi-5.4.0.
  147. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  149. * Mon Aug 4 2014 William Cohen <wcohen@redhat.com> - 5.3.2-1
  150. - Rebase to 5.3.2.
  151. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2.16.ga7f6159
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  153. * Fri Jan 17 2014 Lukas Berk <lberk@redhat.com> - 5.3.0-1.16.ga7f6159
  154. - Automated weekly rawhide release
  155. * Thu Jan 16 2014 William Cohen <wcohen@redhat.com> - 5.3.0-1
  156. - Rebase to 5.3.0.
  157. * Tue Jan 14 2014 William Cohen <wcohen@redhat.com> - 5.2.0-5
  158. - Add presets for Intel Silvermont.
  159. * Mon Jan 13 2014 William Cohen <wcohen@redhat.com> - 5.2.0-4
  160. - Add presets for Haswell and Ivy Bridge.
  161. * Wed Aug 14 2013 William Cohen <wcohen@redhat.com> - 5.2.0-2
  162. - Enable infiniband and stealtime components.
  163. * Wed Aug 07 2013 William Cohen <wcohen@redhat.com> - 5.2.0-1
  164. - Rebase to 5.2.0
  165. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-8
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  167. * Wed Jul 24 2013 William Cohen <wcohen@redhat.com> - 5.1.1-7
  168. - rhbz830275 - Add support for POWER8 processor to PAPI
  169. * Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-6
  170. - Add autoconf buildrequires.
  171. * Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-5
  172. - rhbz986673 - /usr/lib64/libpapi.so is unowned
  173. - Package files in /usr/share/papi only once.
  174. - Avoid dependency problem with parallel make of man pages.
  175. * Fri Jul 19 2013 William Cohen <wcohen@redhat.com> - 5.1.1-4
  176. - Correct changelog.
  177. * Fri Jul 5 2013 William Cohen <wcohen@redhat.com> - 5.1.1-3
  178. - Add man page corrections/updates.
  179. * Fri Jun 28 2013 William Cohen <wcohen@redhat.com> - 5.1.1-2
  180. - Add testsuite subpackage.
  181. * Thu May 30 2013 William Cohen <wcohen@redhat.com> - 5.1.1-1
  182. - Rebase to 5.1.1
  183. * Mon Apr 15 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-2
  184. - Fix arm FTBS rhbz 951806.
  185. * Tue Apr 9 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-1
  186. - Rebase to 5.1.0.2
  187. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-6
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  189. * Mon Jan 14 2013 William Cohen <wcohen@redhat.com> - 5.0.1-5
  190. - Add armv7 cortex a15 presets.
  191. * Tue Dec 04 2012 William Cohen <wcohen@redhat.com> - 5.0.1-4
  192. - Disable ldconfig on install.
  193. * Thu Nov 08 2012 William Cohen <wcohen@redhat.com> - 5.0.1-3
  194. - Avoid duplicated shared library.
  195. * Wed Oct 03 2012 William Cohen <wcohen@redhat.com> - 5.0.1-2
  196. - Make sure using compatible version of libpfm.
  197. * Thu Sep 20 2012 William Cohen <wcohen@redhat.com> - 5.0.1-1
  198. - Rebase to 5.0.1.
  199. * Mon Sep 10 2012 William Cohen <wcohen@redhat.com> - 5.0.0-6
  200. - Back port fixes for Intel Ivy Bridge event presets.
  201. * Thu Aug 30 2012 William Cohen <wcohen@redhat.com> - 5.0.0-5
  202. - Fixes to make papi with unbundled libpfm.
  203. * Mon Aug 27 2012 William Cohen <wcohen@redhat.com> - 5.0.0-2
  204. - Keep libpfm unbundled.
  205. * Fri Aug 24 2012 William Cohen <wcohen@redhat.com> - 5.0.0-1
  206. - Rebase to 5.0.0.
  207. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-5
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  209. * Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-4
  210. - Use siginfo_t rather than struct siginfo.
  211. * Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-3
  212. - Correct build requires.
  213. * Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-2
  214. - Unbundle libpfm4 from papi.
  215. - Correct description spellings.
  216. - Remove unused test section.
  217. * Fri Apr 20 2012 William Cohen <wcohen@redhat.com> - 4.4.0-1
  218. - Rebase to 4.4.0.
  219. * Fri Mar 9 2012 William Cohen <wcohen@redhat.com> - 4.2.1-2
  220. - Fix overrun in lmsensor component. (rhbz797692)
  221. * Tue Feb 14 2012 William Cohen <wcohen@redhat.com> - 4.2.1-1
  222. - Rebase to 4.2.1.
  223. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4
  224. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  225. * Wed Nov 02 2011 William Cohen <wcohen@redhat.com> - 4.2.0-3
  226. - Remove unwanted man1/*.c.1 files. (rhbz749725)
  227. * Mon Oct 31 2011 William Cohen <wcohen@redhat.com> - 4.2.0-2
  228. - Include appropirate man pages with papi rpm. (rhbz749725)
  229. - Rebase to papi-4.2.0, fixup for coretemp component. (rhbz746851)
  230. * Thu Oct 27 2011 William Cohen <wcohen@redhat.com> - 4.2.0-1
  231. - Rebase to papi-4.2.0.
  232. * Fri Aug 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-3
  233. - Provide papi-static.
  234. * Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-2
  235. - Use corrected papi-4.1.3.
  236. * Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-1
  237. - Rebase to papi-4.1.3
  238. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.1.2.1-2
  239. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  240. * Mon Jan 24 2011 William Cohen <wcohen@redhat.com> - 4.1.2.1-1
  241. - Rebase to papi-4.1.2.1
  242. * Fri Oct 1 2010 William Cohen <wcohen@redhat.com> - 4.1.1-1
  243. - Rebase to papi-4.1.1
  244. * Tue Jun 22 2010 William Cohen <wcohen@redhat.com> - 4.1.0-1
  245. - Rebase to papi-4.1.0
  246. * Mon May 17 2010 William Cohen <wcohen@redhat.com> - 4.0.0-5
  247. - Test run with upstream cvs version.
  248. * Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-4
  249. - Resolves: rhbz562935 Rebase to papi-4.0.0 (correct ExcludeArch).
  250. * Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-3
  251. - Resolves: rhbz562935 Rebase to papi-4.0.0 (bump nvr).
  252. * Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-2
  253. - correct the ctests/shlib test
  254. - have PAPI_set_multiplex() return proper value
  255. - properly handle event unit masks
  256. - correct PAPI_name_to_code() to match events
  257. - Resolves: rhbz562935 Rebase to papi-4.0.0
  258. * Wed Jan 13 2010 William Cohen <wcohen@redhat.com> - 4.0.0-1
  259. - Generate papi.spec file for papi-4.0.0.