pandoc-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. %define pkg_name pandoc
  2. %define pkg_version 2.4
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: general markup converter
  5. Summary(ja): 汎用マークアップ変換ツール
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2+
  10. Group: Applications/Text
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. Source11: pandoc-2.4.tar.gz
  14. Source12: pandoc.cabal
  15. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  16. BuildRequires: ghc haskell-platform
  17. BuildRequires: libffi-devel gmp-devel zlib-devel
  18. BuildRequires: libghc-data-default-class
  19. BuildRequires: libghc-dlist
  20. BuildRequires: libghc-old-locale
  21. BuildRequires: libghc-aeson
  22. BuildRequires: libghc-semigroups
  23. BuildRequires: libghc-http-client-tls
  24. BuildRequires: libghc-haddock-library
  25. BuildRequires: libghc-build-pandoc
  26. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  27. Requires: libffi
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: ara_t
  31. %description
  32. Pandoc is a Haskell library for converting from one markup format to another,
  33. and a command-line tool that uses this library.
  34. It can read markdown and (subsets of) HTML, reStructuredText, LaTeX, DocBook,
  35. MediaWiki markup, Haddock markup, OPML, Emacs Org-mode, and Textile,
  36. and it can write markdown, reStructuredText, HTML,
  37. LaTeX (including rendering as plain PDF or beamer slide shows),
  38. ConTeXt, DocBook, OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki, Textile,
  39. groff man pages, GNU Texinfo, plain text, Emacs Org-Mode, AsciiDoc, InDesign
  40. ICML, EPUB (v2 or v3), FictionBook2, and several kinds of HTML/javascript
  41. slide shows (S5, Slidy, Slideous, DZSlides, reveal.js).
  42. Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
  43. definition lists, tables, and other features.
  44. A compatibility mode is provided for those who need a drop-in replacement for
  45. Markdown.pl.
  46. In contrast to existing tools for converting markdown to HTML,
  47. which use regex substitutions, pandoc has a modular design:
  48. it consists of a set of readers, which parse text in a given format
  49. and produce a native representation of the document,
  50. and a set of writers, which convert this native representation into a target
  51. format.
  52. Thus, adding an input or output format requires only adding a reader or writer.
  53. %description -l ja
  54. Pandoc はあるマークアップ形式から別の形式に変換するHaskellライブラリで、
  55. また、このライブラリを使ったコマンドラインツールです。
  56. markdown、HTML (のサブセット)、reStructuredText、 LaTeX、DocBook、
  57. MediaWikiマークアップ、Haddockマークアップ、OPML、Emacs Org-mode、
  58. およびTextileを読み取り、
  59. markdown、reStructuredText、HTML、LaTeX (プレインPDFまたはbeamerスライドショー
  60. での描画を含む)、ConTeXt、DocBook、OPML、OpenDocument、ODT、Word docx、RTF、
  61. MediaWiki、Textile、groff manページ、GNU Texinfo、プレーンテキスト、
  62. Emacs Org-Mode、AsciiDoc、InDesign ICML、EPUB (v2 または v3)、FictionBook2、
  63. およびいくつかの種類のHTML/javascriptスライドショー
  64. (S5, Slidy, Slideous, DZSlides, reveal.js) に書き出せます。
  65. Pandocは標準的なmarkdownの文法に脚注、組み込み LaTeX、定義リスト、表、
  66. およびその他の機能を拡張しています。
  67. Markdown.plの気軽な置き換えを希望する方向けに互換モードを提供しています。
  68. markdownからHTMLに変換する既存のツールは正規表現で置換していますが、
  69. これらとは異なり、pandoc はモジュール式の設計になっています:
  70. テキストを指定された形式でパースし、文書のネイティブ表現を生成するリーダ一式、
  71. および、このネイティブ表現を対象とする形式に変換するライタ一式で構成されて
  72. います。したがって、入力または出力形式を追加するにはリーダやライタを追加する
  73. ことだけが必要です。
  74. %package libs
  75. Summary: Library of pandoc
  76. Group: Development/Libraries
  77. Requires: haskell-platform-dep
  78. Requires: libghc-data-default-class
  79. Requires: libghc-dlist
  80. Requires: libghc-old-locale
  81. Requires: libghc-aeson
  82. Requires: libghc-semigroups
  83. Requires: libghc-http-client-tls
  84. Requires: libghc-haddock-library
  85. Requires: libghc-build-pandoc
  86. %description libs
  87. Librariy of pandoc for building pandoc-citeproc and pandoc-crossref
  88. %prep
  89. %{__rm} -rf ${RPM_BUILD_ROOT}
  90. %build
  91. %ghc_pkg_init
  92. cd %{_builddir}
  93. for pkg in `cat %{SOURCE0}`; do
  94. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  95. pushd ${pkg}
  96. %ghc_fix_dependencies ${pkg}
  97. %cabal_configure1 ${pkg}
  98. %cabal_build
  99. %cabal_haddock
  100. %cabal_copy_resister ${pkg}
  101. popd
  102. done
  103. %install
  104. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
  105. # copy documents and mannual
  106. pushd %{_builddir}/%{name}-%{version}
  107. %{__cp} \
  108. BUGS changelog CONTRIBUTING.md COPYING.md COPYRIGHT \
  109. MANUAL.txt README.md \
  110. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  111. %{__cp} man/pandoc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/
  112. popd
  113. %clean
  114. %{__rm} -rf ${RPM_BUILD_ROOT}
  115. %post libs
  116. %ghc_pkg_recache
  117. %postun libs
  118. %ghc_pkg_recache
  119. %files
  120. %defattr(-, root, root)
  121. %{_bindir}/pandoc
  122. %{_datadir}/%{name}-%{version}/
  123. %{_docdir}/%{name}-%{version}/
  124. %{_mandir}/man1/
  125. %files libs
  126. %defattr(-, root, root)
  127. %{_libdir}/ghc-%{ghc_version}/
  128. %{_libdir}/ghc-lib/%{name}-%{version}/
  129. %changelog
  130. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 2.4-1
  131. - update to 2.4
  132. - build using ghc-8.6.3
  133. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3.2-1
  134. - update to 2.2.3.2
  135. - build using ghc-8.4.3-2
  136. - drop BuildRequires: yaml
  137. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 2.2.2-1
  138. - update to 2.2.2
  139. - build using ghc-8.4.3
  140. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
  141. - update to 2.2.1
  142. - rebuild using ghc-8.4.2
  143. - rewrite using macro
  144. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
  145. - update to 2.0.6
  146. - build using ghc-8.2.2
  147. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-2
  148. - update to 1.19.2.1
  149. - build using ghc-8.0.2
  150. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-2
  151. - rebuild using ghc-8.0.1
  152. * Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
  153. - update to 1.17.1
  154. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-5
  155. - update to 1.17.0.3
  156. - add BuildRequires: libghc-build-pandoc
  157. - provide pandoc-libs for building pandoc-citeproc and pacdoc-crossref
  158. - delete subpackages: pandoc-citeproc and pacdoc-crossref
  159. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-5
  160. - correct SPEC file
  161. * Mon Mar 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-4
  162. - correct pandoc-citeproc error
  163. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
  164. - rebuild under dependent rpm packages
  165. * Sun Feb 21 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
  166. - rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
  167. * Sun Feb 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-1
  168. - new package