pandoc-citeproc-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158
  1. %define pkg_name pandoc-citeproc
  2. %define pkg_version 0.15.0.1
  3. %define pkg_release 1%{?_dist_release}
  4. %define pandoc_version 2.4
  5. Summary: Library and executable for using citeproc with pandoc
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: Applications/Text
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. Source11: hs-bibutils-6.7.0.0.tar.gz
  14. Source12: hs-bibutils.cabal
  15. Source13: rfc5051-0.1.0.4.tar.gz
  16. Source14: rfc5051.cabal
  17. Source15: setenv-0.1.1.3.tar.gz
  18. Source16: setenv.cabal
  19. Source17: typed-process-0.2.3.0.tar.gz
  20. Source18: typed-process.cabal
  21. Source19: unliftio-core-0.1.2.0.tar.gz
  22. Source20: unliftio-core.cabal
  23. Source21: vector-algorithms-0.8.0.1.tar.gz
  24. Source22: vector-algorithms.cabal
  25. Source23: xml-types-0.3.6.tar.gz
  26. Source24: xml-types.cabal
  27. Source25: resourcet-1.2.2.tar.gz
  28. Source26: resourcet.cabal
  29. Source27: mono-traversable-1.0.9.0.tar.gz
  30. Source28: mono-traversable.cabal
  31. Source29: conduit-1.3.1.tar.gz
  32. Source30: conduit.cabal
  33. Source31: libyaml-0.1.0.0.tar.gz
  34. Source32: libyaml.cabal
  35. Source33: conduit-extra-1.3.0.tar.gz
  36. Source34: conduit-extra.cabal
  37. Source35: yaml-0.11.0.0.tar.gz
  38. Source36: yaml.cabal
  39. Source37: xml-conduit-1.8.0.1.tar.gz
  40. Source38: xml-conduit.cabal
  41. Source39: pandoc-citeproc-0.15.0.1.tar.gz
  42. Source40: pandoc-citeproc.cabal
  43. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  44. BuildRequires: ghc haskell-platform
  45. BuildRequires: libffi-devel gmp-devel zlib-devel
  46. BuildRequires: libghc-build-pandoc
  47. BuildRequires: pandoc-libs = %{pandoc_version}
  48. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  49. Requires: pandoc = %{pandoc_version}
  50. Vendor: Project Vine
  51. Distribution: Vine Linux
  52. Packager: ara_t
  53. %description
  54. The pandoc-citeproc library exports functions for using the citeproc system
  55. with pandoc. It relies on citeproc-hs, a library for rendering bibliographic
  56. reference citations into a variety of styles using a macro language called
  57. Citation Style Language (CSL).
  58. More details on CSL can be found here: http://citationstyles.org/.
  59. %prep
  60. %{__rm} -rf ${RPM_BUILD_ROOT}
  61. %build
  62. %ghc_pkg_init
  63. cd %{_builddir}
  64. for pkg in `sed '$d' %{SOURCE0}`; do
  65. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  66. pushd ${pkg}
  67. %ghc_fix_dependencies ${pkg}
  68. %{__cabal} configure
  69. %{__cabal} build
  70. %{__cabal} copy
  71. %{__cabal} register --inplace
  72. popd
  73. done
  74. for pkg in `tail -n 1 %{SOURCE0}`; do
  75. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  76. pushd ${pkg}
  77. %ghc_fix_dependencies ${pkg}
  78. %cabal_configure1 ${pkg}
  79. %cabal_build
  80. %cabal_haddock
  81. %cabal_copy_resister ${pkg}
  82. popd
  83. done
  84. %install
  85. %{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
  86. %{__mv} \
  87. ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/{changelog,README.md} \
  88. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
  89. %{__mv} \
  90. ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man \
  91. ${RPM_BUILD_ROOT}%{_datadir}/
  92. %clean
  93. %{__rm} -rf ${RPM_BUILD_ROOT}
  94. %files
  95. %defattr(-, root, root)
  96. %{_bindir}/pandoc-citeproc
  97. %{_datadir}/%{name}-%{version}/
  98. %{_docdir}/%{name}-%{version}/
  99. %{_mandir}/man1/
  100. %changelog
  101. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.15.0.1-1
  102. - update to 0.15.0.1
  103. - build using ghc-8.6.3 and pandoc-2.4
  104. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-3
  105. - build using ghc-8.4.3-2 and pandoc-2.2.3.2
  106. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-2
  107. - build using ghc-8.4.3 and pandoc-2.2.2
  108. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-1
  109. - update to 0.14.3.1
  110. - rebuild using ghc-8.4.2 and pandoc-2.2.1
  111. - rewrite using macro
  112. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.12.2.5-1
  113. - update to 0.12.2.5
  114. - build using ghc-8.2.2
  115. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4.1-1
  116. - update to 0.10.4.1
  117. - build using ghc-8.0.2
  118. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4-1
  119. - update to 0.10.4
  120. - build using ghc-8.0.1
  121. * Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 0.10-1
  122. - update to 0.10
  123. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 0.9.1.1-1
  124. - new package (devide from pandoc)