pacemaker-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688
  1. %global gname haclient
  2. %global uname hacluster
  3. %global pcmk_docdir %{_docdir}/%{name}
  4. #%global specversion 3
  5. #%global upstream_version Pacemaker-1.1.2
  6. #%global upstream_prefix Pacemaker-1-1-
  7. %global py_site %(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")
  8. # Turn off the auto compilation of python files not in the site-packages directory
  9. # Needed so that the -devel package is multilib compliant
  10. %global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
  11. %global cs_major %(pkg-config corosync --modversion | awk -F . '{print $1}')
  12. %global cs_minor %(pkg-config corosync --modversion | awk -F . '{print $2}')
  13. # Conditionals
  14. # Invoke "rpmbuild --without <feature>" or "rpmbuild --with <feature>"
  15. # to disable or enable specific features
  16. # Legacy stonithd fencing agents
  17. %bcond_with stonithd
  18. # Build with/without support for profiling tools
  19. %bcond_with profiling
  20. # We generate docs using Publican, Asciidoc and Inkscape, but they're not available everywhere
  21. %bcond_without doc
  22. # Use a different versioning scheme
  23. %bcond_with pre_release
  24. # Ship an Upstart job file
  25. %bcond_with upstart_job
  26. %if %{with profiling}
  27. # This disables -debuginfo package creation and also the stripping binaries/libraries
  28. # Useful if you want sane profiling data
  29. %global debug_package %{nil}
  30. %endif
  31. # Keep around for when/if required
  32. #global alphatag %{upstream_version}.hg
  33. #%global pcmk_release %{?alphatag:0.}%{specversion}%{?alphatag:.%{alphatag}}%{?dist}
  34. # When downloading directly from Mercurial, it will automatically add a prefix
  35. # Invoking 'hg archive' wont but you can add one with:
  36. # hg archive -t tgz -p "$upstream_prefix-$upstream_version" -r $upstream_version $upstream_version.tar.gz
  37. Name: pacemaker
  38. Summary: Scalable High-Availability cluster resource manager
  39. Summary(ja): スケーラブルかつ高可用性なクラスタリソースマネージャ
  40. Version: 1.1.12
  41. Release: 1%{?_dist_release}
  42. License: GPLv2+ and LGPLv2+
  43. Group: System Environment/Daemons
  44. URL: http://www.clusterlabs.org
  45. Source0: https://github.com/ClusterLabs/%{name}/archive/Pacemaker-%{version}.tar.gz
  46. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  47. AutoReqProv: on
  48. #Requires(pre): cluster-glue
  49. Requires: resource-agents
  50. Requires: %{name}-libs = %{version}-%{release}
  51. Requires: %{name}-cluster-libs = %{version}-%{release}
  52. Requires: %{name}-cli = %{version}-%{release}
  53. Requires: python >= 2.4
  54. # Required for core functionality
  55. BuildRequires: automake autoconf libtool pkgconfig libtool-ltdl-devel
  56. BuildRequires: glib2-devel libxml2-devel libxslt-devel libuuid-devel
  57. BuildRequires: pkgconfig python-devel gcc-c++ bzip2-devel pam-devel
  58. # Required for agent_config.h which specifies the correct scratch directory
  59. BuildRequires: resource-agents
  60. # We need reasonably recent versions of libqb
  61. BuildRequires: libqb-devel > 0.11.0
  62. Requires: libqb > 0.11.0
  63. # Enables optional functionality
  64. BuildRequires: ncurses-devel openssl-devel docbook-style-xsl
  65. BuildRequires: bison byacc flex help2man dbus-devel
  66. %if %{defined _unitdir}
  67. BuildRequires: systemd-devel
  68. %endif
  69. Requires: corosync
  70. BuildRequires: corosynclib-devel
  71. %if %{with stonithd}
  72. BuildRequires: cluster-glue-libs-devel
  73. %endif
  74. %if %{with doc}
  75. %ifarch %{ix86} x86_64
  76. BuildRequires: inkscape asciidoc
  77. #BuildRequires: publican inkscape asciidoc
  78. %endif
  79. %endif
  80. %description
  81. Pacemaker is an advanced, scalable High-Availability cluster resource
  82. manager for Corosync, CMAN and/or Linux-HA.
  83. It supports more than 16 node clusters with significant capabilities
  84. for managing resources and dependencies.
  85. It will run scripts at initialization, when machines go up or down,
  86. when related resources fail and can be configured to periodically check
  87. resource health.
  88. Available rpmbuild rebuild options:
  89. --with(out) : stonithd doc profiling pre_release upstart_job
  90. %package cli
  91. License: GPLv2+ and LGPLv2+
  92. Summary: Command line tools for controlling Pacemaker clusters
  93. Group: System Environment/Base
  94. Requires: %{name}-libs = %{version}-%{release}
  95. Requires: perl-TimeDate
  96. %description cli
  97. Pacemaker is an advanced, scalable High-Availability cluster resource
  98. manager for Corosync, CMAN and/or Linux-HA.
  99. The %{name}-cli package contains command line tools that can be used
  100. to query and control the cluster from machines that may, or may not,
  101. be part of the cluster.
  102. %package -n %{name}-libs
  103. License: GPLv2+ and LGPLv2+
  104. Summary: Core Pacemaker libraries
  105. Summary(ja): Pacemaker コアライブラリ
  106. Group: System Environment/Libraries
  107. %description -n pacemaker-libs
  108. Pacemaker is an advanced, scalable High-Availability cluster resource
  109. manager for Corosync, CMAN and/or Linux-HA.
  110. The %{name}-libs package contains shared libraries needed for cluster
  111. nodes and those just running the CLI tools.
  112. %package -n %{name}-cluster-libs
  113. License: GPLv2+ and LGPLv2+
  114. Summary: Cluster Libraries used by Pacemaker
  115. Summary(ja): Pacemaker で用いられるクラスタライブラリ
  116. Group: System Environment/Libraries
  117. Requires: %{name}-libs = %{version}-%{release}
  118. %description -n %{name}-cluster-libs
  119. Pacemaker is an advanced, scalable High-Availability cluster resource
  120. manager for Corosync, CMAN and/or Linux-HA.
  121. The %{name}-cluster-libs package contains cluster-aware shared
  122. libraries needed for nodes that will form part of the cluster nodes.
  123. %package remote
  124. License: GPLv2+ and LGPLv2+
  125. Summary: Pacemaker remote daemon for non-cluster nodes
  126. Group: System Environment/Daemons
  127. Requires: %{name}-libs = %{version}-%{release}
  128. Requires: %{name}-cli = %{version}-%{release}
  129. Requires: resource-agents
  130. #%if %{defined systemd_requires}
  131. #%systemd_requires
  132. #%endif
  133. %description remote
  134. Pacemaker is an advanced, scalable High-Availability cluster resource
  135. manager for Corosync, CMAN and/or Linux-HA.
  136. The %{name}-remote package contains the Pacemaker Remote daemon
  137. which is capable of extending pacemaker functionality to remote
  138. nodes not running the full corosync/cluster stack.
  139. %package -n %{name}-libs-devel
  140. License: GPLv2+ and LGPLv2+
  141. Summary: Pacemaker development package
  142. Summary(ja): Pacemaker 開発パッケージ
  143. Group: Development/Libraries
  144. Requires: %{name}-cts = %{version}-%{release}
  145. Requires: %{name}-libs = %{version}-%{release}
  146. Requires: %{name}-cluster-libs = %{version}-%{release}
  147. Requires: libtool-ltdl-devel libqb-devel libuuid-devel
  148. Requires: libxml2-devel libxslt-devel bzip2-devel glib2-devel
  149. Requires: corosynclib-devel
  150. %description -n %{name}-libs-devel
  151. Pacemaker is an advanced, scalable High-Availability cluster resource
  152. manager for Corosync, CMAN and/or Linux-HA.
  153. The %{name}-libs-devel package contains headers and shared libraries
  154. for developing tools for Pacemaker.
  155. %package cts
  156. License: GPLv2+ and LGPLv2+
  157. Summary: Test framework for cluster-related technologies like Pacemaker
  158. Group: Development/Libraries
  159. Requires: python
  160. %description cts
  161. Test framework for cluster-related technologies like Pacemaker
  162. %package doc
  163. License: GPLv2+ and LGPLv2+
  164. Summary: Documentation for Pacemaker
  165. Summary(ja): Pacemaker のドキュメント
  166. Group: Documentation
  167. %description doc
  168. Documentation for Pacemaker.
  169. Pacemaker is an advanced, scalable High-Availability cluster resource
  170. manager for Corosync, CMAN and/or Linux-HA.
  171. %prep
  172. %setup -q -n %{name}-Pacemaker-%{version}
  173. %build
  174. ./autogen.sh
  175. %configure \
  176. %{?with_profiling: --with-profiling} \
  177. --with-initdir=%{_initrddir} \
  178. --docdir=%{pcmk_docdir} \
  179. --localstatedir=%{_var} \
  180. --with-version=%{version}-%{release} \
  181. --disable-ansi
  182. make %{_smp_mflags} V=1 docdir=%{pcmk_docdir} all
  183. %install
  184. rm -rf $RPM_BUILD_ROOT
  185. make DESTDIR=$RPM_BUILD_ROOT install
  186. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  187. mkdir -p $RPM_BUILD_ROOT%{_var}/lib/pacemaker/cores
  188. install -m 644 mcp/pacemaker.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/pacemaker
  189. %if %{with upstart_job}
  190. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init
  191. install -m 644 mcp/pacemaker.upstart $RPM_BUILD_ROOT%{_sysconfdir}/init/pacemaker.conf
  192. install -m 644 mcp/pacemaker.combined.upstart $RPM_BUILD_ROOT%{_sysconfdir}/init/pacemaker.combined.conf
  193. %endif
  194. # Scripts that need should be executable
  195. chmod a+x $RPM_BUILD_ROOT%{_datadir}/pacemaker/tests/cts/CTSlab.py
  196. # These are not actually scripts
  197. find $RPM_BUILD_ROOT -name '*.xml' -type f -print0 | xargs -0 chmod a-x
  198. find $RPM_BUILD_ROOT -name '*.xsl' -type f -print0 | xargs -0 chmod a-x
  199. find $RPM_BUILD_ROOT -name '*.rng' -type f -print0 | xargs -0 chmod a-x
  200. find $RPM_BUILD_ROOT -name '*.dtd' -type f -print0 | xargs -0 chmod a-x
  201. # Dont package static libs or compiled python
  202. find $RPM_BUILD_ROOT -name '*.a' -type f -print0 | xargs -0 rm -f
  203. find $RPM_BUILD_ROOT -name '*.la' -type f -print0 | xargs -0 rm -f
  204. # Don't package these either
  205. rm -f $RPM_BUILD_ROOT%{_libdir}/service_crm.so
  206. # Don't ship init scripts for systemd based platforms
  207. %if %{defined _unitdir}
  208. rm -f $RPM_BUILD_ROOT%{_initrddir}/pacemaker
  209. rm -f $RPM_BUILD_ROOT%{_initrddir}/pacemaker_remote
  210. %endif
  211. %if %{with profiling}
  212. GCOV_BASE=$RPM_BUILD_ROOT/%{_var}/lib/pacemaker/gcov
  213. mkdir -p $GCOV_BASE
  214. find . -name '*.gcno' -type f | while read F ; do
  215. D=`dirname $F`
  216. mkdir -p ${GCOV_BASE}/$D
  217. cp $F ${GCOV_BASE}/$D
  218. done
  219. %endif
  220. %clean
  221. rm -rf $RPM_BUILD_ROOT
  222. %post
  223. %if %{defined _unitdir} && 0%{?systemd_post:1}
  224. %systemd_post pacemaker.service
  225. %else
  226. if [ $1 -eq 1 ]; then
  227. /sbin/chkconfig --add pacemaker || :
  228. fi
  229. %endif
  230. %preun
  231. %if %{defined _unitdir} && 0%{?systemd_preun:1}
  232. %systemd_preun pacemaker.service
  233. %else
  234. if [ $1 -eq 0 ]; then
  235. /sbin/service pacemaker stop &>/dev/null || :
  236. /sbin/chkconfig --del pacemaker || :
  237. fi
  238. %endif
  239. %postun
  240. %if %{defined _unitdir} && 0%{?systemd_postun_with_restart:1}
  241. %systemd_postun_with_restart pacemaker.service
  242. %endif
  243. %post remote
  244. %if %{defined _unitdir} && 0%{?systemd_post:1}
  245. %systemd_post pacemaker_remote.service
  246. %else
  247. if [ $1 -eq 1 ]; then
  248. /sbin/chkconfig --add pacemaker_remote || :
  249. fi
  250. %endif
  251. %preun remote
  252. %if %{defined _unitdir} && 0%{?systemd_preun:1}
  253. %systemd_preun pacemaker_remote.service
  254. %else
  255. if [ $1 -eq 0 ]; then
  256. /sbin/service pacemaker_remote stop &>/dev/null || :
  257. /sbin/chkconfig --del pacemaker_remote || :
  258. fi
  259. %endif
  260. %postun remote
  261. %if %{defined _unitdir} && 0%{?systemd_postun_with_restart:1}
  262. %systemd_postun_with_restart pacemaker_remote.service
  263. %endif
  264. %pre -n %{name}-libs
  265. getent group %{gname} >/dev/null || groupadd -r %{gname} -g 189
  266. getent passwd %{uname} >/dev/null || useradd -r -g %{gname} -u 189 -s /sbin/nologin -c "cluster user" %{uname}
  267. exit 0
  268. %post -n %{name}-libs -p /sbin/ldconfig
  269. %postun -n %{name}-libs -p /sbin/ldconfig
  270. %post -n %{name}-cluster-libs -p /sbin/ldconfig
  271. %postun -n %{name}-cluster-libs -p /sbin/ldconfig
  272. %files
  273. ###########################################################
  274. %defattr(-,root,root)
  275. %doc AUTHORS COPYING ChangeLog
  276. %exclude %{_datadir}/pacemaker/tests
  277. %config(noreplace) %{_sysconfdir}/sysconfig/pacemaker
  278. %{_sbindir}/pacemakerd
  279. %if %{defined _unitdir}
  280. %{_unitdir}/pacemaker.service
  281. %else
  282. %{_initrddir}/pacemaker
  283. %endif
  284. %{_datadir}/pacemaker
  285. %{_datadir}/snmp/mibs/PCMK-MIB.txt
  286. %exclude %{_libexecdir}/pacemaker/lrmd_test
  287. %exclude %{_sbindir}/pacemaker_remoted
  288. %{_libexecdir}/pacemaker/*
  289. %{_sbindir}/crm_attribute
  290. %{_sbindir}/crm_master
  291. %{_sbindir}/crm_node
  292. %{_sbindir}/attrd_updater
  293. %{_sbindir}/fence_legacy
  294. %{_sbindir}/fence_pcmk
  295. %{_sbindir}/stonith_admin
  296. %doc %{_mandir}/man7/*
  297. %doc %{_mandir}/man8/attrd_updater.*
  298. %doc %{_mandir}/man8/crm_attribute.*
  299. %doc %{_mandir}/man8/crm_node.*
  300. %doc %{_mandir}/man8/crm_master.*
  301. %doc %{_mandir}/man8/fence_pcmk.*
  302. %doc %{_mandir}/man8/pacemakerd.*
  303. %doc %{_mandir}/man8/stonith_admin.*
  304. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker
  305. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/cib
  306. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/cores
  307. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/pengine
  308. %dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/blackbox
  309. %ghost %dir %attr (750, %{uname}, %{gname}) %{_var}/run/crm
  310. %dir /usr/lib/ocf
  311. %dir /usr/lib/ocf/resource.d
  312. /usr/lib/ocf/resource.d/pacemaker
  313. %if 0%{?cs_major} < 2
  314. %if 0%{?cs_minor} < 8
  315. %{_libexecdir}/lcrso/pacemaker.lcrso
  316. %endif
  317. %endif
  318. %if %{with upstart_job}
  319. %config(noreplace) %{_sysconfdir}/init/pacemaker.conf
  320. %config(noreplace) %{_sysconfdir}/init/pacemaker.combined.conf
  321. %endif
  322. %files cli
  323. %defattr(-,root,root)
  324. %doc AUTHORS COPYING ChangeLog
  325. %{_sbindir}/cibadmin
  326. %{_sbindir}/crm_diff
  327. %{_sbindir}/crm_error
  328. %{_sbindir}/crm_failcount
  329. %{_sbindir}/crm_mon
  330. %{_sbindir}/crm_resource
  331. %{_sbindir}/crm_standby
  332. %{_sbindir}/crm_verify
  333. %{_sbindir}/crmadmin
  334. %{_sbindir}/iso8601
  335. %{_sbindir}/crm_shadow
  336. %{_sbindir}/crm_simulate
  337. %{_sbindir}/crm_report
  338. %{_sbindir}/crm_ticket
  339. %doc %{_mandir}/man8/*
  340. %exclude %{_mandir}/man8/attrd_updater.*
  341. %exclude %{_mandir}/man8/crm_attribute.*
  342. %exclude %{_mandir}/man8/crm_node.*
  343. %exclude %{_mandir}/man8/crm_master.*
  344. %exclude %{_mandir}/man8/fence_pcmk.*
  345. %exclude %{_mandir}/man8/pacemakerd.*
  346. %exclude %{_mandir}/man8/pacemaker_remoted.*
  347. %exclude %{_mandir}/man8/stonith_admin.*
  348. %files -n %{name}-libs
  349. %defattr(-,root,root)
  350. %doc AUTHORS COPYING.LIB
  351. %{_libdir}/libcib.so.*
  352. %{_libdir}/liblrmd.so.*
  353. %{_libdir}/libcrmservice.so.*
  354. %{_libdir}/libcrmcommon.so.*
  355. %{_libdir}/libpe_status.so.*
  356. %{_libdir}/libpe_rules.so.*
  357. %{_libdir}/libpengine.so.*
  358. %{_libdir}/libstonithd.so.*
  359. %{_libdir}/libtransitioner.so.*
  360. %files -n %{name}-cluster-libs
  361. %defattr(-,root,root)
  362. %{_libdir}/libcrmcluster.so.*
  363. %doc AUTHORS COPYING.LIB
  364. %files remote
  365. %defattr(-,root,root)
  366. %doc AUTHORS COPYING.LIB
  367. %config(noreplace) %{_sysconfdir}/logrotate.d/pacemaker
  368. %config(noreplace) %{_sysconfdir}/sysconfig/pacemaker
  369. %if %{defined _unitdir}
  370. %{_unitdir}/pacemaker_remote.service
  371. %else
  372. %{_initrddir}/pacemaker_remote
  373. %endif
  374. %{_sbindir}/pacemaker_remoted
  375. %{_mandir}/man8/pacemaker_remoted.*
  376. %files doc
  377. %defattr(-,root,root)
  378. %doc %{pcmk_docdir}
  379. %files cts
  380. %defattr(-,root,root)
  381. %doc AUTHORS COPYING.LIB
  382. %{py_site}/cts
  383. %{_datadir}/pacemaker/tests/cts
  384. %{_libexecdir}/pacemaker/lrmd_test
  385. %files -n %{name}-libs-devel
  386. %defattr(-,root,root)
  387. %doc AUTHORS COPYING.LIB
  388. %exclude %{_datadir}/pacemaker/tests/cts
  389. %{_datadir}/pacemaker/tests
  390. %{_includedir}/pacemaker
  391. %{_libdir}/*.so
  392. %if %{with profiling}
  393. %{_var}/lib/pacemaker
  394. %endif
  395. %{_libdir}/pkgconfig/*.pc
  396. %changelog
  397. * Sat Feb 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.12-1
  398. - updated to 1.1.12
  399. - rebuilt with gnutls 3.2.20 and corosync 2.3.4
  400. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-4
  401. - rebuild with net-snmp-5.7.1
  402. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-3
  403. - rebuild with python-2.7.2
  404. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
  405. - rebuild with openssl-1.0.0d
  406. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
  407. - initial build for Vine Linux
  408. * Mon Jun 21 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-3
  409. - publican is only available as a dependancy on i386/x86_64 machines
  410. * Fri Jun 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-2
  411. - Resolves rhbz#602239 - Added patch to documentation so that it passes validation
  412. - High: Core: Bug lf#2401 - Backed out changeset 6e6980376f01
  413. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1.2-1.1
  414. - Mass rebuild with perl-5.12.0
  415. * Wed May 12 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-1
  416. - Update the tarball from the upstream 1.1.2 release
  417. + High: ais: Bug lf#2340 - Force rogue child processes to terminate after waiting 2.5 minutes
  418. + High: ais: Bug lf#2359 - Default expected votes to 2 inside Corosync/OpenAIS plugin
  419. + High: ais: Bug lf#2359 - expected-quorum-votes not correctly updated after membership change
  420. + High: ais: Bug rhbz#525552 - Move non-threadsafe calls to setenv() to after the fork()
  421. + High: ais: Do not count votes from offline nodes and calculate current votes before sending quorum data
  422. + High: ais: Ensure the list of active processes sent to clients is always up-to-date
  423. + High: ais: Fix previous commit, actually return a result in get_process_list()
  424. + High: ais: Fix two more uses of getpwnam() in non-thread-safe locations
  425. + High: ais: Look for the correct conf variable for turning on file logging
  426. + High: ais: Need to find a better and thread-safe way to set core_uses_pid. Disable for now.
  427. + High: ais: Use the threadsafe version of getpwnam
  428. + High: Core: Bug lf#2414 - Prevent use-after-free reported by valgrind when doing xpath based deletions
  429. + High: Core: Bump the feature set due to the new failcount expiry feature
  430. + High: Core: Fix memory leak in replace_xml_child() reported by valgrind
  431. + High: Core: fix memory leaks exposed by valgrind
  432. + High: crmd: Bug 2401 - Improved detection of partially active peers
  433. + High: crmd: Bug bnc#578644 - Improve handling of cancelled operations caused by resource cleanup
  434. + High: crmd: Bug lf#2379 - Ensure the cluster terminates when the PE is not available
  435. + High: crmd: Bug lf#2414 - Prevent use-after-free of the PE connection after it dies
  436. + High: crmd: Bug lf#2414 - Prevent use-after-free of the stonith-ng connection
  437. + High: crmd: Do not allow the target_rc to be misused by resource agents
  438. + High: crmd: Do not ignore action timeouts based on FSA state
  439. + High: crmd: Ensure we dont get stuck in S_PENDING if we loose an election to someone that never talks to us again
  440. + High: crmd: Fix memory leaks exposed by valgrind
  441. + High: crmd: Remove race condition that could lead to multiple instances of a clone being active on a machine
  442. + High: crmd: Send erase_status_tag() calls to the local CIB when the DC is fenced, since there is no DC to accept them
  443. + High: crmd: Use global fencing notifications to prevent secondary fencing operations of the DC
  444. + High: fencing: Account for stonith_get_info() always returning a pointer to the same static buffer
  445. + High: PE: Allow startup probes to be disabled - their calculation is a major bottleneck for very large clusters
  446. + High: PE: Bug lf#2317 - Avoid needless restart of primitive depending on a clone
  447. + High: PE: Bug lf#2358 - Fix master-master anti-colocation
  448. + High: PE: Bug lf#2361 - Ensure clones observe mandatory ordering constraints if the LHS is unrunnable
  449. + High: PE: Bug lf#2383 - Combine failcounts for all instances of an anonymous clone on a host
  450. + High: PE: Bug lf#2384 - Fix intra-set colocation and ordering
  451. + High: PE: Bug lf#2403 - Enforce mandatory promotion (colocation) constraints
  452. + High: PE: Bug lf#2412 - Correctly locate clone instances by their prefix
  453. + High: PE: Correctly implement optional colocation between primitives and clone resources
  454. + High: PE: Do not be so quick to pull the trigger on nodes that are coming up
  455. + High: PE: Fix memory leaks exposed by valgrind
  456. + High: PE: Fix memory leaks reported by valgrind
  457. + High: PE: Repair handling of unordered groups in RHS ordering constraints
  458. + High: PE: Rewrite native_merge_weights() to avoid Fix use-after-free
  459. + High: PE: Suppress duplicate ordering constraints to achieve orders of magnitude speed increases for large clusters
  460. + High: Shell: add support for xml in cli
  461. + High: Shell: always reload status if working with the cluster (bnc#590035)
  462. + High: Shell: check timeouts also against the default-action-timeout property
  463. + High: Shell: Default to using the status section from the live CIB (bnc#592762)
  464. + High: Shell: edit multiple meta_attributes sets in resource management (lf#2315)
  465. + High: Shell: enable comments (lf#2221)
  466. + High: Shell: implement new cibstatus interface and commands (bnc#580492)
  467. + High: Shell: improve configure commit (lf#2336)
  468. + High: Shell: new cibstatus import command (bnc#585471)
  469. + High: Shell: new configure filter command
  470. + High: Shell: restore error reporting in options
  471. + High: Shell: split shell into modules
  472. + High: Shell: support for the utilization element (old patch for the new structure)
  473. + High: Shell: update previous node lookup procedure to include the id where necessary
  474. + High: Tools: crm_mon - fix memory leaks exposed by valgrind
  475. * Thu Feb 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.1-0.1-60b7753f7310.hg
  476. - Update the tarball from upstream to version 60b7753f7310
  477. + First public release of the 1.1 series
  478. * Wed Dec 9 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-5
  479. - Include patch of changeset 66b7bfd467f3:
  480. Some clients such as gfs_controld want a cluster name, allow one to be specified in corosync.conf
  481. * Thu Oct 29 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-4
  482. - Include the fixes from CoroSync integration testing
  483. - Move the resource templates - they are not documentation
  484. - Ensure documentation is placed in a standard location
  485. - Exclude documentation that is included elsewhere in the package
  486. - Update the tarball from upstream to version ee19d8e83c2a
  487. + High: cib: Correctly clean up when both plaintext and tls remote ports are requested
  488. + High: PE: Bug bnc#515172 - Provide better defaults for lt(e) and gt(e) comparisions
  489. + High: PE: Bug lf#2197 - Allow master instances placemaker to be influenced by colocation constraints
  490. + High: PE: Make sure promote/demote pseudo actions are created correctly
  491. + High: PE: Prevent target-role from promoting more than master-max instances
  492. + High: ais: Bug lf#2199 - Prevent expected-quorum-votes from being populated with garbage
  493. + High: ais: Prevent deadlock - dont try to release IPC message if the connection failed
  494. + High: cib: For validation errors, send back the full CIB so the client can display the errors
  495. + High: cib: Prevent use-after-free for remote plaintext connections
  496. + High: crmd: Bug lf#2201 - Prevent use-of-NULL when running heartbeat
  497. + High: Core: Bug lf#2169 - Allow dtd/schema validation to be disabled
  498. + High: PE: Bug lf#2106 - Not all anonymous clone children are restarted after configuration change
  499. + High: PE: Bug lf#2170 - stop-all-resources option had no effect
  500. + High: PE: Bug lf#2171 - Prevent groups from starting if they depend on a complex resource which cannot
  501. + High: PE: Disable resource management if stonith-enabled=true and no stonith resources are defined
  502. + High: PE: Do not include master score if it would prevent allocation
  503. + High: ais: Avoid excessive load by checking for dead children every 1s (instead of 100ms)
  504. + High: ais: Bug rh#525589 - Prevent shutdown deadlocks when running on CoroSync
  505. + High: ais: Gracefully handle changes to the AIS nodeid
  506. + High: crmd: Bug bnc#527530 - Wait for the transition to complete before leaving S_TRANSITION_ENGINE
  507. + High: crmd: Prevent use-after-free with LOG_DEBUG_3
  508. + Medium: xml: Mask the "symmetrical" attribute on rsc_colocation constraints (bnc#540672)
  509. + Medium (bnc#520707): Tools: crm: new templates ocfs2 and clvm
  510. + Medium: Build: Invert the disable ais/heartbeat logic so that --without (ais|heartbeat) is available to rpmbuild
  511. + Medium: PE: Bug lf#2178 - Indicate unmanaged clones
  512. + Medium: PE: Bug lf#2180 - Include node information for all failed ops
  513. + Medium: PE: Bug lf#2189 - Incorrect error message when unpacking simple ordering constraint
  514. + Medium: PE: Correctly log resources that would like to start but cannot
  515. + Medium: PE: Stop ptest from logging to syslog
  516. + Medium: ais: Include version details in plugin name
  517. + Medium: crmd: Requery the resource metadata after every start operation
  518. * Fri Oct 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.5-3
  519. - rebuilt with new net-snmp
  520. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.5-2.1
  521. - rebuilt with new openssl
  522. * Wed Aug 19 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-2
  523. - Add versioned perl dependancy as specified by
  524. https://fedoraproject.org/wiki/Packaging/Perl#Packages_that_link_to_libperl
  525. - No longer remove RPATH data, it prevents us finding libperl.so and no other
  526. libraries were being hardcoded
  527. - Compile in support for heartbeat
  528. - Conditionally add heartbeat-devel and corosynclib-devel to the -devel requirements
  529. depending on which stacks are supported
  530. * Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-1
  531. - Add dependancy on resource-agents
  532. - Use the version of the configure macro that supplies --prefix, --libdir, etc
  533. - Update the tarball from upstream to version 462f1569a437 (Pacemaker 1.0.5 final)
  534. + High: Tools: crm_resource - Advertise --move instead of --migrate
  535. + Medium: Extra: New node connectivity RA that uses system ping and attrd_updater
  536. + Medium: crmd: Note that dc-deadtime can be used to mask the brokeness of some switches
  537. * Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0.5-0.7.c9120a53a6ae.hg
  538. - Use bzipped upstream tarball.
  539. * Wed Jul 29 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.6.c9120a53a6ae.hg
  540. - Add back missing build auto* dependancies
  541. - Minor cleanups to the install directive
  542. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.5.c9120a53a6ae.hg
  543. - Add a leading zero to the revision when alphatag is used
  544. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.4.c9120a53a6ae.hg
  545. - Incorporate the feedback from the cluster-glue review
  546. - Realistically, the version is a 1.0.5 pre-release
  547. - Use the global directive instead of define for variables
  548. - Use the haclient/hacluster group/user instead of daemon
  549. - Use the _configure macro
  550. - Fix install dependancies
  551. * Fri Jul 24 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-3
  552. - Include an AUTHORS and license file in each package
  553. - Change the library package name to pacemaker-libs to be more
  554. Fedora compliant
  555. - Remove execute permissions from xml related files
  556. - Reference the new cluster-glue devel package name
  557. - Update the tarball from upstream to version c9120a53a6ae
  558. + High: PE: Only prevent migration if the clone dependancy is stopping/starting on the target node
  559. + High: PE: Bug 2160 - Dont shuffle clones due to colocation
  560. + High: PE: New implementation of the resource migration (not stop/start) logic
  561. + Medium: Tools: crm_resource - Prevent use-of-NULL by requiring a resource name for the -A and -a options
  562. + Medium: PE: Prevent use-of-NULL in find_first_action()
  563. + Low: Build: Include licensing files
  564. * Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-2
  565. - Reference authors from the project AUTHORS file instead of listing in description
  566. - Change Source0 to reference the project's Mercurial repo
  567. - Cleaned up the summaries and descriptions
  568. - Incorporate the results of Fedora package self-review
  569. * Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-1
  570. - Initial checkin