ocaml-facile-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154
  1. %global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
  2. %global debug_package %{nil}
  3. %global _default_patch_fuzz 2
  4. Name: ocaml-facile
  5. Version: 1.1
  6. Release: 31%{?_dist_release}
  7. Summary: OCaml library for constraint programming
  8. Summary(ja): 制約プログラミング向けの OCaml ライブラリ
  9. Summary(fr): Librairie OCaml de programmation par contraintes
  10. License: LGPLv2+
  11. Group: System Environment/Libraries
  12. URL: http://www.recherche.enac.fr/log/facile/
  13. Source0: http://www.recherche.enac.fr/log/facile/distrib/facile-%{version}.tar.gz
  14. # makefile fixes by Steffen Joeris <white@debian.org>:
  15. # * only build and install native binaries if ocamlopt is available
  16. # * install .mli files
  17. Patch0: facile-1.1-makefile-fixes.patch
  18. # Fix for OCaml 4.00.0.
  19. Patch1: ocaml-facile-ocaml-4.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: ocaml >= 3.02
  22. BuildRequires: ocaml-findlib-devel
  23. Obsoletes: facile < %{version}-%{release}
  24. Provides: facile = %{version}-%{release}
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: inagaki
  28. %description
  29. FaCiLe is a constraint programming library on integer and integer set finite
  30. domains written in OCaml. It offers all usual facilities to create and
  31. manipulate finite domain variables, arithmetic expressions and constraints
  32. (possibly non-linear), built-in global constraints (difference, cardinality,
  33. sorting etc.) and search and optimization goals. FaCiLe allows as well to build
  34. easily user-defined constraints and goals (including recursive ones), making
  35. pervasive use of OCaml higher-order functionals to provide a simple and flexible
  36. interface for the user. As FaCiLe is an OCaml library and not "yet another
  37. language", the user benefits from type inference and strong typing discipline,
  38. high level of abstraction, modules and objects system, as well as native code
  39. compilation efficiency, garbage collection and replay debugger, all features of
  40. OCaml (among many others) that allow to prototype and experiment quickly:
  41. modeling, data processing and interface are implemented with the same powerful
  42. and efficient language.
  43. %package devel
  44. Summary: Development files for %{name}
  45. Summary(ja): %{name} の開発用ファイル
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. %description devel
  49. The %{name}-devel package contains libraries and signature files for
  50. developing applications that use %{name}.
  51. %prep
  52. %setup -q -n facile-%{version}
  53. %patch0 -p1 -b .makefile-fixes
  54. %patch1 -p1 -b .ocaml4
  55. %build
  56. # This is not autoconf, but a simple custom configure script.
  57. # The --faciledir directory is only used for "make install".
  58. ./configure --faciledir $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
  59. make
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
  63. make install
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %check
  67. make check
  68. %files
  69. %defattr(-,root,root)
  70. %doc LICENSE README
  71. %{_libdir}/ocaml/facile/
  72. %if %opt
  73. %exclude %{_libdir}/ocaml/facile/*.a
  74. %exclude %{_libdir}/ocaml/facile/*.cmxa
  75. %endif
  76. %exclude %{_libdir}/ocaml/facile/*.mli
  77. %files devel
  78. %if %opt
  79. %{_libdir}/ocaml/facile/*.a
  80. %{_libdir}/ocaml/facile/*.cmxa
  81. %endif
  82. %{_libdir}/ocaml/facile/*.mli
  83. %changelog
  84. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1-31
  85. - changed package name
  86. - rebuilt with ocaml 4.02.1
  87. - split development files into devel subpackage
  88. * Tue May 15 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-13
  89. - rebuilt with ocaml-3.12.1
  90. * Sat Jun 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1-12
  91. - rebuild with ocaml-3.12.0
  92. * Wed Apr 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-11
  93. - rebuilt with ocaml-3.12.0
  94. - added Japanese summary
  95. - added Vendor and Distribution tag
  96. * Sun Sep 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1-10
  97. - rebuilt with ocaml-3.11.0 (x86_64 has not built with ocaml-3.11.0)
  98. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-9
  99. - rebuilt with ocaml-3.11.0
  100. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-8
  101. - rebuild with ocaml-3.10.2
  102. * Thu Feb 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl5.2
  103. - rebuild with ocaml-3.10.1 on Vine4.2
  104. * Thu Feb 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl7
  105. - rebuild with ocaml-3.10.1
  106. * Tue Oct 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl5.1
  107. - rebuild with ocaml-3.10.0 on Vine4.1
  108. * Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-0vl6
  109. - rebuild with ocaml-3.10.0
  110. * Thu Jun 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1-0vl5
  111. - rebuild with ocaml-3.09.2 on VineSeed
  112. * Thu Mar 23 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
  113. - rebuild with ocaml-3.09.1 on VineSeed
  114. * Thu Mar 23 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
  115. - rebuild with ocaml-3.09.1 on Vine3.2
  116. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
  117. - rebuild for VineSeed
  118. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
  119. - initial release