ocaml-camlpdf-vl.spec 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. %define pkg_name camlpdf
  2. %define pkg_version 2.3
  3. # %define patchlevel 1
  4. %define pkg_release 1%{?_dist_release}
  5. Summary: OCaml library for reading, writing and modifying PDF files
  6. Name: ocaml-%{pkg_name}
  7. Version: %{pkg_version}
  8. # Version: %{pkg_version}.p%{patchlevel}
  9. Release: %{pkg_release}
  10. License: LGPL v2.1+
  11. Group: Development/Languages
  12. URL: https://github.com/johnwhitington/camlpdf
  13. Source0: camlpdf-%{pkg_version}.tar.gz
  14. # Source0: camlpdf-%{pkg_version}-patchlevel%{patchlevel}.tar.gz
  15. BuildRequires: ocaml
  16. BuildRequires: ocaml-findlib
  17. Requires: ocaml
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. OCaml library for reading, writing and modifying PDF files
  22. %prep
  23. %{__rm} -rf ${RPM_BUILD_ROOT}
  24. %setup -q -n %{pkg_name}-%{pkg_version}
  25. # %setup -q -n %{pkg_name}-%{pkg_version}-patchlevel%{patchlevel}
  26. %build
  27. %{__make}
  28. %install
  29. INSTALLDIR=${RPM_BUILD_ROOT}%{_libdir}/ocaml
  30. MYCONF=my.conf
  31. touch ${MYCONF}
  32. %{__mkdir_p} ${INSTALLDIR}
  33. %{__make} install \
  34. OCAMLFIND_INSTFLAGS="-destdir ${INSTALLDIR} -ldconf ${MYCONF}"
  35. %clean
  36. %{__rm} -rf ${RPM_BUILD_ROOT}
  37. %post
  38. echo "%{_libdir}/ocaml/%{pkg_name}" >> %{_libdir}/ocaml/ld.conf
  39. %preun
  40. %{__perl} -pi -e "s|^%{_libdir}/ocaml/%{pkg_name}\n$||" \
  41. %{_libdir}/ocaml/ld.conf
  42. %files
  43. %doc doc/camlpdf/html examples
  44. %doc Changes LICENSE README.md introduction_to_camlpdf.pdf
  45. %{_libdir}/ocaml/camlpdf
  46. %changelog
  47. * Sun Oct 06 2019 Toshiaki Ara <ara_t@384.jp> 2.3-1
  48. - update to 2.3
  49. * Sun Apr 15 2018 Toshiaki Ara <ara_t@384.jp> 2.2.p1
  50. - initial build for Vine Linux