ocaml-camlp4-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define ocaml_version 4.02.1
  2. %define sup 2
  3. #ifarch %{ocaml_native_compiler}
  4. #global native_compiler 1
  5. #else
  6. #global native_compiler 0
  7. #endif
  8. Summary: Pre-Processor-Pretty-Printer for OCaml
  9. Summary(ja): OCaml 用プリプロセッサ、プリティプリンタ
  10. Name: ocaml-camlp4
  11. Version: %{ocaml_version}%{?sup:.%{sup}}
  12. Release: 1%{?_dist_release}
  13. Group: Development/Languages
  14. License: LGPLv2+ with exceptions
  15. URL: https://github.com/ocaml/camlp4
  16. Source0: https://github.com/ocaml/camlp4/archive/%{ocaml_version}%{?sup:+%{sup}}.tar.gz
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. # This package used to be part of the upstream compiler. We still
  19. # need to keep it in lock step with the compiler, so whenever a new
  20. # compiler is released we will also update this package also.
  21. BuildRequires: ocaml = %{ocaml_version}
  22. Requires: ocaml(runtime) = %{ocaml_version}
  23. #Requires: ocaml-runtime = %{version}
  24. %description
  25. Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
  26. file and printing some result on standard output.
  27. This package contains the runtime files.
  28. %package devel
  29. Summary: Development files of Pre-Processor-Pretty-Printer for OCaml
  30. Summary(ja): %{name} の開発用ファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
  35. file and printing some result on standard output.
  36. This package contains the development files.
  37. %prep
  38. %setup -q -n camlp4-%{ocaml_version}%{?sup:-%{sup}}
  39. %build
  40. ./configure
  41. # Incompatible with parallel builds:
  42. unset MAKEFLAGS
  43. #%if !%{native_compiler}
  44. #make byte
  45. #%else
  46. make all
  47. #%endif
  48. %install
  49. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  50. mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/camlp4
  51. make install \
  52. BINDIR=$RPM_BUILD_ROOT%{_bindir} \
  53. LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
  54. PKGDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/camlp4
  55. %files
  56. %doc README.md LICENSE
  57. %dir %{_libdir}/ocaml/camlp4
  58. %{_libdir}/ocaml/camlp4/*.cmi
  59. %{_libdir}/ocaml/camlp4/*.cma
  60. %{_libdir}/ocaml/camlp4/*.cmo
  61. %dir %{_libdir}/ocaml/camlp4/Camlp4Filters
  62. %{_libdir}/ocaml/camlp4/Camlp4Filters/*.cmi
  63. %{_libdir}/ocaml/camlp4/Camlp4Filters/*.cmo
  64. %dir %{_libdir}/ocaml/camlp4/Camlp4Parsers
  65. %{_libdir}/ocaml/camlp4/Camlp4Parsers/*.cmo
  66. %{_libdir}/ocaml/camlp4/Camlp4Parsers/*.cmi
  67. %dir %{_libdir}/ocaml/camlp4/Camlp4Printers
  68. %{_libdir}/ocaml/camlp4/Camlp4Printers/*.cmi
  69. %{_libdir}/ocaml/camlp4/Camlp4Printers/*.cmo
  70. %dir %{_libdir}/ocaml/camlp4/Camlp4Top
  71. %{_libdir}/ocaml/camlp4/Camlp4Top/*.cmi
  72. %{_libdir}/ocaml/camlp4/Camlp4Top/*.cmo
  73. %files devel
  74. %doc LICENSE
  75. %{_bindir}/camlp4*
  76. %{_bindir}/mkcamlp4
  77. #if %{native_compiler}
  78. %{_libdir}/ocaml/camlp4/*.a
  79. %{_libdir}/ocaml/camlp4/*.cmxa
  80. %{_libdir}/ocaml/camlp4/*.cmx
  81. %{_libdir}/ocaml/camlp4/*.o
  82. %{_libdir}/ocaml/camlp4/Camlp4Filters/*.cmx
  83. %{_libdir}/ocaml/camlp4/Camlp4Filters/*.o
  84. %{_libdir}/ocaml/camlp4/Camlp4Parsers/*.cmx
  85. %{_libdir}/ocaml/camlp4/Camlp4Parsers/*.o
  86. %{_libdir}/ocaml/camlp4/Camlp4Printers/*.cmx
  87. %{_libdir}/ocaml/camlp4/Camlp4Printers/*.o
  88. %{_libdir}/ocaml/camlp4/Camlp4Top/*.cmx
  89. %{_libdir}/ocaml/camlp4/Camlp4Top/*.o
  90. #endif
  91. %changelog
  92. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.02.1.2-1
  93. - Initial build for Vine Linux (splitted from ocaml package)
  94. - as of 4.02.1+2
  95. * Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.7.git87c6a6b0
  96. - ocaml-4.02.0 final rebuild.
  97. * Fri Aug 22 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.6.git87c6a6b0
  98. - ocaml-4.02.0+rc1 rebuild.
  99. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.02.0-0.5.git87c6a6b0
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  101. * Fri Aug 01 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.4.git87c6a6b0
  102. - ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
  103. * Sat Jul 19 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.3.git87c6a6b0
  104. - OCaml 4.02.0 beta rebuild.
  105. * Wed Jul 16 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-0.2
  106. - Initial packaging of new out-of-tree ocaml-camlp4.