123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287 |
- Summary: Plug-ins implementation convenience library
- Name: libpeas
- Version: 1.26.0
- Release: 2%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: LGPLv2+
- URL: https://gitlab.gnome.org/GNOME/libpeas/
- %global shortver %(echo %{version} | cut -d . -f 1,2)
- Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
- BuildRequires: gtk3-devel >= 2.99.3
- BuildRequires: pygobject3-devel
- BuildRequires: python3-devel
- BuildRequires: gjs-devel
- BuildRequires: glade3-devel
- BuildRequires: gtk-doc
- BuildRequires: gobject-introspection-devel
- BuildRequires: intltool
- BuildRequires: meson
- %description
- libpeas is a convenience library making adding plug-ins support
- to GTK+ and glib-based applications.
- %package devel
- Summary: Development files for libpeas
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: gobject-introspection-devel
- %description devel
- This package contains development libraries and header files
- that are needed to write applications that use libpeas.
- %package docs
- Summary: Documentation for %{name}
- Summary(ja): %{name} 用のドキュメント
- Group: Documentation
- BuildArch: noarch
- %description docs
- This package contains documentation for %{name}.
- %package python3
- Summary: Python3 loader for %{name}
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: python3
- Provides: python3-%{name} = %{version}-%{release}
- %description python3
- %{summary}
- %prep
- %setup -q
- %build
- %meson -Dgtk_doc=true
- %meson_build
- %install
- %meson_install
- %find_lang libpeas-1.0
- %post
- /sbin/ldconfig
- touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
- %postun
- /sbin/ldconfig
- if [ $1 -eq 0 ]; then
- touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
- gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
- fi
- %posttrans
- gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
- %files -f libpeas-1.0.lang
- %defattr(-,root,root,-)
- %license COPYING
- %doc AUTHORS
- %{_libdir}/libpeas*-1.0.so.*
- %dir %{_libdir}/libpeas-1.0/
- %dir %{_libdir}/libpeas-1.0/loaders
- %{_libdir}/libpeas-1.0/loaders/libpython3loader.so
- %{_libdir}/girepository-1.0/*.typelib
- %{_datadir}/icons/hicolor/*/actions/libpeas-plugin.*
- %dir %{_datadir}/glade
- %dir %{_datadir}/glade/catalogs
- %{_datadir}/glade/catalogs/*
- %files devel
- %defattr(-,root,root,-)
- %{_bindir}/peas-demo
- %{_includedir}/libpeas-1.0/
- %{_libdir}/peas-demo/
- %{_libdir}/libpeas*-1.0.so
- %{_datadir}/gir-1.0/*.gir
- %{_libdir}/pkgconfig/*.pc
- %files docs
- %defattr(-,root,root,-)
- %{_datadir}/gtk-doc/html/libpeas/
- %files python3
- %defattr(-,root,root,-)
- %{_libdir}/libpeas-1.0/loaders/libpython3loader.so
- %changelog
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.0-2
- - rebuilt with python-3.8.
- * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.0-1
- - new upstream release.
- * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
- - new upstream release
- * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
- - new upstream release
- * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-2
- - remove *.la files
- * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
- - new upstream release
- - add BuildRequires: python3-devel
- - create %%{name}-docs,python3 subpackages
- * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
- - new upstream release
- * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
- - new upstream release
- * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
- - new upstream release
- - remove Patch0 (libpeas-1.8.1-gjs-1.36.x.patch)
- - remove Patch1 (libpeas-1.8.1-gjs-plugin-loader.patch)
- * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
- - rebuild with VineSeed environment
- - add Patch0 (libpeas-1.8.1-gjs-1.36.x.patch)
- - add Patch1 (libpeas-1.8.1-gjs-plugin-loader.patch)
- * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
- - new upstream release
- * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
- - new upstream release
- * Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
- - new upstream release
- * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
- - new upstream release
- * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
- - new upstream release
- * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
- - new upstream release
- * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
- - rebuild with python-2.7.2
- * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
- - new upstream release
- * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
- - new upstream release
- - add BuildRequires: gjs-devel
- * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
- - new upstream release
- - change BuildRequires: pygobject3-devel instead of pygobject-devel
- * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
- - initial build for Vine Linux
- * Mon Apr 4 2011 Christopher Aillon <caillon@redhat.com> 1.0.0-1
- - Update to 1.0.0
- * Sun Mar 27 2011 Bastien Nocera <bnocera@redhat.com> 0.9.0-1
- - Update to 0.9.0
- * Thu Mar 10 2011 Bastien Nocera <bnocera@redhat.com> 0.7.4-1
- - Update to 0.7.4
- * Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> 0.7.3-1
- - Update to 0.7.3
- - Drop unneeded dependencies
- * Mon Feb 21 2011 Bastien Nocera <bnocera@redhat.com> 0.7.2-1
- - Update to 0.7.2
- * Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-7
- - Rebuild
- * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Wed Feb 2 2011 Matthias Clasen <mclasen@redhat.com> 0.7.1-5
- - Rebuild against newer gtk
- * Fri Jan 28 2011 Bastien Nocera <bnocera@redhat.com> 0.7.1-4
- - Update to real 0.7.1 release
- * Fri Jan 7 2011 Matthias Clasen <mclasen@redhat.com> - 0.7.1-3.gita2f98e
- - Rebuild against newer gtk
- * Fri Dec 3 2010 Matthias Clasen <mclasen@redhat.com> - 0.7.1-2.gita2f98e
- - Rebuild against newer gtk
- * Thu Nov 11 2010 Dan Williams <dcbw@redhat.com> - 0.7.1-1.gita2f98e
- - Update to 0.7.1
- - Fix some crashes with missing introspection data
- * Mon Nov 1 2010 Matthias Clasen <mclasen@redhat.com> 0.7.0-2
- - Rebuild against newer gtk3
- * Mon Oct 04 2010 Bastien Nocera <bnocera@redhat.com> 0.7.0-1
- - Update to 0.7.0
- * Tue Sep 21 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-2
- - Rebuild against newer gobject-introspection
- * Thu Aug 19 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.5-1
- - Update to 0.5.5
- * Thu Aug 5 2010 Matthias Clasen <mclasen@redhat.com> - 0.5.4-1
- - Update to 0.5.4
- * Tue Jul 27 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 0.5.3-2
- - Rebuild against python 2.7
- * Fri Jul 23 2010 Bastien Nocera <bnocera@redhat.com> 0.5.3-1
- - Update to 0.5.3
- * Thu Jul 22 2010 Bastien Nocera <bnocera@redhat.com> 0.5.2-5
- - Fix post scriplet (#615021)
- * Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.5.2-4
- - Rebuild with new gobject-introspection
- * Tue Jul 13 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-3
- - Rebuild
- * Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 0.5.2-2
- - Rebuild against new gobject-introspection
- * Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> 0.5.2-1
- - Update to 0.5.2
- * Thu Jul 8 2010 Matthias Clasen <mclasen@redhat.com> 0.5.1-2
- - Rebuild
- * Mon Jun 28 2010 Bastien Nocera <bnocera@redhat.com> 0.5.1-1
- - Update to 0.5.1
- * Thu Jun 24 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-4
- - Document rpath work-arounds disabling, and remove verbose build
- * Fri Jun 18 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-3
- - Fix a number of comments from review request
- * Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-2
- - Call ldconfig when installing the package
- * Mon Jun 14 2010 Bastien Nocera <bnocera@redhat.com> 0.5.0-1
- - First package
|