libdb-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define __soversion_major 5
  3. %define __soversion %{__soversion_major}.3
  4. %define __tclversion 8.6
  5. %bcond_with java
  6. Summary: The Berkeley DB database library for C
  7. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  8. Name: libdb
  9. Version: 5.3.28
  10. Release: 12%{?_dist_release}
  11. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  12. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  13. # For mt19937db.c
  14. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  15. Patch0: libdb-multiarch.patch
  16. # db-1.85 upstream patches
  17. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  18. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  19. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  20. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  21. # other patches
  22. Patch20: db-1.85-errno.patch
  23. Patch22: db-4.6.21-1.85-compat.patch
  24. Patch24: db-4.5.20-jni-include-dir.patch
  25. # License clarification patch
  26. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  27. Patch25: 007-mt19937db.c_license.patch
  28. #Adds missing constant to Optcodes.java and changes ClassReader.java to use it. This makes package to build with Java 8.
  29. Patch26: java8-fix.patch
  30. # memp_stat fix provided by upstream (rhbz#1211871)
  31. Patch27: db-5.3.21-memp_stat-upstream-fix.patch
  32. # fix for mutexes not being released provided by upstream (rhbz#1277887)
  33. Patch28: db-5.3.21-mutex_leak.patch
  34. # fix for overflowing hash variable inside bundled lemon
  35. Patch29: db-5.3.28-lemon_hash.patch
  36. # upstream patch adding the ability to recreate libdb's environment on version mismatch
  37. # or when libpthread.so is modified (rhbz#1394862)
  38. Patch30: db-5.3.28-condition_variable.patch
  39. # additional changes to the upstream patch to address rhbz#1460003
  40. Patch31: db-5.3.28-condition-variable-ppc.patch
  41. # downstream patch that adds a check for rpm transaction lock in order to be able to update libdb
  42. # FIXME: remove when able
  43. Patch32: db-5.3.28-rpm-lock-check.patch
  44. # downstream patch to hotfix rhbz#1464033, sent upstream
  45. Patch33: db-5.3.28-cwd-db_config.patch
  46. Patch34: libdb-5.3.21-region-size-check.patch
  47. # Patch sent upstream
  48. Patch35: checkpoint-opd-deadlock.patch
  49. Patch36: db-5.3.28-atomic_compare_exchange.patch
  50. # CDB race (rhbz #1099509)
  51. Patch37: libdb-cbd-race.patch
  52. # Limit concurrency to max 1024 CPUs (rhbz#1245410)
  53. # A fix for the issue should be in an upstream release already
  54. # https://community.oracle.com/message/13274780#13274780
  55. Patch38: libdb-limit-cpu.patch
  56. # rhbz#1608749 Patch sent upstream
  57. # Expects libdb-5.3.21-mutex_leak.patch applied
  58. Patch39: libdb-5.3.21-trickle_cpu.patch
  59. URL: http://www.oracle.com/database/berkeley-db/
  60. License: BSD and LGPLv2 and Sleepycat
  61. Group: System Environment/Libraries
  62. BuildRequires: perl libtool
  63. BuildRequires: tcl-devel >= %{__tclversion}
  64. %if %{with java}
  65. BuildRequires: java-devel >= 1:1.6.0
  66. %endif
  67. #BuildRequires: chrpath
  68. #Conflicts: filesystem < 3
  69. Vendor: Project Vine
  70. Distribution: Vine Linux
  71. Packager: tomop
  72. %description
  73. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  74. provides embedded database support for both traditional and
  75. client/server applications. The Berkeley DB includes B+tree, Extended
  76. Linear Hashing, Fixed and Variable-length record access methods,
  77. transactions, locking, logging, shared memory caching, and database
  78. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  79. used by many applications, including Python and Perl, so this should
  80. be installed on all systems.
  81. %package utils
  82. Summary: Command line tools for managing Berkeley DB databases
  83. Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
  84. Group: Applications/Databases
  85. Requires: %{name}%{?_isa} = %{version}-%{release}
  86. Obsoletes: db4-utils
  87. Provides: db4-utils
  88. %description utils
  89. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  90. provides embedded database support for both traditional and
  91. client/server applications. Berkeley DB includes B+tree, Extended
  92. Linear Hashing, Fixed and Variable-length record access methods,
  93. transactions, locking, logging, shared memory caching, and database
  94. recovery. DB supports C, C++, Java and Perl APIs.
  95. %package devel
  96. Summary: C development files for the Berkeley DB library
  97. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  98. Group: Development/Libraries
  99. Requires: %{name}%{?_isa} = %{version}-%{release}
  100. Obsoletes: db4-devel
  101. Provides: db4-devel
  102. %description devel
  103. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  104. provides embedded database support for both traditional and
  105. client/server applications. This package contains the header files
  106. and libraries for building programs which use the Berkeley DB.
  107. %package devel-doc
  108. Summary: C development documentation files for the Berkeley DB library
  109. Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
  110. Group: Documentation
  111. Requires: %{name} = %{version}-%{release}
  112. Requires: %{name}-devel = %{version}-%{release}
  113. BuildArch: noarch
  114. %description devel-doc
  115. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  116. provides embedded database support for both traditional and
  117. client/server applications. This package contains the documentation
  118. for building programs which use the Berkeley DB.
  119. %package devel-static
  120. Summary: Berkeley DB static libraries
  121. Summary(ja): Berkeley DB 静的ライブラリ
  122. Group: Development/Libraries
  123. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  124. %description devel-static
  125. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  126. provides embedded database support for both traditional and
  127. client/server applications. This package contains static libraries
  128. needed for applications that require static linking of
  129. Berkeley DB.
  130. %package cxx
  131. Summary: The Berkeley DB database library for C++
  132. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  133. Group: System Environment/Libraries
  134. Requires: %{name}%{?_isa} = %{version}-%{release}
  135. %description cxx
  136. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  137. provides embedded database support for both traditional and
  138. client/server applications. The Berkeley DB includes B+tree, Extended
  139. Linear Hashing, Fixed and Variable-length record access methods,
  140. transactions, locking, logging, shared memory caching, and database
  141. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  142. used by many applications, including Python and Perl, so this should
  143. be installed on all systems.
  144. %package cxx-devel
  145. Summary: C++ development files for the Berkeley DB library
  146. Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
  147. Group: Development/Libraries
  148. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  149. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  150. %description cxx-devel
  151. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  152. provides embedded database support for both traditional and
  153. client/server applications. This package contains the header files,
  154. libraries, and documentation for building programs which use the
  155. Berkeley DB in C++.
  156. %package tcl
  157. Summary: The Berkeley DB library for tcl
  158. Summary(ja): tcl 用 Berkeley DB データベースライブラリ
  159. Group: System Environment/Libraries
  160. Requires: %{name}%{?_isa} = %{version}-%{release}
  161. %description tcl
  162. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  163. provides embedded database support for both traditional and
  164. client/server applications. This package contains the libraries
  165. for building programs which use the Berkeley DB in Tcl.
  166. %package tcl-devel
  167. Summary: Development files for using the Berkeley DB with tcl
  168. Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
  169. Group: Development/Libraries
  170. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  171. %description tcl-devel
  172. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  173. provides embedded database support for both traditional and
  174. client/server applications. This package contains the libraries
  175. for building programs which use the Berkeley DB in Tcl.
  176. %package sql
  177. Summary: The Berkeley DB library for SQL
  178. Summary(ja): SQL 用 Berkeley DB データベースライブラリ
  179. Group: System Environment/Libraries
  180. Requires: %{name}%{?_isa} = %{version}-%{release}
  181. %description sql
  182. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  183. provides embedded database support for both traditional and
  184. client/server applications. This package contains the libraries
  185. for building programs which use the Berkeley DB in SQL.
  186. %package sql-devel
  187. Summary: Development files for using the Berkeley DB with sql
  188. Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
  189. Group: Development/Libraries
  190. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  191. %description sql-devel
  192. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  193. provides embedded database support for both traditional and
  194. client/server applications. This package contains the libraries
  195. for building programs which use the Berkeley DB in SQL.
  196. %if %{with java}
  197. %package java
  198. Summary: The Berkeley DB library for Java
  199. Summary(ja): Java 用 Berkeley DB データベースライブラリ
  200. Group: System Environment/Libraries
  201. Requires: %{name}%{?_isa} = %{version}-%{release}
  202. %description java
  203. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  204. provides embedded database support for both traditional and
  205. client/server applications. This package contains the libraries
  206. for building programs which use the Berkeley DB in Java.
  207. %package java-devel
  208. Summary: Development files for using the Berkeley DB with Java
  209. Summary(ja): Java で Berkeley DB を利用するための開発ファイル
  210. Group: Development/Libraries
  211. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  212. %description java-devel
  213. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  214. provides embedded database support for both traditional and
  215. client/server applications. This package contains the libraries
  216. for building programs which use the Berkeley DB in Java.
  217. %endif
  218. # compat32
  219. %package -n compat32-%{name}
  220. Summary: The Berkeley DB database library for C
  221. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  222. Group: System Environment/Libraries
  223. Requires: libdb = %{version}-%{release}
  224. %description -n compat32-%{name}
  225. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  226. provides embedded database support for both traditional and
  227. client/server applications. The Berkeley DB includes B+tree, Extended
  228. Linear Hashing, Fixed and Variable-length record access methods,
  229. transactions, locking, logging, shared memory caching, and database
  230. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  231. used by many applications, including Python and Perl, so this should
  232. be installed on all systems.
  233. %package -n compat32-%{name}-cxx
  234. Summary: The Berkeley DB database library for C++
  235. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  236. Group: System Environment/Libraries
  237. Requires: %{name}-cxx = %{version}-%{release}
  238. Requires: compat32-%{name} = %{version}-%{release}
  239. %description -n compat32-%{name}-cxx
  240. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  241. provides embedded database support for both traditional and
  242. client/server applications. The Berkeley DB includes B+tree, Extended
  243. Linear Hashing, Fixed and Variable-length record access methods,
  244. transactions, locking, logging, shared memory caching, and database
  245. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  246. used by many applications, including Python and Perl, so this should
  247. be installed on all systems.
  248. %package -n compat32-%{name}-devel
  249. Summary: C development files for the Berkeley DB library
  250. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  251. Group: Development/Libraries
  252. Requires: compat32-%{name} = %{version}-%{release}
  253. Requires: %{name}-devel = %{version}-%{release}
  254. Obsoletes: compat32-db4-devel
  255. Provides: compat32-db4-devel
  256. %description -n compat32-%{name}-devel
  257. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  258. provides embedded database support for both traditional and
  259. client/server applications. This package contains the header files,
  260. libraries, and documentation for building programs which use the
  261. Berkeley DB.
  262. %prep
  263. %setup -q -n db-%{version} -a 1
  264. cp %{SOURCE2} .
  265. %patch0 -p1 -b .multiarch
  266. pushd db.1.85/PORT/linux
  267. %patch10 -p0 -b .1.1
  268. popd
  269. pushd db.1.85
  270. %patch11 -p0 -b .1.2
  271. %patch12 -p0 -b .1.3
  272. %patch13 -p0 -b .1.4
  273. %patch20 -p1 -b .errno
  274. popd
  275. %patch22 -p1 -b .185compat
  276. %patch24 -p1 -b .4.5.20.jni
  277. %patch25 -p1 -b .licensefix
  278. %patch26 -p1 -b .java8-fix
  279. %patch27 -p1 -b .memp_stat-fix
  280. %patch28 -p1
  281. %patch29 -p1
  282. %patch30 -p1
  283. %patch31 -p1
  284. %patch32 -p1
  285. %patch33 -p1
  286. %patch34 -p1
  287. %patch35 -p1
  288. %patch36 -p1
  289. %patch37 -p1
  290. %patch38 -p1
  291. %patch39 -p1
  292. cd dist
  293. ./s_config
  294. cd ..
  295. %build
  296. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  297. CFLAGS="$CFLAGS -DSHAREDSTATEDIR='\"%{_sharedstatedir}\"' -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  298. export CFLAGS
  299. # Build the old db-185 libraries.
  300. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  301. test -d dist/dist-tls || mkdir dist/dist-tls
  302. # Static link db_dump185 with old db-185 libraries.
  303. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  304. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  305. # Update config files to understand aarch64
  306. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  307. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  308. #done
  309. pushd dist/dist-tls
  310. %define _configure ../configure
  311. %configure -C \
  312. --enable-compat185 \
  313. --enable-dump185 \
  314. --enable-shared \
  315. --enable-static \
  316. --enable-tcl \
  317. --with-tcl=%{_libdir} \
  318. --enable-cxx \
  319. --enable-sql \
  320. --enable-test \
  321. --disable-rpath \
  322. --with-tcl=%{_libdir}/tcl%{__tclversion} \
  323. %if %{with java}
  324. --enable-java
  325. %endif
  326. # Remove libtool predep_objects and postdep_objects wonkiness so that
  327. # building without -nostdlib doesn't include them twice. Because we
  328. # already link with g++, weird stuff happens if you don't let the
  329. # compiler handle this.
  330. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  331. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  332. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  333. make %{?_smp_mflags}
  334. %if %{with java}
  335. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  336. LDBJ=./.libs/libdb_java-%{__soversion}.la
  337. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  338. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  339. fi
  340. %endif
  341. popd
  342. %install
  343. rm -rf ${RPM_BUILD_ROOT}
  344. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  345. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  346. %makeinstall STRIP=/bin/true -C dist/dist-tls
  347. # XXX Nuke non-versioned archives and symlinks
  348. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  349. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  350. # Move the header files to a subdirectory, in case we're deploying on a
  351. # system with multiple versions of DB installed.
  352. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  353. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  354. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  355. for i in db.h db_cxx.h db_185.h; do
  356. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  357. done
  358. %if %{with java}
  359. # Move java jar file to the correct place
  360. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  361. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  362. %endif
  363. # Eliminate installed doco
  364. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  365. # XXX Avoid Permission denied. strip when building as non-root.
  366. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  367. # remove unneeded .la files (#225675)
  368. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  369. # remove RPATHs
  370. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  371. # unify documentation and examples, remove stuff we don't need
  372. rm -rf docs/csharp
  373. rm -rf examples/csharp
  374. rm -rf docs/installation
  375. mv examples docs
  376. %clean
  377. rm -rf ${RPM_BUILD_ROOT}
  378. %post -p /sbin/ldconfig
  379. %postun -p /sbin/ldconfig
  380. %post cxx -p /sbin/ldconfig
  381. %postun cxx -p /sbin/ldconfig
  382. %post sql -p /sbin/ldconfig
  383. %postun sql -p /sbin/ldconfig
  384. %post tcl -p /sbin/ldconfig
  385. %postun tcl -p /sbin/ldconfig
  386. %if %{with java}
  387. %post java -p /sbin/ldconfig
  388. %postun java -p /sbin/ldconfig
  389. %endif
  390. %if %{build_compat32}
  391. %post -n compat32-%{name} -p /sbin/ldconfig
  392. %postun -n compat32-%{name} -p /sbin/ldconfig
  393. %post -n compat32-%{name}-cxx -p /sbin/ldconfig
  394. %postun -n compat32-%{name}-cxx -p /sbin/ldconfig
  395. %endif
  396. %files
  397. %defattr(-,root,root,-)
  398. %license LICENSE lgpl-2.1.txt
  399. %doc README
  400. %{_libdir}/libdb-%{__soversion}.so
  401. %{_libdir}/libdb-%{__soversion_major}.so
  402. %files devel
  403. %defattr(-,root,root,-)
  404. %{_libdir}/libdb.so
  405. %dir %{_includedir}/%{name}
  406. %{_includedir}/%{name}/db.h
  407. %{_includedir}/%{name}/db_185.h
  408. %{_includedir}/db.h
  409. %{_includedir}/db_185.h
  410. %files devel-doc
  411. %defattr(-,root,root,-)
  412. %doc docs/*
  413. %files devel-static
  414. %defattr(-,root,root,-)
  415. %{_libdir}/libdb-%{__soversion}.a
  416. %{_libdir}/libdb_cxx-%{__soversion}.a
  417. %{_libdir}/libdb_tcl-%{__soversion}.a
  418. %{_libdir}/libdb_sql-%{__soversion}.a
  419. %if %{with java}
  420. %{_libdir}/libdb_java-%{__soversion}.a
  421. %endif
  422. %files utils
  423. %defattr(-,root,root,-)
  424. %{_bindir}/db*_archive
  425. %{_bindir}/db*_checkpoint
  426. %{_bindir}/db*_deadlock
  427. %{_bindir}/db*_dump*
  428. %{_bindir}/db*_hotbackup
  429. %{_bindir}/db*_load
  430. %{_bindir}/db*_printlog
  431. %{_bindir}/db*_recover
  432. %{_bindir}/db*_replicate
  433. %{_bindir}/db*_stat
  434. %{_bindir}/db*_upgrade
  435. %{_bindir}/db*_verify
  436. %{_bindir}/db*_tuner
  437. %files cxx
  438. %defattr(-,root,root,-)
  439. %{_libdir}/libdb_cxx-%{__soversion}.so
  440. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  441. %files cxx-devel
  442. %defattr(-,root,root,-)
  443. %{_includedir}/%{name}/db_cxx.h
  444. %{_includedir}/db_cxx.h
  445. %{_libdir}/libdb_cxx.so
  446. %files tcl
  447. %defattr(-,root,root,-)
  448. %{_libdir}/libdb_tcl-%{__soversion}.so
  449. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  450. %files tcl-devel
  451. %defattr(-,root,root,-)
  452. %{_libdir}/libdb_tcl.so
  453. %files sql
  454. %defattr(-,root,root,-)
  455. %{_libdir}/libdb_sql-%{__soversion}.so
  456. %{_libdir}/libdb_sql-%{__soversion_major}.so
  457. %files sql-devel
  458. %defattr(-,root,root,-)
  459. %{_bindir}/dbsql
  460. %{_libdir}/libdb_sql.so
  461. %{_includedir}/%{name}/dbsql.h
  462. %if %{with java}
  463. %files java
  464. %defattr(-,root,root,-)
  465. %{_libdir}/libdb_java-%{__soversion_major}*.so
  466. %{_datadir}/java/*.jar
  467. %files java-devel
  468. %defattr(-,root,root,-)
  469. %{_libdir}/libdb_java.so
  470. %endif
  471. %if %{build_compat32}
  472. %files -n compat32-%{name}
  473. %defattr(-,root,root)
  474. %{_libdir}/libdb-%{__soversion}.so
  475. %{_libdir}/libdb-%{__soversion_major}.so
  476. %files -n compat32-%{name}-cxx
  477. %defattr(-,root,root)
  478. %{_libdir}/libdb_cxx-%{__soversion}.so
  479. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  480. %files -n compat32-%{name}-devel
  481. %defattr(-,root,root)
  482. %{_libdir}/libdb.so
  483. %endif
  484. %changelog
  485. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-12
  486. - imported Patch36-39 from rawhide.
  487. * Fri Dec 22 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-11
  488. - added Patch28-15.
  489. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-10
  490. - rebuilt with new toolchain.
  491. * Thu May 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-9
  492. - added Patch27.
  493. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
  494. - added compat32 subpackages
  495. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
  496. - updated Summary and Group
  497. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  498. - added "Provides: db4-{utils,devel}".
  499. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  500. - initial build for Vine Linux.
  501. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  502. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  503. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  504. - Fix configure macro usage for better aarch64 build fix
  505. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  506. - Updated config files to allow build on aarch64 (#1022970)
  507. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  508. - Added Sleepycat to the license list (#1013841)
  509. - Updated to 5.3.28 (#1013233)
  510. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  511. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  512. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  513. - add copy of lgpl-2.1.txt
  514. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  515. - Fix missing debuginfo issue for utils subpackage
  516. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  517. - add license clarification fix
  518. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  519. - Added sqlite compability CFLAGS (#788496)
  520. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  521. - Cleaning the specfile - removed gcc-java dependecy other way
  522. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  523. - Removed dependency on obsolete gcc-java package (#927742)
  524. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  525. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  526. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  527. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  528. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  529. - fix license tag
  530. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  531. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  532. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  533. - Specify tag for libtool (fixes FTBFS # 838334 )
  534. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  535. - update to 5.3.21
  536. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  537. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  538. - move C++ header files to cxx-devel
  539. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  540. - fix -devel packages dependencies yet more (#832225)
  541. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  542. - package -devel packages correctly
  543. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  544. - fix multiarch conflict in libdb-devel (#812901)
  545. - remove unneeded dos2unix BR
  546. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  547. - update to 5.3.15
  548. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  549. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  550. - Resolves rhbz#794472
  551. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  552. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  553. - add filesystem guard
  554. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  555. - install everything in /usr
  556. https://fedoraproject.org/wiki/Features/UsrMove
  557. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  558. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  559. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  560. - update to 5.2.36,
  561. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  562. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  563. - move development documentation to devel-doc subpackage (#705386)
  564. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  565. - update to 5.2.28
  566. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  567. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  568. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  569. - update to 5.1.25
  570. * Wed Sep 29 2010 jkeating - 5.1.19-2
  571. - Rebuilt for gcc bug 634757
  572. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  573. - update to 5.1.19
  574. - rename -devel-static to -static subpackage (#617800)
  575. - build java on all arches
  576. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  577. - update to 5.0.26
  578. - drop BR: ed
  579. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  580. - add Requires: libdb-cxx to libdb-devel
  581. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  582. - initial build
  583. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  584. - remove C# documentation
  585. - disable/remove rpath
  586. - fix description
  587. - tighten dependencies
  588. - run ldconfig for cxx and sql subpackages
  589. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  590. - enable sql
  591. - package 5.0.21