lsb-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641
  1. # Define this to link to which library version eg. /lib64/ld-lsb-x86-64.so.3
  2. %define lsbsover 3
  3. %ifarch %{ix86}
  4. %define ldso ld-linux.so.2
  5. %define lsbldso ld-lsb.so
  6. %endif
  7. %ifarch ia64
  8. %define ldso ld-linux-ia64.so.2
  9. %define lsbldso ld-lsb-ia64.so
  10. %endif
  11. %ifarch ppc
  12. %define ldso ld.so.1
  13. %define lsbldso ld-lsb-ppc32.so
  14. %endif
  15. %ifarch ppc64
  16. %define ldso ld64.so.1
  17. %define lsbldso ld-lsb-ppc64.so
  18. %endif
  19. %ifarch s390
  20. %define ldso ld.so.1
  21. %define lsbldso ld-lsb-s390.so
  22. %endif
  23. %ifarch s390x
  24. %define ldso ld64.so.1
  25. %define lsbldso ld-lsb-s390x.so
  26. %endif
  27. %ifarch x86_64
  28. %define ldso ld-linux-x86-64.so.2
  29. %define lsbldso ld-lsb-x86-64.so
  30. %endif
  31. %ifarch ia64 ppc64 s390x x86_64
  32. %define qual ()(64bit)
  33. %else
  34. %define qual %{nil}
  35. %endif
  36. %define upstreamlsbrelver 2.0
  37. %define lsbrelver 4.0
  38. %define srcrelease 1
  39. Summary: LSB support for Vine Linux
  40. Summary(ja): Vine Linux の LSB サポート
  41. Name: lsb
  42. Version: 4.0
  43. Release: 5%{?_dist_release}
  44. URL: http://www.linuxfoundation.org/
  45. Source0: %{name}-vine-%{version}.tar.bz2
  46. License: GPLv2
  47. Group: System Environment/Base
  48. BuildRoot: %{_tmppath}/%{name}-root
  49. BuildRequires: glibc-static
  50. # dependency for primary LSB application for v1.3
  51. Provides: lsb = %{version}
  52. # dependency for primary LSB application for v2.0, v3.0 and v4.0
  53. %ifarch %{ix86}
  54. %define archname ia32
  55. %endif
  56. %ifarch ia64
  57. %define archname ia64
  58. %endif
  59. %ifarch ppc
  60. %define archname ppc32
  61. %endif
  62. %ifarch ppc64
  63. %define archname ppc64
  64. %endif
  65. %ifarch s390
  66. %define archname s390
  67. %endif
  68. %ifarch s390x
  69. %define archname s390x
  70. %endif
  71. %ifarch x86_64
  72. %define archname amd64
  73. %endif
  74. Provides: lsb-core-%{archname} = %{version}
  75. Provides: lsb-graphics-%{archname} = %{version}
  76. Provides: lsb-core-noarch = %{version}
  77. Provides: lsb-graphics-noarch = %{version}
  78. Provides: lsb-printing-%{archname} = %{version}
  79. Provides: lsb-printing-noarch = %{version}
  80. ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x
  81. %ifarch %{ix86}
  82. # archLSB IA32 Base Libraries
  83. Requires: libatk-1.0.so.0
  84. Requires: libc.so.6
  85. Requires: libcrypt.so.1
  86. Requires: libdl.so.2
  87. Requires: libgcc_s.so.1
  88. Requires: libgdk-x11-2.0.so.0
  89. Requires: libgdk_pixbuf-2.0.so.0
  90. Requires: libgdk_pixbuf_xlib-2.0.so.0
  91. Requires: libglib-2.0.so.0
  92. Requires: libgmodule-2.0.so.0
  93. Requires: libgobject-2.0.so.0
  94. Requires: libgthread-2.0.so.0
  95. Requires: libgtk-x11-2.0.so.0
  96. Requires: libm.so.6
  97. Requires: libncurses.so.5
  98. Requires: libpango-1.0.so.0
  99. Requires: libpangoft2-1.0.so.0
  100. Requires: libpangoxft-1.0.so.0
  101. Requires: libpthread.so.0
  102. #Requires: libqt-mt.so.3
  103. Requires: libQtCore.so.4
  104. Requires: libQtGui.so.4
  105. Requires: libQtNetwork.so.4
  106. Requires: libQtOpenGL.so.4
  107. Requires: libQtSql.so.4
  108. Requires: libQtSvg.so.4
  109. Requires: libQtXml.so.4
  110. Requires: libstdc++.so.6
  111. Requires: libutil.so.1
  112. Requires: libz.so.1
  113. %endif
  114. %ifarch x86_64
  115. # archLSB AMD64 Base Libraries
  116. Requires: libatk-1.0.so.0()(64bit)
  117. Requires: libc.so.6()(64bit)
  118. Requires: libcrypt.so.1()(64bit)
  119. Requires: libdl.so.2()(64bit)
  120. Requires: libgcc_s.so.1()(64bit)
  121. Requires: libgdk-x11-2.0.so.0()(64bit)
  122. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  123. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  124. Requires: libglib-2.0.so.0()(64bit)
  125. Requires: libgmodule-2.0.so.0()(64bit)
  126. Requires: libgobject-2.0.so.0()(64bit)
  127. Requires: libgthread-2.0.so.0()(64bit)
  128. Requires: libgtk-x11-2.0.so.0()(64bit)
  129. Requires: libm.so.6()(64bit)
  130. Requires: libncurses.so.5()(64bit)
  131. Requires: libpango-1.0.so.0()(64bit)
  132. Requires: libpangoft2-1.0.so.0()(64bit)
  133. Requires: libpangoxft-1.0.so.0()(64bit)
  134. Requires: libpthread.so.0()(64bit)
  135. #Requires: libqt-mt.so.3()(64bit)
  136. Requires: libQtCore.so.4()(64bit)
  137. Requires: libQtGui.so.4()(64bit)
  138. Requires: libQtNetwork.so.4()(64bit)
  139. Requires: libQtOpenGL.so.4()(64bit)
  140. Requires: libQtSql.so.4()(64bit)
  141. Requires: libQtSvg.so.4()(64bit)
  142. Requires: libQtXml.so.4()(64bit)
  143. Requires: libstdc++.so.6()(64bit)
  144. Requires: libutil.so.1()(64bit)
  145. Requires: libz.so.1()(64bit)
  146. %endif
  147. # gLSB Base/Utility/Stdc++/Graphics Libraries
  148. Requires: libasound.so.2%{qual}
  149. Requires: libatk-1.0.so.0%{qual}
  150. Requires: libcrypt.so.1%{qual}
  151. Requires: libcups.so.2%{qual}
  152. Requires: libcupsimage.so.2%{qual}
  153. Requires: libdl.so.2%{qual}
  154. Requires: libfontconfig.so.1%{qual}
  155. Requires: libfreetype.so.6%{qual}
  156. Requires: libgcc_s.so.1%{qual}
  157. Requires: libgdk-x11-2.0.so.0%{qual}
  158. Requires: libgdk_pixbuf-2.0.so.0%{qual}
  159. Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
  160. Requires: libGL.so.1%{qual}
  161. Requires: libglib-2.0.so.0%{qual}
  162. Requires: libgmodule-2.0.so.0%{qual}
  163. Requires: libgobject-2.0.so.0%{qual}
  164. Requires: libgthread-2.0.so.0%{qual}
  165. Requires: libgtk-x11-2.0.so.0%{qual}
  166. Requires: libICE.so.6%{qual}
  167. Requires: libjpeg.so.62%{qual}
  168. Requires: libncurses.so.5%{qual}
  169. Requires: libpam.so.0%{qual}
  170. Requires: libpango-1.0.so.0%{qual}
  171. Requires: libpangoft2-1.0.so.0%{qual}
  172. Requires: libpangoxft-1.0.so.0%{qual}
  173. Requires: libpng16.so.16%{qual}
  174. Requires: libpthread.so.0%{qual}
  175. #Requires: libqt-mt.so.3%{qual}
  176. Requires: libQtCore.so.4%{qual}
  177. Requires: libQtGui.so.4%{qual}
  178. Requires: libQtNetwork.so.4%{qual}
  179. Requires: libQtOpenGL.so.4%{qual}
  180. Requires: libQtSql.so.4%{qual}
  181. Requires: libQtSvg.so.4%{qual}
  182. Requires: libQtXml.so.4%{qual}
  183. Requires: librt.so.1%{qual}
  184. Requires: libSM.so.6%{qual}
  185. Requires: libstdc++.so.6%{qual}
  186. Requires: libutil.so.1%{qual}
  187. Requires: libX11.so.6%{qual}
  188. Requires: libXext.so.6%{qual}
  189. Requires: libXft.so.2%{qual}
  190. Requires: libXi.so.6%{qual}
  191. Requires: libxml2.so.2%{qual}
  192. Requires: libXrender.so.1%{qual}
  193. Requires: libXt.so.6%{qual}
  194. Requires: libz.so.1%{qual}
  195. # gLSB Command and Utilities
  196. Requires: /bin/awk
  197. Requires: /bin/basename
  198. Requires: /bin/cat
  199. Requires: /bin/chgrp
  200. Requires: /bin/chmod
  201. Requires: /bin/chown
  202. Requires: /bin/cp
  203. Requires: /bin/cpio
  204. Requires: /bin/cut
  205. Requires: /bin/date
  206. Requires: /bin/dd
  207. Requires: /bin/df
  208. Requires: /bin/dmesg
  209. Requires: /bin/echo
  210. Requires: /bin/ed
  211. Requires: /bin/egrep
  212. Requires: /bin/env
  213. Requires: /bin/false
  214. Requires: /bin/fgrep
  215. Requires: /bin/gettext
  216. Requires: /bin/grep
  217. Requires: /bin/gunzip
  218. Requires: /bin/gzip
  219. Requires: /bin/hostname
  220. Requires: /bin/kill
  221. Requires: /bin/ln
  222. Requires: /bin/ls
  223. Requires: mailx
  224. Requires: /bin/mkdir
  225. Requires: /bin/mknod
  226. Requires: /bin/mktemp
  227. Requires: /bin/more
  228. Requires: /bin/mount
  229. Requires: /bin/mv
  230. Requires: /bin/nice
  231. Requires: /bin/ps
  232. Requires: /bin/pwd
  233. Requires: /bin/rm
  234. Requires: /bin/rmdir
  235. Requires: /bin/sed
  236. Requires: /bin/sh
  237. Requires: /bin/sleep
  238. Requires: /bin/sort
  239. Requires: /bin/stty
  240. Requires: /bin/su
  241. Requires: /bin/sync
  242. Requires: /bin/tar
  243. Requires: /bin/touch
  244. Requires: /bin/true
  245. Requires: /bin/umount
  246. Requires: /bin/uname
  247. Requires: /bin/zcat
  248. Requires: /sbin/fuser
  249. Requires: /sbin/pidof
  250. Requires: /sbin/shutdown
  251. Requires: /usr/bin/[
  252. Requires: /usr/bin/ar
  253. Requires: /usr/bin/at
  254. Requires: /usr/bin/batch
  255. Requires: /usr/bin/bc
  256. Requires: /usr/bin/chfn
  257. Requires: /usr/bin/chsh
  258. Requires: /usr/bin/cksum
  259. Requires: /usr/bin/cmp
  260. Requires: /usr/bin/col
  261. Requires: /usr/bin/comm
  262. Requires: /usr/bin/crontab
  263. Requires: /usr/bin/csplit
  264. Requires: /usr/bin/diff
  265. Requires: /usr/bin/dirname
  266. Requires: /usr/bin/du
  267. Requires: /usr/bin/expand
  268. Requires: /usr/bin/expr
  269. Requires: /usr/bin/fc-cache
  270. Requires: /usr/bin/fc-list
  271. Requires: /usr/bin/fc-match
  272. Requires: /usr/bin/file
  273. Requires: /usr/bin/find
  274. Requires: /usr/bin/fold
  275. Requires: /usr/bin/foomatic-rip
  276. Requires: /usr/bin/gencat
  277. Requires: /usr/bin/getconf
  278. Requires: /usr/bin/groups
  279. Requires: /usr/bin/gs
  280. Requires: /usr/bin/head
  281. Requires: /usr/bin/iconv
  282. Requires: /usr/bin/id
  283. Requires: /usr/bin/install
  284. Requires: /usr/bin/ipcrm
  285. Requires: /usr/bin/ipcs
  286. Requires: /usr/bin/join
  287. Requires: /usr/bin/killall
  288. Requires: /usr/bin/locale
  289. Requires: /usr/bin/localedef
  290. Requires: /usr/bin/logger
  291. Requires: /usr/bin/logname
  292. Requires: /usr/bin/lp
  293. Requires: /usr/bin/lpr
  294. Requires: /usr/bin/m4
  295. Requires: /usr/bin/make
  296. Requires: /usr/bin/man
  297. Requires: /usr/bin/md5sum
  298. Requires: /usr/bin/mkfifo
  299. Requires: /usr/bin/msgfmt
  300. Requires: /usr/bin/newgrp
  301. Requires: /usr/bin/nl
  302. Requires: /usr/bin/nohup
  303. Requires: /usr/bin/od
  304. Requires: /usr/bin/passwd
  305. Requires: /usr/bin/paste
  306. Requires: /usr/bin/patch
  307. Requires: /usr/bin/pathchk
  308. # better POSIX compatible
  309. Requires: spax
  310. Requires: /usr/bin/perl
  311. Requires: /usr/bin/pr
  312. Requires: /usr/bin/printf
  313. Requires: /usr/bin/python
  314. Requires: /usr/bin/renice
  315. Requires: /usr/bin/split
  316. Requires: /usr/bin/strip
  317. Requires: /usr/bin/tail
  318. Requires: /usr/bin/tee
  319. Requires: /usr/bin/test
  320. Requires: /usr/bin/time
  321. Requires: /usr/bin/tr
  322. Requires: /usr/bin/tsort
  323. Requires: /usr/bin/tty
  324. Requires: /usr/bin/unexpand
  325. Requires: /usr/bin/uniq
  326. Requires: /usr/bin/wc
  327. Requires: /usr/bin/xargs
  328. Requires: /usr/sbin/groupadd
  329. Requires: /usr/sbin/groupdel
  330. Requires: /usr/sbin/groupmod
  331. Requires: /usr/sbin/sendmail
  332. Requires: /usr/sbin/useradd
  333. Requires: /usr/sbin/userdel
  334. Requires: /usr/sbin/usermod
  335. %description
  336. The Linux Standard Base (LSB) is an attempt to develop a set of
  337. standards that will increase compatibility among Linux distributions.
  338. The lsb package provides utilities needed for LSB Compliant
  339. Applications. It also contains requirements that will ensure that all
  340. components required by the LSB that are provided by Red Hat Linux are
  341. installed on the system.
  342. %prep
  343. %setup -q -n %{name}-vine-%{version}
  344. %build
  345. cd lsb-release-%{upstreamlsbrelver}
  346. make
  347. %install
  348. rm -rf $RPM_BUILD_ROOT
  349. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  350. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
  351. $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
  352. $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
  353. make DESTDIR=$RPM_BUILD_ROOT install
  354. cd lsb-release-%{upstreamlsbrelver}
  355. make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
  356. cd ..
  357. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-%{archname}
  358. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-noarch
  359. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-%{archname}
  360. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-noarch
  361. touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-%{archname}
  362. touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-noarch
  363. # and claim LSB 3.1/3.2 is supported as well
  364. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
  365. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
  366. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
  367. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
  368. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
  369. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
  370. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
  371. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
  372. for LSBVER in %{lsbsover}; do
  373. ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
  374. done
  375. mkdir -p $RPM_BUILD_ROOT/bin
  376. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  377. # According to the lsb-core documentation provided by
  378. # http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
  379. # it's OK to put non binary in /usr/lib.
  380. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
  381. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
  382. ln -snf mail $RPM_BUILD_ROOT/bin/mailx
  383. gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
  384. -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
  385. install -m 700 lsb_vine_trigger.%{_target_cpu} \
  386. $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
  387. cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
  388. %clean
  389. rm -rf $RPM_BUILD_ROOT
  390. %triggerpostun -- glibc
  391. if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
  392. /usr/sbin/lsb_vine_trigger.%{_target_cpu}
  393. fi
  394. %ifnarch %{ix86}
  395. /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
  396. %else
  397. if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
  398. for LSBVER in %{lsbsover}; do
  399. /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  400. done
  401. else
  402. for LSBVER in %{lsbsover}; do
  403. /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  404. done
  405. fi
  406. %endif
  407. %ifarch %{ix86}
  408. %post
  409. # make this softlink again for /emul
  410. if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
  411. for LSBVER in %{lsbsover}; do
  412. /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  413. done
  414. fi
  415. %endif
  416. %files
  417. %defattr(-,root,root)
  418. %{_sysconfdir}/lsb-vine
  419. %dir %{_sysconfdir}/lsb-release.d
  420. %{_sysconfdir}/lsb-release.d/*
  421. %{_mandir}/*/*
  422. %{_bindir}/*
  423. /bin/lsb_vine_init
  424. /usr/lib/lsb
  425. /%{_lib}/*so*
  426. /lib/lsb*
  427. %{_sbindir}/lsb_vine_trigger.%{_target_cpu}
  428. /bin/mailx
  429. %changelog
  430. * Mon Oct 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-5
  431. - made not to require qt3.
  432. - removed stuff for unsuppoted architectures.
  433. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 4.0-4
  434. - rebuild with gcc-5.4.0
  435. * Wed Jan 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0-3
  436. - change Requires: libpng16.so.16 instead of libpng12.so.0
  437. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0-2
  438. - require spax instead of pax (more POSIX compatible)
  439. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
  440. - update to LSB4.0
  441. - add Provide lsb-printing{,-noarch}
  442. - add BR: glibc-static
  443. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
  444. - initial build for Vine Linux
  445. * Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
  446. - Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
  447. * Mon Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
  448. - Port forward to LSB 3.2
  449. - Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
  450. - Since F10 put mailx under /usr/bin, change the corresponding requires
  451. * Tue Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
  452. - Remove 2 requires which provided by redhat-lsb
  453. - Add comments explaining why hard-coded path is kept
  454. - Resolve some hard-coded path problems
  455. - Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
  456. - Replace %{_libdir}/lsb with /usr/lib/lsb
  457. - Replace /%{_lib}/* with /%{_lib}/*so*
  458. - Replace /lib/lsb with /lib/lsb*
  459. * Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
  460. - remove symlink for mailx (Bug #457241)
  461. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
  462. - Autorebuild for GCC 4.3
  463. * Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
  464. - fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
  465. * Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
  466. - fix build issue in minimal build root (Bug #265241)
  467. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
  468. - Rebuild for selinux ppc32 issue.
  469. * Mon Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
  470. - update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
  471. * Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
  472. - Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
  473. - forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
  474. * Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
  475. - fixed Bug 232918 for new glibc version
  476. * Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
  477. - fixed Bug 226363
  478. * Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
  479. - replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
  480. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
  481. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  482. * Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
  483. - Fix upgrade issue; Bug 202548
  484. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
  485. - rebuild
  486. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
  487. - for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
  488. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
  489. - generate spec file on RHEL5-Alpha system
  490. - fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
  491. * Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
  492. - Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
  493. rather than sniffing through sgml
  494. - remove redundent script and bump up tarball version
  495. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
  496. - bump again for double-long bug on ppc(64)
  497. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
  498. - rebuilt for new gcc4.1 snapshot and glibc changes
  499. * Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
  500. - Migrated back to rawhide
  501. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
  502. - Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
  503. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
  504. - Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
  505. depends on /etc/lsb-release.d/ (Advised by LSB committee)
  506. - Removed /etc/lsb-release (Advised by LSB committee)
  507. * Mon Aug 1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
  508. - Made the /etc/lsb-release useful (RH#154605)
  509. - Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
  510. - Fixed AMD64 base libraries requirement parsing (RH#154605)
  511. * Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
  512. - Fixed redhat-lsb's mkredhat-lsb on fetching lib and
  513. cmd requirements
  514. * Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
  515. - Rebuilt
  516. * Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
  517. - Disabled support for LSB 1.3 and 2.0
  518. * Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
  519. - Upgraded to lsb-release 2.0
  520. * Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
  521. - Moved to LSB 3.0
  522. * Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
  523. - Fixed ix86 package with ia32 emul support
  524. * Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
  525. - Sync what we have changed on the branches
  526. Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
  527. - added post section to recreate the softlink in emul mode (bug 140739)
  528. Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
  529. Tiny correction of bug in new triggers
  530. * Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
  531. - Add support provide on lsb-core-* for each arch
  532. * Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
  533. - Add to support multiple LSB test suite version
  534. - Add %%endif in trigger postun
  535. * Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
  536. - Fixed invalid sln call for trigger in postun on ia64 (#137647)
  537. * Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
  538. - Bump release and rebuilt for RHEL4.
  539. * Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
  540. - fix lsb ld.so name for ia64 (#100613)
  541. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  542. - use /usr/lib/lsb for install_initd, remove_initd
  543. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  544. - add ia64 x86_64 ppc ppc64 s390 s390x
  545. * Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
  546. - 1.3
  547. * Wed Sep 4 2002 Matt Wilson <msw@redhat.com>
  548. - 1.2.0
  549. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  550. - automated rebuild
  551. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  552. - automated rebuild
  553. * Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
  554. - addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
  555. forced downgrade case.
  556. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
  557. - add initscripts support
  558. * Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
  559. - Initial build.