js-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. #% global hgdate 51702867d932
  2. Summary: JavaScript interpreter and libraries
  3. Summary(ja): JavaScript インタプリタ及びライブラリ
  4. Name: js
  5. Epoch: 1
  6. Version: 1.8.5
  7. Release: 5%{?hgdate:.hg%{hgdate}}%{?_dist_release}
  8. License: GPLv2+ or LGPLv2+ or MPLv1.1
  9. Group: Development/Languages
  10. URL: http://www.mozilla.org/js/
  11. Source0: http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
  12. Patch0: js-1.8.5-64bit-big-endian.patch
  13. Patch1: js-1.8.5-secondary-jit.patch
  14. Patch2: js185-destdir.patch
  15. #Patch3: js-1.8.5-configure.patch
  16. Patch3: js-1.8.5-537701.patch
  17. Patch4: js185-arm-nosoftfp.patch
  18. Patch5: js185-libedit.patch
  19. Patch6: 0001-Make-js-config.h-multiarch-compatible.patch
  20. Provides: libjs = %{version}-%{release}
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: nspr-devel >= 4.7
  23. BuildRequires:, python
  24. BuildRequires: zip
  25. BuildRequires: libedit-devel
  26. BuildRequires: ncurses-devel
  27. BuildRequires: autoconf213
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %description
  31. JavaScript is the Netscape-developed object scripting language used in millions
  32. of web pages and server applications worldwide. Netscape's JavaScript is a
  33. superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
  34. with only mild differences from the published standard.
  35. %package devel
  36. Summary: Header files, libraries and development documentation for %{name}
  37. Summary(ja): %{name} のヘッダファイル、ライブラリ及び開発用ドキュメント
  38. Group: Development/Libraries
  39. Requires: %{name} = %{epoch}:%{version}-%{release}
  40. Requires: pkgconfig
  41. Requires: ncurses-devel
  42. Provides: libjs-devel = %{version}-%{release}
  43. %description devel
  44. This package contains the header files, static libraries and development
  45. documentation for %{name}. If you like to develop programs using %{name},
  46. you will need to install %{name}-devel.
  47. %prep
  48. # All patches come from old version and maintainer. I think it is Fedora related only
  49. %setup -q -n %{name}-%{version}
  50. %patch0 -p2 -b .64bit-big-endian
  51. %patch1 -p2 -b .secondary-jit
  52. %patch2 -p0 -b .destdir
  53. %patch3 -p1 -b .537701
  54. %patch4 -p1 -b .armhfp
  55. %patch5 -p1 -b .libedit
  56. %patch6 -p1 -b .multiarch
  57. cd js
  58. # Rm parts with spurios licenses, binaries
  59. # Some parts under BSD (but different suppliers): src/assembler
  60. #rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
  61. rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
  62. pushd src
  63. autoconf-2.13
  64. popd
  65. # Create pkgconfig file
  66. %{__cat} > libjs.pc << 'EOF'
  67. prefix=%{_prefix}
  68. exec_prefix=%{_prefix}
  69. libdir=%{_libdir}
  70. includedir=%{_includedir}
  71. Name: libjs
  72. Description: JS library
  73. Requires: nspr >= 4.7
  74. Version: %{version}
  75. Libs: -L${libdir} -ljs
  76. Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
  77. EOF
  78. %build
  79. cd js/src
  80. CPPFLAGS="$(pkg-config --cflags libedit)" \
  81. %configure \
  82. --with-system-nspr \
  83. --enable-threadsafe \
  84. --enable-readline
  85. %{__make} %{?_smp_mflags}
  86. %install
  87. %{__rm} -rf %{buildroot}
  88. cd js
  89. %{__make} -C src install DESTDIR=%{buildroot}
  90. # We don't want this
  91. %{__rm} -f %{buildroot}%{_bindir}/js-config
  92. %{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
  93. %{__rm} -rf %{buildroot}%{_libdir}/*.a
  94. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  95. %{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
  96. # For compatibility
  97. # XXX do we really need libjs?!?!?!
  98. pushd %{buildroot}%{_libdir}
  99. %{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
  100. %{__ln_s} libmozjs185.so.1.0 libjs.so.1
  101. %{__ln_s} libmozjs185.so libmozjs.so
  102. %{__ln_s} libmozjs185.so libjs.so
  103. popd
  104. %{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
  105. %clean
  106. %{__rm} -rf %{buildroot}
  107. %post -p /sbin/ldconfig
  108. %postun -p /sbin/ldconfig
  109. %files
  110. %defattr(-,root,root,-)
  111. %doc js/src/README.html
  112. %{_bindir}/js
  113. %{_libdir}/*.so.*
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %{_bindir}/jscpucfg
  117. %{_libdir}/pkgconfig/*.pc
  118. %{_libdir}/*.so
  119. %{_includedir}/js
  120. %{_includedir}/js*.h
  121. %{_includedir}/*.tbl
  122. %{_includedir}/js.msg
  123. %{_includedir}/prmjtime.h
  124. %changelog
  125. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-5
  126. - rebuild with gcc-5.4.0
  127. * Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1:1.8.5-4
  128. - added Patch5 to build with libedit instead of readline
  129. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-3
  130. - rebuild with VineSeed environment
  131. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-2
  132. - add Patch4 (js-1.8.5-537701.patch) from fedora
  133. - add Patch5 (js185-arm-nosoftfp.patch) from fedora
  134. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-1
  135. - add Patch3 (js-1.8.5-configure.patch)
  136. - merge spec file with fedora package
  137. * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
  138. - new upstream release
  139. - applied new versioning policy
  140. - removed no longer provided perlconnect parts.
  141. * Mon Jun 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
  142. - initial build for Vine Linux
  143. * Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
  144. - Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
  145. - Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
  146. - Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
  147. * Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
  148. - Include mozjs185.pc, clean up build
  149. - Based on work from Christopher Aillon <caillon@redhat.com>
  150. - Switch to using make install DESTDIR=, instead of hardcoding build rules.
  151. - Add DESTDIR= patch from GNOME 3.2 jhbuild
  152. - Make mozjs185 the canonical target for both libmozjs and libmozjs185.
  153. * Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
  154. - add secondary arch patches from xulrunner
  155. * Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
  156. - devel subpackage needs to ask for the newly added epoch
  157. * Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
  158. - Add Epoch: 1 to allow update of 1.70-13 version.
  159. * Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
  160. - Correct symlink to provide backward capabiliies libjs.so.1
  161. * Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
  162. - Update to release.
  163. - Remove unneeded anymore patches.
  164. - Add backward capability symlink.
  165. * Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
  166. - Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
  167. - Gone -DJS_C_STRINGS_ARE_UTF8
  168. - Add BR autoconf213, change build system to use configure.
  169. - Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
  170. - Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
  171. - Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
  172. - Add BR python, zip.
  173. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  175. * Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
  176. - Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
  177. * Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
  178. - updated the va_copy patch for s390
  179. * Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
  180. - Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
  181. * Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
  182. - Reformat spec with tabs.
  183. - By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
  184. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  186. * Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
  187. - update the va_copy patch for s390x
  188. * Thu Apr 9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
  189. - Update description (#487903).
  190. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  192. * Wed Jun 4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
  193. - Add two missing files (#449715)
  194. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
  195. - Rebuild for perl 5.10 (again)
  196. * Sun Feb 3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
  197. - Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
  198. - Remove no longer provided perlconnect parts.
  199. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
  200. - BR: perl(ExtUtils::Embed)
  201. * Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
  202. - rebuild for new perl
  203. * Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
  204. - Rebuild for new BuildID feature.
  205. * Mon Aug 6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
  206. - Update License field.
  207. - Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
  208. * Fri Feb 2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
  209. - Include jsopcode.tbl and js.msg in devel (#235481).
  210. - Install static lib mode 644 instead of 755.
  211. * Fri Feb 2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
  212. - Update to 1.60.
  213. - Rebuild in order to link against ncurses instead of termcap (#226773).
  214. - Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
  215. - Change mode of perl library from 555 to 755 (#224603).
  216. * Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
  217. - Fix pkgconfig file (#204232 & dupe #204236).
  218. * Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
  219. - FC6 rebuild.
  220. - Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
  221. * Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
  222. - FC5 rebuild.
  223. * Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
  224. - Rebuild for new gcc/glibc.
  225. * Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
  226. - Fix .pc file.
  227. * Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
  228. - Update to 1.5.0 final.
  229. - Spec file cleanups.
  230. - Move docs from devel to main, since we need the license there.
  231. - Remove no longer needed js-perlconnect.patch.
  232. - Update js-1.5-va_copy.patch.
  233. - Include a pkgconfig file (#178993).
  234. * Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
  235. - Link shared lib with libperl.
  236. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  237. - rebuilt
  238. * Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
  239. - Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
  240. * Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
  241. - Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
  242. * Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
  243. - Include perlconnect.
  244. - Include readline support, rebuild using "--without readline" to disable.
  245. - Add libjs* provides for upstream compatibility.
  246. - Install header files in %%{_includedir} instead of %%{_includedir}/js.
  247. * Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
  248. - Update to 1.5rc6a.
  249. * Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
  250. - Initial package. (using DAR)