jpackage-utils-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616
  1. # Copyright (c) 2000-2008, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. %define gcj_support 1
  31. %define distver 1.7
  32. %define section free
  33. Name: jpackage-utils
  34. Summary: JPackage utilities
  35. Summary(ja): JPackage ユーティリティ集
  36. Version: 1.7.5
  37. Release: 1%{?_dist_release}
  38. License: BSD
  39. URL: http://www.jpackage.org/
  40. Group: System Environment/Base
  41. Source0: %{name}-%{version}.tar.bz2
  42. Source1: %{name}-README
  43. Source2: abs2rel.sh
  44. Source3: abs2rel.lua
  45. Patch0: %{name}-enable-gcj-support.patch
  46. Patch1: %{name}-own-mavendirs.patch
  47. Patch2: %{name}-prefer-jre.patch
  48. Patch3: %{name}-set-classpath.patch
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. BuildArch: noarch
  51. Requires: coreutils
  52. %description
  53. Utilities for the JPackage Project <http://www.jpackage.org/>:
  54. It contains also the License, man pages, documentation, XSL files of general
  55. use with maven2, a header file for spec files, etc. Please See
  56. the %{_docdir}/%{name}-%{version}/%{name}-README file for more
  57. information.
  58. %prep
  59. %setup -q
  60. %patch0 -p0
  61. %patch1 -p1
  62. %patch2 -p1
  63. %patch3 -p1
  64. cp -p %{SOURCE1} %{SOURCE2} %{SOURCE3} .
  65. %build
  66. echo "JPackage release %{distver} (%{distribution}) for %{buildarch}" \
  67. > etc/jpackage-release
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. # Pull macros out of macros.jpackage and emulate them during install for
  71. # smooth bootstrapping experience.
  72. for dir in \
  73. jvmdir jvmjardir jvmprivdir \
  74. jvmlibdir jvmdatadir jvmsysconfdir \
  75. jvmcommonlibdir jvmcommondatadir jvmcommonsysconfdir \
  76. javadir jnidir javadocdir mavenpomdir \
  77. mavendepmapdir mavendepmapfragdir; do
  78. export _${dir}=$(rpm --eval $(%{__grep} -E "^%_${dir}\b" \
  79. misc/macros.jpackage | %{__awk} '{ print $2 }'))
  80. done
  81. install -dm 755 ${RPM_BUILD_ROOT}%{_bindir}
  82. install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/{java,rpm}
  83. %if %{gcj_support}
  84. install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/java/security
  85. install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/java/security/security.d
  86. %endif
  87. install -dm 755 ${RPM_BUILD_ROOT}${_jvmdir}
  88. install -dm 755 ${RPM_BUILD_ROOT}${_jvmjardir}
  89. install -dm 755 ${RPM_BUILD_ROOT}${_jvmprivdir}
  90. install -dm 755 ${RPM_BUILD_ROOT}${_jvmlibdir}
  91. install -dm 755 ${RPM_BUILD_ROOT}${_jvmdatadir}
  92. install -dm 755 ${RPM_BUILD_ROOT}${_jvmsysconfdir}
  93. install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonlibdir}
  94. install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommondatadir}
  95. install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonsysconfdir}
  96. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}
  97. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-utils
  98. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-ext
  99. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.3.1,1.4.0,1.4.1,1.4.2}
  100. install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0}
  101. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}
  102. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-ext
  103. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.3.1,1.4.0,1.4.1,1.4.2}
  104. install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0}
  105. install -dm 755 ${RPM_BUILD_ROOT}${_javadocdir}
  106. install -dm 755 ${RPM_BUILD_ROOT}${_mavenpomdir}
  107. install -dm 755 ${RPM_BUILD_ROOT}${_mavendepmapfragdir}
  108. install -pm 755 bin/* ${RPM_BUILD_ROOT}%{_bindir}
  109. install -pm 644 etc/font.properties ${RPM_BUILD_ROOT}%{_sysconfdir}/java
  110. # Install abs2rel scripts
  111. install -pm 755 abs2rel.sh ${RPM_BUILD_ROOT}%{_javadir}-utils
  112. install -pm 644 abs2rel.lua ${RPM_BUILD_ROOT}%{_javadir}-utils
  113. # Create an initial (empty) depmap
  114. echo -e "<dependencies>\\n" \
  115. > ${RPM_BUILD_ROOT}${_mavendepmapdir}/maven2-depmap.xml
  116. echo -e "</dependencies>\\n" \
  117. >> ${RPM_BUILD_ROOT}${_mavendepmapdir}/maven2-depmap.xml
  118. cat > etc/java.conf << EOF
  119. # System-wide Java configuration file -*- sh -*-
  120. #
  121. # JPackage Project <http://www.jpackage.org/>
  122. # Location of jar files on the system
  123. JAVA_LIBDIR=${_javadir}
  124. # Location of arch-specific jar files on the system
  125. JNI_LIBDIR=${_jnidir}
  126. # Root of all JVM installations
  127. JVM_ROOT=${_jvmdir}
  128. # You can define a system-wide JVM root here if you're not using the
  129. # default one.
  130. #
  131. # If you have the a base JRE package installed
  132. # (e.g. java-1.6.0-openjdk):
  133. #JAVA_HOME=\$JVM_ROOT/jre
  134. #
  135. # If you have the a devel JDK package installed
  136. # (e.g. java-1.6.0-openjdk-devel):
  137. #JAVA_HOME=\$JVM_ROOT/java
  138. # Options to pass to the java interpreter
  139. JAVACMD_OPTS=
  140. EOF
  141. install -pm 644 etc/java.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/java
  142. install -pm 644 etc/jpackage-release ${RPM_BUILD_ROOT}%{_sysconfdir}/java
  143. install -pm 644 java-utils/* ${RPM_BUILD_ROOT}${_javadir}-utils
  144. install -pm 644 misc/macros.jpackage ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
  145. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
  146. install -pm 644 man/* ${RPM_BUILD_ROOT}%{_mandir}/man1
  147. %{__mkdir_p} ${RPM_BUILD_ROOT}${_javadir}-utils/xml
  148. install -pm 644 xml/* ${RPM_BUILD_ROOT}${_javadir}-utils/xml
  149. cat <<EOF > %{name}-%{version}.files
  150. %{_bindir}/*
  151. %{_mandir}/man1/*
  152. %dir %{_sysconfdir}/java
  153. %if %{gcj_support}
  154. %{_sysconfdir}/java/security
  155. %endif
  156. %dir ${_jvmdir}
  157. %dir ${_jvmjardir}
  158. %dir ${_jvmprivdir}
  159. # %dir ${_jvmlibdir}
  160. %dir ${_jvmdatadir}
  161. %dir ${_jvmsysconfdir}
  162. %dir ${_jvmcommonlibdir}
  163. %dir ${_jvmcommondatadir}
  164. %dir ${_jvmcommonsysconfdir}
  165. %dir ${_javadir}
  166. %dir ${_javadir}-*
  167. %dir ${_jnidir}
  168. %dir ${_jnidir}-*
  169. %dir ${_javadocdir}
  170. %dir %{_datadir}/maven2
  171. %dir ${_mavenpomdir}
  172. %dir ${_mavendepmapdir}
  173. %dir ${_mavendepmapfragdir}
  174. ${_javadir}-utils/*
  175. %config %{_sysconfdir}/java/jpackage-release
  176. %config(noreplace) %{_sysconfdir}/java/java.conf
  177. %config(noreplace) %{_sysconfdir}/java/font.properties
  178. %config(noreplace) %{_sysconfdir}/rpm/macros.jpackage
  179. %config(noreplace) ${_mavendepmapdir}/maven2-depmap.xml
  180. EOF
  181. %clean
  182. rm -rf $RPM_BUILD_ROOT
  183. %files -f %{name}-%{version}.files
  184. %defattr(-,root,root,-)
  185. %doc %{name}-README LICENSE.txt HEADER.JPP doc/* etc/httpd-javadoc.conf
  186. %changelog
  187. * Fri Aug 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.5-1
  188. - updated to 1.7.5
  189. - added abs2rel script
  190. * Wed Apr 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.4-2jpp2
  191. - changed Group to System Environment/Base
  192. * Wed Apr 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-2jpp1
  193. - use new versioning policy
  194. * Thu Mar 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-2jpp0vl1
  195. - initial build for Vine Linux
  196. * Tue Jan 22 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.4-2jpp.2
  197. - Replace GCJ security directory.
  198. * Tue Jan 22 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.4-2jpp.1
  199. - Import jpackage-utils 1.7.4-2jpp.
  200. * Mon Jan 21 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.4
  201. - Remove AutoReqProv.
  202. - Remove Requires and BuildRequires.
  203. - Wrap export, install and maven lines at 80 columns.
  204. - Add jre option to java.conf comment.
  205. - Related: rhbz#428520
  206. - Remove commented jpackage.org sections.
  207. - Remove duplicate files from files list.
  208. - Remove trailing whitespace.
  209. - Remove rebuild-security-providers.
  210. - Resolves: rhbz#260161
  211. * Fri Jan 04 2008 Ralph Apel <r.apel at r-apel.de> - 0:1.7.4-2jpp
  212. - Fix Bug 293
  213. * Wed Dec 19 2007 Ville Skyttä <scop at jpackage.org> - 0:1.7.4-1jpp
  214. - Terminate functions with %%{nil} in macros.jpackage.
  215. - Make %%jpackage_script install the script with 0755 permissions.
  216. - Use exec in java-functions' run().
  217. * Wed Jun 20 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.3
  218. - Add 1.7.0 directories.
  219. * Fri May 25 2007 Jason Corley <jason.corley@gmail.com> - 0:1.7.3-2jpp
  220. - change distribution and vendor to macros
  221. - rebuild in mock
  222. * Thu Jan 11 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.2
  223. - Add 1.6.0 directories missed in merge.
  224. - Resolves: rhbz#221262
  225. * Mon Dec 11 2006 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.1
  226. - Import version 0:1.7.3-1jpp from jpackage.org.
  227. - Change release numbering format to Xjpp.Y.fc7.
  228. - Resolves: rhbz#218936
  229. * Sat Nov 11 2006 Ville Skyttä <scop at jpackage.org> - 0:1.7.3-1jpp
  230. - Add Java 1.6.0 dirs.
  231. * Mon Oct 23 2006 Deepak Bhole <dbhole@redhat.com> 1.7.2-1jpp
  232. - Added maven2 depmap related macros.
  233. * Tue Sep 19 2006 Fernando Nasser <fnasser@jpackage.org> 0:1.7.1-1jpp
  234. - Add new scripts from Deepak Bhole
  235. - Add documentation from Jason Corley
  236. - Add XLT file shared by maven2 packages
  237. * Fri Nov 04 2005 Fernando Nasser <fnasser@jpackage.org> 0:1.7.0-1jpp
  238. - Initial 1.7 release (eq. to 1.6.6)
  239. - Add Copyright notice and license as header
  240. * Sun Sep 18 2005 David Walluck <david@jpackage.org> 0:1.6.6-1jpp
  241. - always define macros
  242. * Sat Sep 17 2005 David Walluck <david@jpackage.org> 0:1.6.5-2jpp
  243. - clean tarball
  244. * Sat Sep 17 2005 David Walluck <david@jpackage.org> 0:1.6.5-1jpp
  245. - fix conditional macros
  246. - merge nim's and robert's changes
  247. * Mon Aug 22 2005 David Walluck <david@jpackage.org> 0:1.6.4-1jpp
  248. - long needed s/All/Some in error messages
  249. * Fri Jan 28 2005 Nicolas Mailhot <nim at jpackage.org> - 0:1.6.3-1jpp
  250. - prefer full JVM to JRE when not specified (my bad, sorry)
  251. - remove LICENSE.txt as it does not seem to exist in the jpp16 branch anymore
  252. * Sat Jan 15 2005 Nicolas Mailhot <nim at jpackage.org> - 0:1.6.2-1jpp
  253. - Happy new year jpackagers!
  254. - No longer define JAVA_HOME in default shipped java.conf (me)
  255. - Search if $JVM_ROOT/jre or $JVM_ROOT/java exist in functions if JAVA_HOME is
  256. not defined in java.conf (me)
  257. - Source ~/.java/java.conf in addition to /etc/java/java.conf in functions
  258. (me)
  259. - Make find-jar use the same error code as build-classpath (Joe Wortmann)
  260. (note however find-jar was never intended to use directly in scripts, it's
  261. a low-level way to test the search engine)
  262. - Change macros slightly so they no longer wreak havoc on x86_64 systems
  263. (Thomas Fitzsimmons for Red Hat)
  264. This is probably only a short-term fix since we've yet to decide how to
  265. handle real x86_64 JVMs cleanly.
  266. * Thu Dec 16 2004 Robert Ottenhag <support@bea.com> - 0:1.6.3-1jpp
  267. - Move the systemPrefs stuff into a separate new package java-systemprefs
  268. * Wed Dec 15 2004 Robert Ottenhag <support@bea.com> - 0:1.6.2-1jpp
  269. - Reapply all updates from 1.5.40-1jpp o 1.5.42-1jpp
  270. + Add support for splitting the installation of Java VMs/SDK/JREs
  271. according to FHS 2.3 in its architecture dependent, architecture
  272. independent, and configuration parts. Added new macros and dirs
  273. - %%{_jvmlibdir}, defined as %%{_libdir}/jvm, equal to %%{_jvmdir},
  274. - %%{_jvmdatadir}, defined as %%{_datadir}/jvm
  275. - %%{_jvmsysconfdir}, defined as %%{_sysconfdir}/jvm
  276. + Add support for splitting the installation of Java VMs/SDK/JREs
  277. in its common architecture dependent, architecture
  278. independent, and configuration parts. Added new macros and dirs
  279. - %%{_jvmcommonlibdir}, defined as %%{_libdir}/jvm-commmon
  280. - %%{_jvmcommondatadir}, defined as %%{_datadir}/jvm-commmon
  281. - %%{_jvmcommonsysconfdir}, defined as %%{_sysconfdir}/jvm-commmon
  282. + Ensure that a global systemPrefs database used by
  283. java.util.prefs.FileSystemPreferences exists at
  284. /etc/.java/.systemPrefs, or create an empty one if not, and
  285. symlink to it from %%{_jvmcommonsysconfdir}/java/jre/systemprefs.
  286. * Sat Dec 4 2004 Ville Skyttä <scop at jpackage.org> - 0:1.6.1-1jpp
  287. - java-functions (set_jvm_dirs): try "java -fullversion" before
  288. "java -version" for performance, improve regexps, use sed from $PATH.
  289. - Include correct specfile in tarball.
  290. * Tue Nov 2 2004 Nicolas Mailhot <nim@jpackage.org> - 0:1.6.0-2jpp
  291. - fix missing %%{_jnidir} in file list
  292. * Tue Oct 12 2004 Ville Skyttä <scop at jpackage.org> - 0:1.6.0-1jpp
  293. - Start preparing for JPackage 1.6:
  294. - License change: jpackage-utils >= 1.6.0 is available under the (BSD-like)
  295. JPackage License. See included LICENSE.txt.
  296. - Remove support for Java < 1.4 (dirs only for now).
  297. - Remove java_home.list and support for it.
  298. - Add support for installing macros.jpackage into Asianux's rpm config,
  299. thanks to Robert Ottenhag for the info.
  300. * Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:1.5.38-2jpp
  301. - Rebuild with ant-1.6.2
  302. * Mon Jun 7 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.38-1jpp
  303. - Update java_home.list with Sun's default 1.5.0beta2 location.
  304. - Nuke extra copy of java.conf from tarball.
  305. * Wed May 26 2004 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> - 0:1.5.37-1jpp
  306. - add the --preserve-naming switch to build-jar-repository, and document it
  307. (following a discussion with Chip Turner)
  308. * Thu May 6 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.36-1jpp
  309. - Fix bootstrap problem by ensuring that build time macro expansion for
  310. %%{_sysconfdir}/java.conf uses macros defined in this package and does not
  311. rely on the macros being already defined.
  312. - Include correct spec file in tarball.
  313. * Tue May 04 2004 David Walluck <david@jpackage.org> 0:1.5.35-1jpp
  314. - expand macros in %%{_sysconfdir}/java.conf
  315. * Fri Mar 26 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.34-1jpp
  316. - Update java_home.list with Sun's default 1.4.2_04, 1.4.1_07, 1.3.1_10
  317. and 1.3.1_11 locations.
  318. * Tue Feb 09 2004 David Walluck <david@anti-microsoft.org> 0:1.5.33-1jpp
  319. - update for J2SE 1.5.0 Beta 1
  320. * Tue Jan 13 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.32-1jpp
  321. - Fix java-functions location in diff-jars.
  322. - Add (X)Emacs mode cookies to java.conf and java-functions.
  323. - Micro-performance improvement to set_javacmd.
  324. - Insert macros.jpackage before anything starting with "~/" in rpmrc's.
  325. - Include example httpd.conf snippet for javadocs.
  326. * Mon Dec 29 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.31-1jpp
  327. - Update java_home.list with Sun's default 1.4.2_03, 1.4.1_06 and 1.4.0_04
  328. locations.
  329. * Thu Nov 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> - 0:1.5.30-1jpp
  330. - Add a minimalist xfonset entry to the default font.properties
  331. * Tue Oct 21 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.29-1jpp
  332. - Update java_home.list with Sun's default 1.4.2_02 and 1.4.1_05 locations.
  333. * Fri Oct 17 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.28-1jpp
  334. - Make package bootstrappable, thanks to Markus Pilzecker for ideas.
  335. * Sun Aug 31 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.27-1jpp
  336. - Update jpackage-1.5-policy wrt. jvm-private and speling fixxes.
  337. * Sat Aug 30 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.26-1jpp
  338. - Add %%{_jvmprivdir} (== %%{_libdir}/jvm-private), a directory for
  339. JVM-private stuff (eg. JCE policy jars).
  340. - Update java_home.list with Sun's default 1.4.2_01 location.
  341. * Thu Aug 14 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.25-1jpp
  342. - Update java_home.list.
  343. - Save .spec in UTF-8.
  344. * Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.24-1jpp
  345. - fix more symlinks/copy corner cases
  346. * Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.23-1jpp
  347. - debug 1.5.22
  348. * Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.22-1jpp
  349. - more correct java version detection regexp, courtesy of Scott Brickner
  350. - allow creation of harlink/copy jar repositories since tomcat4 seems to need
  351. this (reported by Greg Barton)
  352. * Sun May 18 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.21-1jpp
  353. - fix a bug in jar repository handling
  354. - remove unused APPDIR in jar resolution
  355. - add doc for jpackage 1.5 policy
  356. * Tue May 16 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.20-1jpp
  357. - remove unneeded and brittle complexity
  358. * Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.19-1jpp
  359. - fix new jar repository scripts (more corner cases)
  360. - create symlinks for not-found extensions to allow a later repository rebuild
  361. - create symlinks as [extension].jar, for example [jsse][jcert].jar
  362. - allow both extension split and collapsing
  363. (one jar -> one directory of jars or the other way round)
  364. * Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.18-1jpp
  365. - fix new scripts
  366. * Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.17-1jpp
  367. - add initial java repository support
  368. * Sat May 10 2003 David Walluck <david@anti-microsoft.org> 0:1.5.16-1jpp
  369. - %%jpackage_script macro fix
  370. - add %%doc to file list
  371. - add %%config(noreplace) to jpackage-release in file list to shut up rpmlint
  372. * Wed May 7 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.15-1jpp
  373. - fix error message in java dir computation
  374. * Sun Apr 26 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.14-3jpp
  375. - use java fonts if available first
  376. * Sat Apr 26 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.14-1jpp
  377. - add java font config
  378. * Wed Apr 23 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-5jpp
  379. - use quotes in 'test -f'
  380. * Mon Apr 21 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-4jpp
  381. - use hardcoded file list for %%postun and %%triggerin
  382. * Thu Apr 17 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-3jpp
  383. - don't use quotes around the 'find' command in %%postun and %%triggerin
  384. - don't add a 'macrofiles:' line in %%triggerin to rpmrc if one isn't
  385. already there
  386. * Tue Apr 15 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-2jpp
  387. - try to support macros.jpackage on RedHat 9
  388. * Mon Apr 14 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-1jpp
  389. - change CLASSPATH to _CLASSPATH and JARS to _JARS
  390. - clean up trailing ':' in _CLASSPATH
  391. * Mon Apr 14 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.12-1jpp
  392. - remove build-classpath dependency on David's stuff since it fails horribly
  393. when people actually use it
  394. - try to actually fix triggers
  395. * Sat Apr 12 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-3jpp
  396. - don't remove macros.jpackage from rpmrc on jpackage-utils upgrade
  397. * Sat Apr 12 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-2jpp
  398. - remove argouml.log from tarball
  399. * Fri Apr 11 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-1jpp
  400. - add build-classpath-directory
  401. - add epoch
  402. * Thu Apr 10 2003 David Walluck <david@anti-microsoft.org> 1.5.10-1jpp
  403. - back to using %%{_libdir}/rpm/rpmrc for macros.jpackage
  404. - add %%{_javadir}--1.4.2 and %%{_jnidir}-1.4.2 directories
  405. - update package description
  406. - add JAVACMD_OPTS to java.conf
  407. - use new external java.conf
  408. - update build-classpath and java-functions to support directories in
  409. CLASSPATH
  410. * Mon Mar 24 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.9-1jpp
  411. - more symlinks handling
  412. * Wed Mar 19 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.7-1jpp
  413. - register new jvm alternatives
  414. - allow use of build-classpath for incomplete paths
  415. * Tue Mar 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.6-1jpp
  416. - resurect borked icon/menu handling
  417. - hopefuly support jni jars (arch-dependant jars)
  418. * Thu Feb 13 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.4-3jpp
  419. - extract jar resolving logic from classpath builder
  420. - hopefully integrate classpath builder in set_classpath macro
  421. * Wed Feb 12 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.3-1jpp
  422. - add classpath builder
  423. * Wed Feb 12 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.2-1jpp
  424. - New reorg
  425. * Tue Feb 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.1-1jpp
  426. - add some extension handling
  427. - fix some macros broken in 1.5.0
  428. * Tue Feb 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.0-1jpp
  429. - use a tar source file
  430. - use lsb locations
  431. - prepare for multi-jvm extensions support
  432. * Mon Feb 10 2003 David Walluck <david@anti-microsoft.org> 1.4.8-1jpp
  433. - better installation of macros
  434. - update %%description to list all files currently included in this package
  435. - jpackage-release in %%{_sysconfdir}, not /etc (I hope this is more
  436. correct)
  437. * Sun Feb 09 2003 David Walluck <david@anti-microsoft.org> 1.4.7-1jpp
  438. - fix sed in %%jpackage_script when paths to jars contain '/'
  439. - fix typo in macros documentation
  440. - add jpackage-policy
  441. - add jpackage-release
  442. * Wed Feb 05 2003 David Walluck <david@anti-microsoft.org> 1.4.6-1jpp
  443. - macro bugfixes
  444. - instead of tarball we now use %%{SOURCEn} format
  445. * Fri Jan 31 2003 David Walluck <david@anti-microsoft.org> 1.4.5-1jpp
  446. - add macros.jpackage (DO NOT attempt to use this until we figure something
  447. out, but I would still like to get some feedback about how it looks so far)
  448. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.4-1jpp
  449. - fix exiting on failed `which` (Ville Skyttä <scop at jpackage.org>)
  450. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.3-2jpp
  451. - fix release tag in %%changelog
  452. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.3-1jpp
  453. - java-functions changes:
  454. + set_jvm: look for javac first to avoid erroneously setting
  455. JAVA_HOME to the location of the jre unless we have to
  456. + set_jvm: follow symlinks to avoid erroneously setting JAVA_HOME to
  457. /usr/bin
  458. + set_jvm: export JAVA_HOME
  459. - changed to use install instead of mkdir and cp
  460. - remove %%attr and rely on install to set the permissions instead
  461. * Sat Jan 25 2003 Ville Skyttä <scop at jpackage.org> - 1.4.2-1jpp
  462. - java-functions changes:
  463. + Prevent non-success exit code from "which" in set_jvm, it can now
  464. be used when building RPMs.
  465. + Use set_jvm in set_javacmd.
  466. + Use set_javacmd and $JAVACMD in run.
  467. - Fix Group tag.
  468. * Sat Dec 28 2002 Ville Skyttä <scop at jpackage.org> - 1.4.1-1jpp
  469. - Add Sun's 1.4.0_03 and BEA JRockit 7.0SP1 default RPM locations.
  470. * Thu Nov 21 2002 Ville Skyttä <scop at jpackage.org> - 1.4-1jpp
  471. - Fix diff-jars when diffing 2 jars with same basename (#635202).
  472. - Add IBM's 1.4 default RPM location to jvm.list.
  473. * Fri Nov 8 2002 Ville Skyttä <scop at jpackage.org> - 1.3-6jpp
  474. - Add Sun's 1.3.1_06 default RPM location.
  475. * Sat Oct 19 2002 Ville Skyttä <scop at jpackage.org> 1.3-5jpp
  476. - Add Sun's 1.4.1_01 and 1.3.1_05 default RPM locations.
  477. * Tue Sep 17 2002 Ville Skyttä <scop at jpackage.org> 1.3-4jpp
  478. - Add Sun's 1.4.1 default rpm location.
  479. * Thu Sep 12 2002 Ville Skyttä <scop at jpackage.org> 1.3-3jpp
  480. - Add Sun's 1.4.0_02 and new BEA JRockit locations.
  481. * Sat Jun 29 2002 Ville Skyttä <scop at jpackage.org> 1.3-2jpp
  482. - Add section macro.
  483. * Sat Jun 29 2002 Ville Skyttä <scop at jpackage.org> 1.3-1jpp
  484. - Add some variants of Sun J2SE java homes as well as JRockit.
  485. - Add Distribution tag.
  486. * Fri May 3 2002 Nicolas Mailhot <nmailhot@users.sourceforge.net> 1.2-1jpp
  487. Add some stuff to please jakarta ant developpers :
  488. - OSX java home
  489. - new function set_javacmd with AIX hack included
  490. * Wed Dec 19 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.1-1jpp
  491. - java-functions: centralized configuration
  492. - java-functions: jvm list lookup
  493. - diff-jars: fixed typo
  494. - diff-jars: used /tmp for files
  495. - corrected changelog
  496. * Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.0-1jpp
  497. - first JPackage release