glslang-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167
  1. #global commit c9b28b9f3388c607ea5506f5e6197b7150238ad3
  2. #global shortcommit %(c=%{commit}; echo ${c:0:7})
  3. #global commit_date 2020421
  4. #global gitrel .%{commit_date}.git%{shortcommit}
  5. Name: glslang
  6. Summary: OpenGL and OpenGL ES shader front end and validator
  7. Version: 8.13.3743
  8. Release: 1%{?gitrel}%{?_dist_release}
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD and GPLv3+ and ASL 2.0
  12. URL: https://github.com/KhronosGroup
  13. %if 0%{?commit_date}
  14. Source0: %url/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
  15. %else
  16. Source0: %url/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  17. %endif
  18. Patch1: glslang-default-resource-limits_staticlib.patch
  19. # Patch to build against system spirv-tools (rebased locally)
  20. #Patch3: https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/1722.patch#/0001-pkg-config-compatibility.patch
  21. Patch3: 0001-pkg-config-compatibility.patch
  22. BuildRequires: cmake
  23. BuildRequires: gcc-c++
  24. BuildRequires: ninja
  25. BuildRequires: spirv-tools-devel
  26. %description
  27. %{name} is the official reference compiler front end for the OpenGL
  28. ES and OpenGL shading languages. It implements a strict
  29. interpretation of the specifications for these languages.
  30. %package devel
  31. Summary: Development files for %{name}
  32. Requires: %{name}%{?_isa} = %{version}-%{release}
  33. %description devel
  34. %{name} is the official reference compiler front end for the OpenGL
  35. ES and OpenGL shading languages. It implements a strict
  36. interpretation of the specifications for these languages.
  37. %prep
  38. %if 0%{?commit_date}
  39. %autosetup -p1 -n %{name}-%{commit}
  40. %else
  41. %autosetup -p1 -n %{name}-%{version}
  42. %endif
  43. # Fix rpmlint warning on debuginfo
  44. find . -name '*.h' -or -name '*.cpp' -or -name '*.hpp'| xargs chmod a-x
  45. %build
  46. %__mkdir_p build
  47. pushd build
  48. %cmake -DCMAKE_BUILD_TYPE=Release \
  49. -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
  50. -DCMAKE_SKIP_RPATH:BOOL=yes \
  51. -DBUILD_SHARED_LIBS=OFF \
  52. -GNinja ..
  53. %{ninja_build}
  54. popd
  55. %install
  56. %{ninja_install} -C build
  57. # we don't want them in here
  58. rm -rf %{buildroot}%{_includedir}/SPIRV
  59. %ifnarch s390x ppc64
  60. %check
  61. pushd Test
  62. ./runtests localResults ../build/StandAlone/glslangValidator ../build/StandAlone/spirv-remap
  63. popd
  64. %endif
  65. # Install libglslang-default-resource-limits.a
  66. install -pm 0644 build/StandAlone/libglslang-default-resource-limits.a %{buildroot}%{_libdir}/
  67. %files
  68. %doc README.md README-spirv-remap.txt
  69. %{_bindir}/glslangValidator
  70. %{_bindir}/spirv-remap
  71. %files devel
  72. %{_includedir}/glslang/
  73. %{_libdir}/libHLSL.a
  74. %{_libdir}/libOGLCompiler.a
  75. %{_libdir}/libOSDependent.a
  76. %{_libdir}/libSPIRV.a
  77. %{_libdir}/libSPVRemapper.a
  78. %{_libdir}/libglslang.a
  79. %{_libdir}/libglslang-default-resource-limits.a
  80. %{_libdir}/pkgconfig/glslang.pc
  81. %{_libdir}/pkgconfig/spirv.pc
  82. %{_libdir}/cmake/*
  83. %changelog
  84. * Wed Jul 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.13.3743-1
  85. - initial build for Vine Linux.
  86. - new upstream release.
  87. * Wed Apr 22 2020 Dave Airlie <airlied@redhat.com> - 8.13.3559-2
  88. - Update to latest git snapshot
  89. * Wed Jan 29 2020 Dave Airlie <airlied@redhat.com> - 8.13.3559-1
  90. - Update to latest git snapshot
  91. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.13.3496-3.20191102.git7f77b2e
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  93. * Thu Dec 19 2019 Leigh Scott <leigh123linux@googlemail.com> - 7.13.3496-2.20191102.git7f77b2e
  94. - Add patch for 'Fix a couple relative header paths in header'
  95. * Wed Nov 13 2019 Dave Airlie <airlied@redhat.com> - 7.13.3496-1
  96. - Latest upstream snapshot for validation layers build
  97. * Sat Aug 03 2019 Dave Airlie <airlied@redhat.com> - 7.11.3214-3
  98. - Latest upstream snapshot for validation layers build
  99. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.11.3214-2
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  101. * Mon Jun 10 2019 Robert-André Mauchin <zebob.m@gmail.com> - 7.11.3214-1
  102. - Release 7.11.3214
  103. - Add patch to build against system spirv-tools
  104. * Fri Mar 29 2019 Dave Airlie <airlied@redhat.com> - 3.1-0.13.20190329.gite0d59bb
  105. - Update for vulkan 1.1.101.0
  106. * Tue Feb 12 2019 Dave Airlie <airlied@redhat.com> - 3.1-0.12.20190212.git05d12a9
  107. - Update for vulkan 1.1.92.0
  108. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.11.20180727.gite99a268
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  110. * Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.10.20180727.gite99a268
  111. - Update for vulkan 1.1.82.0
  112. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.9.20180416.git3bb4c48
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  114. * Mon Apr 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.8.20180416.git3bb4c48
  115. - Update for vulkan 1.1.73.0
  116. * Wed Mar 07 2018 Adam Williamson <awilliam@redhat.com> - 3.1-0.7.20180205.git2651cca
  117. - Rebuild to fix GCC 8 mis-compilation
  118. See https://da.gd/YJVwk ("GCC 8 ABI change on x86_64")
  119. * Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.6.20180205.git2651cca
  120. - Update for vulkan 1.0.68.0
  121. * Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.5.20171028.git715c353
  122. - Use ninja to build
  123. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.4.20171028.git715c353
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  125. * Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.3.20171028.git715c353
  126. - Exclude s390x and ppc64 from check section
  127. * Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.2.20171028.git715c353
  128. - Add check section to run tests
  129. - Split binaries into main package
  130. * Thu Jul 13 2017 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.1.20171028.git715c353
  131. - First build