galera-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. %bcond_with systemd
  2. %bcond_with python3
  3. %define mariadb_version 10.5.5
  4. %if %{with python3}
  5. %global scons scons-3
  6. %else
  7. %global scons scons
  8. %endif
  9. Summary: Synchronous multi-master wsrep provider (replication engine)
  10. Name: galera
  11. Version: 26.4.5
  12. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  13. %global galera_api_version %(echo %{version} | cut -d . -f 1,2)
  14. Group: servers
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. License: GPLv2
  18. URL: http://galeracluster.com/
  19. # Actually, the truth is, we do use galera source tarball provided by MariaDB on
  20. # following URL (without macros):
  21. # https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
  22. Source0: https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
  23. Source1: garbd.service
  24. Source2: garbd-wrapper
  25. Source3: garbd.init
  26. Patch0: galera-python3.patch
  27. BuildRequires: libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
  28. %if %{with systemd}
  29. BuildRequires: systemd
  30. %endif
  31. Requires: nmap
  32. Provides: galera(%{galera_api_version})
  33. %if %{with systemd}
  34. Requires(post): systemd
  35. Requires(preun): systemd
  36. Requires(postun): systemd
  37. %else
  38. Requires(post): chkconfig
  39. Requires(preun): chkconfig initscripts
  40. %endif
  41. %description
  42. Galera is a fast synchronous multi-master wsrep provider (replication engine)
  43. for transactional databases and similar applications. For more information
  44. about wsrep API see http://launchpad.net/wsrep. For a description of Galera
  45. replication engine see http://www.codership.com.
  46. %debug_package
  47. %prep
  48. %setup -q
  49. %if %{with python3}
  50. %patch0 -p1
  51. %endif
  52. %build
  53. CPPFLAGS="%{optflags}"
  54. CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
  55. export CPPFLAGS
  56. %{scons} %{?_smp_mflags} strict_build_flags=0
  57. %install
  58. %if %{with systemd}
  59. install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
  60. install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
  61. %else
  62. install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
  63. %endif
  64. install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
  65. install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
  66. install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
  67. install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
  68. install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
  69. install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
  70. install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
  71. install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
  72. %post
  73. /sbin/ldconfig
  74. %if %{with systemd}
  75. %systemd_post garbd.service
  76. %else
  77. /sbin/chkconfig --add garbd
  78. %endif
  79. %preun
  80. %if %{with systemd}
  81. %systemd_preun garbd.service
  82. %else
  83. if [ $1 = 0 -o -x /bin/systemctl ]; then
  84. /sbin/service garbd stop >/dev/null 2>/dev/null ||:
  85. /sbin/chkconfig --del garbd
  86. fi
  87. %endif
  88. %postun
  89. /sbin/ldconfig
  90. %if %{with systemd}
  91. %systemd_postun_with_restart garbd.service
  92. %endif
  93. %files
  94. %license %{_docdir}/galera/COPYING
  95. %license %{_docdir}/galera/LICENSE.asio
  96. %license %{_docdir}/galera/LICENSE.crc32
  97. %doc %{_docdir}/galera/README
  98. %doc %{_docdir}/galera/README-MySQL
  99. %config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
  100. %dir %{_docdir}/galera
  101. %dir %{_libdir}/galera
  102. %{_sbindir}/garbd
  103. %if %{with systemd}
  104. %{_sbindir}/garbd-wrapper
  105. %{_unitdir}/garbd.service
  106. %else
  107. %{_initdir}/garbd
  108. %endif
  109. %{_libdir}/galera/libgalera_smm.so
  110. %changelog
  111. * Wed Aug 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.5-1
  112. - new upstream release.
  113. * Thu May 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.4-1
  114. - new upstream release.
  115. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-2
  116. - rebuilt with boost-1.72.0.
  117. * Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
  118. - new upstream release.
  119. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
  120. - updated to 26.4.2 for MariaDB-10.4.
  121. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
  122. - initial build for Vine Linux.
  123. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  125. * Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
  126. - Rebuilt for Boost 1.69
  127. * Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
  128. - Rebase to 25.3.25
  129. * Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
  130. - Require asio also on rhel
  131. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
  132. - Add explicit gcc-c++ BR
  133. - Use python3-scons
  134. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
  135. - Do not require asio on rhel
  136. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  138. * Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
  139. - Update to 25.3.23
  140. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  142. * Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
  143. - Update to 25.3.22
  144. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  146. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  148. * Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
  149. - Rebuilt for Boost 1.64
  150. * Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
  152. * Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
  153. - Use asio-devel instead of bundled asio library
  154. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  156. * Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
  157. - Update to 25.3.16
  158. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  160. * Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
  161. - Rebuilt for Boost 1.60
  162. * Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
  163. - Remove use of -mtune=native which breaks build on secondary architectures
  164. * Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
  165. - Update to 25.3.12.
  166. - Should fix the build on 32 bit ARM (RHBZ#1241164).
  167. - Remove ExcludeArch (should have read the BZ more closely).
  168. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
  169. - Rebuilt for Boost 1.59
  170. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
  171. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  172. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
  173. - rebuild for Boost 1.58
  174. * Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
  175. - Disable ARM builds (#1241164, #1239516)
  176. * Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
  177. - Update to version 25.3.10
  178. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  180. * Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
  181. - Rebuild for boost 1.57.0
  182. * Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
  183. - Add aarch64 support.
  184. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  186. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  188. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
  189. - Rebuild for boost 1.55.0
  190. * Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
  191. - set ExclusiveArch
  192. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
  193. - Use strict_build_flags=0 to avoid -Werror
  194. - Remove unnecessary clean section
  195. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
  196. - Include galera directories in file list
  197. - Set CPPFLAGS to optflags
  198. * Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
  199. - Fix client certificate verification (#1090604)
  200. * Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
  201. - Update to version 25.3.5
  202. * Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
  203. - Add systemd service
  204. * Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
  205. - Initial build