docker-ce-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. %bcond_with systemd
  2. %bcond_with build_nosrc
  3. %if !%{with build_nosrc}
  4. %global _disable_source_fetch 0
  5. %endif
  6. Name: docker-ce
  7. Summary: The open-source application container engine
  8. Version: 20.10.3
  9. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  10. Group: system,virtualization
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop
  14. License: ASL 2.0
  15. URL: https://www.docker.com
  16. Source0: https://download.docker.com/linux/static/stable/x86_64/docker-%{version}.tgz
  17. Source1: https://raw.githubusercontent.com/docker/cli/v%{version}/README.md
  18. Source2: https://raw.githubusercontent.com/docker/cli/v%{version}/LICENSE
  19. Source10: docker.init
  20. Source11: docker.sysconfig
  21. Source12: docker.conf
  22. Source100: docker.service
  23. Source101: docker.socket
  24. %if %{with build_nosrc}
  25. NoSource: 0
  26. NoSource: 1
  27. NoSource: 2
  28. %endif
  29. # required packages on install
  30. Requires: /bin/sh
  31. Requires: libcgroup
  32. Requires: docker-ce-cli = %{version}-%{release}
  33. %if %{with systemd}
  34. %{?systemd_requires}
  35. %endif
  36. Conflicts: docker-ee
  37. Conflicts: docker-ee-cli
  38. %description
  39. Docker is is a product for you to build, ship and run any application as a
  40. lightweight container.
  41. Docker containers are both hardware-agnostic and platform-agnostic. This means
  42. they can run anywhere, from your laptop to the largest cloud compute instance and
  43. everything in between - and they don't require you to use a particular
  44. language, framework or packaging system. That makes them great building blocks
  45. for deploying and scaling web apps, databases, and backend services without
  46. depending on a particular stack or provider.
  47. %package cli
  48. Summary: clients for Docker
  49. Group: admin-tools,virtualization
  50. %description cli
  51. Docker is is a product for you to build, ship and run any application as a
  52. lightweight container.
  53. Docker containers are both hardware-agnostic and platform-agnostic. This means
  54. they can run anywhere, from your laptop to the largest cloud compute instance and
  55. everything in between - and they don't require you to use a particular
  56. language, framework or packaging system. That makes them great building blocks
  57. for deploying and scaling web apps, databases, and backend services without
  58. depending on a particular stack or provider.
  59. %prep
  60. %setup -q -c -n docker
  61. %build
  62. # %check
  63. # cli/build/docker -v
  64. %install
  65. # install binary
  66. install -d %{buildroot}%{_bindir}
  67. install -d %{buildroot}%{_localstatedir}/lib/docker
  68. install -d %{buildroot}%{_localstatedir}/run/docker
  69. for f in docker/*; do
  70. install -p -m 755 $f %{buildroot}%{_bindir}/
  71. done
  72. %if %{with systemd}
  73. install -D -p -m 644 %{SOURCE100} %{buildroot}%{_unitdir}/docker.service
  74. install -D -p -m 755 %{SOURCE101} %{buildroot}%{_unitdir}/docker.socket
  75. %else
  76. install -D -p -m 755 %{SOURCE10} %{buildroot}%{_initdir}/docker
  77. install -D -p -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/docker
  78. install -D -p -m 644 %{SOURCE12} %{buildroot}%{_sysconfdir}/rsyslog.d/docker
  79. %endif
  80. install -p -m 644 %{SOURCE1} ./
  81. install -p -m 644 %{SOURCE2} ./
  82. %clean
  83. rm -rf %{buildroot}
  84. %pre
  85. if ! getent group docker > /dev/null; then
  86. groupadd --system docker
  87. fi
  88. %post
  89. %if %{with systemd}
  90. %systemd_post docker.service
  91. %else
  92. if [ $1 -eq 1 ]; then
  93. /sbin/chkconfig --add docker
  94. fi
  95. %endif
  96. %preun
  97. %if %{with systemd}
  98. %systemd_preun docker.service
  99. %else
  100. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  101. /sbin/chkconfig docker off
  102. /sbin/chkconfig --del docker
  103. fi
  104. %endif
  105. %if %{with systemd}
  106. %postun
  107. %systemd_postun_with_restart docker.service
  108. %endif
  109. # list files owned by the package here
  110. %files
  111. %defattr(-,root,root,-)
  112. %license LICENSE
  113. %doc README.md
  114. %{_bindir}/containerd
  115. %{_bindir}/containerd-shim*
  116. %{_bindir}/ctr
  117. %{_bindir}/docker-init
  118. %{_bindir}/docker-proxy
  119. %{_bindir}/dockerd
  120. %dir %{_localstatedir}/run/docker
  121. %dir %{_localstatedir}/lib/docker
  122. %if %{with systemd}
  123. %{_unitdir}/docker.service
  124. %{_unitdir}/docker.socket
  125. %else
  126. %{_initdir}/docker
  127. %config(noreplace) %{_sysconfdir}/sysconfig/docker
  128. %config(noreplace) %{_sysconfdir}/rsyslog.d/docker
  129. %endif
  130. %files cli
  131. %defattr(-,root,root,-)
  132. %license LICENSE
  133. %doc README.md
  134. %{_bindir}/docker
  135. %{_bindir}/runc
  136. %changelog
  137. * Thu Feb 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.3-1
  138. - new upstream release.
  139. * Thu Dec 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.14-1
  140. - new upstream release.
  141. * Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.09-1
  142. - new upstream release.
  143. - added systemd support (disabled as default).
  144. * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.08-1
  145. - new upstream release.
  146. * Thu Oct 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.03-1
  147. - new upstream release.
  148. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-2
  149. - updated initscript: added syslog support.
  150. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-1
  151. - initial build for Vine Linux.