ddd-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314
  1. %define rpm_clean 1
  2. %define desktop_file 1
  3. %define desktop_file_utils_version 0.2.93
  4. %define debug_package %{nil}
  5. Summary: A GUI for several command-line debuggers.
  6. Summary(ja): コマンドラインデバッガ用のGUIツール
  7. Name: ddd
  8. Version: 3.3.11
  9. Release: 2%{?_dist_release}
  10. License: GPL
  11. Group: Applications/Development
  12. URL: http://www.gnu.org/software/ddd/
  13. BuildRoot: %{_tmppath}/%{name}-root
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Source0: http://heanet.dl.sourceforge.net/sourceforge/ddd/ddd-%{version}.tar.gz
  17. Source2: ddd.desktop
  18. Source3: ddd.png
  19. Patch: ddd-3.3.11-lang.patch
  20. Prereq: /sbin/install-info
  21. BuildPreReq: openMotif-devel
  22. BuildPreReq: libtermcap-devel
  23. BuildPreReq: ncurses-devel
  24. BuildPreReq: gcc-c++
  25. BuildRequires: xorg-x11-devel
  26. Requires: openMotif
  27. %if %{desktop_file}
  28. BuildPrereq: desktop-file-utils >= %{desktop_file_utils_version}
  29. %endif
  30. %description
  31. The Data Display Debugger (DDD) is a popular GUI for command-line
  32. debuggers like GDB, DBX, JDB, WDB, XDB, the Perl debugger, and the
  33. Python debugger. DDD allows you to view source texts and provides an
  34. interactive graphical data display, in which data structures are
  35. displayed as graphs. You can use your mouse to dereference pointers
  36. or view structure contents, which are updated every time the program
  37. stops. DDD can debug programs written in Ada, C, C++, Chill, Fortran,
  38. Java, Modula, Pascal, Perl, and Python. DDD provides machine-level
  39. debugging; hypertext source navigation and lookup; breakpoint,
  40. watchpoint, backtrace, and history editors; array plots; undo and
  41. redo; preferences and settings editors; program execution in the
  42. terminal emulation window, debugging on a remote host, an on-line
  43. manual, extensive help on the Motif user interface, and a command-line
  44. interface with full editing, history and completion capabilities.
  45. %description -l ja
  46. The Data Display Debugger (DDD)はGDB、DBX、JDB、WDB、XDB、Perl
  47. デバッガおよびPythonデバッガのようなコマンドラインデバッガ用の
  48. ポピュラーなGUIツールです。DDD はソーステキストを見ることを可能
  49. にし対話型のグラフィカルなデータ構造の表示を提供します。マウス
  50. を使用して参照や表示内容を操作でき、プログラムが止まるごとに
  51. それらは更新されます。DDDは、Ada, C, C++, Chill, Fortran, Java,
  52. Modula, Pascal, PerlおよびPythonで書かれたプログラムをデバッグ
  53. することができます。DDDはマシンレベルのデバッギングを提供します。
  54. ハイパーテキストなソースナビゲーションおよび検索、ブレークポイント
  55. ウォッチポイント、バックトレースおよびヒストリエディタ、配列プロット
  56. 取消、やり直し、プレファレンスおよびセッティングエディタ、
  57. ターミナルエミュレーションウィンドウでの実行、リモートホスト
  58. デバッキング、オンラインマニュアル、Motifユーザインターフェース
  59. での広範囲なヘルプ、コマンドラインインターフェイスでのフル編集
  60. ヒストリおよび完全な互換性。
  61. %prep
  62. %setup -q
  63. %patch -p1 -b .lang
  64. %build
  65. %configure
  66. make %{?smp_mflags}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. mkdir -p $RPM_BUILD_ROOT%{_bindir} \
  70. $RPM_BUILD_ROOT%{_datadir}/pixmaps
  71. %makeinstall
  72. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir*
  73. # desktop-file-install
  74. %if %{desktop_file}
  75. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications/
  76. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/applications/x-ddd.desktop
  77. %else
  78. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/Development
  79. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/Development/ddd.desktop
  80. %endif
  81. install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/pixmaps
  82. gzip -9nfq $RPM_BUILD_ROOT/%{_infodir}/*
  83. %post
  84. /sbin/install-info %{_infodir}/ddd.info.gz %{_infodir}/dir
  85. %preun
  86. if [ $1 = 0 ]; then
  87. /sbin/install-info --delete %{_infodir}/ddd.info.gz %{_infodir}/dir
  88. fi
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %files
  92. %defattr(-,root,root)
  93. %doc doc/ddd.pdf
  94. %defattr(-,root,root)
  95. %{_bindir}/*
  96. %{_mandir}/*/*
  97. %{_infodir}/*
  98. %if %{desktop_file}
  99. %{_datadir}/applications/*
  100. %else
  101. %{_sysconfdir}/X11/applnk/Development/ddd.desktop
  102. %endif
  103. %{_datadir}/%{name}-%{version}
  104. %{_datadir}/pixmaps/ddd.png
  105. %changelog
  106. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 3.3.11-2vl5
  107. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  108. * Sat Jun 07 2008 Shu KONNO <owa@bg.wakwak.com> 3.3.11-1vl5
  109. - applied new versioning policy and utf-8
  110. - added BuildRequires: xorg-x11-devel
  111. * Mon Jun 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.11-0vl3
  112. - rebuilt with new toolchain
  113. * Tue Mar 13 2007 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.11-0vl2
  114. - updated Patch (fixed locale bug <bts:498>)
  115. * Sat Mar 3 2007 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.11-0vl1
  116. - new upstream release
  117. - changed Group to Applications/Development
  118. - updated Source0 and Patch
  119. * Sun Dec 5 2004 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.10-0vl1
  120. - new upstream release
  121. * Sun Sep 5 2004 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.9-0vl1
  122. - new upstream release
  123. - added summary(ja) and description(ja)
  124. - changed to BuildPreReq XOrg-devel
  125. * Mon Nov 10 2003 Than Ngo <than@redhat.com> 3.3.8-3vl1
  126. - based on Fedora development
  127. - rebuild with new toolchains
  128. - s/Copyright/License/
  129. - added --program-prefix optiion to %configure
  130. * Mon Nov 10 2003 Than Ngo <than@redhat.com> 3.3.8-3
  131. - 3.3.8
  132. * Wed Oct 08 2003 Than Ngo <than@redhat.com> 3.3.7-3
  133. - fixed utf-8 issue, bug #84816
  134. * Thu Aug 21 2003 Than Ngo <than@redhat.com> 3.3.7-2
  135. - install icon in correct place (bug #102794)
  136. * Fri Jun 27 2003 Than Ngo <than@redhat.com> 3.3.7-1
  137. - 3.3.7
  138. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  139. - rebuilt
  140. * Tue Jun 3 2003 Than Ngo <than@redhat.com> 3.3.6-1
  141. - 3.3.6
  142. * Mon May 5 2003 Than Ngo <than@redhat.com> 3.3.5-1.1
  143. - use smp_mflags
  144. * Mon May 5 2003 Than Ngo <than@redhat.com> 3.3.5-1
  145. - 3.3.5 (bug #89523)
  146. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  147. - rebuilt
  148. * Thu Jan 2 2003 Than Ngo <than@redhat.com> 3.3.1-22
  149. - disable debug_package
  150. * Wed Nov 6 2002 Tim Powers <timp@redhat.com> 3.3.1-20
  151. - rebuilt to drop old libelf dep
  152. - add NEWS and COPYING files to filelist
  153. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.3.1-19
  154. - rebuilt with gcc-3.2 (we hope)
  155. * Wed Jul 24 2002 Than Ngo <than@redhat.com> 3.3.1-18
  156. - desktop file issue (bug #69381)
  157. * Sat Jul 20 2002 Than Ngo <than@redhat.com> 3.3.1-17
  158. - use desktop-file-install
  159. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  160. - automated rebuild
  161. * Sat Jun 08 2002 Than Ngo <than@redhat.com> 3.3.1-15
  162. - PHP DBG support (bug #62180)
  163. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  164. - automated rebuild
  165. * Fri Mar 22 2002 Tim Powers <timp@redhat.com>
  166. - rebuilt against openmotif-2.2.2
  167. * Mon Mar 18 2002 Than Ngo <than@redhat.com> 3.3.1-12
  168. - fix broken desktop file (bug #53193)
  169. * Fri Feb 22 2002 Than Ngo <than@redhat.com> 3.3.1-11
  170. - clean up patch file (bug #59935)
  171. - rebuild in new enviroment
  172. * Thu Jan 17 2002 Trond Eivind Glomsr <teg@redhat.com> 3.3.1-10
  173. - Don't include %%{_infodir}/dir
  174. * Thu Jan 17 2002 Than Ngo <than@redhat.com> 3.3.1-9
  175. - fix bug #52954
  176. - fix to build against gcc 3
  177. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  178. - rebuild with new gcc and binutils
  179. * Thu Jul 19 2001 Than Ngo <than@redhat.com>
  180. - add some build requires
  181. - Copyright->License
  182. * Fri Jun 29 2001 Karsten Hopp <karsten@redhat.de>
  183. - add desktop icons (gnome-cpu.png isn't always installed)
  184. * Sun Jun 10 2001 Than Ngo <than@redhat.com>
  185. - buildrequires lesstif-devel
  186. * Tue May 22 2001 Tim Powers <timp@redhat.com>
  187. - built for the distro
  188. * Thu May 03 2001 Than Ngo <than@redhat.com>
  189. - update to 3.3.1, it brings a couple of minor bug fixes
  190. * Sat Feb 03 2001 Than Ngo <than@redhat.com>
  191. - updated to 3.3
  192. * Tue Jan 23 2001 Than Ngo <than@redhat.com>
  193. - updated to 3.2.98, a release candidate for DDD 3.3
  194. * Mon Dec 04 2000 Than Ngo <than@redhat.com>
  195. - updated to 2.3.92 (Bug #16254)
  196. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  197. - rebuilt
  198. * Sat Jul 22 2000 Tim Powers <timp@redhat.com>
  199. - fixed missing BuildPreReq
  200. * Mon Jul 17 2000 Tim Powers <timp@redhat.com>
  201. - added defattr
  202. * Wed Jul 12 2000 Than Ngo <than@redhat.de>
  203. - rebuilt
  204. * Mon Jun 12 2000 Than Ngo <than@redhat.de>
  205. - rebuild with openmotif-2.1.30 for 7.0
  206. - clean up specfile
  207. - FHS fixes
  208. * Mon May 8 2000 Tim Powers <timp@redhat.com>
  209. - updated to 3.2.1
  210. - use applnk
  211. * Fri Feb 11 2000 Tim Powers <timp@redhat.com>
  212. - applied patch for ddd for use with lesstif 0.89 which caused the "view news"
  213. etc. help items not to uncompress the news and manual properly, resulting in
  214. an error message. Patch was from Andreas Zeller
  215. <andreas.zeller@fmi.uni-passau.de>
  216. * Tue Feb 01 2000 Tim Powers <timp@redhat.com>
  217. - bzipped sources to conserve space
  218. - built for 6.2
  219. * Tue Feb 01 2000 Trond Eivind Glomsr <teg@pvv.ntnu.no>
  220. - includes pdf doc instead of postscript
  221. - upgraded to 3.2
  222. - changed source locations and URLs to point at the new GNU sites
  223. - now does a make strip
  224. - added GNOME desktop entry
  225. * Fri Jan 07 2000 Trond Eivind Glomsr <teg@pvv.ntnu.no>
  226. - removed ptrace patch
  227. - now installs pydb
  228. - upgraded to 3.1.99
  229. - removed lots of old log entries
  230. * Thu Aug 19 1999 Tim Powers <timp@redhat.com>
  231. - reapplied patch for ptrace problems with sparc
  232. * Thu Aug 19 1999 Dale Lovelace <dale@redhat.com>
  233. - added ddd.wmconfig
  234. * Thu Jul 1 1999 Tim Powers <timp@redhat.com>
  235. - added the --with-motif-includes= and --with-motif-libraries= lines
  236. so that it would build
  237. - rebuilt package for Powertools
  238. * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
  239. - update to 3.1.5.
  240. * Tue Apr 13 1999 Michael Maher <mike@redhat.com>
  241. - built package for 6.0
  242. - updated package