cmake-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_with gui
  6. %global major_version 3
  7. %global minor_version 18
  8. Name: cmake
  9. Summary: Cross-platform make system
  10. Summary(ja): クロスプラットフォームな Make システム
  11. Version: 3.18.0
  12. Release: 1%{?_dist_release}
  13. Group: Development/Tools
  14. License: BSD
  15. URL: http://www.cmake.org/
  16. Source0: https://github.com/Kitware/CMake/releases/download/v%{version}/cmake-%{version}.tar.gz
  17. Source1: macros.cmake
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: curl-devel
  22. BuildRequires: expat-devel
  23. BuildRequires: gcc-gfortran
  24. BuildRequires: libarchive-devel
  25. #BuildRequires: libidn-devel
  26. BuildRequires: ncurses-devel
  27. BuildRequires: openssl-devel
  28. BuildRequires: zlib-devel
  29. BuildRequires: xz-devel
  30. BuildRequires: jsoncpp-devel
  31. %if %{with gui}
  32. BuildRequires: qt4-devel, desktop-file-utils
  33. %define qt_gui --qt-gui
  34. %else
  35. %define qt_gui --no-qt-gui
  36. %endif
  37. %description
  38. CMake is used to control the software compilation process using simple
  39. platform and compiler independent configuration files. CMake generates
  40. native makefiles and workspaces that can be used in the compiler
  41. environment of your choice. CMake is quite sophisticated: it is possible
  42. to support complex environments requiring system configuration, pre-processor
  43. generation, code generation, and template instantiation.
  44. %package gui
  45. Summary: Qt GUI for %{name}
  46. Group: Development/Tools
  47. Requires: %{name} = %{version}-%{release}
  48. Requires(post): desktop-file-utils, shared-mime-info
  49. Requires(postun): desktop-file-utils, shared-mime-info
  50. %description gui
  51. The %{name}-gui package contains the Qt based GUI for CMake.
  52. %debug_package
  53. %prep
  54. %setup -q
  55. %build
  56. ./bootstrap \
  57. --prefix=%{_prefix} \
  58. --datadir=/share/%{name} \
  59. --docdir=/share/doc/%{name} \
  60. --mandir=/share/man \
  61. %if 0%{?with_bootstrap}
  62. --no-system-libs \
  63. %else
  64. --system-curl \
  65. --system-expat \
  66. --system-jsoncpp \
  67. --system-zlib \
  68. --system-bzip2 \
  69. --system-liblzma \
  70. --system-libarchive \
  71. --no-system-librhash \
  72. %endif
  73. --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
  74. %{?qt_gui} \
  75. -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
  76. # sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  77. make VERBOSE=1 %{?_smp_mflags}
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  82. rm -rf $RPM_BUILD_ROOT/usr/doc
  83. # RPM macros
  84. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  85. sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  86. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  87. %if %{with gui}
  88. # Desktop file
  89. desktop-file-install --delete-original \
  90. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  91. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  92. %endif
  93. rm -rf doc
  94. mv -f %{buildroot}%{_docdir}/%{name} ./doc
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %if %{with gui}
  98. %post gui
  99. update-desktop-database &> /dev/null || :
  100. update-mime-database %{_datadir}/mime &> /dev/null || :
  101. %postun gui
  102. update-desktop-database &> /dev/null || :
  103. update-mime-database %{_datadir}/mime &> /dev/null || :
  104. %endif
  105. %files
  106. %defattr(-,root,root)
  107. %doc CMakeLogo.gif README.* doc
  108. %doc Help
  109. %license Copyright.txt Licenses/*
  110. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  111. %{_bindir}/ccmake
  112. %{_bindir}/cmake
  113. %{_bindir}/cpack
  114. %{_bindir}/ctest
  115. %{_datadir}/%{name}/
  116. %{_datadir}/aclocal/cmake.m4
  117. %dir %{_datadir}/bash-completion
  118. %dir %{_datadir}/bash-completion/completions
  119. %{_datadir}/bash-completion/completions/*
  120. %exclude /usr/share/vim
  121. %exclude /usr/share/emacs
  122. %if %{with gui}
  123. %files gui
  124. %defattr(-,root,root,-)
  125. %{_bindir}/cmake-gui
  126. %{_datadir}/applications/CMake.desktop
  127. %{_datadir}/mime/packages/cmakecache.xml
  128. %{_datadir}/icons/hicolor/*/*/*
  129. %endif
  130. %changelog
  131. * Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.18.0-1
  132. - updated to 3.18.0.
  133. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.15.3-1
  134. - updated to 3.15.3.
  135. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
  136. - updated to 3.10.1.
  137. - updated macros.cmake.
  138. - disabled gui.
  139. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
  140. - rebuild with gcc-5.4.0
  141. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  142. - update to 3.5.2
  143. - add BuildRequires: xz-devel, jsoncpp-devel
  144. - remove old patches
  145. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  146. - update to 2.8.12.2
  147. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  148. - update to 2.8.12.2
  149. - add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
  150. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
  151. - rebuild with libarchive-3.1.2
  152. * Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
  153. - new upstream release
  154. - add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
  155. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
  156. - new upstream release
  157. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
  158. - new upstream release
  159. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  160. - new upstream release
  161. - fixed desktop file warning
  162. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  163. - rebuild with libarchive-3.0.4
  164. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  165. - new upstream release
  166. - forced to link with libtinfo.so (ccmake)
  167. - used --system-libs again
  168. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  169. - new upstream release
  170. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  171. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  172. - fixed typo (not --with-system-libs, but --system-libs)
  173. - added BR: curl-devel, expat-devel, zlib-devel
  174. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  175. - add BuildRequires: ncurses-devel
  176. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  177. - generate gui package
  178. - renamed module directory
  179. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  180. - new upstream release
  181. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  182. - rebuilt with new toolchain
  183. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  184. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  185. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  186. - new upstream release
  187. - added Vendor/Distribution tag
  188. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  189. - new upstream release
  190. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  191. - new upstream release
  192. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  193. - new upstream release
  194. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  195. - new upstream release
  196. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  197. - new upstream release
  198. - drop Patch100
  199. - use bootstrap script instead of configure
  200. - delete caches from %%doc
  201. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  202. - rebuilt with new toolchain
  203. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  204. - new upstream release
  205. - delete duped docs
  206. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  207. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  208. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  209. - source version up
  210. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  211. - initial build for Vine Linux