busybox-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. Summary: Statically linked binary providing simplified versions of system commands
  2. Name: busybox
  3. Version: 1.30.1
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Shells
  6. License: GPLv2
  7. URL: https://www.busybox.net/
  8. Source: https://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
  9. Source10: busybox-static.config
  10. Source11: busybox-anaconda.config
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: uClibc-ng-devel
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. %description
  16. Busybox is a single binary which includes versions of a large number
  17. of system commands, including a shell. This package can be very
  18. useful for recovering from certain types of system failures,
  19. particularly those involving broken shared libraries.
  20. %package anaconda
  21. Group: System Environment/Shells
  22. Summary: Version of busybox configured for use with anaconda
  23. %description anaconda
  24. Busybox is a single binary which includes versions of a large number
  25. of system commands, including a shell. The version contained in this
  26. package is designed for use with the Red Hat installation program,
  27. anaconda. The busybox package provides a binary better suited to
  28. normal use.
  29. %prep
  30. %setup -q
  31. %build
  32. # create static busybox
  33. arch=`uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/' -e 's/ppc64//' -e 's/powerpc64//'`
  34. cp %{SOURCE10} .config
  35. yes "" | make oldconfig
  36. # gcc needs to be convinced to use neither system headers, nor libs,
  37. # nor startfiles (i.e. crtXXX.o files)
  38. if test "$arch"; then \
  39. mv .config .config1 && \
  40. grep -v \
  41. -e ^CONFIG_SELINUX \
  42. -e ^CONFIG_FEATURE_HAVE_RPC \
  43. -e ^CONFIG_FEATURE_MOUNT_NFS \
  44. -e ^CONFIG_FEATURE_INETD_RPC \
  45. .config1 >.config && \
  46. echo "# CONFIG_FEATURE_HAVE_RPC is not set" >>.config && \
  47. echo "# CONFIG_FEATURE_MOUNT_NFS is not set" >>.config && \
  48. echo "# CONFIG_FEATURE_INETD_RPC is not set" >>.config && \
  49. yes "" | make oldconfig && \
  50. cat .config && \
  51. make V=1 %{_smp_mflags} \
  52. EXTRA_CFLAGS="-isystem %{_includedir}/uClibc" \
  53. CFLAGS_busybox="-static -nostartfiles -L%{_libdir}/uClibc %{_libdir}/uClibc/crt1.o %{_libdir}/uClibc/crti.o %{_libdir}/uClibc/crtn.o"; \
  54. else \
  55. cat .config && \
  56. make V=1 CC="gcc $RPM_OPT_FLAGS"; \
  57. fi
  58. cp busybox busybox.static
  59. cp docs/busybox.1 docs/busybox.static.1
  60. # create busybox optimized for anaconda
  61. make clean
  62. #
  63. grep -v \
  64. -e ^CONFIG_SELINUX \
  65. -e ^CONFIG_FEATURE_HAVE_RPC \
  66. -e ^CONFIG_FEATURE_MOUNT_NFS \
  67. -e ^CONFIG_FEATURE_INETD_RPC \
  68. %{SOURCE11} >.config && \
  69. echo "# CONFIG_FEATURE_HAVE_RPC is not set" >>.config && \
  70. echo "# CONFIG_FEATURE_MOUNT_NFS is not set" >>.config && \
  71. echo "# CONFIG_FEATURE_INETD_RPC is not set" >>.config && \
  72. yes "" | make oldconfig
  73. make %{_smp_mflags} CONFIG_DEBUG=y CC="gcc $RPM_OPT_FLAGS"
  74. cp busybox busybox.anaconda
  75. cp docs/busybox.1 docs/busybox.anaconda.1
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. mkdir -p $RPM_BUILD_ROOT/sbin
  79. install -m 755 busybox.static $RPM_BUILD_ROOT/sbin/busybox
  80. install -m 755 busybox.anaconda $RPM_BUILD_ROOT/sbin/busybox.anaconda
  81. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
  82. install -m 644 docs/busybox.static.1 $RPM_BUILD_ROOT/%{_mandir}/man1/busybox.1
  83. install -m 644 docs/busybox.anaconda.1 $RPM_BUILD_ROOT/%{_mandir}/man1/busybox.anaconda.1
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %files
  87. %defattr(-,root,root,-)
  88. %license LICENSE
  89. %doc README
  90. /sbin/busybox
  91. %{_mandir}/man1/busybox.1.gz
  92. %files anaconda
  93. %defattr(-,root,root,-)
  94. %license LICENSE
  95. %doc README
  96. /sbin/busybox.anaconda
  97. %{_mandir}/man1/busybox.anaconda.1.gz
  98. %changelog
  99. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.30.1-1
  100. - new upstream release.
  101. - dropped all patches.
  102. * Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20.2-1
  103. - update to 1.20.2
  104. - Patch1: change uname -p behavior to coreutils's uname
  105. - small config changes
  106. * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.4-1
  107. - update to 1.18.4
  108. - build with system uClibc
  109. * Fri May 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.13.4-2
  110. - add Patch20 to fix build failure on ppc
  111. http://lists.uclibc.org/pipermail/uclibc-cvs/2009-January/025891.html
  112. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.4-1
  113. - new upstream release
  114. - use uClibc for static build instead of glibc
  115. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.0-1vl5
  116. - applied new versioning policy
  117. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  118. - initial build for Vine Linux based on FC-devel
  119. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2.0-1.1
  120. - rebuild
  121. * Tue Jul 4 2006 Ivana Varekova <varekova@redhat.com> - 1:1.2.0-1
  122. - update to 1.2.0
  123. * Thu Jun 8 2006 Jeremy Katz <katzj@redhat.com> - 1:1.1.3-2
  124. - fix so that busybox.anaconda has sh
  125. * Wed May 31 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.3-1
  126. - update to 1.1.3
  127. * Mon May 29 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.2-3
  128. - fix Makefile typo (#193354)
  129. * Fri May 5 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.2-1
  130. - update to 1.1.2
  131. * Thu May 4 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.1-2
  132. - add -Z option to id command, rename ps command -Z option (#190534)
  133. * Wed May 03 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.1-1
  134. - update to 1.1.1
  135. - fix CVE-2006-1058 - BusyBox passwd command
  136. fails to generate password with salt (#187386)
  137. - add -minimal-toc option
  138. - add RPM_OPT_FLAGS
  139. - remove asm/page.h used sysconf command to get PAGE_SIZE
  140. - add overfl patch to aviod Buffer warning
  141. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.01-2.2.1
  142. - bump again for double-long bug on ppc(64)
  143. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.01-2.2
  144. - rebuilt for new gcc4.1 snapshot and glibc changes
  145. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  146. - rebuilt
  147. * Thu Oct 13 2005 Daniel Walsh <dwalsh@redhat.com> - 1.01-2
  148. - Add sepol for linking load_policy
  149. * Thu Sep 1 2005 Ivana Varekova <varekova@redhat.com> - 1.01-1
  150. - update to 1.01
  151. * Wed May 11 2005 Ivana Varekova <varekova@redhat.com> - 1.00-5
  152. - add debug files to debug_package
  153. * Mon Mar 7 2005 Ivana Varekova <varekova@redhat.com> - 1.00-4
  154. - rebuilt
  155. * Wed Jan 26 2005 Ivana Varekova <varekova@redhat.com> - 1.00-3
  156. - update to 1.00 - fix bug #145681
  157. - rebuild
  158. * Thu Jan 13 2005 Jeremy Katz <katzj@redhat.com> - 1.00.rc1-6
  159. - enable ash as the shell in busybox-anaconda
  160. * Sat Oct 2 2004 Bill Nottingham <notting@redhat.com> - 1.00.rc1-5
  161. - fix segfault in SELinux patch (#134404, #134406)
  162. * Fri Sep 17 2004 Phil Knirsch <pknirsch@redhat.com> - 1.00.rc1-4
  163. - Fixed double free in freecon() call (#132809)
  164. * Fri Sep 10 2004 Daniel Walsh <dwalsh@redhat.com> - 1.00.rc1-3
  165. - Add CONFIG_STATIC=y for static builds
  166. * Wed Aug 25 2004 Jeremy Katz <katzj@redhat.com> - 1.00.rc1-2
  167. - rebuild
  168. * Fri Jun 25 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre10.1
  169. - Add BuildRequires libselinux-devel
  170. - Update to latest from upstream
  171. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  172. - rebuilt
  173. * Tue May 11 2004 Karsten Hopp <karsten@redhat.de> 1.00.pre8-4
  174. - add mknod to busybox-anaconda
  175. * Wed Apr 21 2004 Karsten Hopp <karsten@redhat.de> 1.00.pre8-3
  176. - fix LS_COLOR in anaconda patch
  177. * Tue Mar 23 2004 Jeremy Katz <katzj@redhat.com> 1.00.pre8-2
  178. - add awk to busybox-anaconda
  179. * Sat Mar 20 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre8.1
  180. - Update with latest patch.
  181. - Turn off LS_COLOR in static patch
  182. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  183. - rebuilt
  184. * Tue Jan 27 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre5.2
  185. - Fix is_selinux_enabled calls
  186. * Mon Dec 29 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre5.1
  187. -Latest update
  188. * Wed Nov 26 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre3.2
  189. - Add insmod
  190. * Mon Sep 15 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre3.1
  191. - Upgrade to pre3
  192. * Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 1.00.2
  193. - Upgrade selinux support
  194. * Wed Jul 23 2003 Dan Walsh <dwalsh@redhat.com> 1.00.1
  195. - Upgrade to 1.00 package
  196. * Wed Jul 16 2003 Elliot Lee <sopwith@redhat.com> 0.60.5-10
  197. - Rebuild
  198. * Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-9
  199. - rebuild
  200. * Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-8
  201. - add dmesg to busybox-anaconda
  202. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  203. - rebuilt
  204. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  205. - rebuilt
  206. * Mon Jan 13 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-5
  207. - lost nolock for anaconda mount when rediffing, it returns (#81764)
  208. * Mon Jan 6 2003 Dan Walsh <dwalsh@redhat.com> 0.60.5-4
  209. - Upstream developers wanted to eliminate the use of floats
  210. * Fri Jan 3 2003 Dan Walsh <dwalsh@redhat.com> 0.60.5-3
  211. - Fix free to work on large memory machines.
  212. * Sat Dec 28 2002 Jeremy Katz <katzj@redhat.com> 0.60.5-2
  213. - update Config.h for anaconda build to include more useful utils
  214. * Thu Dec 19 2002 Dan Walsh <dwalsh@redhat.com> 0.60.5-1
  215. - update latest release
  216. * Thu Dec 19 2002 Dan Walsh <dwalsh@redhat.com> 0.60.2-8
  217. - incorporate hammer changes
  218. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  219. - automated rebuild
  220. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  221. - automated rebuild
  222. * Mon May 06 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  223. - fix compilation on mainframe
  224. * Tue Apr 2 2002 Jeremy Katz <katzj@redhat.com>
  225. - fix static busybox (#60701)
  226. * Thu Feb 28 2002 Jeremy Katz <katzj@redhat.com>
  227. - don't include mknod in busybox.anaconda so we get collage mknod
  228. * Fri Feb 22 2002 Jeremy Katz <katzj@redhat.com>
  229. - rebuild in new environment
  230. * Wed Jan 30 2002 Jeremy Katz <katzj@redhat.com>
  231. - update to 0.60.2
  232. - include more pieces for the anaconda version so that collage can go away
  233. - make the mount in busybox.anaconda default to -onolock
  234. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  235. `- automated rebuild
  236. * Mon Jul 9 2001 Tim Powers <timp@redhat.com>
  237. - don't obsolete sash
  238. - fix URL and spelling in desc. to satisfy rpmlint
  239. * Thu Jul 05 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  240. - add missing defattr for anaconda subpackage
  241. * Thu Jun 28 2001 Erik Troan <ewt@redhat.com>
  242. - initial build for Red Hat