atlas-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674
  1. %define enable_native_atlas 0
  2. %define disable_CPU_throttling_probe 1
  3. Name: atlas
  4. Version: 3.8.4
  5. %if "%{?enable_native_atlas}" != "0"
  6. %define dist .native
  7. %endif
  8. Release: 5%{?_dist_release}
  9. Summary: Automatically Tuned Linear Algebra Software
  10. Summary(ja): 自動的にCPUに最適化する線形代数ソフトウェア
  11. Group: System Environment/Libraries
  12. License: BSD
  13. URL: http://math-atlas.sourceforge.net/
  14. Source0: http://downloads.sourceforge.net/math-atlas/%{name}%{version}.tar.bz2
  15. Source1: PPRO32.tgz
  16. Source2: K7323DNow.tgz
  17. Source3: README.Fedora
  18. Source4: USII64.tgz
  19. Source5: USII32.tgz
  20. Patch0: atlas-fedora_shared.patch
  21. Patch1: atlas-fedora-arm.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  23. BuildRequires: gcc-gfortran lapack-static
  24. %description
  25. The ATLAS (Automatically Tuned Linear Algebra Software) project is an
  26. ongoing research effort focusing on applying empirical techniques in
  27. order to provide portable performance. At present, it provides C and
  28. Fortran77 interfaces to a portably efficient BLAS implementation, as
  29. well as a few routines from LAPACK.
  30. The performance improvements in ATLAS are obtained largely via
  31. compile-time optimizations and tend to be specific to a given hardware
  32. configuration. In order to package ATLAS for Fedora some compromises
  33. are necessary so that good performance can be obtained on a variety
  34. of hardware. This set of ATLAS binary packages is therefore not
  35. necessarily optimal for any specific hardware configuration. However,
  36. the source package can be used to compile customized ATLAS packages;
  37. see the documentation for information.
  38. %package devel
  39. Summary: Development libraries for ATLAS
  40. Summary(ja): ATLAS を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Obsoletes: %name-header <= %version-%release
  44. Requires(posttrans): chkconfig
  45. Requires(preun): chkconfig
  46. Requires(post): /sbin/alternatives
  47. Requires(postun): /sbin/alternatives
  48. %description devel
  49. This package contains the libraries and headers for development
  50. with ATLAS (Automatically Tuned Linear Algebra Software).
  51. %define types base
  52. %if "%{?enable_native_atlas}" == "0"
  53. ############## Subpackages for architecture extensions #################
  54. #
  55. %ifarch x86_64
  56. %define types base sse3
  57. %package sse3
  58. Summary: ATLAS libraries for SSE3 extensions
  59. Summary(ja): SSE3命令セット拡張に最適化した ATLASライブラリ
  60. Group: System Environment/Libraries
  61. %description sse3
  62. This package contains the ATLAS (Automatically Tuned Linear Algebra
  63. Software) libraries compiled with optimizations for the SSE3
  64. extensions to the x86_64 architecture. The base ATLAS builds in Fedora for the
  65. x86_64 architecture are made for the SSE2 extensions.
  66. %package sse3-devel
  67. Summary: Development libraries for ATLAS with SSE3 extensions
  68. Summary(ja): ATLAS を使ったプログラム開発に必要な SSE3命令セット拡張に最適化したヘッダファイル/ライブラリ
  69. Group: Development/Libraries
  70. Requires: %{name}-sse3 = %{version}-%{release}
  71. Obsoletes: %name-header <= %version-%release
  72. Requires(posttrans): chkconfig
  73. Requires(preun): chkconfig
  74. Requires(post): /sbin/alternatives
  75. Requires(postun): /sbin/alternatives
  76. %description sse3-devel
  77. This package contains shared and static versions of the ATLAS
  78. (Automatically Tuned Linear Algebra Software) libraries compiled with
  79. optimizations for the SSE3 extensions to the x86_64 architecture.
  80. %endif
  81. %ifarch %{ix86}
  82. %define types base 3dnow sse sse2 sse3
  83. %package 3dnow
  84. Summary: ATLAS libraries for 3DNow extensions
  85. Summary(ja): 3DNow命令セット拡張に最適化した ATLASライブラリ
  86. Group: System Environment/Libraries
  87. %description 3dnow
  88. This package contains the ATLAS (Automatically Tuned Linear Algebra
  89. Software) libraries compiled with optimizations for the 3DNow extension
  90. to the ix86 architecture. Fedora also produces ATLAS build with SSE, SSE2
  91. and SSE3 extensions.
  92. %package 3dnow-devel
  93. Summary: Development libraries for ATLAS with 3DNow extensions
  94. Summary(ja): ATLAS を使ったプログラム開発に必要な 3DNow命令セット拡張に最適化したヘッダファイル/ライブラリ
  95. Group: Development/Libraries
  96. Requires: %{name}-3dnow = %{version}-%{release}
  97. Obsoletes: %name-header <= %version-%release
  98. Requires(posttrans): chkconfig
  99. Requires(preun): chkconfig
  100. %description 3dnow-devel
  101. This package contains headers and shared versions of the ATLAS
  102. (Automatically Tuned Linear Algebra Software) libraries compiled with
  103. optimizations for the 3DNow extensions to the ix86 architecture.
  104. %package sse
  105. Summary: ATLAS libraries for SSE extensions
  106. Summary(ja): SSE命令セット拡張に最適化した ATLASライブラリ
  107. Group: System Environment/Libraries
  108. %description sse
  109. This package contains the ATLAS (Automatically Tuned Linear Algebra
  110. Software) libraries compiled with optimizations for the SSE(1) extensions
  111. to the ix86 architecture. Fedora also produces ATLAS build with SSE2 and SSE3
  112. extensions.
  113. %package sse-devel
  114. Summary: Development libraries for ATLAS with SSE extensions
  115. Summary(ja): ATLAS を使ったプログラム開発に必要な SSE命令セット拡張に最適化したヘッダファイル/ライブラリ
  116. Group: Development/Libraries
  117. Requires: %{name}-sse = %{version}-%{release}
  118. Obsoletes: %name-header <= %version-%release
  119. Requires(posttrans): chkconfig
  120. Requires(preun): chkconfig
  121. %description sse-devel
  122. This package contains headers and shared versions of the ATLAS
  123. (Automatically Tuned Linear Algebra Software) libraries compiled with
  124. optimizations for the SSE(1) extensions to the ix86 architecture.
  125. %package sse2
  126. Summary: ATLAS libraries for SSE2 extensions
  127. Summary(ja): SSE2命令セット拡張に最適化した ATLASライブラリ
  128. Group: System Environment/Libraries
  129. %description sse2
  130. This package contains ATLAS (Automatically Tuned Linear Algebra Software)
  131. shared libraries compiled with optimizations for the SSE2
  132. extensions to the ix86 architecture. Fedora also produces ATLAS build with
  133. SSE(1) and SSE3 extensions.
  134. %package sse2-devel
  135. Summary: Development libraries for ATLAS with SSE2 extensions
  136. Summary(ja): ATLAS を使ったプログラム開発に必要な SSE2命令セット拡張に最適化したヘッダファイル/ライブラリ
  137. Group: Development/Libraries
  138. Requires: %{name}-sse2 = %{version}-%{release}
  139. Obsoletes: %name-header <= %version-%release
  140. Requires(posttrans): chkconfig
  141. Requires(preun): chkconfig
  142. %description sse2-devel
  143. This package contains ATLAS (Automatically Tuned Linear Algebra Software)
  144. shared libraries compiled with optimizations for the SSE2 extensions to the
  145. ix86 architecture.
  146. %package sse3
  147. Summary: ATLAS libraries for SSE3 extensions
  148. Summary(ja): SSE3命令セット拡張に最適化した ATLASライブラリ
  149. Group: System Environment/Libraries
  150. %description sse3
  151. This package contains the ATLAS (Automatically Tuned Linear Algebra
  152. Software) libraries compiled with optimizations for the SSE3.
  153. Fedora also produces ATLAS build with SSE(1) and SSE2 extensions.
  154. %package sse3-devel
  155. Summary: Development libraries for ATLAS with SSE3 extensions
  156. Summary(ja): ATLAS を使ったプログラム開発に必要な SSE3命令セット拡張に最適化したヘッダファイル/ライブラリ
  157. Group: Development/Libraries
  158. Requires: %{name}-sse3 = %{version}-%{release}
  159. Obsoletes: %name-header <= %version-%release
  160. Requires(posttrans): chkconfig
  161. Requires(preun): chkconfig
  162. %description sse3-devel
  163. This package contains ATLAS (Automatically Tuned Linear Algebra Software)
  164. shared libraries compiled with optimizations for the SSE3 extensions to the ix86 architecture.
  165. %endif
  166. %endif
  167. %global mode %{__isa_bits}
  168. %ifarch %{arm}
  169. %define arch_option -A 38
  170. %define threads_option -t 2
  171. %global mode ' '
  172. %endif
  173. %prep
  174. %setup -q -n ATLAS
  175. %patch0 -p0 -b .shared
  176. %ifarch %{arm}
  177. %patch1 -p0 -b .arm
  178. %endif
  179. cp %{SOURCE1} CONFIG/ARCHS/
  180. cp %{SOURCE2} CONFIG/ARCHS/
  181. cp %{SOURCE3} doc
  182. cp %{SOURCE4} CONFIG/ARCHS/
  183. cp %{SOURCE5} CONFIG/ARCHS/
  184. %build
  185. for type in %{types}; do
  186. if [ "$type" = "base" ]; then
  187. libname=atlas
  188. %define pr_base %(echo $((%{__isa_bits}+0)))
  189. else
  190. libname=atlas-${type}
  191. fi
  192. mkdir -p %{_arch}_${type}
  193. pushd %{_arch}_${type}
  194. ../configure -b %{mode} %{?threads_option} %{?arch_option} -D c -DWALL -Fa alg '-g -Wa,--noexecstack -fPIC'\
  195. --prefix=%{buildroot}%{_prefix} \
  196. --incdir=%{buildroot}%{_includedir} \
  197. --libdir=%{buildroot}%{_libdir}/${libname} \
  198. --with-netlib-lapack=%{_libdir}/liblapack_pic.a \
  199. %if %{disable_CPU_throttling_probe}
  200. -Si cputhrchk 0
  201. %endif
  202. %if "%{?enable_native_atlas}" == "0"
  203. %ifarch x86_64
  204. if [ "$type" = "base" ]; then
  205. sed -i 's#ARCH =.*#ARCH = HAMMER64SSE2#' Make.inc
  206. sed -i 's#-DATL_SSE3##' Make.inc
  207. sed -i 's#-msse3#-msse2#' Make.inc
  208. elif [ "$type" = "sse3" ]; then
  209. sed -i 's#ARCH =.*#ARCH = HAMMER64SSE3#' Make.inc
  210. %define pr_sse3 %(echo $((%{__isa_bits}+4)))
  211. fi
  212. %endif
  213. %ifarch %{ix86}
  214. if [ "$type" = "base" ]; then
  215. sed -i 's#ARCH =.*#ARCH = PPRO32#' Make.inc
  216. sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
  217. sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
  218. elif [ "$type" = "3dnow" ]; then
  219. sed -i 's#ARCH =.*#ARCH = K7323DNow#' Make.inc
  220. sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
  221. sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
  222. %define pr_3dnow %(echo $((%{__isa_bits}+1)))
  223. elif [ "$type" = "sse" ]; then
  224. sed -i 's#ARCH =.*#ARCH = PIII32SSE1#' Make.inc
  225. sed -i 's#-DATL_SSE3 -DATL_SSE2##' Make.inc
  226. sed -i 's#-msse3#-msse#' Make.inc
  227. %define pr_sse %(echo $((%{__isa_bits}+2)))
  228. elif [ "$type" = "sse2" ]; then
  229. sed -i 's#ARCH =.*#ARCH = P432SSE2#' Make.inc
  230. sed -i 's#-DATL_SSE3##' Make.inc
  231. sed -i 's#-msse3#-msse2#' Make.inc
  232. %define pr_sse2 %(echo $((%{__isa_bits}+3)))
  233. elif [ "$type" = "sse3" ]; then
  234. sed -i 's#ARCH =.*#ARCH = P4E32SSE3#' Make.inc
  235. %define pr_sse3 %(echo $((%{__isa_bits}+4)))
  236. fi
  237. %endif
  238. %endif
  239. make build
  240. cd lib
  241. make shared
  242. make ptshared
  243. popd
  244. done
  245. %install
  246. rm -rf %{buildroot}
  247. for type in %{types}; do
  248. pushd %{_arch}_${type}
  249. make DESTDIR=%{buildroot} install
  250. mv %{buildroot}%{_includedir}/atlas %{buildroot}%{_includedir}/atlas-%{_arch}-${type}
  251. if [ "$type" = "base" ]; then
  252. cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas/
  253. rm -f %{buildroot}%{_libdir}/atlas/*.a
  254. else
  255. cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas-${type}/
  256. rm -f %{buildroot}%{_libdir}/atlas-${type}/*.a
  257. fi
  258. popd
  259. mkdir -p %{buildroot}/etc/ld.so.conf.d
  260. if [ "$type" = "base" ]; then
  261. echo "%{_libdir}/atlas" \
  262. > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}.conf
  263. else
  264. echo "%{_libdir}/atlas-${type}" \
  265. > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}-${type}.conf
  266. fi
  267. done
  268. mkdir -p %{buildroot}%{_includedir}/atlas
  269. %clean
  270. rm -rf %{buildroot}
  271. %post -p /sbin/ldconfig
  272. %postun -p /sbin/ldconfig
  273. %posttrans devel
  274. if [ $1 -eq 0 ] ; then
  275. /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  276. %{_includedir}/atlas-%{_arch}-base %{pr_base}
  277. fi
  278. %preun devel
  279. if [ $1 -ge 0 ] ; then
  280. /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-base
  281. fi
  282. %if "%{?enable_native_atlas}" == "0"
  283. %ifarch x86_64
  284. %post -n atlas-sse3 -p /sbin/ldconfig
  285. %postun -n atlas-sse3 -p /sbin/ldconfig
  286. %posttrans sse3-devel
  287. if [ $1 -eq 0 ] ; then
  288. /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  289. %{_includedir}/atlas-%{_arch}-sse3 %{pr_sse3}
  290. fi
  291. %preun sse3-devel
  292. if [ $1 -ge 0 ] ; then
  293. /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
  294. fi
  295. %endif
  296. %ifarch %{ix86}
  297. %post -n atlas-3dnow -p /sbin/ldconfig
  298. %postun -n atlas-3dnow -p /sbin/ldconfig
  299. %posttrans 3dnow-devel
  300. if [ $1 -eq 0 ] ; then
  301. /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  302. %{_includedir}/atlas-%{_arch}-3dnow %{pr_3dnow}
  303. fi
  304. %preun 3dnow-devel
  305. if [ $1 -ge 0 ] ; then
  306. /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-3dnow
  307. fi
  308. %post -n atlas-sse -p /sbin/ldconfig
  309. %postun -n atlas-sse -p /sbin/ldconfig
  310. %posttrans sse-devel
  311. if [ $1 -eq 0 ] ; then
  312. /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  313. %{_includedir}/atlas-%{_arch}-sse %{pr_sse}
  314. fi
  315. %preun sse-devel
  316. if [ $1 -ge 0 ] ; then
  317. /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse
  318. fi
  319. %post -n atlas-sse2 -p /sbin/ldconfig
  320. %postun -n atlas-sse2 -p /sbin/ldconfig
  321. %posttrans sse2-devel
  322. if [ $1 -eq 0 ] ; then
  323. /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  324. %{_includedir}/atlas-%{_arch}-sse2 %{pr_sse2}
  325. fi
  326. %preun sse2-devel
  327. if [ $1 -ge 0 ] ; then
  328. /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse2
  329. fi
  330. %post -n atlas-sse3 -p /sbin/ldconfig
  331. %postun -n atlas-sse3 -p /sbin/ldconfig
  332. %posttrans sse3-devel
  333. if [ $1 -eq 0 ] ; then
  334. /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  335. %{_includedir}/atlas-%{_arch}-sse3 %{pr_sse3}
  336. fi
  337. %preun sse3-devel
  338. if [ $1 -ge 0 ] ; then
  339. /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
  340. fi
  341. %endif
  342. %endif
  343. %files
  344. %defattr(-,root,root,-)
  345. %doc doc/README.Fedora
  346. %dir %{_libdir}/atlas
  347. %{_libdir}/atlas/*.so.*
  348. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}.conf
  349. %files devel
  350. %defattr(-,root,root,-)
  351. %doc doc
  352. %{_libdir}/atlas/*.so
  353. %{_includedir}/atlas-%{_arch}-base/
  354. %{_includedir}/*.h
  355. %ghost %{_includedir}/atlas
  356. %if "%{?enable_native_atlas}" == "0"
  357. %ifarch x86_64
  358. %files sse3
  359. %defattr(-,root,root,-)
  360. %doc doc/README.Fedora
  361. %dir %{_libdir}/atlas-sse3
  362. %{_libdir}/atlas-sse3/*.so.*
  363. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
  364. %files sse3-devel
  365. %defattr(-,root,root,-)
  366. %doc doc
  367. %{_libdir}/atlas-sse3/*.so
  368. %{_includedir}/atlas-%{_arch}-sse3/
  369. %{_includedir}/*.h
  370. %ghost %{_includedir}/atlas
  371. %endif
  372. %ifarch %{ix86}
  373. %files 3dnow
  374. %defattr(-,root,root,-)
  375. %doc doc/README.Fedora
  376. %dir %{_libdir}/atlas-3dnow
  377. %{_libdir}/atlas-3dnow/*.so.*
  378. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-3dnow.conf
  379. %files 3dnow-devel
  380. %defattr(-,root,root,-)
  381. %doc doc
  382. %{_libdir}/atlas-3dnow/*.so
  383. %{_includedir}/atlas-%{_arch}-3dnow/
  384. %{_includedir}/*.h
  385. %ghost %{_includedir}/atlas
  386. %files sse
  387. %defattr(-,root,root,-)
  388. %doc doc/README.Fedora
  389. %dir %{_libdir}/atlas-sse
  390. %{_libdir}/atlas-sse/*.so.*
  391. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse.conf
  392. %files sse-devel
  393. %defattr(-,root,root,-)
  394. %doc doc
  395. %{_libdir}/atlas-sse/*.so
  396. %{_includedir}/atlas-%{_arch}-sse/
  397. %{_includedir}/*.h
  398. %ghost %{_includedir}/atlas
  399. %files sse2
  400. %defattr(-,root,root,-)
  401. %doc doc/README.Fedora
  402. %dir %{_libdir}/atlas-sse2
  403. %{_libdir}/atlas-sse2/*.so.*
  404. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse2.conf
  405. %files sse2-devel
  406. %defattr(-,root,root,-)
  407. %doc doc
  408. %{_libdir}/atlas-sse2/*.so
  409. %{_includedir}/atlas-%{_arch}-sse2/
  410. %{_includedir}/*.h
  411. %ghost %{_includedir}/atlas
  412. %files sse3
  413. %defattr(-,root,root,-)
  414. %doc doc/README.Fedora
  415. %dir %{_libdir}/atlas-sse3
  416. %{_libdir}/atlas-sse3/*.so.*
  417. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
  418. %files sse3-devel
  419. %defattr(-,root,root,-)
  420. %doc doc
  421. %{_libdir}/atlas-sse3/*.so
  422. %{_includedir}/atlas-%{_arch}-sse3/
  423. %{_includedir}/*.h
  424. %ghost %{_includedir}/atlas
  425. %endif
  426. %endif
  427. %changelog
  428. * Fri May 25 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.8.4-5
  429. - added Japanese Summary
  430. - turned off throttle checking
  431. * Thu Mar 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.8.4-4
  432. - initial build for Vine Linux
  433. * Thu Sep 01 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-3
  434. - Apply patch to enable arm build (Patch provided by Jitesh Shah <jiteshs@marvell.com>)
  435. - Stop turning off throttle checking, upstream frown at it (seems O.K. for Koji)
  436. * Mon Jun 20 2011 Dan Horák <dan[at]danny.cz> - 3.8.4-2
  437. - Use -march=z10 for z196 optimised build because the builder is a z10
  438. (Christian Bornträger)
  439. * Tue Jun 14 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-1
  440. - Update to 3.8.4
  441. - Build the default package for SSE2 and add a SSE3 subpackage on x86_64
  442. - Apply patch (and arch defs.) to build on s390 and s390x (Dan Horák)
  443. - Fix-up build on s390 and s390x (Christian Bornträger)
  444. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  445. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  446. * Mon Jul 26 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-18
  447. - Create a subpackage for SSE2 on x86_64
  448. * Sat Jul 17 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-17
  449. - rebuild against fixed lapack libraries
  450. * Thu Jul 15 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-16
  451. - fix build on s390 (patch by Karsten Hopp)
  452. * Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-15
  453. - Disable the problematic sparc patch
  454. - Change lapack-devel BR to lapack-static, where liblapack_pic.a now resides.
  455. * Wed Feb 03 2010 Dennis Gilmore <dennis@ausil.us> - 3.8.3-14
  456. - fix sparc build
  457. * Fri Jan 29 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-13
  458. - Remove static libraries.
  459. - Fix typo in SSE3 subpackage's summary.
  460. * Sat Oct 24 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-12
  461. - Use alternatives to workaround multilib conflicts (BZ#508565).
  462. * Tue Sep 29 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-11
  463. - Obsolete the -header subpackage properly.
  464. * Sat Sep 26 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-10
  465. - Use the new arch. default for Pentium PRO (Fedora bug #510498)
  466. - (Re-)Introduce 3dNow subpackage
  467. * Sun Sep 6 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 3.8.3-9
  468. - Rebuild against fixed lapack (see #520518)
  469. * Wed Aug 13 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-8
  470. - Revert the last change, it doesn't solve the problem.
  471. * Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-7
  472. - Create a -header subpackage to avoid multilib conflicts (BZ#508565).
  473. * Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-6
  474. - Add '-g' to build flag to allow proper genration of debuginfo subpackages (Fedora bug #509813)
  475. - Build for F12
  476. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-5
  477. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  478. * Sat May 02 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-4
  479. - Use the right -msse* option for the -sse* subpackages (Fedora bug #498715)
  480. * Tue Apr 21 2009 Karsten Hopp <karsten@redhat.com> 3.8.3-3.1
  481. - add s390x to 64 bit archs
  482. * Fri Feb 27 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-3
  483. - Rebuild
  484. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-2
  485. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  486. * Sun Feb 22 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-1
  487. - Update to version 3.8.3
  488. * Sun Dec 21 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-5
  489. - Link in appropriate libs when creating shared libs, reported by Orcan 'oget' Ogetbil (BZ#475411)
  490. * Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-4
  491. - Don't symlink the atlas libdir on i386, cause upgrade issue (BZ#476787)
  492. - Fix options passed to gcc when making shared libs
  493. * Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-3
  494. - Use 'gcc -shared' to build shared libs instead of stock 'ld'
  495. * Sat Dec 13 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-2
  496. - Properly obsolete/provide older subpackages that are no longer packaged.
  497. * Mon Sep 01 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-1
  498. - Upgrade to ver 3.8.2 with refined build procedures.
  499. * Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-15
  500. - Disable altivec package--it is causing illegal instructions during build.
  501. * Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-14
  502. - Enable compilation on alpha (bug 426086).
  503. - Patch for compilation on ia64 (bug 432744).
  504. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.6.0-13
  505. - Autorebuild for GCC 4.3
  506. * Mon Jun 4 2007 Orion Poplawski <orion@cora.nwra.com> 3.6.0-12
  507. - Rebuild for ppc64
  508. * Fri Sep 8 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-11
  509. - Rebuild for FC6.
  510. - Remove outdated comments from spec file.
  511. * Mon Feb 13 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-10
  512. - Rebuild for Fedora Extras 5.
  513. - Add --noexecstack to compilation of assembly kernels. These were
  514. previously marked executable, which caused problems with selinux.
  515. * Mon Dec 19 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-9
  516. - Rebuild for gcc 4.1.
  517. * Mon Oct 10 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-8
  518. - Make all devel subpackages depend on their non-devel counterparts.
  519. - Add /etc/ld.so.conf.d files for -sse and -3dnow, because they don't
  520. seem to get picked up automatically.
  521. * Wed Oct 05 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-7
  522. - Forgot to add the new patch to sources.
  523. * Tue Oct 04 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-6
  524. - Use new Debian patch, and enable shared libs (they previously failed
  525. to build on gcc 4).
  526. - Minor updates to description and README.Fedora file.
  527. - Fix buildroot name to match FE preferred form.
  528. - Fixes for custom optimized builds.
  529. - Add dist tag.
  530. * Wed Sep 28 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-5
  531. - fix files lists.
  532. * Mon Sep 26 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-4
  533. - generate library symlinks earlier for the benefit of later linking steps.
  534. * Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-3
  535. - Change lapack dependency to lapack-devel, and use lapack_pic.a for
  536. building liblapack.so.
  537. * Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-2
  538. - Add "bit" macro to correctly build on x86_64.
  539. * Tue Aug 16 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-1
  540. - Initial version.