Zope2-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692
  1. # if you want to checkout new modules, add "--define '_co 1'" to rpm option
  2. %define checkout_new_modules %{?_co:1}%{!?_co:0}
  3. %define zope2_version 2.12.3
  4. %define zope2_updates 20101124
  5. %define name Zope2
  6. %define zope2_libdir %{_libdir}/%{name}
  7. %define zope2_confdir %{_sysconfdir}/%{name}
  8. %define instance_home %{_var}/lib/%{name}
  9. %define sv_http_port 8280
  10. %define sv_ftp_port 8221
  11. %define sv_admin admin
  12. %define sv_password 123
  13. Summary: An application server and portal toolkit for building Web sites.
  14. Summary(ja): アプリケーションサーバおよびウェブサイト構築ツールキット
  15. Name: %{name}
  16. Version: %{zope2_version}
  17. Release: 2%{?_dist_release}
  18. License: ZPL (Zope Public License) 2.1
  19. URL: http://www.zope.org/
  20. Group: Development/Web Applications
  21. Source0: http://pypi.python.org/packages/source/Z/%{name}/%{name}-%{version}.tar.gz
  22. Source1: init.sh
  23. Source10: stable-req.txt
  24. Source11: Zope2-modules.%{zope2_updates}.tgz
  25. Buildrequires: python-devel >= 2.6.4
  26. Buildrequires: python-setuptools >= 0.6c11
  27. BuildRequires: python-virtualenv
  28. BuildRequires: chkconfig
  29. Requires: shadow-utils
  30. Requires: python >= 2.6.4
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. Packager: owa
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. The Z Object Programming Environment (Zope) is a free, Open Source[tm]
  37. Python-based application server for building high-performance, dynamic
  38. web sites, using a powerful and simple scripting object model and
  39. high-performance, integrated object database.
  40. For a fully functional installation of Zope, install this single huge
  41. package and then the Zope-zserver RPM
  42. %description -l ja
  43. Zオブジェクトプログラミング環境(Zope)はフリーです,オープンソースである
  44. Pythonをベースにした、高性能で動的なWebサイトを構築するためのアプリケー
  45. ションサーバです.強力でしかも単純なスクリプトからなるオブジェクトモデル
  46. と高性能な統合オブジェクトデータベースを使うことができます.
  47. %package zserver
  48. Summary: Initial Object Database/Standalone HTTP Server
  49. Summary(ja): %{name} インスタンス
  50. Group: Development/Web Applications
  51. Requires: %{name}
  52. Requires: /etc/rc.d/init.d
  53. %description zserver
  54. The %{name}-zserver package contains the files needed for setting up a
  55. Zope website, including an empty object database. Zope is an application
  56. server and portal toolkit.
  57. Also included is the ZServer, which is a small, standalone web server
  58. written in Python. The ZServer uses the very fast Medusa technology
  59. and is multithreaded. This package comes preconfigured to serve
  60. web pages on port %{sv_http_port} and ftp access on %{sv_ftp_port}. The programmer's port
  61. interface comes disabled for security reasons but can be reenabled.
  62. %description -l ja zserver
  63. %{name}-zserver パッケージは Zope web サイトをセットアップするのに必要な
  64. ファイルを含んでいます,そこには空のオブジェクトデータベースも含みます.
  65. Zope はアプリケーションサーバであり,Webサイト構築のためのツール集です.
  66. また Python で書かれた小さなスタンドアロン Web サーバである ZServer も
  67. 含まれています. ZServer は非常に高速な Medusa の技術を利用し,マルチス
  68. レッド化されています.このパッケージでは Web ページを %{sv_http_port} ポート, FTP
  69. アクセスを %{sv_ftp_port} でサービスするようにあらかじめ設定してあります.セキュ
  70. リティ上の理由のため,プログラマ用ポートインタフェースは使用できないよ
  71. うになっていますが,再び利用できるように戻すことが可能です.
  72. 初期ユーザは "%{sv_admin}" パスワードは "%{sv_password}" に設定されています。
  73. 初回の起動直後にこれらは変更すべきです。
  74. %prep
  75. %setup -T -c %{name}-%{version}
  76. (cd $RPM_BUILD_DIR; virtualenv --no-site-packages --unzip-setuptools %{name}-%{version})
  77. ## for normal build: include stable-req.txt and Zope2-modules.%{zope2_updates}.tgz
  78. %if %{checkout_new_modules} == 0
  79. cp %{SOURCE10} .
  80. tar xvzf %{SOURCE11} > /dev/null
  81. tar xvzf %{SOURCE0} -C build > /dev/null
  82. mv build/%{name}-%{version} build/%{name}
  83. %endif
  84. %build
  85. source bin/activate
  86. export PIP_REQUIRE_VIRTUALENV=true
  87. ## normal build: don't allow downloads
  88. %if %{checkout_new_modules} == 0
  89. bin/pip install --no-download --log=pip_install.log -r stable-req.txt
  90. ## upgrade build: upgrade all packages to the newest available version
  91. %else
  92. cp %{SOURCE0} .
  93. bin/pip install %{name}-%{version}.tar.gz
  94. bin/easy_install %{name}-%{version}.tar.gz Zope2
  95. bin/pip freeze > stable-req.txt
  96. bin/pip install -I --no-install --log=pip_download.log -r stable-req.txt
  97. savedate=`date '+%Y%m%d'`
  98. tar cvzf Zope2-modules.$savedate.tgz build
  99. %endif
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. %{__install} -d $RPM_BUILD_ROOT%{zope2_libdir}
  103. %{__install} -d $RPM_BUILD_ROOT%{zope2_libdir}/bin
  104. %{__install} -m 755 bin/* $RPM_BUILD_ROOT%{zope2_libdir}/bin
  105. cp -a lib $RPM_BUILD_ROOT%{zope2_libdir}
  106. (cd $RPM_BUILD_ROOT%{zope2_libdir}; ln -s ./lib lib64)
  107. ## make zope server instance
  108. bin/mkzopeinstance -d $RPM_BUILD_ROOT%{instance_home} -u %{sv_admin}:%{sv_password}
  109. ## make zeo server instance (failed now: fix me!)
  110. #bin/mkzeoinstance $RPM_BUILD_ROOT%{instance_home}
  111. ## put init script
  112. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  113. install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
  114. ## put system config, logs
  115. install -d $RPM_BUILD_ROOT%{zope2_confdir}
  116. (cd $RPM_BUILD_ROOT%{zope2_confdir}; ln -sf %{instance_home}/etc/site.zcml)
  117. (cd $RPM_BUILD_ROOT%{zope2_confdir}; ln -sf %{instance_home}/etc/zope.conf)
  118. install -d $RPM_BUILD_ROOT%{_var}/log
  119. (cd $RPM_BUILD_ROOT%{_var}/log; ln -sf %{instance_home}/log %{name})
  120. ## remove unused files
  121. find $RPM_BUILD_ROOT/ -name "*.pyc" | xargs rm
  122. ## change python paths
  123. pushd $RPM_BUILD_ROOT%{zope2_libdir}/bin
  124. for s in `ls` ; do
  125. if ! file -s -e elf $s | grep -s ELF ; then
  126. sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|" $s
  127. fi
  128. done
  129. popd
  130. pushd $RPM_BUILD_ROOT%{zope2_libdir}/lib
  131. find ./ -name "*.py" | xargs sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|"
  132. popd
  133. pushd $RPM_BUILD_ROOT%{instance_home}/bin
  134. sed -i "s|$RPM_BUILD_ROOT||" runzope
  135. sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|" runzope
  136. sed -i "s|$RPM_BUILD_ROOT||" zopectl
  137. sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|" zopectl
  138. popd
  139. ## update zope.conf
  140. pushd $RPM_BUILD_ROOT%{instance_home}/etc
  141. cp -p zope.conf zope.conf.orig
  142. sed "s|$RPM_BUILD_ROOT||" zope.conf.orig \
  143. | sed 's|^#.*effective-user chrism.*$|effective-user %{name}|' \
  144. | sed 's|^#.*rest-input-encoding iso-8859-15.*$|rest-input-encoding utf-8|' \
  145. | sed 's|^#.*rest-output-encoding iso-8859-15.*$|rest-output-encoding utf-8|' \
  146. | sed 's|address 8080|address %{sv_http_port}|' \
  147. | sed 's|address 8021|address %{sv_ftp_port}|' \
  148. > zope.conf
  149. rm -f zope.conf.orig
  150. popd
  151. %clean
  152. rm -rf $RPM_BUILD_ROOT
  153. %pre zserver
  154. if [ "$1" = 1 ] ; then
  155. %{__grep} "%{name}:" /etc/group > /dev/null 2>&1
  156. if [ $? == 0 ]; then
  157. /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} -g %{name} \
  158. %{name} > /dev/null 2>&1 || :
  159. else
  160. /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} \
  161. %{name} > /dev/null 2>&1 || :
  162. fi
  163. fi
  164. %post zserver
  165. if [ "$1" = 1 ] ; then
  166. /sbin/chkconfig --add %{name}
  167. /etc/rc.d/init.d/%{name} start
  168. else
  169. mv %{instance_home}/inituser %{instance_home}/inituser.admin
  170. /etc/rc.d/init.d/%{name} condrestart
  171. fi
  172. %preun zserver
  173. if [ "$1" = 0 ] ; then
  174. /etc/rc.d/init.d/%{name} stop > /dev/null 2>&1
  175. /sbin/chkconfig --del %{name}
  176. fi
  177. %postun zserver
  178. if [ "$1" = 0 ] ; then
  179. /usr/sbin/userdel %{name} > /dev/null 2>&1 || :
  180. fi
  181. %files
  182. %defattr(-, root, root)
  183. %dir %{zope2_libdir}
  184. %{zope2_libdir}/bin
  185. %{zope2_libdir}/lib
  186. %{zope2_libdir}/lib64
  187. %files zserver
  188. %defattr(-, root, root)
  189. %config %{_sysconfdir}/rc.d/init.d/%{name}
  190. %config %{zope2_confdir}/site.zcml
  191. %config %{zope2_confdir}/zope.conf
  192. %{_var}/log/%{name}
  193. %defattr(700, %{name}, %{name})
  194. %dir %{instance_home}
  195. %dir %{instance_home}/Extensions
  196. %dir %{instance_home}/Products
  197. %dir %{instance_home}/bin
  198. %dir %{instance_home}/etc
  199. %dir %{instance_home}/import
  200. %dir %{instance_home}/lib
  201. %dir %{instance_home}/lib/python
  202. %dir %{instance_home}/log
  203. %defattr(1703, %{name}, %{name})
  204. %dir %{instance_home}/var
  205. %attr(600, %{name}, %{name})
  206. %{instance_home}/inituser
  207. %defattr(-, %{name}, %{name})
  208. %{instance_home}/Products/__init__.py
  209. %{instance_home}/bin/runzope
  210. %{instance_home}/bin/zopectl
  211. %{instance_home}/import/ZopeTutorialExamples.zexp
  212. %config %{instance_home}/etc/site.zcml
  213. %config %{instance_home}/etc/zope.conf
  214. #%{instance_home}/bin/runzeo
  215. #%{instance_home}/bin/zeoctl
  216. #%config %{instance_home}/etc/zeo.conf
  217. %exclude %{instance_home}/README.txt
  218. %exclude %{instance_home}/*/README.txt
  219. %exclude %{instance_home}/lib/python/README.txt
  220. %exclude %{instance_home}/bin/runzope.bat
  221. %exclude %{instance_home}/bin/zopectl.bat
  222. %changelog
  223. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> Zope2-2.12.3-2
  224. - rebuild with python-2.7.2
  225. * Sun Dec 05 2010 Shu KONNO <owa@bg.wakwak.com> Zope2-2.12.3-1
  226. - updated zope to 2.12.3
  227. - changed package name to Zope2
  228. - use virtualenv and easy_install to build
  229. - added checkout_new_modules macro (0:no-download, 1:download new modules)
  230. - added stable-req.txt
  231. - added Zope2-modules.20101124.tgz
  232. * Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.7-1
  233. - updated zope to 2.11.7-final
  234. * Thu Jan 14 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.6-1
  235. - updated zope to 2.11.6-final
  236. * Thu Dec 24 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.5-1
  237. - updated zope to 2.11.5-final
  238. * Thu Aug 06 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.4-1
  239. - updated zope to 2.11.4-final
  240. * Sun May 03 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.3-1vl5
  241. - updated zope to 2.11.3-final
  242. * Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.2-1vl5
  243. - updated zope to 2.11.2-final
  244. - dropt Hotfix_20080812.tar.gz
  245. * Wed Aug 13 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-3vl5
  246. - added Hotfix_20080812.tar.gz
  247. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-2vl5
  248. - rebuilt with python-2.5.2
  249. * Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-1vl5
  250. - updated zope to 2.11.1-final
  251. * Tue Jul 01 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.0-1vl5
  252. - updated zope to 2.11.0-final
  253. * Mon Jun 09 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.6-1vl5
  254. - applied new versioning policy and spec in utf-8
  255. - updated zope to 2.10.6-final
  256. * Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl2
  257. - fixed prereq, buildrequires pkgs
  258. * Tue Oct 30 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl1
  259. - updated zope to 2.10.5-final
  260. - updated Requires python >= 2.4.4
  261. * Thu Aug 23 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.4-0vl1
  262. - updated zope to 2.10.4-final
  263. - updated %%install scripts
  264. - dropped Hotfix_20070320.tgz
  265. * Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.2-0vl1
  266. - updated zope to 2.10.2
  267. - added Hotfix_20070320.tgz
  268. * Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl3
  269. - added japanese summary
  270. * Fri Oct 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl2
  271. - updated zope to 2.9.5-final
  272. * Thu Jul 20 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.4-0vl1
  273. - updated zope to 2.9.4
  274. - dropped Hotfix_20060705.tar.gz
  275. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl2
  276. - added Hotfix_20060705.tar.gz
  277. * Fri May 12 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl1
  278. - updated zope to 2.9.3
  279. * Tue Mar 28 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.2-0vl1
  280. - updated zope to 2.9.2
  281. * Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.1-0vl1
  282. - updated zope to 2.9.1
  283. - x86_64 architecture support
  284. * Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.0-0vl1
  285. - updated zope to 2.9.0
  286. * Thu Oct 27 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.4-0vl1
  287. - updated zope to 2.8.4-final
  288. * Wed Oct 19 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.3-0vl1
  289. - updated zope to 2.8.3-final
  290. * Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.2-0vl1
  291. - updated zope to 2.8.2-final
  292. * Mon Oct 10 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl2
  293. - added Hotfix_2005-10-09.tar.gz (security)
  294. * Thu Aug 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl1
  295. - updated zope to 2.8.1-final
  296. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.0-0vl1
  297. - updated zope to 2.8.0-final
  298. * Sun May 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl2
  299. - updated init.sh (added condrestart)
  300. - updated spec 'post zserver section'
  301. * Fri Apr 29 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl1
  302. - updated zope to 2.7.6-final
  303. * Wed Apr 06 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl4
  304. - added Hotfix_20050405.tar.gz
  305. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl2
  306. - rebuilded with python 2.4.1
  307. * Sun Mar 20 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl1
  308. - updated zope to 2.7.5-final
  309. * Fri Mar 18 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl0.c1
  310. - updated zope to 2.7.5-rc1
  311. * Sat Jan 15 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl2
  312. - updated zope to 2.7.4-0
  313. * Sat Jan 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.c2
  314. - updated zope to 2.7.4-RC2
  315. * Thu Dec 16 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.b2
  316. - updated zope to 2.7.4-b2
  317. * Sun Oct 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl1
  318. - updated zope to 2.7.3
  319. * Mon Oct 11 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.2
  320. - updated zope to 2.7.3b2
  321. * Sun Sep 26 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.1
  322. - updated zope to 2.7.3b1
  323. - droped Hotfix-20040807.tar.gz
  324. * Tue Aug 10 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl2
  325. - added Hotfix-20040807.tar.gz
  326. * Wed Jul 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl1
  327. - updated zope to 2.7.2
  328. * Thu Jul 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl3
  329. - droped Hotfix_2004-07-13.tar.gz
  330. - added Hotfix_2004-07-14.tar.gz
  331. * Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl2
  332. - added Hotfix_2004-07-13.tar.gz
  333. * Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl1
  334. - updated zope to 2.7.1
  335. - added option with '--no-compile' to configure at the %build section
  336. - added to compile at the %post section
  337. * Sat Apr 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.0-0vl1
  338. - build with python-2.3.3-0vl1
  339. - added 'Obsoletes: Zope27'
  340. * Tue Mar 02 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl3
  341. - changed init.sh to use zopectl
  342. * Tue Feb 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl1
  343. - updated zope to 2.7.0
  344. - rewrited spec file
  345. * Sun Feb 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.4-0vl1
  346. - updated zope to 2.6.4
  347. * Fri Jan 9 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.3-0vl1
  348. - updated zope to 2.6.3
  349. * Wed Sep 10 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2-0vl1
  350. - updated zope to 2.6.2
  351. * Fri Aug 29 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b6-0vl1
  352. - updated zope to 2.6.2b6
  353. * Thu Jul 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl2
  354. - rebuild with python-2.2.3
  355. * Wed Jul 30 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl1
  356. - updated zope to 2.6.2b5
  357. * Sat Jul 19 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b4-0vl1
  358. - updated zope to 2.6.2b4
  359. * Sat Jul 12 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b3-0vl1
  360. - updated zope to 2.6.2b3
  361. * Sat May 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b2-0vl1
  362. - updated zope to 2.6.2b2
  363. - fixed many important bugs
  364. * Sun Apr 13 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1-0vl1
  365. - updated zope to 2.6.1
  366. - changed 'Requires: python >= 2.2.2'
  367. - japanese patch below has been included in zope 2.6.1
  368. * Thu Jan 16 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1b1-0vp1
  369. - updated zope to 2.6.1b1
  370. - added Zope261b.patch (by fukamachi, nakagami, tahara)
  371. - changed option parameter with -Z in startup script
  372. - added command 'umask 077' in startup script
  373. - added option -D in startup script that logout debug infomation
  374. - added 'chown root', 'chmod o+t' script in %%post section
  375. - this is a experimental release!!
  376. * Fri Oct 4 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl3
  377. Security fix for XML-RPC handling (by tahara)
  378. * Fri Jun 21 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl2
  379. added Hotfix_2002-06-14.tgz
  380. * Sat Jun 15 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl1
  381. modified for Vine
  382. * Sat May 18 2002 Adam Manock <abmanock@earthlink.net>
  383. Completely reworked the spec for Zope 2.5.1
  384. PCGI is no longer built by default.
  385. Build now simply wraps up the default "wo_pcgi" build, creating 2 packages.
  386. (This will make it trivial to upgrade the spec for new Zope versions.)
  387. Logging via syslog is now turned off by default. See the RPM-README
  388. * Wed Nov 14 2001 Jeff Rush <jrush@taupro.com>
  389. bumped to zope 2.4.3.
  390. * Sat Nov 10 2001 Jeff Rush <jrush@taupro.com>
  391. changed args to useradd, to work with Red Hat 7.2.
  392. * Sun Oct 21 2001 Jeff Rush <jrush@taupro.com>
  393. bumped to zope 2.4.2, removed Hotfix 2001-09-28.
  394. * Thu Oct 18 2001 Jeff Rush <jrush@taupro.com>
  395. Fixed broken syslogging facility and added Hotfix 2001-09-28.
  396. * Mon Sep 04 2001 Jeff Rush <jrush@taupro.com>
  397. bumped to zope 2.4.1, removed Hotfix 2001-08-04.
  398. * Mon Aug 15 2001 Jeff Rush <jrush@taupro.com>
  399. bumped to zope 2.4.0, changed to use python2.1, added Hotfix 2001-08-04.
  400. Merged in Jun 29 2001 patch from Durval Menezes re support for ZPatterns:
  401. "No longer removes cPersistence.h from lib/python/ZODB before installing
  402. (this is needed to compile DynPersist, as part of the ZPatterns
  403. installation. Installs ExtensionClass.h into /usr/include/python2.1
  404. (it too is needed to compile DynPersist, as part of the ZPatterns install)"
  405. Merged in Jun 12 2001 additions from Jared Kelsey <jared@dolphinsearch.com>
  406. to make more compatible with future releases of python.
  407. * Mon Aug 14 2001 Jeff Rush <jrush@taupro.com>
  408. bumped to zope 2.3.3, added Hotfix 2001-08-04.
  409. * Mon May 07 2001 Jeff Rush <jrush@taupro.com>
  410. bumped to zope 2.3.2, added Hotfix 2001-05-01, revised access
  411. file permissions (600->640) and ownership (root.root->root.zope)
  412. to fix the "can't log in" bug under ZServer subpackage.
  413. * Sat Mar 31 2001 Jeff Rush <jrush@taupro.com>
  414. bumped to zope 2.3.1
  415. * Mon Jan 29 2001 Jeff Rush <jrush@taupro.com>
  416. bumped to zope 2.3.0; removed obsolete Hotfixes.
  417. * Fri Dec 08 2000 Jeff Rush <jrush@taupro.com>
  418. bumped to zope 2.2.4; removed obsolete Hotfixes.
  419. * Fri Nov 03 2000 Jeff Rush <jrush@taupro.com>
  420. fixed misplaced SiteAccess, where dirs in tar moved btw v1 and v2.
  421. * Sun Oct 16 2000 Jeff Rush <jrush@taupro.com>
  422. bumped to zope 2.2.2; added Hotfixes 2000-10-02 and 2000-10-11.
  423. * Sun Aug 27 2000 Jeff Rush <jrush@taupro.com>
  424. bumped to zope 2.2.1; removed no-longer-needed Hotfix_2000-08-17
  425. * Tue Aug 22 2000 Jeff Rush <jrush@taupro.com>
  426. - added Hotfix_2000-08-17
  427. - temporarily removed /etc/init.d (RH7.0) until I figure out how
  428. to support both RH6.x *and* RH7.0 in the same RPM. <sigh>
  429. - removed troublesome/obsolete ComputedAttribute.py
  430. * Sun Jul 16 2000 Jeff Rush <jrush@taupro.com>
  431. - bumped to zope 2.2.0; removed no-longer-needed Hotfix-06_16_2000
  432. * Thu Jul 06 2000 Tim Powers <timp@redhat.com>
  433. - fixed PreReq to PreReq /etc/init.d
  434. - added Hotfix-06_16_2000
  435. * Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
  436. - moved init script, added condrestart directive
  437. - auto stop/restart service on upgrades
  438. * Thu Jun 1 2000 Tim Powers <timp@redhat.com>
  439. - fixed so that it's no longer putting files into /home, instead they are
  440. going into /var/www (FHS compliant).
  441. * Mon May 22 2000 Tim Powers <timp@redhat.com>
  442. - built for 7.0, thanks Jeff!
  443. * Fri Apr 28 2000 Jeff Rush <jrush@taupro.com>
  444. - bumped to zope 2.1.6
  445. * Sun Mar 12 2000 Jeff Rush <jrush@taupro.com>
  446. - added zpasswd.py back in, since my rename to just zpasswd confused some.
  447. both are now present in the RPM, for all audiences.
  448. - modified the README.RPM re the section about Apache rewrite rules; I
  449. discussed and removed the trailing slash, the presence of which causes
  450. Zope to reject attempts to delete objects in the root folder.
  451. * Thu Feb 26 2000 Jeff Rush <jrush@taupro.com>
  452. - 2.1.4-1 Release on Zope.org site
  453. - bumped to zope 2.1.4
  454. - changed Zope-core to provide 'Zope', to satisfy zserver and pcgi subpkgs.
  455. * Fri Jan 14 2000 Tim Powers <timp@redhat.com>
  456. - added Provides lines to Zope-pcgi and Zope-zserver so that addon packages
  457. such as Squishdot have something useful to require.
  458. * Thu Jan 13 2000 Tim Powers <timp@redhat.com>
  459. - built for Powertools 6.2
  460. * Thu Jan 11 2000 Jeff Rush <jrush@taupro.com>
  461. - bumped to zope 2.1.2
  462. - folded in Jonathan Marsden <jonathan@xc.org> Changes (many below)
  463. - used zpasswd.py to generate initial pw in encrypted form.
  464. - fixed syslog logging in various ways, and re-enabled it, for both
  465. - ZServer AND pcgi-wrapper.
  466. - fixed /etc/rc.d/init.d/zope to be consistent about pid file.
  467. - fixed /etc/rc.d/init.d/zope to use RH killproc function.
  468. - added 'noreplace' so that Zope database and access file are retained
  469. - on an RPM upgrade.
  470. - patched PCGI to support syslog logging, and then default to it.
  471. - patched ZServer/Medusa to properly support syslog logging.
  472. - added a user 'zope' and made many zope files/dirs owned by it.
  473. - cleaned up pcgi-wrapper's msg about can't find ZServer, since it is
  474. - one of the most common errors. It now explains what it is doing.
  475. - moved all *.{pid,soc} files into /var/run, to cleanly separate ownership
  476. - issues in /var/zope hierarchy for user 'zope' and user 'nobody'.
  477. * Mon Jan 03 2000 Jeff Rush <jrush@taupro.com>
  478. - bumped to zope 2.1.1
  479. - added to /etc/rc.d/init.d/zope code to correctly kill the process specified
  480. - in /var/zope/pcgi.pid
  481. - changed permissions on /var/zope/access such that only root can read/write
  482. - it, to protect the Zope superuser password.
  483. * Sat Nov 29 1999 Jeff Rush <jrush@taupro.com>
  484. - changed ownership on /var/zope/access from nobody.nobody to root.root.
  485. * Sat Nov 20 1999 Jeff Rush <jrush@taupro.com>
  486. - updated to zope 2.1.0beta2
  487. - fixed permissions/ownership on /var/zope/access to be more secure (600).
  488. - removed pypath.patch, as those changes got into the zope distribution.
  489. * Tue Nov 2 1999 Jeff Rush <jrush@taupro.com>
  490. - added accidentally omitted /usr/bin/zpasswd to the RPM output.
  491. - clarified wording re use of zpasswd in README.RPM file.
  492. - added "-u nobody" to both zserver_*.sh files, for clarity of intent;
  493. - it already ran as nobody by default, but some people worried.
  494. * Wed Oct 27 1999 Jeff Rush <jrush@taupro.com>
  495. - fixed /etc/rc.d/init.d/zope file to *NOT* delete /var/zope/zserver.pid
  496. - fixed /var/zope/Zope.cgi to use PCGI_PUBLISHER=/var/zope/pcgi_nullpublisher.py,
  497. - so that when the PCGI wrapper can't find ZServer, it won't try to start one
  498. - and generate bogus error messages, because PCGI doesn't do it right.
  499. - fixed /var/zope/zserver.sh to NOT specify syslog-style logging, since under
  500. - Red Hat 6.1, the syslog daemon no longer listens to the port we expected.
  501. * Sat Sep 25 1999 Jeff Rush <jrush@taupro.com>
  502. - updated documents ZCMG, ZSQL and ZDTML to Sep 24th 1999 versions
  503. - added empty directories /var/zope/{import,Extensions}
  504. - relocated zope from /usr/lib/python1.5/site-packages/ZopeWorld/
  505. - to /usr/share/zope/
  506. - added user zope, for better security control
  507. * Fri Sep 17 1999 Jeff Rush <jrush@taupro.com>
  508. - updated sources to minor (security fix) release 2.0.1
  509. * Fri Sep 10 1999 Jeff Rush <jrush@taupro.com>
  510. - heavily reworked spec file for 2.0.0
  511. * Thu Sep 9 1999 Tim Powers <timp@redhat.com>
  512. - updated sources to 2.0.0
  513. - _major_ spec file cleanups
  514. - merged patch from src.rpm authored by Andreas Kostyrka <andreas@mtg.co.at>
  515. - borrowed some things from Andreas Kostyrka's spec file
  516. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  517. - changed groups
  518. * Tue Aug 17 1999 Tim Powers <timp@redhat.com>
  519. - chown permissions on some files in /var/local for the pcgi package
  520. * Mon Aug 2 1999 Tim Powers <timp@redhat.com>
  521. - changed buildroot to be in /var/tmp instead of /tmp
  522. - rebuilt for 6.1
  523. * Mon Jul 21 1999 Jeff Rush <jrush@taupro.com>
  524. - Added in accidently omitted SearchIndex/{Query,Splitter}.so
  525. * Tue Jul 6 1999 Tim Powers <timp@redhat.com>
  526. - started changelog
  527. - cleaned up spec file
  528. - built for powertools
  529. * Mon Jun 24 1999 Jeff Rush <jrush@taupro.com>
  530. - Updated to 1.10.3
  531. * Mon Jun 23 1999 Jeff Rush <jrush@taupro.com>
  532. - Added /etc/rc.d/init.d/zope and reworked scripts
  533. * Tue Mar 1 1999 Jeff Rush <jrush@taupro.com>
  534. - Updated to 1.10.2
  535. * Wed Jan 29 1999 Jeff Rush <jrush@taupro.com>
  536. - Updated to 1.9.0 Final Release
  537. * Wed Dec 9 1998 Jeff Rush <jrush@taupro.com>
  538. - Original 1.9beta1 Release