libpwquality-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. Summary: A library for password generation and password quality checking
  2. Name: libpwquality
  3. Version: 1.4.2
  4. Release: 2%{?_dist_release}
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. # The package is BSD licensed with option to relicense as GPLv2+
  9. # - this option is redundant as the BSD license allows that anyway.
  10. License: BSD or GPLv2+
  11. URL: https://fedorahosted.org/libpwquality/
  12. Source0: https://github.com/libpwquality/libpwquality/releases/download/libpwquality-%{version}/libpwquality-%{version}.tar.bz2
  13. %global _moduledir /%{_lib}/security
  14. %global _secconfdir %{_sysconfdir}/security
  15. Requires: cracklib-dicts >= 2.8
  16. Requires: pam
  17. BuildRequires: cracklib
  18. BuildRequires: gettext
  19. BuildRequires: pam-devel
  20. BuildRequires: python-rpm-macros
  21. BuildRequires: python-devel
  22. BuildRequires: python2-rpm-macros
  23. BuildRequires: python3-devel
  24. BuildRequires: python3-rpm-macros
  25. # we don't want to provide private python extension libs
  26. %define __provides_exclude_from ^(%{python_sitearch}|%{python3_sitearch})/.*\.so$.
  27. %description
  28. This is a library for password quality checks and generation
  29. of random passwords that pass the checks.
  30. This library uses the cracklib and cracklib dictionaries
  31. to perform some of the checks.
  32. %package devel
  33. Summary: Files needed for developing PAM-aware applications and modules for PAM
  34. Group: programming
  35. Requires: libpwquality = %{version}-%{release}
  36. Requires: pkgconfig
  37. %description devel
  38. Files needed for development of applications using the libpwquality
  39. library.
  40. See the pwquality.h header file for the API.
  41. %package -n python-pwquality
  42. Summary: Python bindings for the libpwquality library
  43. Group: programming
  44. Requires: libpwquality = %{version}-%{release}
  45. %description -n python-pwquality
  46. This is pwquality Python module that provides Python bindings
  47. for the libpwquality library. These bindings can be used
  48. for easy password quality checking and generation of random
  49. pronounceable passwords from Python applications.
  50. %package -n python3-pwquality
  51. Summary: Python bindings for the libpwquality library
  52. Group: programming
  53. Requires: libpwquality = %{version}-%{release}
  54. %description -n python3-pwquality
  55. This is pwquality Python module that provides Python bindings
  56. for the libpwquality library. These bindings can be used
  57. for easy password quality checking and generation of random
  58. pronounceable passwords from Python applications.
  59. %prep
  60. %setup -q
  61. rm -rf %{py3dir}
  62. cp -a . %{py3dir}
  63. %build
  64. %configure \
  65. --with-securedir=%{_moduledir} \
  66. --with-pythonsitedir=%{python2_sitearch} \
  67. --with-python-binary=%{__python2} \
  68. --disable-static
  69. make %{?_smp_mflags}
  70. pushd %{py3dir}
  71. %configure \
  72. --with-securedir=%{_moduledir} \
  73. --with-pythonsitedir=%{python3_sitearch} \
  74. --with-python-binary=%{__python3} \
  75. --disable-static
  76. make %{?_smp_mflags}
  77. popd
  78. %install
  79. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  80. pushd %{py3dir}
  81. make -C python install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  82. popd
  83. pushd $RPM_BUILD_ROOT%{_libdir}
  84. mv libpwquality.so.* $RPM_BUILD_ROOT/%{_lib}/
  85. ln -sf ../../%{_lib}/libpwquality.so.*.* libpwquality.so
  86. popd
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  88. rm -f $RPM_BUILD_ROOT%{_moduledir}/*.la
  89. mkdir $RPM_BUILD_ROOT%{_secconfdir}/pwquality.conf.d
  90. %find_lang libpwquality
  91. %check
  92. # Nothing yet
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files -f libpwquality.lang
  96. %defattr(-,root,root,-)
  97. %{!?_licensedir:%global license %%doc}
  98. %license COPYING
  99. %doc README NEWS AUTHORS
  100. %{_bindir}/pwmake
  101. %{_bindir}/pwscore
  102. %{_moduledir}/pam_pwquality.so
  103. /%{_lib}/libpwquality.so.*
  104. %config(noreplace) %{_secconfdir}/pwquality.conf
  105. %{_mandir}/man1/*
  106. %{_mandir}/man5/*
  107. %{_mandir}/man8/*
  108. %files devel
  109. %defattr(-,root,root,-)
  110. %{_includedir}/pwquality.h
  111. %{_libdir}/libpwquality.so
  112. %{_libdir}/pkgconfig/*.pc
  113. %{_mandir}/man3/*
  114. %files -n python-pwquality
  115. %defattr(-,root,root,-)
  116. %{python2_sitearch}/pwquality.so
  117. %{python2_sitearch}/*.egg-info
  118. %files -n python3-pwquality
  119. %defattr(-,root,root,-)
  120. %{python3_sitearch}/*.so
  121. %{python3_sitearch}/*.egg-info
  122. %changelog
  123. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-2
  124. - rebuilt with python-3.8.
  125. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
  126. - new upstream release.
  127. - dropped Patch1: fixed in upstream.
  128. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.0-1
  129. - new upstream release.
  130. - added python3 support.
  131. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  132. - new upstream release
  133. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  134. - new upstream release
  135. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-2
  136. - rebuild with VineSeed environment
  137. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  138. - new upstream release
  139. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  140. - initial build for Vine Linux
  141. * Thu Aug 16 2012 Tomas Mraz <tmraz@redhat.com> 1.2.0-1
  142. - add maxsequence check for too long monotonic character sequence.
  143. - clarified alternative licensing to GPLv2+.
  144. - add local_users_only option to skip the pwquality checks for
  145. non-locals. (thanks to Stef Walter)
  146. * Wed Jun 13 2012 Tomas Mraz <tmraz@redhat.com> 1.1.1-1
  147. - use rpm built-in filtering of provides (rhbz#830153)
  148. - remove strain debug fprintf() (rhbz#831567)
  149. * Thu May 24 2012 Tomas Mraz <tmraz@redhat.com> 1.1.0-1
  150. - fix leak when throwing PWQError exception
  151. - added pkgconfig file
  152. - call the simplicity checks before the cracklib check
  153. - add enforce_for_root option to the PAM module
  154. - updated translations from Transifex
  155. * Thu Dec 8 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0-1
  156. - added a few additional password quality checks
  157. - bugfix in configuration file parsing
  158. * Fri Nov 11 2011 Tomas Mraz <tmraz@redhat.com> 0.9.9-1
  159. - added python bindings and documentation
  160. * Mon Oct 10 2011 Tomas Mraz <tmraz@redhat.com> 0.9-2
  161. - fixes for problems found in review (missing BR on pam-devel,
  162. License field, Source URL, Require pam, other cleanups)
  163. * Mon Oct 3 2011 Tomas Mraz <tmraz@redhat.com> 0.9-1
  164. - first spec file for libpwquality