elogind-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: elogind
  3. Summary: The systemd project's "logind", extracted to a standalone package
  4. Summary(ja): systemdプロジェクトのlogindを単独で動作するようにしたソフトウェア
  5. Version: 246.9.2
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: tomop
  11. License: GPL2/LGPL2.1
  12. URL: https://wiki.gentoo.org/wiki/Elogind
  13. Source0: https://github.com/elogind/elogind/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. Source1: elogind.init
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires: util-linux
  17. Requires: polkit
  18. Requires: dbus
  19. Requires: elogind-libs = %{version}-%{release}
  20. BuildRequires: meson
  21. BuildRequires: ninja
  22. BuildRequires: gperf
  23. BuildRequires: audit-libs-devel
  24. BuildRequires: libacl-devel
  25. BuildRequires: libblkid-devel
  26. BuildRequires: libcap-devel
  27. BuildRequires: libmount-devel
  28. BuildRequires: libxcrypt-devel
  29. BuildRequires: dbus-devel
  30. BuildRequires: eudev-libudev-devel
  31. BuildRequires: glib2-devel
  32. BuildRequires: pam-devel
  33. BuildRequires: pkgconfig
  34. BuildRequires: python3-devel
  35. BuildRequires: libxslt
  36. BuildRequires: docbook-style-xsl
  37. %description
  38. elogind is the systemd project's logind, extracted to a standalone package. It's designed for users who prefer a non-systemd init system, but still want to use popular software such as KDE/Wayland or GNOME that otherwise hard-depends on systemd.
  39. %description -l ja
  40.  eloginは、systemdプロジェクトのlogindを単体で抽出したものです。これは
  41. systemdを利用していないシステム上で、KDE、Wayland、GNOMEのようにsystemd
  42. に強く依存しているソフトウェアを使用したいユーザのために設計されています。
  43. %package libs
  44. Summary: shared libraries for elogind
  45. Summary(ja): eloginのための共有ライブラリファイル
  46. Group: system
  47. %description libs
  48. This package contains shared libraries for elogind
  49. %description libs -l ja
  50.  このパッケージにはeloginを用いた開発のための共有ライブラリファイル
  51. が含まれています。
  52. %package devel
  53. Summary: headers and libraries for elogind
  54. Summary(ja): eloginを用いた開発のためのヘッダ・ライブラリファイル
  55. Group: programming
  56. Requires: elogind-libs = %{version}-%{release}
  57. %description devel
  58. This package contains headers and libraries for elogind
  59. %description devel -l ja
  60.  このパッケージにはeloginを用いた開発のためのヘッダ・ライブラリファイル
  61. が含まれています。
  62. %package -n compat32-elogind-libs
  63. Summary: shared libraries for elogind
  64. Summary(ja): eloginのための共有ライブラリファイル
  65. Group: system
  66. %description -n compat32-elogind-libs
  67. This package contains shared libraries for elogind
  68. %description -n compat32-elogind-libs -l ja
  69.  このパッケージにはeloginを用いた開発のための共有ライブラリファイル
  70. が含まれています。
  71. %debug_package
  72. %prep
  73. %autosetup -p1
  74. %build
  75. export LANG=ja_JP.UTF-8
  76. %meson \
  77. -Dman=true
  78. %meson_build
  79. %install
  80. export LANG=ja_JP.UTF-8
  81. %{__rm} -rf %{buildroot}
  82. %meson_install
  83. install -m755 -d %{buildroot}%{_initdir}
  84. install -m755 %{SOURCE1} %{buildroot}%{_initdir}/%{name}
  85. rm -f %{buildroot}/%{_lib}/libelogind.so
  86. ln -s ../../%{_lib}/libelogind.so.0 %{buildroot}%{_libdir}/libelogind.so
  87. perl -pi -e 's|^libdir=.*$|libdir=%{_libdir}|' %{buildroot}%{_libdir}/pkgconfig/libelogind.pc
  88. rm -rf %{buildroot}%{_datadir}/factory
  89. %find_lang %{name}
  90. %check
  91. export LANG=ja_JP.UTF-8
  92. %meson_test
  93. %clean
  94. %{__rm} -rf %{buildroot}
  95. %pre
  96. if [ $1 -gt 1 ]; then
  97. if [ -e /etc/rc2.d/S03elogind ]; then
  98. /sbin/chkconfig elogind off
  99. touch /tmp/chkconfig-elogind-on
  100. fi
  101. fi
  102. %post
  103. /sbin/chkconfig --add elogind
  104. if [ $1 -eq 1 ]; then
  105. /sbin/chkconfig elogind on
  106. else
  107. if [ -e /tmp/chkconfig-elogind-on ]; then
  108. /sbin/chkconfig elogind on
  109. rm -f /tmp/chkconfig-elogind-on
  110. fi
  111. fi
  112. %preun
  113. if [ $1 -eq 0 ]; then
  114. /sbin/chkconfig elogind off
  115. /sbin/chkconfig --add elogind
  116. fi
  117. %post libs -p /sbin/ldconfig
  118. %postun libs -p /sbin/ldconfig
  119. %files -f %{name}.lang
  120. %defattr(-,root,root)
  121. %license LICENSE*
  122. %doc NEWS README
  123. %config(noreplace) %{_sysconfdir}/elogind/logind.conf
  124. %config(noreplace) %{_sysconfdir}/pam.d/elogind-user
  125. %{_initdir}/elogind
  126. /bin/*
  127. %{_bindir}/*
  128. /lib/elogind
  129. /lib/udev/rules.d/*
  130. /%{_lib}/security/*
  131. %{_datadir}/dbus-1/system-services/*
  132. %{_datadir}/dbus-1/system.d/*
  133. %{_datadir}/polkit-1/actions/*
  134. %dir %{_datadir}/zsh
  135. %{_datadir}/zsh/site-functions/*
  136. %dir %{_datadir}/bash-completion
  137. %dir %{_datadir}/bash-completion/completions
  138. %{_datadir}/bash-completion/completions/*
  139. %{_mandir}/man1/*
  140. %{_mandir}/man5/*
  141. %{_mandir}/man7/*
  142. %{_mandir}/man8/*
  143. %files libs
  144. /%{_lib}/*.so.*
  145. %files devel
  146. %defattr(-,root,root)
  147. %{_libdir}/libelogind.so
  148. %{_includedir}/elogind
  149. %{_libdir}/pkgconfig/libelogind.pc
  150. %{_mandir}/man3/*
  151. %if %{build_compat32}
  152. %files -n compat32-elogind-libs
  153. /%{_lib}/*.so.*
  154. %endif
  155. %changelog
  156. * Sat Feb 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 246.9.2-1
  157. - new upstream release.
  158. - updated Source1.
  159. * Sat May 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-2
  160. - added a initscript.
  161. * Fri May 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-1
  162. - new upstream release.
  163. - dropped Patch0: fixed in upstream.
  164. - added BR:libxcrypt-devel.
  165. - fixed %%post and %%postun scripts.
  166. - added BR:audit-libs-devel.
  167. - added BR:dbus-devel.
  168. - added BR:glib2-devel.
  169. * Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-3
  170. - added compat32-elogind-libs.
  171. * Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-2
  172. - separated libs.
  173. - built manuals.
  174. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-1
  175. - initial build for Vine Linux.