cantor-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. Name: cantor
  2. Summary: Interface for mathematical applications
  3. Version: 4.7.0
  4. Release: 1%{?_dist_release}
  5. License: GPLv2+
  6. Group: Applications/Edutainment
  7. URL: http://edu.kde.org/cantor/
  8. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
  9. ## upstream patches
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: desktop-file-utils
  12. BuildRequires: gcc-gfortran
  13. BuildRequires: kdelibs4-devel >= %{version}
  14. BuildRequires: libspectre-devel
  15. BuildRequires: R libRmath-devel
  16. BuildRequires: soprano-devel
  17. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  18. Conflicts: kdeedu4 < 4.6.50
  19. %description
  20. Cantor is an application to allow you to you use your favorite mathematical applications from within an elegant KDE-integrated worksheet interface. It provides dialogs to assist with common tasks and allows you to share your worksheets with others.
  21. Cantor supports various mathematical applications as backends (provided in external packages):
  22. * KAlgebra
  23. * Maxima Computer Algebra System
  24. * R Project for Statistical Computing (cantor-backend-R)
  25. * Sage Mathematics Software
  26. * Octave
  27. This package is part of the KDE education module.
  28. %package backend-R
  29. Summary: R backend for Cantor
  30. Summary(ja): Cantor の R バックエンド
  31. Group: Applications/Edutainment
  32. Requires: %{name} = %{version}-%{release}
  33. %description backend-R
  34. %{summary}.
  35. %package libs
  36. Summary: Runtime libraries for %{name}
  37. Summary(ja): %{name} のランタイムライブラリ
  38. Group: System Environment/Libraries
  39. Conflicts: kdeedu4-math-libs < 4.6.50
  40. %description libs
  41. %{summary}.
  42. %package devel
  43. Summary: Development files for %{name}
  44. Summary(ja): %{name} の開発用ファイル
  45. Group: Development/Libraries
  46. Requires: %{name}-libs = %{version}-%{release}
  47. Conflicts: kdeedu4-devel < 4.6.50
  48. %description devel
  49. Header files for developing applications using %{name}.
  50. %prep
  51. %setup -q
  52. %build
  53. mkdir -p %{_target_platform}
  54. pushd %{_target_platform}
  55. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  56. %cmake \
  57. -DCMAKE_BUILD_TYPE=release \
  58. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  59. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  60. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  61. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  62. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  63. ..
  64. popd
  65. make %{?_smp_mflags} -C %{_target_platform}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %check
  72. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  73. desktop-file-validate $f
  74. done
  75. %post
  76. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  77. %posttrans
  78. update-desktop-database -q &> /dev/null ||:
  79. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  80. %postun
  81. if [ $1 -eq 0 ] ; then
  82. update-desktop-database -q &> /dev/null ||:
  83. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  84. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  85. fi
  86. %post backend-R
  87. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  88. %posttrans backend-R
  89. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  90. %postun backend-R
  91. if [ $1 -eq 0 ] ; then
  92. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  94. fi
  95. %post libs -p /sbin/ldconfig
  96. %postun libs -p /sbin/ldconfig
  97. %files
  98. %defattr(-,root,root)
  99. %doc COPYING COPYING.DOC
  100. %{_bindir}/cantor
  101. %{_libdir}/libcantor_config.so
  102. %{_libdir}/kde4/*.so
  103. %exclude %{_libdir}/kde4/cantor_rbackend.so
  104. %{_datadir}/applications/kde4/cantor.desktop
  105. %{_datadir}/config/*.knsrc
  106. %exclude %{_datadir}/config/cantor_r.knsrc
  107. %{_datadir}/config.kcfg/*.kcfg
  108. %exclude %{_datadir}/config.kcfg/rserver.kcfg
  109. %{_datadir}/icons/hicolor/*/*/*
  110. %exclude %{_datadir}/icons/hicolor/*/*/rbackend.*
  111. %{_datadir}/kde4/apps/cantor
  112. %{_datadir}/kde4/services/cantor/*.desktop
  113. %exclude %{_datadir}/kde4/services/cantor/rbackend.desktop
  114. %{_datadir}/kde4/servicetypes/cantor_*.desktop
  115. %doc %{_docdir}/HTML/en/cantor/
  116. %files backend-R
  117. %defattr(-,root,root,-)
  118. %{_bindir}/cantor_rserver
  119. %{_libdir}/kde4/cantor_rbackend.so
  120. %{_datadir}/config/cantor_r.knsrc
  121. %{_datadir}/config.kcfg/rserver.kcfg
  122. %{_datadir}/icons/hicolor/*/*/rbackend.*
  123. %{_datadir}/kde4/services/cantor/rbackend.desktop
  124. %files libs
  125. %defattr(-,root,root)
  126. %{_libdir}/libcantorlibs.so.*
  127. %files devel
  128. %defattr(-,root,root)
  129. %{_includedir}/kde4/cantor
  130. %{_libdir}/libcantorlibs.so
  131. %changelog
  132. * Thu Sep 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
  133. - split from kdeedu