libldb-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define talloc_version 2.1.1
  3. %define tdb_version 1.3.4
  4. %define tevent_version 0.9.24
  5. Name: libldb
  6. Summary: A schema-less, ldap like, API and database
  7. Version: 1.1.20
  8. Release: 2%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPLv3+
  11. URL: http://ldb.samba.org/
  12. Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
  13. # Patches
  14. Patch1001: FED01-fix-tevent-check.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libtalloc-devel >= %{talloc_version}
  17. BuildRequires: libtdb-devel >= %{tdb_version}
  18. BuildRequires: libtevent-devel >= %{tevent_version}
  19. BuildRequires: popt-devel
  20. BuildRequires: autoconf
  21. BuildRequires: libxslt
  22. BuildRequires: docbook-style-xsl
  23. BuildRequires: python-devel
  24. BuildRequires: python-tdb
  25. BuildRequires: pytalloc-devel
  26. BuildRequires: python-tevent
  27. BuildRequires: doxygen
  28. Requires: libtalloc >= %{talloc_version}
  29. Requires: libtdb >= %{tdb_version}
  30. Requires: libtevent >= %{tevent_version}
  31. Provides: bundled(libreplace)
  32. Provides: bundled(libtdb_compat)
  33. Provides: bundled(libccan)
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: tomop
  37. %description
  38. An extensible library that implements an LDAP like API to access remote LDAP
  39. servers, or use local tdb databases.
  40. %package -n ldb-tools
  41. Group: Applications/System
  42. Summary: Tools to manage LDB files
  43. Requires: libldb = %{version}-%{release}
  44. %description -n ldb-tools
  45. Tools to manage LDB files
  46. %package devel
  47. Group: Development/Libraries
  48. Summary: Developer tools for the LDB library
  49. Requires: libldb = %{version}-%{release}
  50. Requires: libtdb-devel >= %{tdb_version}
  51. Requires: libtalloc-devel >= %{talloc_version}
  52. Requires: libtevent-devel >= %{tevent_version}
  53. Requires: pkgconfig
  54. %description devel
  55. Header files needed to develop programs that link against the LDB library.
  56. %package -n pyldb
  57. Group: System Environment/Libraries
  58. Summary: Python bindings for the LDB library
  59. Requires: libldb = %{version}-%{release}
  60. Requires: python-tdb >= %{tdb_version}
  61. %description -n pyldb
  62. Python bindings for the LDB library
  63. %package -n pyldb-devel
  64. Group: Development/Libraries
  65. Summary: Development files for the Python bindings for the LDB library
  66. Requires: pyldb = %{version}-%{release}
  67. %description -n pyldb-devel
  68. Development files for the Python bindings for the LDB library
  69. %if %build_compat32
  70. %package -n compat32-%{name}
  71. Summary: A schema-less, ldap like, API and database
  72. Group: System Environment/Libraries
  73. %description -n compat32-%{name}
  74. An extensible library that implements an LDAP like API to access remote LDAP
  75. servers, or use local tdb databases.
  76. %endif
  77. %prep
  78. %setup -q -n ldb-%{version}
  79. %patch1001 -p1
  80. %build
  81. # tdb_compat and ccan have no upstream releases to link against yet and their
  82. # API is in flux. It is unsafe to make them public and shared at this time.
  83. %configure --disable-rpath \
  84. --disable-rpath-install \
  85. --bundled-libraries=NONE \
  86. --builtin-libraries=tdb_compat,ccan,replace \
  87. --with-modulesdir=%{_libdir}/ldb/modules \
  88. --with-privatelibdir=%{_libdir}/ldb
  89. make V=1 %{?_smp_mflags}
  90. doxygen Doxyfile
  91. %install
  92. make install DESTDIR=%{buildroot}
  93. rm -f %{buildroot}%{_libdir}/libldb.a
  94. # Remove _tevent.so (it's managed by python-tevent)
  95. #rm -f %{buildroot}/%{python_sitearch}/_tevent.so
  96. # Shared libraries need to be marked executable for
  97. # rpmbuild to strip them and include them in debuginfo
  98. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  99. # Install API docs
  100. cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
  101. %clean
  102. rm -rf %{buildroot}
  103. %post
  104. /sbin/ldconfig
  105. %postun
  106. /sbin/ldconfig
  107. %post -n pyldb
  108. /sbin/ldconfig
  109. %postun -n pyldb
  110. /sbin/ldconfig
  111. %if %build_compat32
  112. %post -n compat32-%{name}
  113. /sbin/ldconfig
  114. %postun -n compat32-%{name}
  115. /sbin/ldconfig
  116. %endif
  117. %files
  118. %defattr(-,root,root,-)
  119. %dir %{_libdir}/ldb
  120. %{_libdir}/libldb.so.*
  121. %dir %{_libdir}/ldb/modules
  122. %dir %{_libdir}/ldb/modules/ldb
  123. %{_libdir}/ldb/libldb-cmdline.so
  124. %{_libdir}/ldb/modules/ldb/*.so
  125. %files -n ldb-tools
  126. %defattr(-,root,root,-)
  127. %{_bindir}/ldbadd
  128. %{_bindir}/ldbdel
  129. %{_bindir}/ldbedit
  130. %{_bindir}/ldbmodify
  131. %{_bindir}/ldbrename
  132. %{_bindir}/ldbsearch
  133. %{_mandir}/man1/ldbadd.1.*
  134. %{_mandir}/man1/ldbdel.1.*
  135. %{_mandir}/man1/ldbedit.1.*
  136. %{_mandir}/man1/ldbmodify.1.*
  137. %{_mandir}/man1/ldbrename.1.*
  138. %{_mandir}/man1/ldbsearch.1.*
  139. %files devel
  140. %defattr(-,root,root,-)
  141. %{_includedir}/ldb_module.h
  142. %{_includedir}/ldb_handlers.h
  143. %{_includedir}/ldb_errors.h
  144. %{_includedir}/ldb_version.h
  145. %{_includedir}/ldb.h
  146. %{_libdir}/libldb.so
  147. %{_libdir}/pkgconfig/ldb.pc
  148. %{_mandir}/man3/ldb*.gz
  149. %files -n pyldb
  150. %defattr(-,root,root,-)
  151. %{python_sitearch}/ldb.so
  152. %{_libdir}/libpyldb-util.so.1*
  153. %files -n pyldb-devel
  154. %defattr(-,root,root,-)
  155. %{_includedir}/pyldb.h
  156. %{_libdir}/libpyldb-util.so
  157. %{_libdir}/pkgconfig/pyldb-util.pc
  158. %{_mandir}/man*/Py*.gz
  159. %if %build_compat32
  160. %files -n compat32-%{name}
  161. %defattr(-,root,root,-)
  162. %dir %{_libdir}/ldb
  163. %{_libdir}/libldb.so.*
  164. %dir %{_libdir}/ldb/modules
  165. %dir %{_libdir}/ldb/modules/ldb
  166. %{_libdir}/ldb/libldb-cmdline.so
  167. %{_libdir}/ldb/modules/ldb/*.so
  168. %endif
  169. %changelog
  170. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
  171. - added compat32 package.
  172. * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
  173. - new upstream release.
  174. * Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
  175. - new upstream release.
  176. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
  177. - new upstream release.
  178. * Fri Oct 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
  179. - moved libldb and pyldb to System Environment/Libraries Group
  180. - moved ldb-tool to Applications/System Group
  181. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
  182. - new upstream release.
  183. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
  184. - rebuilt with current environment.
  185. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
  186. - new upstream release.
  187. * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
  188. - new upstream release.
  189. * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
  190. - moved libldb-cmdline.so to main package.
  191. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
  192. - fixed dependency.
  193. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
  194. - new upstream release.
  195. - initial build for Vine Linux.
  196. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  198. * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
  199. - New upstream release
  200. - Add ldb_module_error() routine
  201. - Fedora: work around unreliable configure check for pytevent
  202. - Drop patch to ignore --disable-silent-rules (included in tarball)
  203. * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
  204. - Add patch to ignore --disable-silent-rules
  205. * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
  206. - Add explicit mention of the bundled libreplace
  207. - https://fedorahosted.org/fpc/ticket/120
  208. - Add explicit mention of bundled libtdb_compat and libccan
  209. - https://fedorahosted.org/fpc/ticket/119
  210. * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
  211. - Build and install API documentation
  212. - Build tdb_compat and ccan statically. They have no upstream releases to
  213. link against yet and their API is in flux. It is unsafe to make them
  214. public and shared at this time.
  215. * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
  216. - New upstream release
  217. - Required for building newer samba4 packages
  218. * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
  219. - Update to 1.1.0
  220. (dependency for samba4 alpha16 snapshot)
  221. * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
  222. - Update to 1.0.2
  223. (dependency for samba4 alpha15 snapshot)
  224. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
  225. - Disable rpath
  226. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
  227. - New upstream release 1.0.0
  228. - SOname bump to account for module loading changes
  229. - Rename libldb-tools to ldb-tools to make upgrades easier
  230. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
  231. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  232. * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
  233. - Fixes from package review
  234. - Change Requires: on tools subpackage to be the exact version/release
  235. - Remove unnecessary BuildRoot directive
  236. * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
  237. - Update to 0.9.22 (first independent release of libldb upstream)