acl-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: acl
  3. Summary: Access control list utilities
  4. Version: 2.2.52
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Base
  7. License: GPLv2+
  8. URL: http://oss.sgi.com/projects/xfs/
  9. Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
  10. # fix a typo in setfacl(1) man page (#675451)
  11. Patch1: 0001-acl-2.2.49-bz675451.patch
  12. # prepare the test-suite for SELinux and arbitrary umask
  13. Patch3: 0003-acl-2.2.52-tests.patch
  14. # Install the libraries to the appropriate directory
  15. Patch4: 0004-acl-2.2.52-libdir.patch
  16. # fix SIGSEGV of getfacl -e on overly long group name
  17. Patch5: 0005-acl-2.2.52-getfacl-segv.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: gawk
  20. BuildRequires: gettext
  21. BuildRequires: libattr-devel >= 2.4.1
  22. BuildRequires: libtool
  23. Requires: libacl = %{version}-%{release}
  24. %description
  25. This package contains the getfacl and setfacl utilities needed for
  26. manipulating access control lists.
  27. %package -n libacl
  28. Summary: Dynamic library for access control list support
  29. License: LGPLv2+
  30. Group: System Environment/Libraries
  31. Requires(post): /sbin/ldconfig
  32. Requires(postun): /sbin/ldconfig
  33. %description -n libacl
  34. This package contains the libacl.so dynamic library which contains
  35. the POSIX 1003.1e draft standard 17 functions for manipulating access
  36. control lists.
  37. %package -n libacl-devel
  38. Summary: Access control list static libraries and headers.
  39. License: LGPLv2+
  40. Group: Development/Libraries
  41. Requires: libacl = %{version}-%{release}
  42. Requires: libattr-devel
  43. %description -n libacl-devel
  44. This package contains static libraries and header files needed to develop
  45. programs which make use of the access control list programming interface
  46. defined in POSIX 1003.1e draft standard 17.
  47. %if %build_compat32
  48. %package -n compat32-libacl
  49. Summary: Dynamic library for access control list support
  50. License: LGPLv2+
  51. Group: System Environment/Libraries
  52. Requires(post): /sbin/ldconfig
  53. Requires(postun): /sbin/ldconfig
  54. %description -n compat32-libacl
  55. This package contains the libacl.so dynamic library which contains
  56. the POSIX 1003.1e draft standard 17 functions for manipulating access
  57. control lists.
  58. %endif
  59. %prep
  60. %setup -q
  61. %patch1 -p1
  62. %patch3 -p1
  63. %patch4 -p1
  64. %patch5 -p1
  65. %build
  66. touch .census
  67. # acl abuses libexecdir
  68. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  69. make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
  70. %install
  71. rm -rf %{buildroot}
  72. make install DESTDIR=%{buildroot}
  73. make install-dev DESTDIR=%{buildroot}
  74. make install-lib DESTDIR=%{buildroot}
  75. mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
  76. # get rid of libacl.a and libacl.la
  77. rm -f %{buildroot}/%{_lib}/libacl.a
  78. rm -f %{buildroot}/%{_lib}/libacl.la
  79. rm -f %{buildroot}%{_libdir}/libacl.a
  80. rm -f %{buildroot}%{_libdir}/libacl.la
  81. # fix links to shared libs and permissions
  82. rm -f %{buildroot}%{_libdir}/libacl.so
  83. mkdir -p %{buildroot}%{_libdir}
  84. ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
  85. chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
  86. %find_lang %{name}
  87. %check
  88. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  89. make tests || exit $?
  90. if test 0 = `id -u`; then
  91. make root-tests || exit $?
  92. fi
  93. else
  94. echo '*** ACLs are probably not supported by the file system,' \
  95. 'the test-suite will NOT run ***'
  96. fi
  97. %clean
  98. rm -rf %{buildroot}
  99. %post -n libacl
  100. /sbin/ldconfig
  101. %postun -n libacl
  102. /sbin/ldconfig
  103. %if %build_compat32
  104. %post -n compat32-libacl
  105. /sbin/ldconfig
  106. %postun -n compat32-libacl
  107. /sbin/ldconfig
  108. %endif
  109. %files -f %{name}.lang
  110. %defattr(-,root,root)
  111. %doc doc-nover/*
  112. %{_bindir}/chacl
  113. %{_bindir}/getfacl
  114. %{_bindir}/setfacl
  115. %{_mandir}/man1/chacl.1*
  116. %{_mandir}/man1/getfacl.1*
  117. %{_mandir}/man1/setfacl.1*
  118. %{_mandir}/man5/acl.5*
  119. %files -n libacl-devel
  120. %defattr(-,root,root)
  121. /%{_lib}/libacl.so
  122. %{_includedir}/acl
  123. %{_includedir}/sys/acl.h
  124. %{_libdir}/libacl.*
  125. %{_mandir}/man3/acl_*
  126. %files -n libacl
  127. %defattr(-,root,root)
  128. /%{_lib}/libacl.so.*
  129. %if %build_compat32
  130. %files -n compat32-libacl
  131. %defattr(-,root,root,-)
  132. /%{_lib}/libacl.so.*
  133. %endif
  134. %changelog
  135. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
  136. - added compat32 package.
  137. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
  138. - new upstream release.
  139. - replaced patches to the newest rawhide's.
  140. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  141. - updated to 2.2.49
  142. - added Patch2-7 from Fedora
  143. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  144. - add function acl_extended_file_nofollow() (#692982)
  145. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  146. - fix typos in setfacl(1) man page (#675451)
  147. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  148. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  149. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  150. - let acl depend on the same version of libacl (#595674)
  151. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  152. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  153. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  154. - initial build for Vine Linux
  155. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  156. - new upstream version
  157. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  158. - Fixed segfault when using only "--" as parameter
  159. - Resolves: #430458
  160. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  161. - Fixed setfacl exitcodes
  162. - Resolves: #368451
  163. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  164. - New version
  165. - dropped walk patch
  166. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  167. - Rewriten path_max patch to support long UTF8 names
  168. - Resolves #287701, #183181
  169. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  170. - Removed NFS4 ACL patch since it was rejected by upstream.
  171. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  172. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  173. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  174. - Build Require gawk
  175. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  176. - Rebuild for selinux ppc32 issue.
  177. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  178. - Added NFS v4 ACL support
  179. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  180. - Updated man page for getfacl
  181. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  182. - Added support fort short params to getfacl
  183. - Resolves: #204087
  184. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  185. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  186. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  187. - fix buildroot
  188. - remove trailing dot from summary
  189. - -devel requires same version of libacl
  190. - escape macro in changelog
  191. - make .so symlink relative
  192. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  193. - Apply patch to make order consistent.
  194. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  195. - rebuild
  196. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  197. - new version 2.2.39
  198. - fixed usage of long UTF-8 filenames (#183181)
  199. Thanks to Andrey for the initial patch.
  200. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  201. - rebuild for -devel deps
  202. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  203. - bump again for double-long bug on ppc(64)
  204. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  205. - rebuilt for new gcc4.1 snapshot and glibc changes
  206. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  207. - new version 2.2.34
  208. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  209. - rebuilt
  210. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  211. - fixed permissions of libacl
  212. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  213. - spec file cleanup
  214. - mark po files as lang specific
  215. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  216. - 2.2.32
  217. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  218. - update to 2.2.31
  219. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  220. - get rid of *.la files
  221. - remove duplicate doc files
  222. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  223. - Rebuild
  224. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  225. - make the libs executable so that we find their dependencies (#132696)
  226. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  227. - libacl-devel Requires: libattr-devel for libattr.la
  228. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  229. - Requires libtool >= 1.5 for building
  230. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  231. - Make libacl.so.* executable.
  232. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  233. - Update to latest upstream version.
  234. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  235. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  236. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  237. - rebuilt
  238. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  239. - Add missing %%defattr
  240. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  241. - Add /usr/include/acl to files manifest
  242. - Fix location of doc files, add main doc dir to files manifest
  243. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  244. - rebuilt
  245. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  246. - rebuilt
  247. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  248. - Fix libtool invocation
  249. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  250. - Update to acl-2.2.7
  251. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  252. - include patch from Jay Berkenbilt to print better error messages
  253. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  254. - udpate/rebuild
  255. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  256. - set execute bits on library so that requires are generated.
  257. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  258. - Correct patch in previous fix so that shared libraries go in /lib*
  259. instead of /usr/lib*
  260. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  261. - Fix multilibbing
  262. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  263. - Added fix to install libs in correct directory on 64bit machine
  264. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  265. - Made the package only own the one directory that is unique to it:
  266. /usr/include/acl
  267. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  268. - Initial Red Hat package
  269. Made as few changes as possible relative to upstream packaging to
  270. make it easier to maintain long-term. This means that some of
  271. the techniques used here are definitely not standard Red Hat
  272. techniques. If you are looking for an example package to fit
  273. into Red Hat Linux transparently, this would not be the one to
  274. pick.
  275. - acl-devel -> libacl-devel